Heads up - gcc-4.0

Matthew Burgess matthew at linuxfromscratch.org
Sun Apr 17 03:10:21 PDT 2005


Hi guys,

Just thought I'd let you know that work on getting gcc-4.0 into the LFS 
book will be going on in a new branch of the LFS repo.  In an attempt to 
reduce the number of support queries you may well get as a result of 
this, I'll be putting a big fat warning on the gcc related pages saying 
something along the lines of:

"Some packages (including those in the BLFS book) may not build with 
this version of the compiler due to stricter handling of invalid code. 
  Please try to find patches for these problems and let the LFS team 
know about them first, before bothering the BLFS team with them"

This way we can hopefully get a list of problematic packages, patches 
for them, and pass them on to you guys (with patches to the BLFS book if 
you want).

Once BLFS builds fine with gcc-4.0.x, I'll merge the branch back up to 
trunk to give it wider exposure.

If you've any problems with the approach above, let me know.  I'm open 
to suggestions on making this as easy on you guys as possible.

Regards,

Matt.



More information about the blfs-dev mailing list