hal and dbus

Matthew Burgess matthew at linuxfromscratch.org
Sun Apr 17 01:57:50 PDT 2005


Jeremy Utley wrote:

> Randy - both of these are strictly cmmi installations - their configure
> scripts will pick up deps just fine.  I can take a look for the deps for
> you guys, if you like.

I started looking into this, but soon got distracted unfortunately.  As 
you're probably already aware, Jeremy, hal & dbus rely on particular 
versions of each other to compile correctly.  Basically hal-0.5.0 needs 
the latest dbus.  However, gnome-vfs can use hal, but is incompatible 
with hal-0.5.0 (a patch is available somewhere though).  Likewise, hal 
is heavily dependent on gnome, but only at runtime (hal-device-manager 
seems to want all of gnome and its python bindings installed in order to 
do anything!).

Regards,

Matt.



More information about the blfs-dev mailing list