openoffice fun

DJ Lucas dj at linuxfromscratch.org
Fri Apr 15 22:32:28 PDT 2005


Randy McMurchy wrote:

> I'm going to work on the issues with FOP this weekend. 

Well I took a quick blind shot at it.  source="1.4" in build.xml got
through all the depreciated enum errors for warnings, but left me
stumped with this error:

    [javac]
/usr/src/fop-0.20.5/build/src/org/apache/fop/svg/PDFGraphics2D.java:1242:
org.apache.fop.svg.PDFGraphics2D.PDFGraphicsConfiguration is not
abstract and does not override abstract method
createCompatibleVolatileImage(int,int,int) in java.awt.GraphicsConfiguration
    [javac]     static class PDFGraphicsConfiguration extends
GraphicsConfiguration {
    [javac]            ^
    [javac] Note: * uses or overrides a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
    [javac] 1 error
    [javac] 20 warnings

This one is way outa my league.  Any furthur comments that I will _not_
make on this error should be immediately prefixed with "Well it says in
my Java For Dummies book..." ;-)

-- DJ Lucas



More information about the blfs-dev mailing list