libmikmod-3.1.11

Bruce Dubbs bdubbs at swbell.net
Fri Apr 15 21:55:48 PDT 2005


There is a patch to this package to bring it up to libmikmod-3.1.11a.
The books's sed:

sed -i -e "s/VERSION=10/VERSION=11/" \
       -e "s/sys_asoundlib/alsa_asoundlib/" \
       -e "s/snd_cards/snd_card_load/g" \
       -e "s|sys/asoundlib.h|alsa/asoundlib.h|g" \
    configure.in

looks like it is still valid after the patch is made. However, autoconf
bombs for me:

$ autoconf
configure.in:16: warning: do not use m4_patsubst: use patsubst or
m4_bpatsubst
aclocal.m4:546: AM_CONFIG_HEADER is expanded from...
configure.in:16: the top level
configure.in:705: warning: do not use m4_regexp: use regexp or m4_bregexp
aclocal.m4:559: _AM_DIRNAME is expanded from...
configure.in:705: the top level
configure.in:380: error: do not use LIBOBJS directly, use AC_LIBOBJ (see
section `AC_LIBOBJ vs LIBOBJS'
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.

Can anyone else validate this problem?  It looks like a autoconf version
issue to me, but I'm not really that familiar with autoconf.

  -- Bruce



More information about the blfs-dev mailing list