OpenOffice compilation Failures, LFS Unstable

Randy McMurchy randy at linuxfromscratch.org
Sun Dec 26 22:39:14 PST 2004


blfs-dev at lucasit.com wrote:
>>just a heads up, for when LFS Testing has an updated glibc,
>>
>>OpenOffice 1.1.4 [I think it's the res program, but not sure], reports
>>*** glibc detected *** double free or corruption (!prev).
>>
>>[I reported it earlier, just mentioning that it's still on 1.1.4]
>>

> Nathan, did you do this with gcc-3.3.x or 3.4.x?  Just curious if it is
> definately a glibc error.  I had seen this error when using gcc-3.4.2
> against glibc-20041105 IIRC and later...but I did not build with gcc-3.3.x
> against that glibc.  Also, which glibc version, and if you should possibly
> recall, about when did you first see it?  I'd hate to start pulling random
> snaps to see exactly what changes caused this issue.  I know it's fine
> with glibc from 20040701 and gcc-3.3.4.

Hopefully, Nathan was using something other than a default LFS-6.0
build. If so, let's not worry about it for now. If it was an LFS-6.0
build, we need to figure out why your build is different than his. :-)

-- 
Randy



More information about the blfs-dev mailing list