MPlayer notes

Matthew Burgess matthew at linuxfromscratch.org
Fri Dec 24 14:40:18 PST 2004


Randy McMurchy wrote:
> Matthew Burgess wrote:
> 
> 
>> Thirdly, running 'gmplayer' (which incidentally never worked correctly
>> for me in previous versions) outputs the following to the console:
> 
> That's odd. It's *always* worked correctly for me.

Well, "never" was a little too strong I think...I've only ever compiled
MPlayer once, so in all likelihood it was a case of PEBKAC.
> 
>> "Failed to open /dev/rtc: Permission denied (it should be readable by
>> the user.)"
>>
>> Sure enough, `ls -l /dev/rtc` gives:
>>
>> crw-rw----  1 root root 10, 135 2004-12-24 08:15 rtc
>>
>> which ties in with /etc/udev/permissions.d/25-udev.permissions:
>>
>> rtc:root:root:0660
>>
>> So, is a) LFS default configuration wrong, b) MPlayer wrong in thinking
>> normal users should have access to the rtc device or c) BLFS missing a
>> note telling folks they'll need to add another permissions file in the 
>> udev configuration directory to allow access to /dev/rtc?
> 
> 
> And there' more to it than that. If you set the permissions to
> 666 just to see what happens, then there's other messages.
> 
> Here's the message:
> 
> Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
> Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system 
> startup scripts.
> Using usleep() timing

Yikes!  Methinks I might've opened a can of worms with this one :)
Although MPlayer apparently works fine here without access to /dev/rtc, 
I'd prefer to not see that warning.  There's a post at 
http://lists.suse.com/archive/suse-linux-e/2002-Dec/0479.html which 
suggests that blindly following what MPlayer suggests will cause the 
warning to disappear, along with the reasoning behind the use of /dev/rtc.

So, I changed the permissions in the udev configuration, then kinda 
reverse hacked the sysctl bootscript functionality currently in the LFS 
Bootscripts trunk/ area.  Basically, having "dev.rtc.max-user-freq = 
1024" in /etc/sysctl.conf and calling 'sysctl -p' will set the required 
value.  MPlayer no longer complains, and everyone's happy - except for 
the fact that the bootscript functionality isn't in the LFS-6.0 book, 
and the current implemenation is incorrect anyhow (bug 1007).

Cheers,

Matt.



More information about the blfs-dev mailing list