MPlayer notes

Randy McMurchy randy at linuxfromscratch.org
Fri Dec 24 07:17:51 PST 2004


Matthew Burgess wrote:
> Hi guys,
> 
> Just thought I'd let you know a couple of issues I've encountered with
> MPlayer.
> 
> First of all the trivial: It's now on version 1.0pre6, with some
> important security fixes and loads of bug fixes.

I was in the middle of updating the book to 1.0pre5try2 when I
see your email. :-) I guess they updated today. Thanks for the
message. It saves me some time.


> Secondly, the tar command used to extract the codecs fails with recent
> versions of tar which don't support the '--strip-paths' option.  It
> looks like this got renamed to '--strip-components' in tar-1.15.  As
> BLFS-6.0 will be targetting LFS-6.0 I'm not sure this is an issue at all
> really.

It will be an issue after we release BLFS-6.0. I'll BZ this
to make sure it doesn't get forgotten.


> Thirdly, running 'gmplayer' (which incidentally never worked correctly
> for me in previous versions) outputs the following to the console:

That's odd. It's *always* worked correctly for me.


> "Failed to open /dev/rtc: Permission denied (it should be readable by
> the user.)"
> 
> Sure enough, `ls -l /dev/rtc` gives:
> 
> crw-rw----  1 root root 10, 135 2004-12-24 08:15 rtc
> 
> which ties in with /etc/udev/permissions.d/25-udev.permissions:
> 
> rtc:root:root:0660
> 
> So, is a) LFS default configuration wrong, b) MPlayer wrong in thinking
> normal users should have access to the rtc device or c) BLFS missing a
> note telling folks they'll need to add another permissions file in the 
> udev configuration directory to allow access to /dev/rtc?

And there' more to it than that. If you set the permissions to
666 just to see what happens, then there's other messages.

Here's the message:

Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing



> Finally, the instructions for DVD Playback are out of date with regards
> to udev configuration.  Instead of using a symlink (which will get lost
> on every reboot), one should be adding a udev rule under the
> /etc/udev/rules.d/ directory to create the symlink and have it persist
> across reboots.  I managed to get it working by simply putting
> 'KERNEL="hdc", SYMLINK="dvd"' into /etc/udev/rules.d/24-dvd.rules 
> (you'll then have to run 'udevstart').

I just asked about this on the dev list in regards to a
package that needs /dev/cdrom (I forget which one). I will test
this out and update the book according.


> If you'd rather these be put in bugzilla I'll be happy to do so.

I'll do it, but thanks. And thanks for the report

> Here's wishing everyone a merry Christmas and a very happy new year!

Same wishes to all from me.

-- 
Randy



More information about the blfs-dev mailing list