LibXv.a won't compile

Randy McMurchy randy at linuxfromscratch.org
Wed Dec 1 12:19:44 PST 2004


[cc'd to blfs.dev]

David Jensen wrote in blfs.support:
> leclerch wrote:
> 
>> Hello,
>>
>> I'm using LFS 5.1.1 whith 2.4.26 kernel, and when I compile
>> Xorg 6.8.1 or XFree86 4.4.0, I can't get the file libXv.a, I
>> only get the libXv.so.1 and its link, despite the fact that
>> it reports a successful compilation. Thus, xine can't build
>> its xv plugin.
> 
> 
> There is a patch in blfs patches/xine to have xine check for and use the 
> shared lib.
> 
> xine-lib-1-rc7_Xv-2.patch

Has anyone used this patch yet and actually tested that it works
as designed? (not questioning the validity of the patch, but if it
works as designed, and Xine successfully can use the Xv driver with
the shared library, I'm thinking the patch should be added to BLFS)

Any comments?

-- 
Randy



More information about the blfs-dev mailing list