libfam missing .so extension (was: gnome-vfs-2.2.3 configure error with libfam)

Dagmar d'Surreal dagmar.wants at nospam.com
Tue May 27 01:30:38 PDT 2003


On Tue, 2003-05-27 at 01:43, Jeremy Utley wrote:

> Well, upon further checking, it would seem that my gnome-vfs didn't pick
> up on fam - I got the same error about it.  So, just for kicks and
> giggles, I tried this:
> 
> cp /usr/lib/libfam.0.0.0 /usr/lib/libfam.so.0.0.0
> ln -s libfam.so.0.0.0 /usr/lib/libfam.so.0
> ln -s libfam.so.0.0.0 /usr/lib/libfam.so
> 
> then ran ldconfig, then reconfigured gnome-vfs - this time, it did pick
> up on the presence of FAM, and compiled successfully.
> 
> It now does seem that fam is building it's shared libraries incorrectly,
> causing other applications to fail on it.  Cross-posting this message to
> blfs-dev for possible inclusion into the BLFS-book.

I'm not subbed to BLFS-Support so I missed the start of this, but I'm
going to make a semi-educated guess that you're using libtool-1.5.  I
tried it (libtool 1.5) when it was released and this "library filename
missing .so extension" problem screwed up about a half dozen packages
for me.  I'm not sure if the problem is with libtool-1.5 itself or if
there's something unusual the maintainers of the failing packages are
doing because I've not had the time to look too closely into the matter
yet.

If you drop back to libtool-1.4.3 your library should build properly. 
If this was the case you should be _very_ watchful of your libraries
when you're upgrading Gnome since at least two of those packages will
fall prey to the problem as well and might leave you linking to stale
versions of libraries without knowing it.

-- 
The email address above is just as phony as it looks, and for obvious reasons.
Instant messaging contact nfo: AIM: evilDagmar  Jabber: evilDagmar at jabber.org

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-dev' in the subject header of the message



More information about the blfs-dev mailing list