libfam missing .so extension (was: gnome-vfs-2.2.3 configure error with libfam)

Jeremy Utley jeremy at jutley.org
Mon May 26 23:43:02 PDT 2003


On Tue, 2003-05-27 at 02:27, Jeremy Utley wrote:


> 
> Well, I just looked at my libfam libraries, and I have the exact same
> thing.  But, my gnome-vfs package compiled just fine with it like that,
> no problems.  KDE also found the libfam package.  So either these
> packages know how to find the correct libs, or they are compiling that
> in as static instead of dynamic.
> 
> -J-

Well, upon further checking, it would seem that my gnome-vfs didn't pick
up on fam - I got the same error about it.  So, just for kicks and
giggles, I tried this:

cp /usr/lib/libfam.0.0.0 /usr/lib/libfam.so.0.0.0
ln -s libfam.so.0.0.0 /usr/lib/libfam.so.0
ln -s libfam.so.0.0.0 /usr/lib/libfam.so

then ran ldconfig, then reconfigured gnome-vfs - this time, it did pick
up on the presence of FAM, and compiled successfully.

It now does seem that fam is building it's shared libraries incorrectly,
causing other applications to fail on it.  Cross-posting this message to
blfs-dev for possible inclusion into the BLFS-book.

-J-

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-dev' in the subject header of the message



More information about the blfs-dev mailing list