Xfree, GTK and Gnome

Larry Lawrence larry at linuxfromscratch.org
Sat Jan 25 07:39:59 PST 2003


What a mess.  Here is my status.

All GTK and Gnome-2.2 compile and run under the xfree rc3, there are new
packages for gnome and some to be deleted from the book.  I will be able
to update that section within 24 hours of the xfree update to the book.

For those that don't want to wait. The significant changes are:

Add /usr/X11R6/lib/pkgconfig to your PKG_CONFIG_PATH.
librsvg now needs the --sysconfdir=/etc/gnome switch.
metacity must be installed (required for control-center) with
--prefix=/usr --sysconfdir-/etc --libexecdir=/usr/sbin.

This will get you through the first two chapters of Gnome-2.2.

It appears that adding xft-2 and fontconfig to the book would allow
us to make the changes now, however I did not test it. I had hopes of a
fairly quick release of xfree86.  I didn't and still don't think this is
the way to go.

It might save us some stress if we put xfree86rc4 in the book and make the
changes, but that really shouldn't be considered until Gnome-2.2
officially releases, IMHO.

I seemed to have a lot less trouble with mozilla-1.2.1 against gtk-2.2
than with gtk-2.0 and having the xfree86rc3 removed all the font compile
issues.  I may even get galeon to run now, it was one giant segfault a few
weeks ago.

Larry


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-dev' in the subject header of the message



More information about the blfs-dev mailing list