Xfree86 freetype `inflate' error

Rui Ferreira ruifmferreira at sapo.pt
Fri Jan 17 06:31:43 PST 2003


Hi guys,

I hope I'm not making a FAQ...

LFS-4.0
BLFS-20030115

While compiling Xfree86, in 'make install' I get:
------------%---------------------
installing in programs/x11perf...
make[3]: Entering directory `/usr/src/xc/programs/x11perf'
rm -f x11perf
gcc -o x11perf -O2 -fomit-frame-pointer -march=i686 -ansi -pedantic
-pipe     -L../../exports/lib x11perf.o bitmaps.o do_tests.o
do_simple.o do_rects.o do_valgc.o               do_lines.o do_segs.o
do_dots.o do_windows.o do_movewin.o do_text.o                   do_blt.o
do_arcs.o
 do_tris.o do_complex.o do_traps.o -lXft -L/usr/lib -lfreetype -lXrender
-lXrender -lXmuu -lXext -lX11   -lm   -Wl,-rpath-link,../../exports/lib
/usr/lib/libfreetype.so: undefined reference to `inflate'
/usr/lib/libfreetype.so: undefined reference to `inflateReset'
/usr/lib/libfreetype.so: undefined reference to `inflateInit2_'
collect2: ld returned 1 exit status
make[3]: *** [x11perf] Error 1
make[3]: Leaving directory `/usr/src/xc/programs/x11perf'
make[2]: *** [install] Error 2
make[2]: Leaving directory `/usr/src/xc/programs'
make[1]: *** [install] Error 2
make[1]: Leaving directory `/usr/src/xc'
make: *** [install] Error 2
------------%---------------------

I've already checked libz.so and libfreetype.so and they're ok.
ld.so.conf is complete. I've runned ldconfig and re-extracted and
recompiled X.

>From what I googled last night, nothing helped me.
This is my 11th build (lfs+blfs) but this has never happened before.
Since I don't keep a track of what I did in the past, I don't know now what
am I doing diferently.
Maybe is just a typo somewhere but I don't seem to find it.

Hints please.
Thank you.
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-dev' in the subject header of the message



More information about the blfs-dev mailing list