Gnome2: bonobo-activation-1.0.3 and bison-1.75 incompatibility

Jeremy Larner jeremy.larner at dunelm.org.uk
Sun Jan 5 05:23:16 PST 2003


Hmmm, having actually read other posts on this newsgroup (particularly 
the whole do we upgrade to LFS CVS thread), I'm guessing you already 
know that bison-1.75 messes up several packages.  Oh well, I guess this 
might help if you do decide to update...

Jeremy Larner wrote:
> I can't seem to get bonobo-activation-1.0.3 to compile with bison-1.75:
> 
> The errors I get are as follows:
> 
> Making all in server
> make[2]: Entering directory `/usr/src/bonobo-activation-1.0.3/server'
> bison -y -d -v ./activation-context-query-parser.y
> ./activation-context-query-parser.y:158.14-160.13: type clash (`qexp' 
> `') on default action
> ./activation-context-query-parser.y:160.14: parse error, unexpected ":", 
> expecting ";" or "|"
> ./activation-context-query-parser.y:160.50-77: $1 of `expr_variable' has 
> no declared type
> ./activation-context-query-parser.y:160.50-81: $3 of `expr_variable' has 
> no declared type
> ./activation-context-query-parser.y:161.29-56: $1 of `expr_variable' has 
> no declared type
> ./activation-context-query-parser.y:162.56-163.26: $3 of `expr_variable' 
> has no declared type
> ./activation-context-query-parser.y:162.56-163.47: invalid $ value
> ./activation-context-query-parser.y:162.56-163.47: $5 of `expr_variable' 
> has no declared type
> ./activation-context-query-parser.y:162.56-163.64: $1 of `expr_variable' 
> has no declared type
> ./activation-context-query-parser.y:164.47-165.26: $3 of `expr_variable' 
> has no declared type
> ./activation-context-query-parser.y:164.47-165.66: $1 of `expr_variable' 
> has no declared type
> make[2]: *** [stamp-parser] Error 1
> make[2]: Leaving directory `/usr/src/bonobo-activation-1.0.3/server'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/usr/src/bonobo-activation-1.0.3'
> make: *** [all-recursive-am] Error 2
> 
> (I got round it by downgrading to bison-1.35, and then upgrading again...)
> 
> As bison-1.75 is now in the CVS version of LFS, would it be worth noting 
> this as a workaround, at least until v1.0.5 arives...  Incidently, 
> v1.0.4 compiles fine, but I had problems getting Gnome2 to run with it, 
> and from the look of the newsgroups, I wasn't the only one...
> 
> Can someone confirm that it's not just me?  Would a patch be possible? 
> I'd have a go myself, but I really wouldn't know where to start....
> 
> 
> Yours,
> 
> Jeremy
> 

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-dev' in the subject header of the message



More information about the blfs-dev mailing list