j2sdk 1.4.0 with glibc-2.3.1

Tushar Teredesai tushar at linuxfromscratch.org
Fri Jan 3 08:29:46 PST 2003


Tobias Stöckmann wrote:

>I've applied the glibc-2.3.1-patch which I have downloaded
>from http://tushar.lfsforum.org/files/JavaFromScratch/...
>(so this mail is primary for tushar ;)  )
>
>This patch only works if you are using the patched
>version of glibc-2.3.1, this means, the first glibc-2.3.1 which
>will be compiled with the lfs-book...
>
>I've used the seconde-glibc compilation first and get
>unresolved symbols during make-stage in "sun/awt".
>  
>
I think you are using the motif libraries provided by Sun. Since the 
static library libXm.a is linked against glibc < 2.3.1, it gives 
problems when compiling with an unpatched glibc-2.3.1. That is why I 
moved the hint to use system installed lesstif.

If you want to use unpatched glibc to compile j2sdk (as the book 
suggests), you will need to use lesstif (as the hint suggests) and not 
the motif libs that can be downloaded from Sun's website. This is 
mentioned in the hint. I am using unpatched glibc-2.3.1 without any 
compile problems.

BTW, the location of the hint has changed. See my sig.

-- 
Tushar Teredesai
   http://www.linuxfromscratch.org/~tushar/
   http://www.geocities.com/tushar/


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-dev' in the subject header of the message



More information about the blfs-dev mailing list