problem building g-wrap

Vassili Dzuba vassilidzuba at nerim.net
Thu Jan 2 14:13:55 PST 2003


On Thu, 2 Jan 2003 21:55:06 +0000 (UTC)
gschafer at zip.com.au (Greg Schafer) wrote:

> On Thu, Jan 02, 2003 at 10:48:03PM +0100, Vassili Dzuba wrote:
> > On Thu, 2 Jan 2003 21:40:06 +0000 (UTC)
> > gschafer at zip.com.au (Greg Schafer) wrote:
> > 
> > > On Thu, Jan 02, 2003 at 03:45:04PM -0500, Billy O'Connor wrote:
> > > > daniels at ling.ohio-state.edu (Michael W Daniels) writes:
> > > > 
> > > > > At 02:41 PM 1/2/2003 -0500, you wrote:
> > > > > >That's true, but the problem here is that these are the instructions
> > > > > >from the BLFS book, they're expected to work as advertised.  I'm still
> > > > > >looking into what could be causing this.
> > > > > 
> > > > > What's your gcc version? This is a rather recent warning.
> > > > > 
> > > > 
> > > > 3.2.1 is what I'm testing with.
> > > 
> > > This is one of the things they fixed in gcc-3.2.1 so I bet Vassili is using
> > > 3.2 or lower.
> > > 
> > 
> > Yes; i'm testing my BLFS profile on top of LFS 4.0,
> > hence I'm using gcc 3.2
> 
> So the workaround is to fiddle your CPPFLAGS
> 
> CPPFLAGS=-w ./configure blah
> 

I tried, but it doesn't work.
The command line is then :

gcc -DHAVE_CONFIG_H -I. -I. -I.. -w -O2 -Werror -Wall -g -I../libruntime-guile -g -O2 -I/usr/include -c gw-test-parent.c -MT gw-test-parent.lo -MD -MP -MF .deps/gw-test-parent.TPlo    -fPIC -DPIC -o .libs/gw-test-parent.lo

I guess it's because the -w is before the -Werror

Vassili

> Greg
> -- 
> Unsubscribe: send email to listar at linuxfromscratch.org
> and put 'unsubscribe blfs-dev' in the subject header of the message
> 
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-dev' in the subject header of the message



More information about the blfs-dev mailing list