problem building g-wrap

Billy O'Connor billyoc at linuxfromscratch.org
Thu Jan 2 10:08:48 PST 2003


Vassili Dzuba <vassilidzuba at nerim.net> writes:

> gcc -DHAVE_CONFIG_H -I. -I. -I.. -O2 -Werror -Wall -g -I../libruntime-guile -g -O2 -I/usr/include -c gw-test-parent.c -MT gw-test-parent.lo -MD -MP -MF .deps/gw-test-parent.TPlo  -fPIC -DPIC -o .libs/gw-test-parent.lo
> cc1: changing search order for system directory "/usr/include"
> cc1:   as it has already been specified as a non-system directory
> make[2]: *** [gw-test-parent.lo] Error 1
> make[2]: Leaving directory `/usr/src/g-wrap-1.2.1/test'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/usr/src/g-wrap-1.2.1'
> make: *** [all] Error 2
> 
> The file test/Makefile contains :
> 
> #BEGIN TEMP JUNK ============================================================
> CFLAGS = -O2 -Werror -Wall -g -I../libruntime-guile -g -O2 -I/usr/include
> 
> 
> and it seems that the final "-I/usr/include" at the end of the CFLAGS
> definition is the culprit. If I remove it, the compilation works successfully
> 
> Of course, the Makefile is generated, and i don't know enough
> about automake to understand it(s origin.
> 
> Has somebody an idea ?

Oh, man.  I hate these errors.  I don't get the error with this, even
thought my test/Makefile contains:

#BEGIN TEMP JUNK ============================================================
CFLAGS = -O2 -Werror -Wall -g -I../libruntime-guile -I/usr/include

Do you have any CFLAGS set when you run ./configure?


Billy

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-dev' in the subject header of the message



More information about the blfs-dev mailing list