XFree and freetype2

Dagmar d'Surreal dagmar at speakeasy.net
Mon Sep 9 21:04:26 PDT 2002


On Sun, 2002-09-08 at 01:06, Tushar Teredesai wrote:

> Yep, so it is possible to build freetype-2.1.2 before X. So issue about 
> recompiling X won't arise. Personally, I prefer installing two smaller 
> packages to installing one big one.

Actually, it probably _will_.  You _really don't_ want Xfree86 building
it's version of Freetype2 if you can at all help it.  That version is
_very_ old, and since then at least one change to the API has been made
which breaks somewhere around 2.0.9, and rumbles along in various states
of functionality until about 2.1.1 and/or 2.1.2 which seem to be able to
properly guess what the client software is trying to do.  Forgive me for
not being able to recite the history of the library from the past _year_
since 2.0.6 came out_.

Build the system with 2.1.2 from the start, and you will never have a
smidgen of trouble out of Freetype2.  Fail to do so, and you can expect
to see errors about there being two arguments instead of three (or
vice-versa) to one of the FT_Get_* calls.  That's probably not the right
name for it, but most people have see this pop up at least _once_ if
they have been trying to use Freetype 2.0.6.  It plagued me at least
once a month for about eight months running until I started building X
in the manner mentioned in the hint I wrote.

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-dev' in the subject header of the message



More information about the blfs-dev mailing list