[blfs-book] [BLFS Trac] #4605: DHCPCD 6.2.1

BLFS Trac trac at linuxfromscratch.org
Fri Jan 24 05:04:14 PST 2014


#4605: DHCPCD 6.2.1
-------------------------+----------------------
 Reporter:  Krejzi       |       Owner:  fo
     Type:  enhancement  |      Status:  closed
 Priority:  normal       |   Milestone:  current
Component:  BOOK         |     Version:  SVN
 Severity:  normal       |  Resolution:  fixed
 Keywords:               |
-------------------------+----------------------

Comment (by fo):

 Ragnar, it is working fine now, apparently. I verified that /lib/dhcpcd
 /dhcpcd-run-hooks are very different, between versions 6.0.5 and 6.2.1
 (will attach the diff), where I read:
 {{{
 # With the advent of alternative init systems, it's possible to have
 # more than one installed. So we need to try and guess what one we're
 # using unless overriden by configure.
 }}}

 Bruce will certainly blame systemd's advent :-)

 Tried many things, including an sed to modify dhcpcd-run-hooks.in.

 Finally, found:

 [https://bbs.archlinux.org/viewtopic.php?id=165793]

 where it is stated
 {{{
 Make sure you don't have a dhcp-daemon, dhclient or similiar running.
 }}}

 In my case, I do not have systemd, but they have, there.

 I stopped then network, and then, network-manager worked, when I tried.

 I modified the /etc/sysconfig/ifconfig.enp2s1 (your interfaces may have
 different names) to:


 {{{
 $ cat /etc/sysconfig/ifconfig.enp2s1
 ONBOOT=no
 IFACE=enp2s1
 SERVICE=dhcpcd
 DHCP_START="-b -q <customized, in my case>"
 DHCP_STOP="-k"
 }}}

 so that the configuration is skipped, and will be done by NM.

 Then rebooted, and there was the interface configured and up running.

 Please, try this, if it works, we probably will have to modify dhcpcd and
 NM pages (perhaps dhcp, too, but I never touched the page nor built the
 package).

-- 
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/4605#comment:10>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch



More information about the blfs-book mailing list