[blfs-book] [BLFS Trac] #4553: qemu-1.7.0 won't build with libcap-2.24

BLFS Trac trac at linuxfromscratch.org
Sat Jan 11 17:33:42 PST 2014


#4553: qemu-1.7.0 won't build with libcap-2.24
----------------------+-------------------------
 Reporter:  wblaszcz  |      Owner:  blfs-book@…
     Type:  defect    |     Status:  new
 Priority:  normal    |  Milestone:  current
Component:  BOOK      |    Version:  SVN
 Severity:  normal    |   Keywords:
----------------------+-------------------------
 The following error occurs during make
 {{{
   LINK  qemu-io
   CC    fsdev/virtfs-proxy-helper.o
 In file included from /usr/include/sys/capability.h:30:0,
                  from fsdev/virtfs-proxy-helper.c:15:
 /usr/include/sys/xattr.h:31:3: error: expected identifier before numeric
 constant
    XATTR_CREATE = 1, /* set value, fail if attr already exists.  */
    ^
 make: *** [fsdev/virtfs-proxy-helper.o] Error 1

 }}}

 Removing the line:
 include <linux/xattr.h>
 from /usr/include/sys/capability.h
 fixes the issue, but I'm not sure if this is the correct way of fixing it.
 i.e. why was this line inserted since the previous release?

-- 
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/4553>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch



More information about the blfs-book mailing list