[blfs-book] [BLFS Trac] #4727: Remove XML::Parser, move GTK+ and and libjpeg and GLU as recommended LibreOffice dependencies (was: Move gtk+ and xml::parser to recommended libreoffice dependencies)

BLFS Trac trac at linuxfromscratch.org
Fri Feb 21 05:20:49 PST 2014


#4727: Remove XML::Parser, move  GTK+ and and libjpeg and GLU as recommended
LibreOffice dependencies
-------------------------+----------------------
 Reporter:  izivkov      |       Owner:  izivkov
     Type:  enhancement  |      Status:  closed
 Priority:  normal       |   Milestone:  7.5
Component:  BOOK         |     Version:  SVN
 Severity:  normal       |  Resolution:  fixed
 Keywords:               |
-------------------------+----------------------
Changes (by izivkov):

 * status:  assigned => closed
 * resolution:   => fixed


Comment:

 Fixed at r12758.

 When using --disable-gtk switch LO requires X libs, Mesa and GLU. I listed
 only GLU.
 Nothing above is required when using --enable-headless switch.
 I guess XML::Parser is not used any more. I was testing the build on a
 clean LFS with the following options:

 {{{
 ./autogen.sh --prefix=/usr \
              --with-vendor="BLFS"
              --with-alloc=system
              --with-parallelism=$(getconf _NPROCESSORS_ONLN)
              --without-java
              --disable-gconf
              --disable-odk
              --disable-postgresql-sdbc
              --enable-release-build=yes
              --disable-dbus
              --disable-gstreamer-0-10
 }}}

-- 
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/4727#comment:6>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch



More information about the blfs-book mailing list