[blfs-book] r12953 - in trunk/BOOK: . general/genutils general/sysutils gnome/platform introduction/welcome networking/netutils pst/printing x/lib

fernando at higgs.linuxfromscratch.org fernando at higgs.linuxfromscratch.org
Sun Apr 13 13:51:21 PDT 2014


Author: fernando
Date: Sun Apr 13 13:51:20 2014
New Revision: 12953

Log:
ImageMagick-6.8.9-0, nmap-6.45, gtk+-3.12.1, gvfs-1.20.1 and bluez-5.18. Add fc-cache to instructions for font install in ghostscript-9.14.

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/general/genutils/imagemagick.xml
   trunk/BOOK/general/sysutils/bluez.xml
   trunk/BOOK/gnome/platform/gvfs.xml
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/networking/netutils/nmap.xml
   trunk/BOOK/pst/printing/gs.xml
   trunk/BOOK/x/lib/gtk+3.xml

Modified: trunk/BOOK/general.ent
==============================================================================
--- trunk/BOOK/general.ent	Sun Apr 13 13:06:13 2014	(r12952)
+++ trunk/BOOK/general.ent	Sun Apr 13 13:51:20 2014	(r12953)
@@ -316,7 +316,7 @@
 <!ENTITY gtk-doc-version              "1.20">
 <!ENTITY hd2u-version                 "1.0.3">
 <!ENTITY icon-naming-utils-version    "0.8.90">
-<!ENTITY imagemagick-version          "6.8.8">
+<!ENTITY imagemagick-version          "6.8.9">
 <!ENTITY intltool-version             "0.50.2">
 <!ENTITY lsof-version                 "4.87">
 <!ENTITY pinentry-version             "0.8.3">
@@ -336,7 +336,7 @@
 <!ENTITY acpid-version                "2.0.21">
 <!ENTITY at-version                   "3.1.14">
 <!ENTITY autofs-version               "5.0.8">
-<!ENTITY bluez-version                "5.17">
+<!ENTITY bluez-version                "5.18">
 <!ENTITY colord-version               "1.2.0">    <!-- Even minors only -->
 <!ENTITY cpio-version                 "2.11">
 <!ENTITY dbus-version                 "1.8.0">   <!-- Even minors only -->
@@ -457,7 +457,7 @@
 <!ENTITY bind-version                 "9.9.5">
 <!ENTITY mod_dnssd-version            "0.6">
 <!ENTITY NetworkManager-version       "0.9.8.9">
-<!ENTITY nmap-version                 "6.40">
+<!ENTITY nmap-version                 "6.45">
 <!ENTITY traceroute-version           "2.0.19">
 <!ENTITY whois-version                "5.1.1">
 <!ENTITY wicd-version                 "1.7.2.4">
@@ -563,7 +563,7 @@
 <!ENTITY glu-version                  "9.0.0">
 <!ENTITY goffice010-version           "0.10.13">
 <!ENTITY gtk2-version                 "2.24.23">
-<!ENTITY gtk3-version                 "3.12.0">
+<!ENTITY gtk3-version                 "3.12.1">
 <!ENTITY gtk-engines-version          "2.20.2">
 <!ENTITY gtkmm2-version               "2.24.4">
 <!ENTITY gtkmm3-version               "3.10.1">
@@ -620,7 +620,7 @@
 <!ENTITY libsecret-version            "0.18">
 <!ENTITY gcr-version                  "3.12.0">
 <!ENTITY gnome-keyring-version        "3.12.0">
-<!ENTITY gvfs-version                 "1.20.0">
+<!ENTITY gvfs-version                 "1.20.1">
 <!ENTITY gjs-version                  "1.40.0">
 <!ENTITY gnome-desktop-version        "3.12.0">
 <!ENTITY gnome-video-effects-version  "0.4.1">

Modified: trunk/BOOK/general/genutils/imagemagick.xml
==============================================================================
--- trunk/BOOK/general/genutils/imagemagick.xml	Sun Apr 13 13:06:13 2014	(r12952)
+++ trunk/BOOK/general/genutils/imagemagick.xml	Sun Apr 13 13:51:20 2014	(r12953)
@@ -4,7 +4,7 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY imagemagick-patch-version "6">
+  <!ENTITY imagemagick-patch-version "0">
   <!-- Not sure what to do here as ImageMagick is one of the fastest-moving
        targets in all of open-source. One solution is to always use the last
        version of a specific major-minor from the 'legacy' subdirectory of
@@ -15,14 +15,10 @@
 
   <!ENTITY imagemagick-download-http " ">
   <!ENTITY imagemagick-download-ftp  "ftp://ftp.imagemagick.org/pub/ImageMagick/ImageMagick-&imagemagick-version;-&imagemagick-patch-version;.tar.xz">
-  <!ENTITY imagemagick-md5sum        "3b9be99a2f49e60bc2acfde0c2bbe0c6">
+  <!ENTITY imagemagick-md5sum        "d89b4b5db15cf8fb1486cec1067244ae">
   <!ENTITY imagemagick-size          "7.2 MB">
-  <!ENTITY imagemagick-buildsize     "156 MB (with typical dependencies,
-                                      additional 29 MB to run the test suite,
-                                      reputedly 450 MB with all dependencies)">
-  <!ENTITY imagemagick-time          "2.3 SBU (typical build - additional 4.9
-                                      SBU to run the test suite and 6.0 SBU to
-                                      run the validation suite)">
+  <!ENTITY imagemagick-buildsize     "158 MB (with typical dependencies, additional 29 MB to run the test suite, reputedly 450 MB with all dependencies)">
+  <!ENTITY imagemagick-time          "2.5 SBU (typical build - additional 7.1 SBU to run the test suite and 11 SBU to run the validation suite)">
 ]>
 
 <!-- Editors: It is highly unlikely that the buildsize (disk space used) will
@@ -245,7 +241,8 @@
       comprehensive test, run the <application>ImageMagick</application>
       validation suite, also after the package is installed. Note that the EPS,
       PS, and PDF tests require a working
-      <application>Ghostscript</application>.
+      <application>Ghostscript</application>. One test needs "Helvetica" from
+      "Standard Fonts" which are optionally installed in <xref linkend="gs"/>.
     </para>
 
     <!-- This is not necessary as the 'make install' process installs PerlMagick
@@ -364,7 +361,7 @@
 
       <seglistitem>
         <seg>animate, compare, composite, conjure, convert, display,
-        identify, import, Magick-config, Magic++-config, MagickCore-config,
+        identify, import, Magick-config, Magick++-config, MagickCore-config,
         MagickWand-config, mogrify, montage, stream, and Wand-config</seg>
 
         <seg>libMagickCore-6.Q16.so, libMagickWand-6.Q16.so,

Modified: trunk/BOOK/general/sysutils/bluez.xml
==============================================================================
--- trunk/BOOK/general/sysutils/bluez.xml	Sun Apr 13 13:06:13 2014	(r12952)
+++ trunk/BOOK/general/sysutils/bluez.xml	Sun Apr 13 13:51:20 2014	(r12953)
@@ -6,9 +6,9 @@
 
   <!ENTITY bluez-download-http "http://www.kernel.org/pub/linux/bluetooth/bluez-&bluez-version;.tar.xz">
   <!ENTITY bluez-download-ftp  "ftp://ftp.kernel.org/pub/linux/bluetooth/bluez-&bluez-version;.tar.xz">
-  <!ENTITY bluez-md5sum        "5e6e41f0a275092ace303e813cd6f33b">
+  <!ENTITY bluez-md5sum        "9c71404f86287cd9441e86783be3aae1">
   <!ENTITY bluez-size          "1.3 MB">
-  <!ENTITY bluez-buildsize     "51 MB">
+  <!ENTITY bluez-buildsize     "52 MB">
   <!ENTITY bluez-time          "0.6 SBU">
 ]>
 
@@ -34,7 +34,7 @@
       Bluetooth protocol stack for Linux.
     </para>
 
-    &lfs75_checked;
+    &lfs75_built;
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">

Modified: trunk/BOOK/gnome/platform/gvfs.xml
==============================================================================
--- trunk/BOOK/gnome/platform/gvfs.xml	Sun Apr 13 13:06:13 2014	(r12952)
+++ trunk/BOOK/gnome/platform/gvfs.xml	Sun Apr 13 13:51:20 2014	(r12953)
@@ -6,10 +6,10 @@
 
   <!ENTITY gvfs-download-http "&gnome-download-http;/gvfs/1.20/gvfs-&gvfs-version;.tar.xz">
   <!ENTITY gvfs-download-ftp  "&gnome-download-ftp;/gvfs/1.20/gvfs-&gvfs-version;.tar.xz">
-  <!ENTITY gvfs-md5sum        "5c19d31f61af35ca7da3413a1db46bb0">
+  <!ENTITY gvfs-md5sum        "2c6d4d08ebd691ccdb3f8da88a7c4b20">
   <!ENTITY gvfs-size          "1.5 MB">
-  <!ENTITY gvfs-buildsize     "59 MB">
-  <!ENTITY gvfs-time          "0.6 SBU">
+  <!ENTITY gvfs-buildsize     "59 MB (additional 2 MB for the tests)">
+  <!ENTITY gvfs-time          "0.6 SBU (additional 0.1 SBU for the tests)">
 ]>
 
 <sect1 id="gvfs" xreflabel="Gvfs-&gvfs-version;">
@@ -140,7 +140,8 @@
 make</userinput></screen>
 
     <para>
-      This package does not come with a test suite.
+      To test the results, issue: <command>make -k check</command>. Some tests
+      may fail for unknown reasons.
     </para>
 
     <para>
@@ -192,7 +193,7 @@
         <seg>
           libgvfscommon.so,
           libgvfsdaemon.so, and
-          several under /usr/lib/gio/modules/
+          two under /usr/lib/gio/modules/
         </seg>
         <seg>
           /usr/include/gvfs-client,

Modified: trunk/BOOK/introduction/welcome/changelog.xml
==============================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	Sun Apr 13 13:06:13 2014	(r12952)
+++ trunk/BOOK/introduction/welcome/changelog.xml	Sun Apr 13 13:51:20 2014	(r12953)
@@ -47,6 +47,30 @@
     <listitem>
       <para>April 13th, 2014</para>
       <itemizedlist>
+       <listitem>
+          <para>[fernando] - Add fc-cache to instructions for font install in
+          ghostscript-9.14.</para>
+        </listitem>
+       <listitem>
+          <para>[fernando] - bluez-5.18. Fixes
+          <ulink url="&blfs-ticket-root;4946">#4946</ulink>.</para>
+        </listitem>
+       <listitem>
+          <para>[fernando] - gvfs-1.20.1. Fixes
+          <ulink url="&blfs-ticket-root;4941">#4941</ulink>.</para>
+        </listitem>
+       <listitem>
+          <para>[fernando] - gtk+-3.12.1. Fixes
+          <ulink url="&blfs-ticket-root;4945">#4945</ulink>.</para>
+        </listitem>
+       <listitem>
+          <para>[fernando] - nmap-6.45. Fixes
+          <ulink url="&blfs-ticket-root;4943">#4943</ulink>.</para>
+        </listitem>
+       <listitem>
+          <para>[fernando] - ImageMagick-6.8.9-0. Fixes
+          <ulink url="&blfs-ticket-root;4942">#4942</ulink>.</para>
+        </listitem>
         <listitem>
           <para>[pierre] - Update to Icedtea-2.4.6. Fixes
           <ulink url="&blfs-ticket-root;4897">#4897</ulink>.</para>

Modified: trunk/BOOK/networking/netutils/nmap.xml
==============================================================================
--- trunk/BOOK/networking/netutils/nmap.xml	Sun Apr 13 13:06:13 2014	(r12952)
+++ trunk/BOOK/networking/netutils/nmap.xml	Sun Apr 13 13:51:20 2014	(r12953)
@@ -5,11 +5,12 @@
   %general-entities;
 
   <!ENTITY nmap-download-http "http://nmap.org/dist/nmap-&nmap-version;.tar.bz2">
-  <!ENTITY nmap-download-ftp  "&gentoo-ftp-repo;/nmap-&nmap-version;.tar.bz2">
-  <!ENTITY nmap-md5sum        "c0e2f3370e1fb97fb53185b15aa22aff">
-  <!ENTITY nmap-size          "7.5 MB">
-  <!ENTITY nmap-buildsize     "107 MB">
-  <!ENTITY nmap-time          "1.1 SBU">
+<!--  <!ENTITY nmap-download-ftp  "&gentoo-ftp-repo;/nmap-&nmap-version;.tar.bz2">-->
+  <!ENTITY nmap-download-ftp  " ">
+  <!ENTITY nmap-md5sum        "e8c337456a692bada3ee53e7f5b87bac">
+  <!ENTITY nmap-size          "7.6 MB">
+  <!ENTITY nmap-buildsize     "105 MB (additional 1 MB for the tests)">
+  <!ENTITY nmap-time          "0.7 SBU (additional 4.3 SBU for the tests)">
 ]>
 
 <sect1 id="nmap" xreflabel="Nmap-&nmap-version;">
@@ -106,7 +107,9 @@
 <screen><userinput>./configure --prefix=/usr &&
 make -j1</userinput></screen>
 
-    <para>This package does not come with a test suite.</para>
+    <para>To test the results, issue: <command>make -k check</command> as the
+    <systemitem class="username">root</systemitem> user. Tests need a
+    graphical session. Some tests may fail.</para>
 
     <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
 
@@ -125,7 +128,8 @@
       <seglistitem>
         <seg>ncat, ndiff, nmap, nmapfe, nmap-update, nping, uninstall_zenmap,
         xnmap and zenmap</seg>
-        <seg>/usr/lib/python&python2-version;/site-packages/</seg>
+<!--    <seg>/usr/lib/python&python2-version;/site-packages/</seg>-->
+        <seg>None</seg>
         <seg>/usr/share/ncat, /usr/share/nmap and /usr/share/zenmap</seg>
       </seglistitem>
     </segmentedlist>

Modified: trunk/BOOK/pst/printing/gs.xml
==============================================================================
--- trunk/BOOK/pst/printing/gs.xml	Sun Apr 13 13:06:13 2014	(r12952)
+++ trunk/BOOK/pst/printing/gs.xml	Sun Apr 13 13:51:20 2014	(r12953)
@@ -116,7 +116,8 @@
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional">
       <xref linkend="cairo"/>,
-      <xref linkend="fontconfig"/>,
+      <xref linkend="fontconfig"/> (required, if you are installing any
+      suggested font),
       <xref linkend="gtk2"/>,
       <xref linkend="cups"/>,
       <xref linkend="lcms"/> (not used by default, nor if lcms2 is present or found),
@@ -227,7 +228,8 @@
       command below for the fonts you wish to install:
     </para>
 
-<screen role="root"><userinput>tar -xvf ../<replaceable><font-tarball></replaceable> -C /usr/share/ghostscript --no-same-owner</userinput></screen>
+<screen role="root"><userinput>tar -xvf ../<replaceable><font-tarball></replaceable> -C /usr/share/ghostscript --no-same-owner &&
+fc-cache -v /usr/share/ghostscript/fonts/</userinput></screen>
   </sect2>
 
   <sect2 role="commands">
@@ -249,8 +251,8 @@
     </para>
 
     <para>
-      <parameter>--with-system-libtiff</parameter>: Remove this option if you've not
-      installed <xref linkend="libtiff"/>.
+      <parameter>--with-system-libtiff</parameter>: Remove this option if
+      you've not installed <xref linkend="libtiff"/>.
     </para>
 
     <para>

Modified: trunk/BOOK/x/lib/gtk+3.xml
==============================================================================
--- trunk/BOOK/x/lib/gtk+3.xml	Sun Apr 13 13:06:13 2014	(r12952)
+++ trunk/BOOK/x/lib/gtk+3.xml	Sun Apr 13 13:51:20 2014	(r12953)
@@ -6,10 +6,10 @@
 
   <!ENTITY gtk3-download-http "&gnome-download-http;/gtk+/3.12/gtk+-&gtk3-version;.tar.xz">
   <!ENTITY gtk3-download-ftp  "&gnome-download-ftp;/gtk+/3.12/gtk+-&gtk3-version;.tar.xz">
-  <!ENTITY gtk3-md5sum        "4e493fb68cded7420a7d8bcebdf13811">
+  <!ENTITY gtk3-md5sum        "d4fa17f3916bdd737c37cdf123c1b24a">
   <!ENTITY gtk3-size          "15 MB">
   <!ENTITY gtk3-buildsize     "380 MB (additional 4 MB for the test suite and 19 MB to rebuild the docs)">
-  <!ENTITY gtk3-time          "4.1 SBU (additional 0.4 SBU for the test suite and 3.5 SBU to rebuild the docs)">
+  <!ENTITY gtk3-time          "4 SBU (additional 0.4 SBU for the test suite and 3.5 SBU to rebuild the docs)">
 ]>
 
 <sect1 id="gtk3" xreflabel="GTK+-&gtk3-version;">



More information about the blfs-book mailing list