[blfs-book] r11898 - in trunk/BOOK: . introduction/welcome x/lib

bdubbs at higgs.linuxfromscratch.org bdubbs at higgs.linuxfromscratch.org
Mon Sep 30 10:18:59 PDT 2013


Author: bdubbs
Date: Mon Sep 30 10:18:59 2013
New Revision: 11898

Log:
Update to webkitgtk-2.2.0

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/x/lib/webkitgtk2.xml

Modified: trunk/BOOK/general.ent
==============================================================================
--- trunk/BOOK/general.ent	Mon Sep 30 09:01:36 2013	(r11897)
+++ trunk/BOOK/general.ent	Mon Sep 30 10:18:59 2013	(r11898)
@@ -575,7 +575,7 @@
 <!ENTITY shared-mime-info-version     "1.1">
 <!ENTITY startup-notification-version "0.12">
 <!ENTITY webkitgtk-version            "1.10.2">   <!-- Even minors only -->
-<!ENTITY webkitgtk2-version           "2.0.4">    <!-- Even minors only -->
+<!ENTITY webkitgtk2-version           "2.2.0">    <!-- Even minors only -->
 <!ENTITY xulrunner-version            "24.0">
 
 <!ENTITY gtk2-libdir                  "2.0/2.10.0">

Modified: trunk/BOOK/introduction/welcome/changelog.xml
==============================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	Mon Sep 30 09:01:36 2013	(r11897)
+++ trunk/BOOK/introduction/welcome/changelog.xml	Mon Sep 30 10:18:59 2013	(r11898)
@@ -47,6 +47,9 @@
       <para>September 30th, 2013</para>
       <itemizedlist>
         <listitem>
+          <para>[bdubbs] - Update to webkitgtk-2.2.0.</para>
+        </listitem>
+        <listitem>
           <para>[igor] - Update to cups-1.6.4. Fixes
           <ulink url="&blfs-ticket-root;4123">#4123</ulink>.</para>
         </listitem>

Modified: trunk/BOOK/x/lib/webkitgtk2.xml
==============================================================================
--- trunk/BOOK/x/lib/webkitgtk2.xml	Mon Sep 30 09:01:36 2013	(r11897)
+++ trunk/BOOK/x/lib/webkitgtk2.xml	Mon Sep 30 10:18:59 2013	(r11898)
@@ -6,10 +6,10 @@
 
   <!ENTITY webkitgtk2-download-http "http://webkitgtk.org/releases/webkitgtk-&webkitgtk2-version;.tar.xz">
   <!ENTITY webkitgtk2-download-ftp  " ">
-  <!ENTITY webkitgtk2-md5sum        "413be319ba171feed9348d1bede6b0a7">
-  <!ENTITY webkitgtk2-size          "9.4 MB">
-  <!ENTITY webkitgtk2-buildsize     "900 MB">
-  <!ENTITY webkitgtk2-time          "50 SBU">
+  <!ENTITY webkitgtk2-md5sum        "9c337812667c4885ebe29a54084dcd4c">
+  <!ENTITY webkitgtk2-size          "9.0 MB">
+  <!ENTITY webkitgtk2-buildsize     "784 MB">
+  <!ENTITY webkitgtk2-time          "42 SBU">
 ]>
 
 <sect1 id="webkitgtk2" xreflabel="WebKitGTK+-&webkitgtk2-version;">
@@ -86,14 +86,14 @@
       <xref linkend="ruby"/>,
       <xref linkend="sqlite"/>,
       <xref linkend="udev"/> or
-      <xref linkend="udev-extras"/> (for GUdev) and
+      <xref linkend="udev-extras"/> (for GUdev), and
       <xref linkend="which"/>
     </para>
 
     <bridgehead renderas="sect4">Recommended</bridgehead>
     <para role="recommended">
       <xref linkend="enchant"/>,
-      <xref linkend="geoclue"/> and
+      <xref linkend="geoclue"/>, and
       <xref linkend="gobject-introspection"/>
     </para>
 
@@ -118,7 +118,7 @@
         it with the following
         <ulink url="&patch-downloads;/make/make-3.82-upstream_fixes-3.patch">
         patch</ulink> applied or <application>WebKitGTK+</application>
-        build will fail.
+        build may fail.
       </para>
     </warning>
 
@@ -134,10 +134,7 @@
       following commands:
     </para>
 
-<screen><userinput>sed -i "/%union/i %lex-param {YYLEX_PARAM}" \
-   Source/ThirdParty/ANGLE/src/compiler/glslang.y &&
-
-./configure --prefix=/usr \
+<screen><userinput>./configure --prefix=/usr                    \
             --libexecdir=/usr/lib/webkitgtk3 \
             --enable-introspection &&
 make</userinput></screen>
@@ -201,12 +198,14 @@
           jsc-3
         </seg>
         <seg>
-          libjavascriptcoregtk-3.0.so, libwebkit2gtk-3.0.so and
-          libwebkit-3.0.so
+          libjavascriptcoregtk-3.0.so, 
+          libwebkit2gtk-3.0.so, and
+          libwebkitgtk-3.0.so
         </seg>
         <seg>
-          /usr/include/webkit-3.0, /usr/lib/webkitgtk3 and
-          /usr/share/webkit-3.0
+          /usr/include/webkitgtk-3.0, 
+          /usr/lib/webkitgtk3, and
+          /usr/share/webkitgtk-3.0
         </seg>
       </seglistitem>
     </segmentedlist>



More information about the blfs-book mailing list