[blfs-book] [BLFS Trac] #4022: A circular dependency GTK+-2 => Pixman

BLFS Trac trac at linuxfromscratch.org
Mon Sep 2 20:44:37 PDT 2013


#4022: A circular dependency GTK+-2 => Pixman
--------------------+----------------------------------------
 Reporter:  stoat   |      Owner:  blfs-book@…
     Type:  defect  |     Status:  new
 Priority:  normal  |  Milestone:  current
Component:  BOOK    |    Version:  SVN
 Severity:  normal  |   Keywords:  circular dependency pixman
--------------------+----------------------------------------
 The Pixman-0.30.2 optional dependencies listed in the current BLFS SVN:

 GTK+-2.24.20 and libpng-1.6.3

 However...

 GTK+-2.24.20 requires Pango-1.34.1 which requires Cairo-1.12.14 which
 requires Pixman-0.30.2

 I haven't tried anything for it yet, but I guess the usual routine of
 installing this group once without GTK+-2 and then again with it would
 work. Anyway, a note for this in the book might be useful.

-- 
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/4022>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch



More information about the blfs-book mailing list