[blfs-book] [BLFS Trac] #4164: dbus-1.6.16

BLFS Trac trac at linuxfromscratch.org
Sat Oct 12 07:43:17 PDT 2013


#4164: dbus-1.6.16
-------------------------+--------------------------
 Reporter:  bdubbs@…     |       Owner:  blfs-book@…
     Type:  enhancement  |      Status:  new
 Priority:  normal       |   Milestone:  current
Component:  BOOK         |     Version:  SVN
 Severity:  normal       |  Resolution:
 Keywords:               |
-------------------------+--------------------------

Comment (by fo):

 I am trying to update this. Builds and works fine. However, test fails to
 even configure:

 {{{
 configure: Full test coverage was requested with --enable-tests=yes
 configure: This has many dependencies (GLib, dbus-glib, Python)
 checking for GLIB... yes
 checking for DBUS_GLIB... yes
 configure: Full test coverage (--enable-tests=yes) requires Python, dbus-
 python, pygobject
 checking for a Python interpreter with version >= 2.6... python
 checking for python... /usr/bin/python
 checking for python version... 2.7
 checking for python platform... linux2
 checking for python script directory... ${prefix}/lib/python2.7/site-
 packages
 checking for python extension module directory...
 ${exec_prefix}/lib/python2.7/site-packages
 checking for Python modules for full test coverage... Traceback (most
 recent call last):
   File "<string>", line 1, in <module>
 ImportError: No module named dbus
 no
 configure: error: cannot import dbus, gobject, dbus.mainloop.glib Python
 modules

 }}}

 I see, that there are some restrictions to the tests, so wanted to report
 the failure, before proceeding. Tried to include --prefix=/usr in the
 configure for the tests, but obtained similar error.

-- 
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/4164#comment:1>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch



More information about the blfs-book mailing list