[blfs-book] r11945 - trunk/BOOK/multimedia/videoutils

igor at higgs.linuxfromscratch.org igor at higgs.linuxfromscratch.org
Wed Oct 9 02:29:37 PDT 2013


Author: igor
Date: Wed Oct  9 02:29:36 2013
New Revision: 11945

Log:
clarify chosen ffmpeg configure switches

Modified:
   trunk/BOOK/multimedia/videoutils/ffmpeg.xml

Modified: trunk/BOOK/multimedia/videoutils/ffmpeg.xml
==============================================================================
--- trunk/BOOK/multimedia/videoutils/ffmpeg.xml	Tue Oct  8 14:42:43 2013	(r11944)
+++ trunk/BOOK/multimedia/videoutils/ffmpeg.xml	Wed Oct  9 02:29:36 2013	(r11945)
@@ -256,16 +256,6 @@
     </para>
 
     <para>
-      <command>gcc tools/qt-faststart.c -o tools/qt-faststart</command>:
-      This builds the <command>qt-faststart</command> program which can
-      modify QuickTime formatted movies
-      (<filename class="extension">.mov</filename> or
-      <filename class="extension">.mp4</filename>) so that the header information
-      is located at the beginning of the file instead of the end. This allows
-      the movie file to begin playing before the entire file has been downloaded.
-    </para>
-
-    <para>
       <parameter>--enable-gpl</parameter>: Enables the use of GPL code and
       permits support for postprocessing, swscale and many other features.
     </para>
@@ -300,40 +290,37 @@
     </para>
 
     <para>
-      <parameter>--enable-libfdk-aac</parameter>: Enables AAC format de/encoding
-      via <filename class="libraryfile">libfdk-aac</filename>.
+      <parameter>--enable-libfdk-aac</parameter>: Enables currently the
+      highest-quality AAC audio encoding via <filename
+      class="libraryfile">libfdk-aac</filename>.
     </para>
 
     <para>
-      <parameter>--enable-libmp3lame</parameter>: Enables MP3 de/encoding via
+      <parameter>--enable-libmp3lame</parameter>: Enables MP3 audio encoding via
       <filename class="libraryfile">libmp3lame</filename>.
     </para>
 
     <para>
-      <parameter>--enable-libopus</parameter>: Enables Opus format de/encoding
-      via <filename class="libraryfile">libopus</filename>.
+      <parameter>--enable-libopus</parameter>: Enables Opus encoding for low
+      latency streaming via <filename class="libraryfile">libopus</filename>.
     </para>
 
     <para>
-      <parameter>--enable-libtheora</parameter>: Enables
-      <application>Theora</application> de/encoding
-      via <filename class="libraryfile">libtheora</filename>.
+      <parameter>--enable-libvorbis --enable-libtheora</parameter>: Enables
+      Theora video encoding via <filename
+      class="libraryfile">libvorbis</filename> and <filename
+      class="libraryfile">libtheora</filename>.
     </para>
 
     <para>
-      <parameter>--enable-libvorbis</parameter>: Enables
-      <application>Vorbis</application> de/encoding
-      via <filename class="libraryfile">libvorbis</filename>.
+      <parameter>--enable-libvorbis --enable-libvpx</parameter>: Enables WebM
+      encoding via <filename class="libraryfile">libvorbis</filename> and
+      <filename class="libraryfile">libvpx</filename>.
     </para>
 
     <para>
-      <parameter>--enable-libvpx</parameter>: Enables VP8 de/encoding
-      via <filename class="libraryfile">libvpx</filename>.
-    </para>
-
-    <para>
-      <parameter>--enable-libx264</parameter>: Enables H.264 de/encoding
-      via <filename class="libraryfile">libx264</filename>.
+      <parameter>--enable-libx264</parameter>: Enables high-quality H.264/MPEG-4
+      AVC encoding via <filename class="libraryfile">libx264</filename>.
     </para>
 
     <para>
@@ -341,20 +328,24 @@
     </para>
 
     <para>
-      Support for most of the dependency packages requires using options passed
-      to the <command>configure</command> script. View the the output from
-      <command>./configure --help</command> for complete information about
-      enabling dependency packages. The only reason to enable a specific codec
-      (and make <application>FFmpeg</application> link to the prerequisite
-      shared library installed on your system) is to make
-      <application>FFmpeg</application> compile an <emphasis>encoder</emphasis>
-      and/or <emphasis>decoder</emphasis> for that codec. If you just want to
-      use <application>FFmpeg</application> to watch video or listen to music
-      (via other applications such as <application>Gstreamer</application> or
-      <application>Xine</application>) then you will not benefit from linking
-      <application>FFmpeg</application> to other codec libraries.
+      <command>gcc tools/qt-faststart.c -o tools/qt-faststart</command>:
+      This builds the <command>qt-faststart</command> program which can
+      modify QuickTime formatted movies
+      (<filename class="extension">.mov</filename> or
+      <filename class="extension">.mp4</filename>) so that the header information
+      is located at the beginning of the file instead of the end. This allows
+      the movie file to begin playing before the entire file has been downloaded.
     </para>
 
+    <note>
+      <para>
+        Support for most of the dependency packages requires using options
+        passed to the <command>configure</command> script. View the the output
+        from <command>./configure --help</command> for complete information
+        about enabling dependency packages.
+      </para>
+    </note>
+
   </sect2>
 
   <sect2 role="configuration">



More information about the blfs-book mailing list