[blfs-book] r12147 - in trunk/BOOK: introduction/welcome networking/netutils

ken at higgs.linuxfromscratch.org ken at higgs.linuxfromscratch.org
Wed Nov 6 13:19:45 PST 2013


Author: ken
Date: Wed Nov  6 13:19:45 2013
New Revision: 12147

Log:
Fix avahi to build with current gtk+-3.

Modified:
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/networking/netutils/avahi.xml

Modified: trunk/BOOK/introduction/welcome/changelog.xml
==============================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	Wed Nov  6 09:22:46 2013	(r12146)
+++ trunk/BOOK/introduction/welcome/changelog.xml	Wed Nov  6 13:19:45 2013	(r12147)
@@ -47,6 +47,9 @@
       <para>November 6th, 2013</para>
       <itemizedlist>
         <listitem>
+          <para>[ken] - fix avahi for deprecation in current gtk+-3.</para>
+        </listitem>
+        <listitem>
           <para>[fernando] - Update to gnutls-3.2.6. Fixes
           <ulink url="&blfs-ticket-root;4264">#4264</ulink>.</para>
         </listitem>

Modified: trunk/BOOK/networking/netutils/avahi.xml
==============================================================================
--- trunk/BOOK/networking/netutils/avahi.xml	Wed Nov  6 09:22:46 2013	(r12146)
+++ trunk/BOOK/networking/netutils/avahi.xml	Wed Nov  6 13:19:45 2013	(r12147)
@@ -123,7 +123,11 @@
     <para>Install <application>Avahi</application> by running the following
     commands:</para>
 
-<screen><userinput>./configure --prefix=/usr        \
+<!-- final part of sed removes " -DGDK_DISABLE_DEPRECATED=1 -DGTK_DISABLE_DEPRECATED=1 \" -->
+<screen><userinput>sed -i 's/\(CFLAGS=.*\)-Werror \(.*\)/\1\2/' configure &&
+sed -i -e 's/-DG_DISABLE_DEPRECATED=1//' \
+ -e '/-DGDK_DISABLE_DEPRECATED/d' avahi-ui/Makefile.in &&
+./configure --prefix=/usr        \
             --sysconfdir=/etc    \
             --localstatedir=/var \
             --disable-static     \
@@ -149,6 +153,13 @@
   <sect2 role="commands">
     <title>Command Explanations</title>
 
+    <para>
+      <command>sed -i ...</command>: These seds allow the package to build after
+      the deprecation of symbols in <literal>gtkstock.h</literal> by current
+      <application>gtk+-3</application> by removing <literal>-Werror</literal>
+      and by removing the defines for G{,DK,TK}_DISABLE_DEPRECATED.
+    </para>
+
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
       href="../../xincludes/static-libraries.xml"/>
 



More information about the blfs-book mailing list