[blfs-book] r11101 - in trunk/BOOK: . gnome/applications gnome/core introduction/welcome x/lib xsoft/office

krejzi at higgs.linuxfromscratch.org krejzi at higgs.linuxfromscratch.org
Sat Mar 16 09:48:02 PDT 2013


Author: krejzi
Date: Sat Mar 16 09:48:02 2013
New Revision: 11101

Log:
More package updates.

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/gnome/applications/evolution.xml
   trunk/BOOK/gnome/core/evolution-data-server.xml
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/x/lib/goffice010.xml
   trunk/BOOK/xsoft/office/abiword.xml
   trunk/BOOK/xsoft/office/gnumeric.xml

Modified: trunk/BOOK/general.ent
==============================================================================
--- trunk/BOOK/general.ent	Sat Mar 16 05:17:25 2013	(r11100)
+++ trunk/BOOK/general.ent	Sat Mar 16 09:48:02 2013	(r11101)
@@ -555,7 +555,7 @@
 <!ENTITY freeglut-version             "2.8.0">
 <!ENTITY gdk-pixbuf-version           "2.26.5">
 <!ENTITY goffice-version              "0.8.17">
-<!ENTITY goffice010-version           "0.10.0">
+<!ENTITY goffice010-version           "0.10.1">
 <!ENTITY gtk2-version                 "2.24.16">
 <!ENTITY gtk3-version                 "3.6.4">
 <!ENTITY gtk-engines-version          "2.20.2">
@@ -639,7 +639,7 @@
 <!ENTITY libwacom-version             "0.6.1">
 <!ENTITY gnome-online-accounts-version "3.6.2">
 <!ENTITY libgdata-version             "0.13.2">
-<!ENTITY evolution-data-server-version "3.6.3">
+<!ENTITY evolution-data-server-version "3.6.4">
 <!ENTITY libzeitgeist-version         "0.3.18">
 <!ENTITY folks-version                "0.8.0">
 <!ENTITY gnome-js-common-version      "0.1.2">
@@ -697,7 +697,7 @@
 <!ENTITY epiphany-version             "3.6.1">
 <!ENTITY epiphany-extensions-version  "3.6.0">
 <!ENTITY evince-version               "3.6.1">
-<!ENTITY evolution-version            "3.6.3">
+<!ENTITY evolution-version            "3.6.4">
 <!ENTITY file-roller-version          "3.6.3">
 <!ENTITY gcalctool-version            "6.6.2">
 <!ENTITY gedit-version                "3.6.2">
@@ -763,8 +763,8 @@
 
 <!-- Part X -->
 <!-- Chapter 35 -->
-<!ENTITY AbiWord-version              "2.9.3">
-<!ENTITY gnumeric-version             "1.12.0">
+<!ENTITY AbiWord-version              "2.9.4">
+<!ENTITY gnumeric-version             "1.12.1">
 <!ENTITY gnucash-version              "2.4.11">
 
 <!ENTITY libreoffice-version          "4.0.1">

Modified: trunk/BOOK/gnome/applications/evolution.xml
==============================================================================
--- trunk/BOOK/gnome/applications/evolution.xml	Sat Mar 16 05:17:25 2013	(r11100)
+++ trunk/BOOK/gnome/applications/evolution.xml	Sat Mar 16 09:48:02 2013	(r11101)
@@ -6,7 +6,7 @@
 
   <!ENTITY evolution-download-http "&gnome-download-http;/evolution/3.6/evolution-&evolution-version;.tar.xz">
   <!ENTITY evolution-download-ftp  "&gnome-download-ftp;/evolution/3.6/evolution-&evolution-version;.tar.xz">
-  <!ENTITY evolution-md5sum        "5662efe3f61da457cf6f9aae634bfbbf">
+  <!ENTITY evolution-md5sum        "699c29a0179df3866ecc2f972bc626a4">
   <!ENTITY evolution-size          "12 MB">
   <!ENTITY evolution-buildsize     "505 MB">
   <!ENTITY evolution-time          "4.5 SBU">

Modified: trunk/BOOK/gnome/core/evolution-data-server.xml
==============================================================================
--- trunk/BOOK/gnome/core/evolution-data-server.xml	Sat Mar 16 05:17:25 2013	(r11100)
+++ trunk/BOOK/gnome/core/evolution-data-server.xml	Sat Mar 16 09:48:02 2013	(r11101)
@@ -8,8 +8,8 @@
            "&gnome-download-http;/evolution-data-server/3.6/evolution-data-server-&evolution-data-server-version;.tar.xz">
   <!ENTITY evolution-data-server-download-ftp
            "&gnome-download-ftp;/evolution-data-server/3.6/evolution-data-server-&evolution-data-server-version;.tar.xz">
-  <!ENTITY evolution-data-server-md5sum        "61da6b2895c2a77cc766ed9535894fb3">
-  <!ENTITY evolution-data-server-size          "3.8 MB">
+  <!ENTITY evolution-data-server-md5sum        "9a66998e1986a003c42222f41ea15d2e">
+  <!ENTITY evolution-data-server-size          "3.9 MB">
   <!ENTITY evolution-data-server-buildsize     "225 MB">
   <!ENTITY evolution-data-server-time          "2.2 SBU">
 ]>
@@ -144,17 +144,15 @@
     </para>
 
     <para>
-      <option>--without-weather</option>: Use this switch to disable the
-      weather calendar backend and is required if
-      <application>libgweather</application> is not installed.
+      <option>--with-openldap</option>: Use this switch to enable
+      <application>OpenLDAP</application> support in
+      <application>Evolution Data Server</application>.
     </para>
 
     <para>
-      <parameter>--with-krb5=/usr</parameter>: Enables Kerberos 5 support.
-    </para>
-
-    <para>
-      <option>--with-openldap</option>: Enables LDAP support.
+      <parameter>--with-krb5=/usr</parameter>: Use this switch to
+      enable <application>Kerberos 5</application> support in
+      <application>Evolution Data Server</application>.
     </para>
 
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"

Modified: trunk/BOOK/introduction/welcome/changelog.xml
==============================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	Sat Mar 16 05:17:25 2013	(r11100)
+++ trunk/BOOK/introduction/welcome/changelog.xml	Sat Mar 16 09:48:02 2013	(r11101)
@@ -50,6 +50,9 @@
           <para>[krejzi] - Added libgusb 0.1.6.</para>
         </listitem>
         <listitem>
+          <para>[krejzi] - AbiWord 2.9.4.</para>
+        </listitem>
+        <listitem>
           <para>[krejzi] - Colord 0.1.30.</para>
         </listitem>
         <listitem>
@@ -61,12 +64,21 @@
         <listitem>
           <para>[krejzi] - DejaGnu 1.5.1.</para>
         </listitem>
+        <listitem> 
+          <para>[krejzi] - Evolution 3.6.4.</para>
+        </listitem>
         <listitem>
           <para>[krejzi] - FFmpeg 1.2.</para>
         </listitem>
         <listitem>
           <para>[krejzi] - Git 1.8.2.</para>
         </listitem>
+        <listitem> 
+          <para>[krejzi] - Gnumeric 1.12.1.</para>
+        </listitem>
+        <listitem> 
+          <para>[krejzi] - GOffice 0.10.1.</para>
+        </listitem>
         <listitem>
           <para>[krejzi] - GPGME 1.4.0.</para>
         </listitem>

Modified: trunk/BOOK/x/lib/goffice010.xml
==============================================================================
--- trunk/BOOK/x/lib/goffice010.xml	Sat Mar 16 05:17:25 2013	(r11100)
+++ trunk/BOOK/x/lib/goffice010.xml	Sat Mar 16 09:48:02 2013	(r11101)
@@ -8,7 +8,7 @@
            "&gnome-download-http;/goffice/0.10/goffice-&goffice010-version;.tar.xz">
   <!ENTITY goffice010-download-ftp
             "&gnome-download-ftp;/goffice/0.10/goffice-&goffice010-version;.tar.xz">
-  <!ENTITY goffice010-md5sum        "a260760abed11f510db712305d82884b">
+  <!ENTITY goffice010-md5sum        "90fd17c6fe205b779571e00d9b0b4727">
   <!ENTITY goffice010-size          "2.1 MB">
   <!ENTITY goffice010-buildsize     "91 MB">
   <!ENTITY goffice010-time          "1.2 SBU">

Modified: trunk/BOOK/xsoft/office/abiword.xml
==============================================================================
--- trunk/BOOK/xsoft/office/abiword.xml	Sat Mar 16 05:17:25 2013	(r11100)
+++ trunk/BOOK/xsoft/office/abiword.xml	Sat Mar 16 09:48:02 2013	(r11101)
@@ -4,16 +4,21 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
+  <!ENTITY AbiWord-minor-version "2.9">
+
   <!ENTITY AbiWord-download-http
-  "http://www.abisource.com/downloads/abiword/&AbiWord-version;/source/abiword-&AbiWord-version;.tar.gz">
+           "http://www.abisource.com/downloads/abiword/&AbiWord-version;/source/abiword-&AbiWord-version;.tar.gz">
   <!ENTITY AbiWord-download-ftp  " ">
-  <!ENTITY AbiWord-md5sum        "cb9852ee7245eea41a290e8fe5e2dff2">
+  <!ENTITY AbiWord-md5sum        "62e59bea4279c7ec48de8824aea8dc58">
   <!ENTITY AbiWord-size          "10 MB">
-  <!ENTITY AbiWord-buildsize     "484 MB">
-  <!ENTITY AbiWord-time          "6.6 SBU">
+
   <!ENTITY AbiWordDocs-download-http
-  "http://www.abisource.com/downloads/abiword/&AbiWord-version;/source/abiword-docs-&AbiWord-version;.tar.gz">
-  <!ENTITY AbiWord-minor-version "2.9">
+           "http://www.abisource.com/downloads/abiword/&AbiWord-version;/source/abiword-docs-&AbiWord-version;.tar.gz">
+  <!ENTITY AbiWordDocs-md5sum        "1.4 MB">
+  <!ENTITY AbiWordDocs-size          "4e694a7ba6bf8294b3498118f2b6eb27">
+
+  <!ENTITY AbiWord-buildsize     "1.8 GB (160 MB installed)">
+  <!ENTITY AbiWord-time          "6.6 SBU">
 ]>
 
 <sect1 id="abiword" xreflabel="AbiWord-&AbiWord-version;">
@@ -34,7 +39,7 @@
     <title>Introduction to AbiWord</title>
 
     <para>
-      <application>AbiWord</application> is a word processor. It is useful for
+      <application>AbiWord</application> is a word processor which is useful for
       writing reports, letters and other formatted documents.
     </para>
 
@@ -75,19 +80,20 @@
     </itemizedlist>
 
     <bridgehead renderas="sect3">Additional Downloads</bridgehead>
-    <itemizedlist spacing='compact'>
+    <itemizedlist spacing="compact">
       <listitem>
         <para>
-          Optional Documentation: If running on a gnome desktop, the help menu
-          will open <application>epiphany</application> at
-          <ulink url="http://www.abisource.com/help/en-US/index.html"/>. If you
-          wish to install a copy of the en-US, fr-FR and pl-PL HTML
-          documentation on your machine, download
-          <ulink url="&AbiWordDocs-download-http;"/> (size 1.4MB md5sum
-          ca0b5bc27d20d542297bffd707b07d63). The local files will not be
-          automatically referenced if you do not have a fairly complete gnome
-          desktop (epiphany and yelp on their own are not enough), but you can
-          still open them in your browser of choice.
+          AbiWord Docs: <ulink url="&AbiWordDocs-download-http;"/>
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          AbiWord Docs MD5 sum: &AbiWordDocs-md5sum;
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          AbiWord Docs size: &AbiWordDocs-size;
         </para>
       </listitem>
     </itemizedlist>
@@ -98,58 +104,47 @@
     <para role="required">
       <xref linkend="boost"/>,
       <xref linkend="fribidi"/>,
-      <xref linkend="goffice"/>,
-      <xref linkend="libjpeg"/>,
-      <xref linkend="libpng"/>,
-      <xref linkend="librsvg"/> and
+      <xref linkend="goffice010"/> and
       <xref linkend="wv"/>
     </para>
 
     <bridgehead renderas="sect4">Recommended</bridgehead>
     <para role="recommended">
-      <xref linkend="enchant"/> (for spellchecking)
+      <xref linkend="enchant"/> 
     </para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional">
-      <xref linkend="dbus-glib"/> (for the collab sugar backend),
-      <xref linkend="empathy"/> and
-      <xref linkend="telepathy-glib"/> (for the collab telepathy backend),
-      <xref linkend="gnutls"/> and
-      <xref linkend="libsoup"/> (for the collab service),
-      <ulink url="http://www.abisource.com/projects/link-grammar/">Link Grammar Parser</ulink>,
       <ulink url="http://aiksaurus.sourceforge.net/">Aiksaurus</ulink>,
-      <ulink url="http://helm.cs.unibo.it/mml-widget/">GtkMathView</ulink>
-      (requires
-      <ulink url="http://www.gnome-db.org/">libgnomedb version <1.3.0</ulink>*
-      which requires
-      <ulink url="http://www.gnome-db.org/">libgda version <1.3.0</ulink>),
-      <ulink url="http://sourceforge.net/projects/mission-control/files/">libmissioncontrol</ulink>,
-      <ulink url="http://ftp.imendio.com/pub/imendio/loudmouth/src/">loudmouth</ulink>
-      (for the collab xmpp backend),
+      <xref linkend="dbus-glib"/>,
+      <xref linkend="evolution-data-server"/>,
+      <xref linkend="gobject-introspection"/>,
+      <ulink url="http://helm.cs.unibo.it/mml-widget/">GtkMathView</ulink>,
+      <ulink url="&gnome-download-http;/libchamplain">libchamplain</ulink>,
+      <xref linkend="libgcrypt"/>,
+      <xref linkend="libical"/>,
+      <xref linkend="libsoup"/>,
       <ulink url="http://sourceforge.net/projects/wvware">libwmf</ulink>,
-      <ulink url="http://helm.cs.unibo.it/mml-widget/">GtkMathView</ulink> (requires
-      <ulink url="http://sourceforge.net/projects/gmetadom/">Gnome DOM Bindings</ulink>
-      which requires
-      <ulink url="http://gdome2.cs.unibo.it/">gdome2</ulink>),
-      <ulink url="http://libwpd.sourceforge.net/">libwpd</ulink>,
-      <ulink url="http://libots.sourceforge.net/">OTS</ulink>, and
-      <ulink url="http://software.frodo.looijaard.name/psiconv/">Psiconv</ulink>
-      Some of these are not automatically detected and need to be specified to the
-      configure script.
+      <ulink url="http://sourceforge.net/projects/libwpd/">libwpd</ulink>,
+      <ulink url="http://sourceforge.net/projects/libwpg/">libwpg</ulink>,
+      <ulink url="http://sourceforge.net/projects/libwps/">libwps</ulink>,
+      <ulink url="http://www.abisource.com/projects/link-grammar/">Link Grammar Parser</ulink>,
+      <ulink url="&gnome-download-http;/loudmouth">Loudmouth</ulink>,
+      <xref linkend="redland"/>,
+      <xref linkend="telepathy-glib"/>,
+      <ulink url="http://libots.sourceforge.net/">OTS</ulink>
+      <ulink url="http://software.frodo.looijaard.name/psiconv/">Psiconv</ulink> and
+      <ulink url="http://www.valgrind.org/">Valgrind</ulink>
     </para>
 
-    <para>
-      * The
-      <application>libgda</application>/<application>libgnomedb</application>
-      stack required for <application>AbiWord</application> database access may
-      conflict with the versions used by the <xref linkend="gnumeric"/> database
-      plugin. Though the libraries themselves pose no conflict, the executables
-      and support files may overwrite one another. Note that the current
-      (version 4.1.x) stack does not pose a conflict with any of the previous
-      versions (but does not support <application>AbiWord</application> database
-      access. <application>AbiWord</application> requires versions <1.3.0.
-    </para>
+    <note>
+      <para>
+        To enable many of the optional dependencies, review the information
+        from <command>./configure --help</command> for the necessary switches
+        you must pass to the <command>configure</command> script.
+      </para>
+    </note>
+
 
     <para condition="html" role="usernotes">
       User Notes: <ulink url="&blfs-wiki;/abiword"/>
@@ -164,7 +159,7 @@
       commands:
     </para>
 
-<screen><userinput>./configure --prefix=/usr --disable-static &&
+<screen><userinput>./configure --prefix=/usr &&
 make</userinput></screen>
 
     <para>
@@ -191,14 +186,24 @@
     </para>
 
 <screen role="root"><userinput>make install</userinput></screen>
+
   </sect2>
 
   <sect2 role="commands">
     <title>Command Explanations</title>
 
     <para>
-      <option>--disable-static</option>: This switch prevents the static library
-      being built.
+      <option>--disable-collab-backend-telepathy</option>: This switch disables
+      <application>Telepathy</application> Colab backend which causes build to
+      fail when using recent versions of <xref linkend="telepathy-glib"/>.
+    </para>
+
+    <para>
+      <option>--without-evolution-data-server</option>: This switch disables
+      <application>AbiWord</application>
+      <application>Evolution Data Server</application> support which is known
+      to fail when using recent versions of
+      <xref linkend="evolution-data-server"/>.
     </para>
 
     <para>
@@ -209,6 +214,7 @@
       <ulink url="http://www.abisource.com/projects/link-grammar/">Link Grammar
       Parser</ulink>
     </para>
+
   </sect2>
 
   <sect2 role="configuration">
@@ -265,23 +271,31 @@
         run the <command>update-desktop-database</command> command to update the
         mimeinfo cache and allow the Help system to work.
       </para>
+
     </sect3>
+
   </sect2>
 
   <sect2 role="content">
     <title>Contents</title>
 
     <segmentedlist>
-      <segtitle>Installed Programs</segtitle>
-      <segtitle>Installed Libraries</segtitle>
+      <segtitle>Installed Program</segtitle>
+      <segtitle>Installed Library</segtitle>
       <segtitle>Installed Directories</segtitle>
 
       <seglistitem>
-        <seg>abiword</seg>
-        <seg>libabiword-&AbiWord-minor-version; and one or more plugin library
-        support modules</seg>
-        <seg>/usr/lib/abiword-&AbiWord-minor-version; and
-        /usr/share/abiword-&AbiWord-minor-version;</seg>
+        <seg>
+          abiword
+        </seg>
+        <seg>
+          libabiword-&AbiWord-minor-version;.so
+        </seg>
+        <seg>
+          /usr/include/abiword-&AbiWord-minor-version;,
+          /usr/lib/abiword-&AbiWord-minor-version; and
+          /usr/share/abiword-&AbiWord-minor-version;
+        </seg>
       </seglistitem>
     </segmentedlist>
 
@@ -305,7 +319,7 @@
       </varlistentry>
 
       <varlistentry id="libabiword">
-        <term><filename class='libraryfile'>libabiword-&AbiWord-minor-version;.so</filename></term>
+        <term><filename class="libraryfile">libabiword-&AbiWord-minor-version;.so</filename></term>
         <listitem>
           <para>
             provides functions to access MS Word documents.
@@ -315,6 +329,9 @@
           </indexterm>
         </listitem>
       </varlistentry>
+
     </variablelist>
+
   </sect2>
+
 </sect1>

Modified: trunk/BOOK/xsoft/office/gnumeric.xml
==============================================================================
--- trunk/BOOK/xsoft/office/gnumeric.xml	Sat Mar 16 05:17:25 2013	(r11100)
+++ trunk/BOOK/xsoft/office/gnumeric.xml	Sat Mar 16 09:48:02 2013	(r11101)
@@ -6,14 +6,14 @@
 
   <!ENTITY gnumeric-download-http "&gnome-download-http;/gnumeric/1.12/gnumeric-&gnumeric-version;.tar.xz">
   <!ENTITY gnumeric-download-ftp  "&gnome-download-ftp;/gnumeric/1.12/gnumeric-&gnumeric-version;.tar.xz">
-  <!ENTITY gnumeric-md5sum        "3fd87cca95334b5d8ac922989670fe27">
+  <!ENTITY gnumeric-md5sum        "b6b56865113678a6f59b7f9f43be737d">
   <!ENTITY gnumeric-size          "15 MB">
   <!ENTITY gnumeric-buildsize     "280 MB">
   <!ENTITY gnumeric-time          "2.6 SBU">
 ]>
 
 <sect1 id="gnumeric" xreflabel="Gnumeric-&gnumeric-version;">
-  <?dbhtml filename="gnumeric.html" ?>
+  <?dbhtml filename="gnumeric.html"?>
 
   <sect1info>
     <othername>$LastChangedBy$</othername>
@@ -108,7 +108,8 @@
     <para>Install <application>Gnumeric</application> by running the following
     commands:</para>
 
-<screen><userinput>./configure --prefix=/usr &&
+<screen><userinput>sed -e "s at zz-application/zz-winassoc-xls;@@" -i gnumeric.desktop.in &&
+./configure --prefix=/usr &&
 make</userinput></screen>
 
     <para>
@@ -133,6 +134,11 @@
     <title>Command Explanations</title>
 
     <para>
+      <command>sed -e "s at zz-application/zz-winassoc-xls;@@" ...</command>: This
+      sed removes invalid mime type from the .desktop file.
+    </para>
+
+    <para>
       <option>--enable-pdfdocs</option>: Use this switch if you have
       installed dblatex and wish to create PDF docs.
     </para>



More information about the blfs-book mailing list