[blfs-book] r11099 - in trunk/BOOK: . general/genlib general/graphlib general/prog general/sysutils gnome/core introduction/welcome multimedia/libdriv multimedia/videoutils postlfs/config postlfs/security pst/printing server/other x/installing xsoft/other

krejzi at higgs.linuxfromscratch.org krejzi at higgs.linuxfromscratch.org
Sat Mar 16 05:11:58 PDT 2013


Author: krejzi
Date: Sat Mar 16 05:11:58 2013
New Revision: 11099

Log:
Package updates, additions and tweaks. See commit log and blfs changelog.

Added:
   trunk/BOOK/general/genlib/libgusb.xml   (contents, props changed)
Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/general/genlib/genlib.xml
   trunk/BOOK/general/genlib/libassuan.xml
   trunk/BOOK/general/genlib/telepathy-logger.xml
   trunk/BOOK/general/graphlib/harfbuzz.xml
   trunk/BOOK/general/prog/dejagnu.xml
   trunk/BOOK/general/prog/git.xml
   trunk/BOOK/general/sysutils/colord.xml
   trunk/BOOK/general/sysutils/dbus-bindings.xml
   trunk/BOOK/gnome/core/libsecret.xml
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/multimedia/libdriv/libdvdcss.xml
   trunk/BOOK/multimedia/videoutils/ffmpeg.xml
   trunk/BOOK/multimedia/videoutils/mplayer.xml
   trunk/BOOK/postlfs/config/users.xml
   trunk/BOOK/postlfs/security/gpgme.xml
   trunk/BOOK/postlfs/security/iptables.xml
   trunk/BOOK/pst/printing/cups-filters.xml
   trunk/BOOK/server/other/openldap.xml
   trunk/BOOK/x/installing/x7driver.xml
   trunk/BOOK/xsoft/other/thunderbird.xml

Modified: trunk/BOOK/general.ent
==============================================================================
--- trunk/BOOK/general.ent	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/general.ent	Sat Mar 16 05:11:58 2013	(r11099)
@@ -3,13 +3,13 @@
 $Date$
 -->
 
-<!ENTITY day          "15">                   <!-- Always 2 digits -->
+<!ENTITY day          "16">                   <!-- Always 2 digits -->
 <!ENTITY month        "03">                   <!-- Always 2 digits -->
 <!ENTITY year         "2013">
 <!ENTITY copyrightdate "2001-&year;">
 <!ENTITY copyholder   "The BLFS Development Team">
 <!ENTITY version      "&year;-&month;-&day;">
-<!ENTITY releasedate  "March 15th, &year;">
+<!ENTITY releasedate  "March 16th, &year;">
 <!ENTITY pubdate      "&year;-&month;-&day;"> <!-- metadata req. by TLDP -->
 <!ENTITY blfs-version "svn">                  <!-- svn|[release #] -->
 <!ENTITY lfs-version  "development">          <!-- version|testing|unstable|development] -->
@@ -150,8 +150,8 @@
 <!ENTITY gnupg-version                "1.4.13">
 <!ENTITY gnupg2-version               "2.0.19">
 <!ENTITY gnutls-version               "3.1.9">
-<!ENTITY gpgme-version                "1.3.2">
-<!ENTITY iptables-version             "1.4.17">
+<!ENTITY gpgme-version                "1.4.0">
+<!ENTITY iptables-version             "1.4.18">
 <!ENTITY libcap2-version              "2.22">
 <!ENTITY liboauth-version             "1.0.0">
 <!ENTITY libpwquality-version         "1.2.1">
@@ -229,7 +229,7 @@
 <!ENTITY json-c-version               "0.10">
 <!ENTITY json-glib-version            "0.15.2">
 <!ENTITY keyutils-version             "1.5.5">
-<!ENTITY libassuan-version            "2.0.3">
+<!ENTITY libassuan-version            "2.1.0">
 <!ENTITY libatasmart-version          "0.19">
 <!ENTITY libatomic_ops-version        "7.2d">
 <!ENTITY libcroco-version             "0.6.8">
@@ -242,6 +242,7 @@
 <!ENTITY libglade-version             "2.6.4">
 <!ENTITY libgpg-error-version         "1.11">
 <!ENTITY libgsf-version               "1.14.26">
+<!ENTITY libgusb-version              "0.1.6">
 <!ENTITY libical-version              "0.48">
 <!ENTITY libidl-version               "0.8.14">
 <!ENTITY libidn-version               "1.25">
@@ -266,9 +267,9 @@
 <!ENTITY sbc-version                  "1.0">
 <!ENTITY slib-version                 "3b3">
 <!ENTITY talloc-version               "2.0.8">
-<!ENTITY telepathy-farstream-version  "0.6.0">
 <!ENTITY telepathy-glib-version       "0.20.1">
-<!ENTITY telepathy-logger-version     "0.6.0">
+<!ENTITY telepathy-logger-version     "0.8.0">
+<!ENTITY telepathy-farstream-version  "0.6.0">
 <!ENTITY telepathy-mission-control-version "5.14.0">
 <!ENTITY wv-version                   "1.2.9">
 
@@ -281,7 +282,7 @@
 <!ENTITY fribidi-version              "0.19.5">
 <!ENTITY gegl-version                 "0.2.0">
 <!ENTITY giflib-version               "4.1.6">
-<!ENTITY harfbuzz-version             "0.9.9">
+<!ENTITY harfbuzz-version             "0.9.13">
 <!ENTITY ijs-version                  "0.35">
 <!ENTITY imlib2-version               "1.4.5">
 <!ENTITY jasper-version               "1.900.1">
@@ -330,10 +331,10 @@
 <!ENTITY at-version                   "3.1.13">
 <!ENTITY autofs-version               "5.0.7">
 <!ENTITY bluez-version                "4.101">
-<!ENTITY colord-version               "0.1.28">
+<!ENTITY colord-version               "0.1.30">
 <!ENTITY cpio-version                 "2.11">
 <!ENTITY dbus-version                 "1.6.8">
-<!ENTITY dbus-glib-version            "0.100">
+<!ENTITY dbus-glib-version            "0.100.2">
 <!ENTITY dbus-python-version          "1.1.1">
 <!ENTITY eject-version                "2.1.5">
 <!ENTITY fcron-version                "3.1.1">
@@ -367,13 +368,13 @@
 <!ENTITY check-version                "0.9.9">
 <!ENTITY cmake-version                "2.8.10.2">
 <!ENTITY cvs-version                  "1.11.23">
-<!ENTITY dejagnu-version              "1.5">
+<!ENTITY dejagnu-version              "1.5.1">
 <!ENTITY doxygen-version              "1.8.3.1">
 <!ENTITY expect-version               "5.45">
 <!ENTITY gcc-version                  "4.7.2">
 <!ENTITY gc-version                   "7.2d">
 <!ENTITY gdb-version                  "7.5">
-<!ENTITY git-version                  "1.8.1.5">
+<!ENTITY git-version                  "1.8.2">
 <!ENTITY guile-version                "2.0.7">
 <!ENTITY icedtea-version              "2.3.3">
 <!ENTITY openjdk-version              "1.7.0.9">
@@ -507,7 +508,7 @@
 <!ENTITY sqlite-version               "3.7.15.2">
 
 <!-- Chapter 23 -->
-<!ENTITY openldap-version             "2.4.33">
+<!ENTITY openldap-version             "2.4.34">
 <!ENTITY virtuoso-version             "6.1.6">
 <!ENTITY soprano-version              "2.9.0">
 <!ENTITY xinetd-version               "2.3.15">
@@ -625,7 +626,7 @@
 <!ENTITY gnome-doc-utils-version      "0.20.10">
 <!ENTITY yelp-xsl-version             "3.6.1">
 <!ENTITY libgnome-keyring-version     "3.6.0">
-<!ENTITY libsecret-version            "0.12">
+<!ENTITY libsecret-version            "0.14">
 <!ENTITY gsettings-desktop-schemas-version "3.6.1">
 <!ENTITY dconf-version                "0.14.1">
 <!ENTITY GConf-version                "3.2.6">
@@ -786,7 +787,7 @@
 <!ENTITY pan-version                  "0.133">
 <!ENTITY pidgin-version               "2.10.7">
 <!ENTITY rox-filer-version            "2.11">
-<!ENTITY thunderbird-version          "17.0.3">
+<!ENTITY thunderbird-version          "17.0.4">
 <!ENTITY transmission-version         "2.77">
 <!ENTITY xchat-version                "2.8.8">
 <!ENTITY xdg-utils-version            "1.1.0-rc1">
@@ -862,7 +863,7 @@
 
 <!-- Chapter 40 -->
 <!ENTITY dvb-apps-version             "2012-06-10">
-<!ENTITY ffmpeg-version               "1.1.3">
+<!ENTITY ffmpeg-version               "1.2">
 <!ENTITY mplayer-version              "1.1">
 <!ENTITY xine-ui-version              "0.99.7">
 <!ENTITY transcode-version            "1.1.7">
@@ -879,7 +880,7 @@
 <!-- Part XII -->
 <!-- Chapter 42 -->
 <!ENTITY cups-version                 "1.6.1">
-<!ENTITY cups-filters-version         "1.0.29">
+<!ENTITY cups-filters-version         "1.0.30">
 <!ENTITY LPRng-version                "3.8.B">
 <!ENTITY gs-version                   "9.06">
 <!ENTITY gutenprint-version           "5.2.9">

Modified: trunk/BOOK/general/genlib/genlib.xml
==============================================================================
--- trunk/BOOK/general/genlib/genlib.xml	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/general/genlib/genlib.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -73,6 +73,7 @@
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="libglade.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="libgpg-error.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="libgsf.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="libgusb.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="libical.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="libidl.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="libidn.xml"/>

Modified: trunk/BOOK/general/genlib/libassuan.xml
==============================================================================
--- trunk/BOOK/general/genlib/libassuan.xml	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/general/genlib/libassuan.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -6,10 +6,10 @@
 
   <!ENTITY libassuan-download-http " ">
   <!ENTITY libassuan-download-ftp
-  "ftp://ftp.gnupg.org/gcrypt/libassuan/libassuan-&libassuan-version;.tar.bz2">
-  <!ENTITY libassuan-md5sum        "179d1918325fdb928c7bd90b8a514fc7">
-  <!ENTITY libassuan-size          "520 KB">
-  <!ENTITY libassuan-buildsize     "6.4 MB">
+           "ftp://ftp.gnupg.org/gcrypt/libassuan/libassuan-&libassuan-version;.tar.bz2">
+  <!ENTITY libassuan-md5sum        "b3231eec8e567f4f9294474a387378f5">
+  <!ENTITY libassuan-size          "528 KB">
+  <!ENTITY libassuan-buildsize     "7.5 MB">
   <!ENTITY libassuan-time          "less than 0.1 SBU">
 ]>
 
@@ -21,95 +21,119 @@
     <date>$Date$</date>
   </sect1info>
 
-  <title>Libassuan-&libassuan-version;</title>
+  <title>libassuan-&libassuan-version;</title>
 
   <indexterm zone="libassuan">
-    <primary sortas="a-Libassuan">Libassuan</primary>
+    <primary sortas="a-libassuan">libassuan</primary>
   </indexterm>
 
   <sect2 role="package">
-    <title>Introduction to Libassuan</title>
+    <title>Introduction to libassuan</title>
 
-    <para>The <application>Libassuan</application> package contains an inter
-    process communication library used by some of the other
-    <application>GnuPG</application> related packages.
-    <application>Libassuan</application>'s primary use is to allow a client to
-    interact with a non-persistent server. <application>Libassuan</application>
-    is not, however, limited to use with <application>GnuPG</application>
-    servers and clients. It was designed to be flexible enough to meet the
-    demands of many transaction based environments with non-persistent
-    servers.</para>
+    <para>
+      The <application>libassuan</application> package contains an inter
+      process communication library used by some of the other
+      <application>GnuPG</application> related packages.
+      <application>libassuan</application>'s primary use is to allow a
+      client to interact with a non-persistent server.
+      <application>libassuan</application> is not, however, limited to
+      use with <application>GnuPG</application> servers and clients. It
+      was designed to be flexible enough to meet the demands of many
+      transaction based environments with non-persistent servers.
+    </para>
 
     &lfs72_checked;
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
-        <para>Download (HTTP): <ulink url="&libassuan-download-http;"/></para>
+        <para>
+          Download (HTTP): <ulink url="&libassuan-download-http;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download (FTP): <ulink url="&libassuan-download-ftp;"/></para>
+        <para>
+          Download (FTP): <ulink url="&libassuan-download-ftp;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download MD5 sum: &libassuan-md5sum;</para>
+        <para>
+          Download MD5 sum: &libassuan-md5sum;
+        </para>
       </listitem>
       <listitem>
-        <para>Download size: &libassuan-size;</para>
+        <para>
+          Download size: &libassuan-size;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated disk space required: &libassuan-buildsize;</para>
+        <para>
+          Estimated disk space required: &libassuan-buildsize;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated build time: &libassuan-time;</para>
+        <para>
+          Estimated build time: &libassuan-time;
+        </para>
       </listitem>
     </itemizedlist>
 
-    <bridgehead renderas="sect3">Libassuan Dependencies</bridgehead>
+    <bridgehead renderas="sect3">libassuan Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="libgpg-error"/></para>
+    <para role="required">
+      <xref linkend="libgpg-error"/>
+    </para>
+
+    <bridgehead renderas="sect4">Optional</bridgehead>
+    <para role="optional">
+      <xref linkend="texlive"/>
+    </para>
 
     <para condition="html" role="usernotes">User Notes:
-    <ulink url="&blfs-wiki;/libassuan"/></para>
+      <ulink url="&blfs-wiki;/libassuan"/>
+    </para>
   </sect2>
 
   <sect2 role="installation">
-    <title>Installation of Libassuan</title>
+    <title>Installation of libassuan</title>
 
-    <para>Install <application>Libassuan</application> by running the
-    following commands:</para>
+    <para>
+      Install <application>libassuan</application> by running the
+      following commands:
+    </para>
 
+<!-- .texi documentation does not build with Texinfo 5.1 -->
 <screen><userinput>./configure --prefix=/usr &&
-make &&
+make</userinput></screen>
 
-makeinfo --html --no-split -o doc/assuan_nochunks.html doc/assuan.texi &&
-makeinfo --plaintext       -o doc/assuan.txt           doc/assuan.texi</userinput></screen>
-
-    <para>If you wish to build alternate formats of the documentation, you
-    must have <xref linkend="texlive"/>
-    installed, then issue the following command:</para>
-
-<screen><userinput>make -k -C doc pdf ps html</userinput></screen>
-
-    <para>To test the results, issue: <command>make check</command>.</para>
-
-    <para>Now, as the <systemitem class="username">root</systemitem>
-    user:</para>
-
-<screen role="root"><userinput>make install &&
-
-install -v -m755 -d /usr/share/doc/libassuan-&libassuan-version;/html &&
-install -v -m644    README doc/assuan{_nochunks.html,.txt,.texi} \
-                    /usr/share/doc/libassuan-&libassuan-version;</userinput></screen>
-
-    <para>If you built the additional documentation, install it by issuing the
-    following commands as the <systemitem class="username">root</systemitem>
-    user:</para>
-
-<screen role="root"><userinput>install -v -m644 doc/assuan.html/* \
-                 /usr/share/doc/libassuan-&libassuan-version;/html &&
-install -v -m644 doc/assuan.{pdf,ps,dvi} \
-                 /usr/share/doc/libassuan-&libassuan-version;</userinput></screen>
+    <para>
+      If you wish to build documentation, you must have
+      <xref linkend="texlive"/> installed, then issue
+      the following command:
+    </para>
+
+<screen><userinput>make -C doc pdf ps</userinput></screen>
+
+    <para>
+      To test the results, issue: <command>make check</command>.
+    </para>
+
+    <para>
+      Now, as the <systemitem class="username">root</systemitem> user:
+    </para>
+
+<screen role="root"><userinput>make install</userinput></screen>
+
+    <para>
+      If you built the documentation, install it by running the
+      following commands as the
+      <systemitem class="username">root</systemitem> user:
+    </para>
+
+<screen role="root"><userinput>install -v -dm755 /usr/share/doc/libassuan-&libassuan-version; &&
+install -v -m644  doc/assuan.{pdf,ps,dvi} \
+                  /usr/share/doc/libassuan-&libassuan-version;</userinput></screen>
   </sect2>
 
   <sect2 role="content">
@@ -117,13 +141,19 @@
 
     <segmentedlist>
       <segtitle>Installed Program</segtitle>
-      <segtitle>Installed Libraries</segtitle>
+      <segtitle>Installed Library</segtitle>
       <segtitle>Installed Directory</segtitle>
 
       <seglistitem>
-        <seg>libassuan-config</seg>
-        <seg>libassuan.so</seg>
-        <seg>/usr/share/doc/libassuan-&libassuan-version;</seg>
+        <seg>
+          libassuan-config
+        </seg>
+        <seg>
+          libassuan.so
+        </seg>
+        <seg>
+          /usr/share/doc/libassuan-&libassuan-version;
+        </seg>
       </seglistitem>
     </segmentedlist>
 
@@ -132,29 +162,21 @@
       <?dbfo list-presentation="list"?>
       <?dbhtml list-presentation="table"?>
 
-      <varlistentry id="libassuan-config">
-        <term><command>libassuan-config</command></term>
-        <listitem>
-          <para>is a utility used to configure and build applications based on
-          the libassuan library. It can be used to query the C compiler and
-          linker flags which are required to correctly compile and link the
-          application against the libassuan library.</para>
-          <indexterm zone="libassuan libassuan-config">
-            <primary sortas="b-libassuan-config">libassuan-config</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
       <varlistentry id="libassuan-lib">
         <term><filename class="libraryfile">libassuan.so</filename></term>
         <listitem>
-          <para>is an inter process communication library which implements the
-          Assuan protocol.</para>
+          <para>
+            is an inter process communication library which
+            implements the Assuan protocol.
+          </para>
           <indexterm zone="libassuan libassuan-lib">
             <primary sortas="c-libassuan">libassuan.so</primary>
           </indexterm>
         </listitem>
       </varlistentry>
+
     </variablelist>
+
   </sect2>
+
 </sect1>

Added: trunk/BOOK/general/genlib/libgusb.xml
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ trunk/BOOK/general/genlib/libgusb.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -0,0 +1,177 @@
+<?xml version="1.0" encoding="ISO-8859-1"?>
+<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
+   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
+  <!ENTITY % general-entities SYSTEM "../../general.ent">
+  %general-entities;
+
+  <!ENTITY libgusb-download-http "http://people.freedesktop.org/~hughsient/releases/libgusb-&libgusb-version;.tar.xz">
+  <!ENTITY libgusb-download-ftp  " ">
+  <!ENTITY libgusb-md5sum        "672058e7a49a38259ab6ea01470c2fa2">
+  <!ENTITY libgusb-size          "260 KB">
+  <!ENTITY libgusb-buildsize     "4.2 MB">
+  <!ENTITY libgusb-time          "0.1 SBU">
+]>
+
+<sect1 id="libgusb" xreflabel="libgusb-&libgusb-version;">
+  <?dbhtml filename="libgusb.html"?>
+
+  <sect1info>
+    <othername>$LastChangedBy$</othername>
+    <date>$Date$</date>
+  </sect1info>
+
+  <title>libgusb-&libgusb-version;</title>
+
+  <indexterm zone="libgusb">
+    <primary sortas="a-libgusb">libgusb</primary>
+  </indexterm>
+
+  <sect2 role="package">
+    <title>Introduction to libgusb</title>
+
+    <para>
+      The <application>libgusb</application> package contains the GObject
+      wrappers for <application>libusb-1.0</application> that makes it
+      easy to do asynchronous control, bulk and interrupt transfers with
+      proper cancellation and integration into a mainloop.
+    </para>
+
+    &lfs72_checked;
+
+    <bridgehead renderas="sect3">Package Information</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>
+          Download (HTTP): <ulink url="&libgusb-download-http;"/>
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          Download (FTP): <ulink url="&libgusb-download-ftp;"/>
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          Download MD5 sum: &libgusb-md5sum;
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          Download size: &libgusb-size;
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          Estimated disk space required: &libgusb-buildsize;
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          Estimated build time: &libgusb-time;
+        </para>
+      </listitem>
+    </itemizedlist>
+
+    <bridgehead renderas="sect3">libgusb Dependencies</bridgehead>
+
+    <bridgehead renderas="sect4">Required</bridgehead>
+    <para role="required">
+      <xref linkend="glib2"/> and
+      <xref linkend="libusb"/>
+    </para>
+
+    <bridgehead renderas="sect4">Recommended</bridgehead>
+    <para role="recommended">
+      <xref linkend="gobject-introspection"/>,
+      <xref linkend="udev"/> or
+      <xref linkend="udev-extras"/> (for GUdev) and
+      <xref linkend="vala"/>
+    </para>
+
+    <bridgehead renderas="sect4">Optional</bridgehead>
+    <para role="optional">
+      <xref linkend="gtk-doc"/>
+    </para>
+
+    <para condition="html" role="usernotes">
+      User Notes: <ulink url="&blfs-wiki;/libgusb"/>
+    </para>
+  </sect2>
+
+  <sect2 role="installation">
+    <title>Installation of libgusb</title>
+
+    <para>
+      Install <application>libgusb</application> by running the following
+      commands:
+    </para>
+
+<screen><userinput>./configure --prefix=/usr --disable-static &&
+make</userinput></screen>
+
+    <para>
+      To test the results, issue: <command>make check</command>.
+    </para>
+
+    <para>
+      Now, as the <systemitem class="username">root</systemitem> user:
+    </para>
+
+<screen role="root"><userinput>make install</userinput></screen>
+  </sect2>
+
+  <sect2 role="commands">
+    <title>Command Explanations</title>
+
+    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
+      href="../../xincludes/static-libraries.xml"/>
+
+    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
+    href="../../xincludes/gtk-doc-rebuild.xml"/>
+
+  </sect2>
+
+  <sect2 role="content">
+    <title>Contents</title>
+
+    <segmentedlist>
+      <segtitle>Installed Programs</segtitle>
+      <segtitle>Installed Library</segtitle>
+      <segtitle>Installed Directories</segtitle>
+
+      <seglistitem>
+        <seg>
+          None
+        </seg>
+        <seg>
+          libgusb.so
+        </seg>
+        <seg>
+          /usr/include/gusb-1 and
+          /usr/share/gtk-doc/html/gusb
+        </seg>
+      </seglistitem>
+    </segmentedlist>
+
+    <variablelist>
+      <bridgehead renderas="sect3">Short Descriptions</bridgehead>
+      <?dbfo list-presentation="list"?>
+      <?dbhtml list-presentation="table"?>
+
+      <varlistentry id="libgusb-lib">
+        <term><filename class="libraryfile">libgusb.so</filename></term>
+        <listitem>
+          <para>
+            contains the <application>libgusb</application> API functions.
+          </para>
+          <indexterm zone="libgusb libgusb-lib">
+            <primary sortas="c-libgusb">libgusb.so</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+    </variablelist>
+
+  </sect2>
+
+</sect1>

Modified: trunk/BOOK/general/genlib/telepathy-logger.xml
==============================================================================
--- trunk/BOOK/general/genlib/telepathy-logger.xml	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/general/genlib/telepathy-logger.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -7,9 +7,9 @@
   <!ENTITY telepathy-logger-download-http
            "http://telepathy.freedesktop.org/releases/telepathy-logger/telepathy-logger-&telepathy-logger-version;.tar.bz2">
   <!ENTITY telepathy-logger-download-ftp  " ">
-  <!ENTITY telepathy-logger-md5sum        "f453c49e53898c64bc423f0fdf117290">
-  <!ENTITY telepathy-logger-size          "512 KB">
-  <!ENTITY telepathy-logger-buildsize     "12 MB">
+  <!ENTITY telepathy-logger-md5sum        "e513eaa767344821073a0b7bb8b45217">
+  <!ENTITY telepathy-logger-size          "528 KB">
+  <!ENTITY telepathy-logger-buildsize     "16 MB">
   <!ENTITY telepathy-logger-time          "0.2 SBU">
 ]>
 

Modified: trunk/BOOK/general/graphlib/harfbuzz.xml
==============================================================================
--- trunk/BOOK/general/graphlib/harfbuzz.xml	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/general/graphlib/harfbuzz.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -7,8 +7,8 @@
   <!ENTITY harfbuzz-download-http
            "http://www.freedesktop.org/software/harfbuzz/release/harfbuzz-&harfbuzz-version;.tar.bz2">
   <!ENTITY harfbuzz-download-ftp  " ">
-  <!ENTITY harfbuzz-md5sum        "e901ffe556d706b7d43b272f83be7f09">
-  <!ENTITY harfbuzz-size          "860 KB">
+  <!ENTITY harfbuzz-md5sum        "00cdc6644fae1be8c1d566082286b6f9">
+  <!ENTITY harfbuzz-size          "836 KB">
   <!ENTITY harfbuzz-buildsize     "35 MB">
   <!ENTITY harfbuzz-time          "0.3 SBU">
 ]>
@@ -75,8 +75,6 @@
 
     <bridgehead renderas="sect4">Recommended</bridgehead>
     <para role="recommended">
-      <xref linkend="cairo"/> (Built with
-      <xref linkend="fontconfig"/> support),
       <xref linkend="glib2"/>,
       <xref linkend="icu"/> and
       <xref linkend="freetype2"/>
@@ -84,6 +82,7 @@
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional">
+      <xref linkend="cairo"/> and
       <ulink url="http://projects.palaso.org/projects/graphitedev/files">Graphite2</ulink>.
     </para>
 

Modified: trunk/BOOK/general/prog/dejagnu.xml
==============================================================================
--- trunk/BOOK/general/prog/dejagnu.xml	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/general/prog/dejagnu.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -4,12 +4,11 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!-- <!ENTITY dejagnu-download-http "http://freshmeat.net/redir/dejagnu/12564/url_tgz/dejagnu-&dejagnu-version;.tar.gz"> -->
-  <!ENTITY dejagnu-download-http " ">
+  <!ENTITY dejagnu-download-http "http://ftp.gnu.org/pub/gnu/dejagnu/dejagnu-&dejagnu-version;.tar.gz">
   <!ENTITY dejagnu-download-ftp  "ftp://ftp.gnu.org/pub/gnu/dejagnu/dejagnu-&dejagnu-version;.tar.gz">
-  <!ENTITY dejagnu-md5sum        "3df1cbca885e751e22d3ebd1ac64dc3c">
+  <!ENTITY dejagnu-md5sum        "8386e04e362345f50ad169f052f4c4ab">
   <!ENTITY dejagnu-size          "568 KB">
-  <!ENTITY dejagnu-buildsize     "4.5 MB">
+  <!ENTITY dejagnu-buildsize     "5.0 MB">
   <!ENTITY dejagnu-time          "less than 0.1 SBU">
 ]>
 
@@ -35,7 +34,7 @@
       suites on GNU tools. It is written in <command>expect</command>, which
       uses <application>Tcl</application> (Tool command language). It was installed
       by LFS in the temporary <filename class="directory">/tools</filename>
-      directory.  These instructions install it permanently.
+      directory. These instructions install it permanently.
     </para>
 
     &lfs73_checked;
@@ -43,22 +42,34 @@
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
-        <para>Download (HTTP): <ulink url="&dejagnu-download-http;"/></para>
+        <para>
+          Download (HTTP): <ulink url="&dejagnu-download-http;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download (FTP): <ulink url="&dejagnu-download-ftp;"/></para>
+        <para>
+          Download (FTP): <ulink url="&dejagnu-download-ftp;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download MD5 sum: &dejagnu-md5sum;</para>
+        <para>
+          Download MD5 sum: &dejagnu-md5sum;
+        </para>
       </listitem>
       <listitem>
-        <para>Download size: &dejagnu-size;</para>
+        <para>
+          Download size: &dejagnu-size;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated disk space required: &dejagnu-buildsize;</para>
+        <para>
+          Estimated disk space required: &dejagnu-buildsize;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated build time: &dejagnu-time;</para>
+        <para>
+          Estimated build time: &dejagnu-time;
+        </para>
       </listitem>
     </itemizedlist>
 
@@ -95,16 +106,6 @@
 makeinfo --plaintext       -o doc/dejagnu.txt  doc/dejagnu.texi</userinput></screen>
 
     <para>
-      HTML and text documentation was created in the previous step. There
-      are different ways to create additional forms of documentation, if desired.
-      If you have <xref linkend="texlive"/> installed, create PDF and Postscript
-      docs in the <filename class="directory">doc</filename> directory by issuing
-      <command>make pdf ps</command>. If you have <xref linkend="docbook-utils"/>
-      installed, create PDF and Postscript docs in the top-level directory
-      by issuing <command>make dejagnu.{pdf,ps}</command>.
-    </para>
-
-    <para>
       To test the results, issue <command>make check</command>.
     </para>
 
@@ -113,7 +114,7 @@
     </para>
 
 <screen role="root"><userinput>make install &&
-install -v -m755 -d /usr/share/doc/dejagnu-&dejagnu-version; &&
+install -v -dm755   /usr/share/doc/dejagnu-&dejagnu-version; &&
 install -v -m644    doc/dejagnu.{html,txt} \
                     /usr/share/doc/dejagnu-&dejagnu-version;</userinput></screen>
   </sect2>
@@ -124,15 +125,18 @@
     <segmentedlist>
       <segtitle>Installed Program</segtitle>
       <segtitle>Installed Libraries</segtitle>
-      <segtitle>Installed Scripts</segtitle>
       <segtitle>Installed Directory</segtitle>
 
       <seglistitem>
-        <seg>runtest</seg>
-        <seg>None</seg>
-        <seg>There are numerous <application>Expect</application> scripts installed in
-        the <filename class='directory'>/usr/share/dejagnu</filename> hierarchy.</seg>
-        <seg>/usr/share/dejagnu</seg>
+        <seg>
+          runtest
+        </seg>
+        <seg>
+          None
+        </seg>
+        <seg>
+          /usr/share/dejagnu
+        </seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/BOOK/general/prog/git.xml
==============================================================================
--- trunk/BOOK/general/prog/git.xml	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/general/prog/git.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -6,10 +6,10 @@
 
   <!ENTITY git-download-http "http://git-core.googlecode.com/files/git-&git-version;.tar.gz">
   <!ENTITY git-download-ftp  " ">
-  <!ENTITY git-md5sum        "ce168861c23a700b40ffe94475bb1d9e">
+  <!ENTITY git-md5sum        "210834d73c857931c3da34a65eb3e597">
   <!ENTITY git-size          "4.2 MB">
-  <!ENTITY git-buildsize     "200 MB">
-  <!ENTITY git-time          "3.3 SBU (including tests)">
+  <!ENTITY git-buildsize     "225 MB">
+  <!ENTITY git-time          "5.0 SBU (including tests)">
 ]>
 
 <sect1 id="git" xreflabel="git-&git-version;">

Modified: trunk/BOOK/general/sysutils/colord.xml
==============================================================================
--- trunk/BOOK/general/sysutils/colord.xml	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/general/sysutils/colord.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -7,10 +7,10 @@
   <!ENTITY colord-download-http
            "http://www.freedesktop.org/software/colord/releases/colord-&colord-version;.tar.xz">
   <!ENTITY colord-download-ftp  " ">
-  <!ENTITY colord-md5sum        "14a37f7aae8b47d247adea77686d6bd1">
-  <!ENTITY colord-size          "844 KB">
-  <!ENTITY colord-buildsize     "25 MB">
-  <!ENTITY colord-time          "0.2 SBU">
+  <!ENTITY colord-md5sum        "88ec2c419a9903f5bec91d603c0e7097">
+  <!ENTITY colord-size          "908 KB">
+  <!ENTITY colord-buildsize     "30 MB">
+  <!ENTITY colord-time          "0.3 SBU">
 ]>
 
 <sect1 id="colord" xreflabel="Colord-&colord-version;">
@@ -78,7 +78,7 @@
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required">
       <xref linkend="dbus"/>,
-      <xref linkend="glib2"/>,
+      <xref linkend="libgusb"/>,
       <xref linkend="lcms2"/> and
       <xref linkend="sqlite"/>
     </para>
@@ -97,8 +97,7 @@
       <xref linkend="colord-gtk"/> and <xref linkend="gnome-desktop"/>
       (To build example tools),
       <xref linkend="docbook-utils"/>,
-      <xref linkend="gtk-doc"/>,
-      <ulink url="http://people.freedesktop.org/~hughsient/releases/">libgusb</ulink> and
+      <xref linkend="gtk-doc"/> and
       <xref linkend="sane"/>
     </para>
 
@@ -111,6 +110,17 @@
     <title>Installation of Colord</title>
 
     <para>
+      There should be a dedicated user and group to take control
+      of the <command>colord</command> daemon after it is started.
+      Issue the following commands as the
+      <systemitem class="username">root</systemitem> user:
+    </para>
+
+<screen role="root"><userinput>groupadd -g 71 colord &&
+useradd -c "Color Daemon Owner" -d /var/lib/colord -u 71 \
+        -g colord -s /bin/false colord</userinput></screen>
+
+    <para>
       Install <application>Colord</application> by running the following
       commands:
     </para>
@@ -119,37 +129,39 @@
             --sysconfdir=/etc \
             --localstatedir=/var \
             --libexecdir=/usr/lib/colord \
+            --with-daemon-user=colord \
             --enable-vala \
-            --disable-gusb \
             --disable-static &&
 make</userinput></screen>
 
     <para>
-      To test the results, issue: <command>make check</command>.
-    </para>
-
-    <para>
       Now, as the <systemitem class="username">root</systemitem> user:
     </para>
 
 <screen role="root"><userinput>make install</userinput></screen>
 
+    <para>
+      To test the results, issue: <command>make check</command>. Note
+      that system-wide <application>D-Bus</application> daemon must
+      be running or the tests will fail.
+    </para>
+
   </sect2>
 
   <sect2 role="commands">
     <title>Command Explanations</title>
 
     <para>
-      <option>--enable-vala</option>: This switch enables
-      building of the Vala bindings. Remove if you don't
-      have <xref linkend="vala"/> installed.
+      <parameter>--with-daemon-user=colord</parameter>: This
+      switch is used so the <command>colord</command> daemon
+      will run as an unprivileged user instead of
+      <systemitem class="username">root</systemitem> user.
     </para>
 
     <para>
-       <option>--disable-gusb</option>: This switch disables
-       building of the <application>libgusb</application>
-       specific code. Remove it if you have installed
-       <application>libgusb</application>.
+      <option>--enable-vala</option>: This switch enables
+      building of the Vala bindings. Remove if you don't
+      have <xref linkend="vala"/> installed.
     </para>
 
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
@@ -165,16 +177,18 @@
 
     <segmentedlist>
       <segtitle>Installed Programs</segtitle>
-      <segtitle>Installed Library</segtitle>
+      <segtitle>Installed Libraries</segtitle>
       <segtitle>Installed Directories</segtitle>
 
       <seglistitem>
         <seg>
           cd-create-profile, cd-fix-profile, colord,
-          colord-sane and colormgr
+          colord-sane, colord-session and colormgr
         </seg>
         <seg>
-          libcolord.so
+          libcolordprivate.so, libcolord.so, libcolorhug.so,
+          libdtp94-private.so, libhuey-private.so and
+          libmunki-private.so
         </seg>
         <seg>
           /usr/include/colord-1,
@@ -217,18 +231,6 @@
           </indexterm>
         </listitem>
       </varlistentry>
-
-      <varlistentry id="colord-prog">
-        <term><command>colord</command></term>
-        <listitem>
-          <para>
-            is the Color Daemon.
-          </para>
-          <indexterm zone="colord colord-prog">
-            <primary sortas="b-colord">colord</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
 
       <varlistentry id="colormgr">
         <term><command>colormgr</command></term>

Modified: trunk/BOOK/general/sysutils/dbus-bindings.xml
==============================================================================
--- trunk/BOOK/general/sysutils/dbus-bindings.xml	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/general/sysutils/dbus-bindings.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -6,9 +6,9 @@
 
   <!ENTITY dbus-glib-download-http "http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-&dbus-glib-version;.tar.gz">
   <!ENTITY dbus-glib-download-ftp  " ">
-  <!ENTITY dbus-glib-md5sum        "d33959a9c0c6a158f5ac6d640316e89e">
-  <!ENTITY dbus-glib-size          "714 KB">
-  <!ENTITY dbus-glib-buildsize     "8 MB">
+  <!ENTITY dbus-glib-md5sum        "ad0920c7e3aad669163bb59171cf138e">
+  <!ENTITY dbus-glib-size          "732 KB">
+  <!ENTITY dbus-glib-buildsize     "12 MB">
   <!ENTITY dbus-glib-time          "0.1 SBU">
 
   <!ENTITY dbus-python-download-http "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-&dbus-python-version;.tar.gz">
@@ -18,15 +18,6 @@
   <!ENTITY dbus-python-buildsize     "5.7 MB">
   <!ENTITY dbus-python-time          "0.2 SBU">
 
-  <!--
-  <!ENTITY dbus-qt3-download-http "&trinity-repo-http;/dbus-tqt-&trinity-version;.tar.gz">
-  <!ENTITY dbus-qt3-download-ftp  "&trinity-repo-ftp;/dbus-tqt-&trinity-version;.tar.gz">
-  <!ENTITY dbus-qt3-md5sum        "46ae165c068271485c827f6fc6687a9a">
-  <!ENTITY dbus-qt3-size          "234 KB">
-  <!ENTITY dbus-qt3-buildsize     "4 MB">
-  <!ENTITY dbus-qt3-time          "less than 0.1 SBU">
-  -->
-
   <!-- All the other bindings info should be here as well -->
 ]>
 
@@ -67,9 +58,6 @@
       <listitem>
         <para><xref linkend="dbus-python"/></para>
       </listitem>
-      <!-- <listitem>
-        <para><xref linkend="dbus-qt3"/></para>
-      </listitem> -->
     </itemizedlist>
 
   </sect2>
@@ -90,22 +78,34 @@
       <bridgehead renderas="sect4">Package Information</bridgehead>
       <itemizedlist spacing="compact">
         <listitem>
-          <para>Download (HTTP): <ulink url="&dbus-glib-download-http;"/></para>
+          <para>
+            Download (HTTP): <ulink url="&dbus-glib-download-http;"/>
+          </para>
         </listitem>
         <listitem>
-          <para>Download (FTP): <ulink url="&dbus-glib-download-ftp;"/></para>
+          <para>
+            Download (FTP): <ulink url="&dbus-glib-download-ftp;"/>
+          </para>
         </listitem>
         <listitem>
-         <para>Download MD5 sum: &dbus-glib-md5sum;</para>
+         <para>
+            Download MD5 sum: &dbus-glib-md5sum;
+          </para>
         </listitem>
         <listitem>
-          <para>Download size: &dbus-glib-size;</para>
+          <para>
+            Download size: &dbus-glib-size;
+          </para>
         </listitem>
         <listitem>
-          <para>Estimated disk space required: &dbus-glib-buildsize;</para>
+          <para>
+            Estimated disk space required: &dbus-glib-buildsize;
+          </para>
         </listitem>
         <listitem>
-          <para>Estimated build time: &dbus-glib-time;</para>
+          <para>
+            Estimated build time: &dbus-glib-time;
+          </para>
         </listitem>
       </itemizedlist>
 
@@ -114,7 +114,7 @@
       <bridgehead renderas="sect5">Required</bridgehead>
       <para role="required">
         <xref linkend="dbus"/>,
-        <xref linkend="expat"/>, and
+        <xref linkend="expat"/> and
         <xref linkend="glib2"/>
       </para>
 
@@ -124,15 +124,17 @@
       </para>
 
       <para condition="html" role="usernotes">User Notes:
-      <ulink url="&blfs-wiki;/dbus-glib"/></para>
-
+        <ulink url="&blfs-wiki;/dbus-glib"/>
+      </para>
     </sect3>
 
     <sect3 role="installation">
       <title>Installation of D-Bus GLib Bindings</title>
 
-      <para>Install <application>D-Bus GLib Bindings</application> by
-      running the following commands:</para>
+      <para>
+        Install <application>D-Bus GLib Bindings</application> by
+        running the following commands:
+      </para>
 
 <screen><userinput>./configure --prefix=/usr \
             --sysconfdir=/etc \
@@ -140,12 +142,16 @@
             --disable-static &&
 make</userinput></screen>
 
-      <para>To test the results, issue: <command>make check</command>. Note that
-      more comprehensive tests can be run by following the same method used in
-      <application>D-Bus</application> instructions, which requires building the
-      package twice.</para>
+      <para>
+        To test the results, issue: <command>make check</command>. Note that
+        more comprehensive tests can be run by following the same method used in
+        <application>D-Bus</application> instructions, which requires building the
+        package twice.
+      </para>
 
-      <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+      <para>
+        Now, as the <systemitem class="username">root</systemitem> user:
+      </para>
 
 <screen role="root"><userinput>make install</userinput></screen>
 
@@ -154,15 +160,11 @@
     <sect3 role="commands">
       <title>Command Explanations</title>
 
-      <para><parameter>--libexecdir=/usr/lib/dbus-1.0</parameter>: This
-      moves <command>dbus-bash-completion-helper</command> out of <filename
-      class="directory">/usr/libexec</filename>.</para>
-
       <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-      href="../../xincludes/gtk-doc-rebuild.xml"/>
+        href="../../xincludes/static-libraries.xml"/>
 
       <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-      href="../../xincludes/static-libraries.xml"/>
+        href="../../xincludes/gtk-doc-rebuild.xml"/>
 
     </sect3>
 
@@ -170,16 +172,21 @@
       <title>Contents</title>
 
       <segmentedlist>
-        <segtitle>Installed Programs</segtitle>
-        <segtitle>Installed Libraries</segtitle>
+        <segtitle>Installed Program</segtitle>
+        <segtitle>Installed Library</segtitle>
         <segtitle>Installed Directories</segtitle>
 
         <seglistitem>
-          <seg>dbus-binding-tool</seg>
-          <seg>libdbus-glib-1.so</seg>
-          <seg>/etc/bash_completion.d and optionally
-          /usr/share/gtk-doc/html/dbus-glib and
-          /usr/share/doc/dbus-glib-&dbus-glib-version;/api</seg>
+          <seg>
+            dbus-binding-tool
+          </seg>
+          <seg>
+            libdbus-glib-1.so
+          </seg>
+          <seg>
+            /usr/share/gtk-doc/html/dbus-glib and
+            /usr/share/doc/dbus-glib-&dbus-glib-version;
+          </seg>
         </seglistitem>
       </segmentedlist>
 
@@ -191,7 +198,9 @@
         <varlistentry id="glib-dbus-binding-tool">
           <term><command>dbus-binding-tool</command></term>
           <listitem>
-            <para>is a tool used to interface with the D-Bus API.</para>
+            <para>
+              is a tool used to interface with the D-Bus API.
+            </para>
             <indexterm zone="dbus-glib glib-dbus-binding-tool">
               <primary sortas="b-dbus-binding-tool">dbus-binding-tool</primary>
             </indexterm>
@@ -199,10 +208,12 @@
         </varlistentry>
 
         <varlistentry id="libdbus-glib-1">
-          <term><filename class='libraryfile'>libdbus-glib-1.so</filename></term>
+          <term><filename class="libraryfile">libdbus-glib-1.so</filename></term>
           <listitem>
-            <para>contains <application>GLib</application> interface functions
-            to the D-Bus API.</para>
+            <para>
+              contains <application>GLib</application> interface functions
+              to the <application>D-Bus</application> API.
+            </para>
             <indexterm zone="dbus-glib libdbus-glib-1">
               <primary sortas="c-libdbus-glib-1">libdbus-glib-1.so</primary>
             </indexterm>
@@ -219,8 +230,6 @@
   <sect2 id="dbus-python" xreflabel="D-Bus Python Bindings-&dbus-python-version;">
     <title>D-Bus Python Bindings</title>
 
-    &lfs73_checked;
-
     <indexterm zone="dbus-python">
       <primary sortas="a-dbus-python">D-Bus Python Bindings</primary>
     </indexterm>
@@ -228,6 +237,8 @@
     <sect3 role="package">
       <title>Introduction to D-Bus Python Bindings</title>
 
+      &lfs73_checked;
+
       <bridgehead renderas="sect4">Package Information</bridgehead>
       <itemizedlist spacing="compact">
         <listitem>
@@ -323,119 +334,4 @@
 
   </sect2>
 
-  <!-- Begin D-Bus Qt3 Bindings -->
-  <!--
-  <sect2 id="dbus-qt3" xreflabel="D-Bus Trinity Qt3 Bindings-&dbus-qt3-version;">
-  <title>Trinity D-Bus Qt3 Bindings</title>
-
-  <indexterm zone="dbus-qt3">
-    <primary sortas="a-dbus-qt3">D-Bus Qt3 Bindings</primary>
-  </indexterm>
-
-    <sect3 role="package">
-      <title>Introduction to D-Bus Qt3 Bindings</title>
-
-      <bridgehead renderas="sect4">Package Information</bridgehead>
-      <itemizedlist spacing="compact">
-        <listitem>
-          <para>Download (HTTP): <ulink url="&dbus-qt3-download-http;"/></para>
-        </listitem>
-        <listitem>
-          <para>Download (FTP): <ulink url="&dbus-qt3-download-ftp;"/></para>
-        </listitem>
-        <listitem>
-          <para>Download MD5 sum: &dbus-qt3-md5sum;</para>
-        </listitem>
-        <listitem>
-          <para>Download size: &dbus-qt3-size;</para>
-        </listitem>
-        <listitem>
-          <para>Estimated disk space required: &dbus-qt3-buildsize;</para>
-        </listitem>
-        <listitem>
-          <para>Estimated build time: &dbus-qt3-time;</para>
-        </listitem>
-      </itemizedlist>
-
-      <bridgehead renderas="sect4">D-Bus Qt3 Dependencies</bridgehead>
-
-      <bridgehead renderas="sect5">Required</bridgehead>
-      <para role="required">
-        <xref linkend="dbus"/> and
-        <xref linkend="qt"/>
-      </para>
-
-      <para condition="html" role="usernotes">User Notes:
-      <ulink url="&blfs-wiki;/dbus-qt3"/></para>
-
-    </sect3>
-
-    <sect3 role="installation">
-      <title>Installation of D-Bus Trinity/Qt3 Bindings</title>
-
-      <note><para>Be sure your environment is set up as described in
-      <xref linkend='kde-pre-install-config'/></para></note>
-
-      <para>Install <application>D-Bus Trinity/Qt3 Bindings</application> by
-      running the following commands:</para>
-
-<screen><userinput>
-BUILD=/tmp/build-dbus-tqt &&
-DBUSTQT=`pwd`             &&
-rm -rf   $BUILD           &&
-mkdir -p $BUILD           &&
-cd       $BUILD           &&
-
-cmake -DCMAKE_INSTALL_PREFIX=$TRINITY_PREFIX \
-      -DCMAKE_VERBOSE_MAKEFILE=ON            \
-      $DBUSTQT            &&
-
-unset BUILD DBUSTQT       &&
-make</userinput></screen>
-
-      <para>This package does not come with a test suite.</para>
-
-      <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
-
-<screen role="root"><userinput>make install</userinput></screen>
-
-    </sect3>
-
-    <sect3 role="content">
-      <title>Contents</title>
-
-      <segmentedlist>
-        <segtitle>Installed Programs</segtitle>
-        <segtitle>Installed Library</segtitle>
-        <segtitle>Installed Directory</segtitle>
-
-        <seglistitem>
-          <seg>None</seg>
-          <seg>libdbus-tqt-1.so</seg>
-          <seg>$TRINITY_PREFIX/include/dbus-1.0</seg>
-        </seglistitem>
-      </segmentedlist>
-
-      <variablelist>
-        <bridgehead renderas="sect4">Short Descriptions</bridgehead>
-        <?dbfo list-presentation="list"?>
-        <?dbhtml list-presentation="table"?>
-
-        <varlistentry id="libdbus-qt-1">
-          <term><filename class='libraryfile'>libdbus-tqt-1.so</filename></term>
-          <listitem>
-            <para>contains <application>Trinity/Qt3</application> interface functions
-            to the D-Bus API.</para>
-            <indexterm zone="dbus-qt3 libdbus-qt-1">
-              <primary sortas="c-libdbus-qt-1">libdbus-tqt-1.so</primary>
-            </indexterm>
-          </listitem>
-        </varlistentry>
-
-      </variablelist>
-
-    </sect3>
-  </sect2>
-  -->
-
 </sect1>

Modified: trunk/BOOK/gnome/core/libsecret.xml
==============================================================================
--- trunk/BOOK/gnome/core/libsecret.xml	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/gnome/core/libsecret.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -6,8 +6,8 @@
 
   <!ENTITY libsecret-download-http "&gnome-download-http;/libsecret/&libsecret-version;/libsecret-&libsecret-version;.tar.xz">
   <!ENTITY libsecret-download-ftp  "&gnome-download-ftp;/libsecret/&libsecret-version;/libsecret-&libsecret-version;.tar.xz">
-  <!ENTITY libsecret-md5sum        "2f787eea16ef992daa62c1ee41072bbc">
-  <!ENTITY libsecret-size          "468 KB">
+  <!ENTITY libsecret-md5sum        "ac4db2be8e970899ca5091791c1f7c36">
+  <!ENTITY libsecret-size          "476 KB">
   <!ENTITY libsecret-buildsize     "21 MB">
   <!ENTITY libsecret-time          "0.2 SBU">
 ]>

Modified: trunk/BOOK/introduction/welcome/changelog.xml
==============================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/introduction/welcome/changelog.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -44,6 +44,57 @@
 
 -->
     <listitem>
+      <para>March 16th, 2013</para>
+      <itemizedlist>
+        <listitem>
+          <para>[krejzi] - Added libgusb 0.1.6.</para>
+        </listitem>
+        <listitem>
+          <para>[krejzi] - Colord 0.1.30.</para>
+        </listitem>
+        <listitem>
+          <para>[krejzi] - CUPS Filters 1.0.30.</para>
+        </listitem>
+        <listitem>
+          <para>[krejzi] - D-Bus GLib Bindings 0.100.2.</para>
+        </listitem>
+        <listitem>
+          <para>[krejzi] - DejaGnu 1.5.1.</para>
+        </listitem>
+        <listitem>
+          <para>[krejzi] - FFmpeg 1.2.</para>
+        </listitem>
+        <listitem>
+          <para>[krejzi] - Git 1.8.2.</para>
+        </listitem>
+        <listitem>
+          <para>[krejzi] - GPGME 1.4.0.</para>
+        </listitem>
+        <listitem>
+          <para>[krejzi] - Harfbuzz 0.9.13.</para>
+        </listitem>
+        <listitem>
+          <para>[krejzi] - Iptables 1.4.18.</para>
+        </listitem>
+        <listitem>
+          <para>[krejzi] - libassuan 2.1.0.</para>
+        </listitem>
+        <listitem>
+          <para>[krejzi] - OpenLDAP 2.4.30.</para>
+        </listitem>
+        <listitem>
+          <para>[krejzi] - Telepathy Logger 0.8.0.</para>
+        </listitem>
+        <listitem>
+          <para>[krejzi] - Thunderbird 17.0.4.</para>
+        </listitem>
+        <listitem>
+          <para>[krejzi] - Xorg Intel Driver 2.21.4.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
+    <listitem>
       <para>March 15th, 2013</para>
       <itemizedlist>
         <listitem>

Modified: trunk/BOOK/multimedia/libdriv/libdvdcss.xml
==============================================================================
--- trunk/BOOK/multimedia/libdriv/libdvdcss.xml	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/multimedia/libdriv/libdvdcss.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -5,10 +5,10 @@
   %general-entities;
 
   <!ENTITY libdvdcss-download-http "http://www.videolan.org/pub/libdvdcss/&libdvdcss-version;/libdvdcss-&libdvdcss-version;.tar.bz2">
-  <!ENTITY libdvdcss-download-ftp  "&gentoo-ftp-repo;/libdvdcss-&libdvdcss-version;.tar.bz2">
-  <!ENTITY libdvdcss-md5sum        "2218a193900e3203aa10dc24cdf54275">
-  <!ENTITY libdvdcss-size          "324 KB">
-  <!ENTITY libdvdcss-buildsize     "3.5 MB">
+  <!ENTITY libdvdcss-download-ftp  " ">
+  <!ENTITY libdvdcss-md5sum        "53cfc52a60a156763c425572e5179273">
+  <!ENTITY libdvdcss-size          "332 KB">
+  <!ENTITY libdvdcss-buildsize     "4.0 MB">
   <!ENTITY libdvdcss-time          "less than 0.1 SBU">
 ]>
 
@@ -23,7 +23,7 @@
   <title>libdvdcss-&libdvdcss-version;</title>
 
   <indexterm zone="libdvdcss">
-    <primary sortas="a-Libdvdcss">Libdvdcss</primary>
+    <primary sortas="a-libdvdcss">libdvdcss</primary>
   </indexterm>
 
   <sect2 role="package">
@@ -75,55 +75,28 @@
 
     <bridgehead renderas="sect4">Optional (to Create Documentation)</bridgehead>
     <para role="optional">
-      <xref linkend="doxygen"/> and
-      <xref linkend="texlive"/>
+      <xref linkend="doxygen"/>
     </para>
 
     <para condition="html" role="usernotes">User Notes:
-    <ulink url="&blfs-wiki;/libdvdcss"/></para>
-
+      <ulink url="&blfs-wiki;/libdvdcss"/>
+    </para>
   </sect2>
 
   <sect2 role="installation">
     <title>Installation of libdvdcss</title>
 
-    <note>
-      <para>
-        In certain circumstances the 'inputenc' package in the
-        <application>LaTeX</application> installation may not work properly
-        during the build, causing it to hang up. If this happens, issue
-        <userinput>quit</userinput> at the <application>LaTeX</application>
-        prompt and then issue the following command at the shell prompt:
-      </para>
-
-<screen><userinput>echo "INPUT_ENCODING         = ISO-8859-1" >>doc/doxygen.cfg</userinput></screen>
-
-      <para>
-        Now either resume the build, or start over. Disregard this note
-        if you do not have a <application>LaTeX</application> package or
-        <application>Doxygen</application> installed.
-      </para>
-    </note>
-
     <para>
       Install <application>libdvdcss</application> by running the
       following commands:
     </para>
 
-<screen><userinput>./configure --prefix=/usr --disable-static &&
+<screen><userinput>./configure --prefix=/usr    \
+            --disable-static \
+            --docdir=/usr/share/doc/libdvdcss-&libdvdcss-version; &&
 make</userinput></screen>
 
     <para>
-      If you have <application>Doxygen</application> and
-      <application>TeX Live</application> installed, HTML and Postscript
-      documentation was created during the build.
-      If you also want to install a PDF version of the reference manual, issue
-      the following command:
-    </para>
-
-<screen><userinput>make -C doc/latex pdf</userinput></screen>
-
-    <para>
       This package does not come with a test suite.
     </para>
 
@@ -133,18 +106,6 @@
 
 <screen role="root"><userinput>make install</userinput></screen>
 
-    <para>
-      If you have <application>Doxygen</application> and
-      <application>TeX Live</application> installed, install the
-      documentation using the following commands as the
-      <systemitem class="username">root</systemitem> user:
-    </para>
-
-<screen role="root"><userinput>install -v -m755 -d         /usr/share/doc/libdvdcss-&libdvdcss-version;/html &&
-install -v -m644 doc/html/* /usr/share/doc/libdvdcss-&libdvdcss-version;/html &&
-install -v -m644 doc/latex/*.{pdf,ps,dvi} \
-                            /usr/share/doc/libdvdcss-&libdvdcss-version;</userinput></screen>
-
   </sect2>
 
   <sect2 role="commands">
@@ -183,7 +144,7 @@
       <?dbhtml list-presentation="table"?>
 
       <varlistentry id="libdvdcss-lib">
-        <term><filename class='libraryfile'>libdvdcss.so</filename></term>
+        <term><filename class="libraryfile">libdvdcss.so</filename></term>
         <listitem>
           <para>
             provides the functionality that is required for transparent

Modified: trunk/BOOK/multimedia/videoutils/ffmpeg.xml
==============================================================================
--- trunk/BOOK/multimedia/videoutils/ffmpeg.xml	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/multimedia/videoutils/ffmpeg.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -7,8 +7,8 @@
   <!ENTITY ffmpeg-download-http
            "http://ffmpeg.org/releases/ffmpeg-&ffmpeg-version;.tar.bz2">
   <!ENTITY ffmpeg-download-ftp  " ">
-  <!ENTITY ffmpeg-md5sum        "f66eee18559ba59da63b895164a189c3">
-  <!ENTITY ffmpeg-size          "5.6 MB">
+  <!ENTITY ffmpeg-md5sum        "c871d20559cb64c015b5cf0858812a56">
+  <!ENTITY ffmpeg-size          "5.7 MB">
   <!ENTITY ffmpeg-buildsize     "100 MB">
   <!ENTITY ffmpeg-time          "4.0 SBU">
 ]>
@@ -125,14 +125,14 @@
       <ulink url="http://opencv.org/">OpenCV</ulink>,
       <ulink url="http://www.opus-codec.org/">Opus</ulink>,
       <ulink url="http://sourceforge.net/projects/librtmp">librtmp</ulink>,
-      <ulink url="http://diracvideo.org/">libschroedinger</ulink>,
+      <ulink url="http://diracvideo.org/">Schroedinger</ulink>,
       <ulink url="http://www.twolame.org/">TwoLAME</ulink>,
       <ulink url="http://linuxtv.org/downloads/v4l-utils/">Video4Linux</ulink>,
       <ulink url="http://sourceforge.net/projects/opencore-amr/files/vo-aacenc/">vo-aaenc</ulink>,
       <ulink url="http://sourceforge.net/projects/opencore-amr/files/vo-amrwbenc/">vo-amrwbenc</ulink>,
       <ulink url="http://www.videolan.org/developers/x264.html">x264</ulink>,
       <ulink url="http://xavs.sourceforge.net/">libxavs</ulink> (SVN checkout),
-      <ulink url="http://connect.creativelabs.com/openal/default.aspx">OpenAL</ulink>, and
+      <ulink url="http://kcat.strangesoft.net/openal-releases/">OpenAL</ulink>, and
       <ulink url="http://www.nongnu.org/texi2html">texi2html</ulink> (to build HTML documentation)
     </para>
 

Modified: trunk/BOOK/multimedia/videoutils/mplayer.xml
==============================================================================
--- trunk/BOOK/multimedia/videoutils/mplayer.xml	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/multimedia/videoutils/mplayer.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -134,10 +134,10 @@
       <xref linkend="alsa"/>,
       <!-- <xref linkend="arts"/>, -->
       <xref linkend="esound"/>,
-      <xref linkend='pulseaudio'/>,
+      <xref linkend="pulseaudio"/>,
       <xref linkend="sdl"/>,
       <ulink url="http://jackaudio.org/">JACK</ulink>,
-      <ulink url="http://openal.org/">OpenAL</ulink> and
+      <ulink url="http://kcat.strangesoft.net/openal-releases/">OpenAL</ulink> and
       <ulink url="http://www.radscan.com/nas.html">NAS</ulink>
     </para>
 

Modified: trunk/BOOK/postlfs/config/users.xml
==============================================================================
--- trunk/BOOK/postlfs/config/users.xml	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/postlfs/config/users.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -77,6 +77,7 @@
         <row><entry>named   </entry><entry>20</entry><entry>20</entry></row>
         <row><entry>gdm     </entry><entry>21</entry><entry>21</entry></row>
         <row><entry>fcron   </entry><entry>22</entry><entry>22</entry></row>
+        <row><entry>systemd-journal</entry><entry></entry><entry>23</entry></row>
         <row><entry>apache  </entry><entry>25</entry><entry>25</entry></row>
         <row><entry>smmsp   </entry><entry>26</entry><entry>26</entry></row>
         <row><entry>polkitd </entry><entry>27</entry><entry>27</entry></row>
@@ -105,6 +106,7 @@
         <row><entry>kvm     </entry><entry>  </entry><entry>61</entry></row>
         <row><entry>wireshark</entry><entry> </entry><entry>62</entry></row>
         <row><entry>scanner </entry><entry>  </entry><entry>70</entry></row>
+        <row><entry>colord  </entry><entry>71</entry><entry>71</entry></row>
         <row><entry>avahi   </entry><entry>84</entry><entry>84</entry></row>
         <row><entry>avahi-autoipd</entry><entry>85</entry><entry>85</entry></row>
         <row><entry>netdev  </entry><entry>  </entry><entry>86</entry></row>

Modified: trunk/BOOK/postlfs/security/gpgme.xml
==============================================================================
--- trunk/BOOK/postlfs/security/gpgme.xml	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/postlfs/security/gpgme.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -6,9 +6,9 @@
 
   <!ENTITY gpgme-download-http " ">
   <!ENTITY gpgme-download-ftp  "ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-&gpgme-version;.tar.bz2">
-  <!ENTITY gpgme-md5sum        "326fe97077141713f0930aa87949a287">
-  <!ENTITY gpgme-size          "852 KB">
-  <!ENTITY gpgme-buildsize     "19 MB">
+  <!ENTITY gpgme-md5sum        "a0f93aba6d8a831ba14905085027f2f9">
+  <!ENTITY gpgme-size          "936 KB">
+  <!ENTITY gpgme-buildsize     "23 MB">
   <!ENTITY gpgme-time          "0.3 SBU">
 ]>
 
@@ -29,86 +29,93 @@
   <sect2 role="package">
     <title>Introduction to GPGME</title>
 
-    <para>The <application>GPGME</application> package is a C language library
-    that allows to add support for cryptography to a program. It is designed to
-    make access to public key crypto engines like
-    <application>GnuPG</application> or GpgSM easier for applications.
-    <application>GPGME</application> provides a high-level crypto API for
-    encryption, decryption, signing, signature verification and key
-    management.</para>
+    <para>
+      The <application>GPGME</application> package is a C language
+      library that allows to add support for cryptography to a
+      program. It is designed to make access to public key crypto
+      engines like <application>GnuPG</application> or GpgSM easier
+      for applications. <application>GPGME</application> provides
+      a high-level crypto API for encryption, decryption, signing,
+      signature verification and key management.
+    </para>
 
     &lfs72_checked;
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
-        <para>Download (HTTP): <ulink url="&gpgme-download-http;"/></para>
+        <para>
+          Download (HTTP): <ulink url="&gpgme-download-http;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download (FTP): <ulink url="&gpgme-download-ftp;"/></para>
+        <para>
+          Download (FTP): <ulink url="&gpgme-download-ftp;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download MD5 sum: &gpgme-md5sum;</para>
+        <para>
+          Download MD5 sum: &gpgme-md5sum;
+        </para>
       </listitem>
       <listitem>
-        <para>Download size: &gpgme-size;</para>
+        <para>
+          Download size: &gpgme-size;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated disk space required: &gpgme-buildsize;</para>
+        <para>
+          Estimated disk space required: &gpgme-buildsize;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated build time: &gpgme-time;</para>
+        <para>
+          Estimated build time: &gpgme-time;
+        </para>
       </listitem>
     </itemizedlist>
 
     <bridgehead renderas="sect3">GPGME Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="libassuan"/></para>
+    <para role="required">
+      <xref linkend="libassuan"/>
+    </para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional">
-      <xref linkend="gnupg"/>,
-      <xref linkend="gnupg2"/>, and
-      <xref linkend="pth"/>
-      </para>
+      <xref linkend="gnupg"/> or
+      <xref linkend="gnupg2"/> (used during the testsuite)
+    </para>
 
     <para condition="html" role="usernotes">User Notes:
-    <ulink url="&blfs-wiki;/gpgme"/></para>
-
+      <ulink url="&blfs-wiki;/gpgme"/>
+    </para>
   </sect2>
 
   <sect2 role="installation">
     <title>Installation of GPGME</title>
 
-    <para>Install <application>GPGME</application> by running the following
-    commands:</para>
+    <para>
+      Install <application>GPGME</application> by running the following
+      commands:
+    </para>
 
-<screen><userinput>./configure --prefix=/usr         \
-            --libexecdir=/usr/lib \
-            --without-g13         &&
+<screen><userinput>./configure --prefix=/usr &&
 make</userinput></screen>
 
-    <para>To test the results, issue: <command>make check</command>.</para>
-
-    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+    <para>
+      To test the results, issue: <command>make check</command>.
+    </para>
+
+    <para>
+      Now, as the <systemitem class="username">root</systemitem> user:
+    </para>
 
 <screen role="root"><userinput>make install</userinput></screen>
 
   </sect2>
 
-  <sect2 role="commands">
-    <title>Command Explanations</title>
-
-    <para><parameter>--libexecdir=/usr/lib</parameter>: This parameter stops the
-    creation of an empty /usr/libexec directory.</para>
-
-    <para><option>--without-g13</option>: This option merely prevents a warning
-    about about an un-released development library during
-    <command>configure</command>.</para>
-
-  </sect2>
-
   <sect2 role="content">
     <title>Contents</title>
 
@@ -118,9 +125,15 @@
       <segtitle>Installed Directory</segtitle>
 
       <seglistitem>
-        <seg>gpgme-config</seg>
-        <seg>libgpgme-pthread.so, libgpgme-pth.so, and libgpgme.so</seg>
-        <seg>/usr/share/common-lisp/source/gpgme</seg>
+        <seg>
+          gpgme-config
+        </seg>
+        <seg>
+          libgpgme-pthread.so and libgpgme.so
+        </seg>
+        <seg>
+          /usr/share/common-lisp/source/gpgme
+        </seg>
       </seglistitem>
     </segmentedlist>
 
@@ -130,33 +143,26 @@
       <?dbhtml list-presentation="table"?>
 
       <varlistentry id="libgpgme-pthread">
-        <term><filename class='libraryfile'>libgpgme-pthread.{so,a}</filename></term>
+        <term><filename class="libraryfile">libgpgme-pthread.so</filename></term>
         <listitem>
-          <para>contains the gpgme API functions for applications using
-          pthread.</para>
+          <para>
+            contains the <application>GPGME</application> API functions for
+            applications using pthread.
+          </para>
           <indexterm zone="gpgme libgpgme-pthread">
-            <primary sortas="c-libgpgme-pthread">libgpgme-pthread.{so,a}</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
-      <varlistentry id="libgpgme-pth">
-        <term><filename class='libraryfile'>libgpgme-pth.{so,a}</filename></term>
-        <listitem>
-          <para>contains the gpgme API functions for applications using GNU
-          Pth.</para>
-          <indexterm zone="gpgme libgpgme-pth">
-            <primary sortas="c-libgpgme-pth">libgpgme-pth.{so,a}</primary>
+            <primary sortas="c-libgpgme-pthread">libgpgme-pthread.so</primary>
           </indexterm>
         </listitem>
       </varlistentry>
 
       <varlistentry id="libgpgme">
-        <term><filename class='libraryfile'>libgpgme.{so,a}</filename></term>
+        <term><filename class="libraryfile">libgpgme.so</filename></term>
         <listitem>
-          <para>contains the gpgme API functions.</para>
+          <para>
+            contains the <application>GPGME</application> API functions.
+          </para>
           <indexterm zone="gpgme libgpgme">
-            <primary sortas="c-libgpgme">libgpgme.{so,a}</primary>
+            <primary sortas="c-libgpgme">libgpgme.so</primary>
           </indexterm>
         </listitem>
       </varlistentry>

Modified: trunk/BOOK/postlfs/security/iptables.xml
==============================================================================
--- trunk/BOOK/postlfs/security/iptables.xml	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/postlfs/security/iptables.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -6,10 +6,10 @@
 
   <!ENTITY iptables-download-http "http://www.netfilter.org/projects/iptables/files/iptables-&iptables-version;.tar.bz2">
   <!ENTITY iptables-download-ftp  "ftp://ftp.netfilter.org/pub/iptables/iptables-&iptables-version;.tar.bz2">
-  <!ENTITY iptables-md5sum        "c3fb2ffd5b39d0d54b06ccc4c8660116">
+  <!ENTITY iptables-md5sum        "a819199d5ec013b82da13a8ffbba857e">
   <!ENTITY iptables-size          "532 KB">
-  <!ENTITY iptables-buildsize     "18 MB">
-  <!ENTITY iptables-time          "0.2 SBU">
+  <!ENTITY iptables-buildsize     "20 MB">
+  <!ENTITY iptables-time          "0.3 SBU">
 ]>
 
 <sect1 id="iptables" xreflabel="Iptables-&iptables-version;">
@@ -30,7 +30,7 @@
     <title>Introduction to Iptables</title>
 
     <para>
-      The next part of this chapter deals with firewalls.  The principal
+      The next part of this chapter deals with firewalls. The principal
       firewall tool for Linux is <application>Iptables</application>. You will
       need to install <application>Iptables</application> if you intend on using
       any form of a firewall.
@@ -71,17 +71,7 @@
         </para>
       </listitem>
     </itemizedlist>
-<!--
-    <bridgehead renderas="sect3">Additional Downloads</bridgehead>
-    <itemizedlist spacing="compact">
-      <listitem>
-        <para>
-          Required patch:
-          <ulink url="&patch-root;/iptables-&iptables-version;-missing-includes-1.patch"/>
-        </para>
-      </listitem>
-    </itemizedlist>
--->
+
     <para condition="html" role="usernotes">User Notes:
       <ulink url="&blfs-wiki;/iptables"/>
     </para>
@@ -134,8 +124,7 @@
       commands:
     </para>
 
-<screen><userinput>LDFLAGS="-L$PWD/libiptc/.libs"                     \
-./configure --prefix=/usr                          \
+<screen><userinput>./configure --prefix=/usr                          \
             --exec-prefix=                         \
             --bindir=/usr/bin                      \
             --with-xtlibdir=/lib/xtables           \

Modified: trunk/BOOK/pst/printing/cups-filters.xml
==============================================================================
--- trunk/BOOK/pst/printing/cups-filters.xml	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/pst/printing/cups-filters.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -6,8 +6,8 @@
 
   <!ENTITY cups-filters-download-http "http://www.openprinting.org/download/cups-filters/cups-filters-&cups-filters-version;.tar.xz">
   <!ENTITY cups-filters-download-ftp  " ">
-  <!ENTITY cups-filters-md5sum        "01e2d9abc4ea69521334a0ee2f70d98a">
-  <!ENTITY cups-filters-size          "984 KB">
+  <!ENTITY cups-filters-md5sum        "c6cca1041657a23192547010f8f2cca8">
+  <!ENTITY cups-filters-size          "992 KB">
   <!ENTITY cups-filters-buildsize     "31 MB">
   <!ENTITY cups-filters-time          "0.3 SBU">
 ]>
@@ -72,16 +72,6 @@
       </listitem>
     </itemizedlist>
 
-    <bridgehead renderas="sect3">Additional Downloads</bridgehead>
-    <itemizedlist spacing="compact">
-      <listitem>
-        <para>
-          Required patch:
-          <ulink url="&patch-root;/cups-filters-&cups-filters-version;-poppler_fix-1.patch"/>
-        </para>
-      </listitem>
-    </itemizedlist>
-
     <bridgehead renderas="sect3">CUPS Filters Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
@@ -102,12 +92,11 @@
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional">
-      <xref linkend="avahi"/> and
-      <xref linkend="php"/>
+      <xref linkend="avahi"/>
     </para>
 
     <bridgehead renderas="sect4">Required (Runtime)</bridgehead>
-    <para role="optional"><!-- Yes, optional -->
+    <para role="optional">
       <xref linkend="gs"/> (Needed for PostScript printers)
     </para>
 
@@ -124,8 +113,7 @@
       commands:
     </para>
 
-<screen><userinput>patch -Np0 -i ../cups-filters-&cups-filters-version;-poppler_fix-1.patch &&
-./configure --prefix=/usr                               \
+<screen><userinput>./configure --prefix=/usr                               \
             --sysconfdir=/etc                           \
             --docdir=/usr/share/doc/cups-filters-&cups-filters-version; \
             --without-rcdir                             \
@@ -151,8 +139,9 @@
     <title>Command Explanations</title>
 
     <para>
-      <option>--without-rcdir</option>: This switch disables installation of
-      the bundled bootscript which is not compatible with BLFS.
+      <parameter>--without-rcdir</parameter>: This switch disables
+      installation of the bundled bootscript which is not compatible
+      with BLFS.
     </para>
 
     <para>
@@ -168,8 +157,8 @@
     </para>
 
     <para>
-      <option>--disable-avahi</option>: This switch is required if
-      <application>Avahi</application> is not installed.
+      <parameter>--disable-avahi</parameter>: This switch is required if you have
+      not installed <xref linkend="avahi"/>.
     </para>
 
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"

Modified: trunk/BOOK/server/other/openldap.xml
==============================================================================
--- trunk/BOOK/server/other/openldap.xml	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/server/other/openldap.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -6,9 +6,9 @@
 
   <!ENTITY openldap-download-http " ">
   <!ENTITY openldap-download-ftp  "ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/openldap-&openldap-version;.tgz">
-  <!ENTITY openldap-md5sum        "5adae44897647c15ce5abbff313bc85a">
+  <!ENTITY openldap-md5sum        "df93a62e396ac312333cdeab0c5b48b6">
   <!ENTITY openldap-size          "5.3 MB">
-  <!ENTITY openldap-buildsize     "100 MB">
+  <!ENTITY openldap-buildsize     "130 MB">
   <!ENTITY openldap-time          "1.2 SBU">
 ]>
 
@@ -147,11 +147,13 @@
 <screen><userinput>patch -Np1 -i ../openldap-&openldap-version;-blfs_paths-1.patch &&
 patch -Np1 -i ../openldap-&openldap-version;-symbol_versions-1.patch &&
 autoconf &&
-./configure --prefix=/usr \
+./configure --prefix=/usr     \
             --sysconfdir=/etc \
-            --enable-dynamic \
-            --disable-debug \
-            --disable-slapd</userinput></screen>
+            --enable-dynamic  \
+            --disable-debug   \
+            --disable-slapd &&
+make depend &&
+make</userinput></screen>
     </note>
 
     <para>
@@ -162,19 +164,20 @@
 <screen><userinput>patch -Np1 -i ../openldap-&openldap-version;-blfs_paths-1.patch &&
 patch -Np1 -i ../openldap-&openldap-version;-symbol_versions-1.patch &&
 autoconf &&
-./configure --prefix=/usr \
-            --sysconfdir=/etc \
-            --localstatedir=/var \
+./configure --prefix=/usr         \
+            --sysconfdir=/etc     \
+            --localstatedir=/var  \
             --libexecdir=/usr/lib \
-            --disable-static \
-            --disable-debug \
-            --enable-dynamic \
-            --enable-crypt \
-            --enable-modules \
-            --enable-rlookups \
+            --disable-static      \
+            --disable-debug       \
+            --enable-dynamic      \
+            --enable-crypt        \
+            --enable-spasswd      \
+            --enable-modules      \
+            --enable-rlookups     \
             --enable-backends=mod \
             --enable-overlays=mod \
-            --disable-ndb \
+            --disable-ndb         \
             --disable-sql &&
 make depend &&
 make</userinput></screen>
@@ -189,7 +192,7 @@
 
 <screen role="root"><userinput>make install &&
 
-install -v -dm 755 /usr/share/doc/openldap-&openldap-version; &&
+install -v -dm755  /usr/share/doc/openldap-&openldap-version; &&
 cp -vfr doc/drafts /usr/share/doc/openldap-&openldap-version; &&
 cp -vfr doc/rfc    /usr/share/doc/openldap-&openldap-version; &&
 cp -vfr doc/guide  /usr/share/doc/openldap-&openldap-version;</userinput></screen>
@@ -203,69 +206,69 @@
       href="../../xincludes/static-libraries.xml"/>
 
     <para>
-      <option>--disable-debug</option>: This parameter disables
+      <option>--disable-debug</option>: This switch disables
       the debugging code in <application>OpenLDAP</application>.
     </para>
 
     <para>
-      <option>--enable-dynamic</option>: This parameter forces the
+      <option>--enable-dynamic</option>: This switch forces the
       <application>OpenLDAP</application> libraries to be dynamically
       linked to the executable programs.
     </para>
 
     <para>
-      <option>--enable-crypt</option>: This parameter enables using of
+      <option>--enable-crypt</option>: This switch enables using of
       <command>crypt(3)</command> passwords.
     </para>
 
     <para>
-      <option>--enable-modules</option>: This parameter enables dynamic
+      <option>--enable-spasswd</option>: This switch enables
+      <application>SASL</application> password verification.
+    </para>
+
+    <para>
+      <option>--enable-modules</option>: This switch enables dynamic
       module support.
     </para>
 
     <para>
-      <option>--enable-rlookups</option>: This parameter enables
+      <option>--enable-rlookups</option>: This switch enables
       reverse lookups of client hostnames.
     </para>
 
     <para>
-      <option>--enable-backends</option>: This parameter enables
+      <option>--enable-backends</option>: This switch enables
       all available backends.
     </para>
 
     <para>
-      <option>--enable-overlays</option>: This parameter enables
+      <option>--enable-overlays</option>: This switch enables
       all available overlays.
     </para>
 
     <para>
-      <option>--disable-ndb</option>: This parameter disables
+      <option>--disable-ndb</option>: This switch disables
       <application>MySQL</application> NDB Cluster backend
       which causes configure to fail if
       <application>MySQL</application> is present.
     </para>
 
     <para>
-      <option>--disable-sql</option>: This parameter explicitly
+      <option>--disable-sql</option>: This switch explicitly
       disables the SQL backend.  Omit this switch if a SQL server is
       installed and you are going to use a SQL backend.
     </para>
 
     <para>
-      <option>--enable-spasswd</option>: This parameter enables
-      <application>SASL</application> password verification.
-    </para>
-
-    <para>
-      <option>--enable-slp</option>: This parameter enables
-      SLPv2 support. Use this switch if you have installed
+      <option>--enable-slp</option>: This switch enables
+      SLPv2 support. Use it if you have installed
       <ulink url="http://www.openslp.org/">OpenSLP</ulink>.
     </para>
 
     <note>
       <para>
         You can run <command>./configure --help</command> to see if there
-        are other parameters you can pass to the <command>configure</command>
+        are other switch you can pass to the <command>configure</command>
         command to enable other options or dependency packages.
       </para>
     </note>
@@ -317,7 +320,7 @@
         and setting a <command>chroot</command> environment include:
       </para>
 
-      <itemizedlist spacing='compact'>
+      <itemizedlist spacing="compact">
         <listitem>
           <para>
             The <command>slapd</command> man page.
@@ -444,7 +447,7 @@
           slapcat, slapd, slapdn, slapindex, slappasswd, slapschema and slaptest
         </seg>
         <seg>
-          liblber.so, libldap.so,a and libldap_r.so
+          liblber.so, libldap.so and libldap_r.so
         </seg>
         <seg>
           /etc/openldap,
@@ -716,7 +719,7 @@
       </varlistentry>
 
       <varlistentry id="liblber">
-        <term><filename class='libraryfile'>liblber.so</filename></term>
+        <term><filename class="libraryfile">liblber.so</filename></term>
         <listitem>
           <para>
             is a set of Lightweight Basic Encoding Rules routines. These
@@ -733,7 +736,7 @@
       </varlistentry>
 
       <varlistentry id="libldap">
-        <term><filename class='libraryfile'>libldap.so</filename></term>
+        <term><filename class="libraryfile">libldap.so</filename></term>
         <listitem>
           <para>
             supports the LDAP programs and provide functionality for
@@ -746,7 +749,7 @@
       </varlistentry>
 
       <varlistentry id="libldap_r">
-        <term><filename class='libraryfile'>libldap_r.so</filename></term>
+        <term><filename class="libraryfile">libldap_r.so</filename></term>
         <listitem>
           <para>
             contains the functions required by the LDAP programs to

Modified: trunk/BOOK/x/installing/x7driver.xml
==============================================================================
--- trunk/BOOK/x/installing/x7driver.xml	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/x/installing/x7driver.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -58,11 +58,11 @@
   <!ENTITY xorg-fbdev-driver-buildsize     "2.3 MB">
   <!ENTITY xorg-fbdev-driver-time          "less than 0.1 SBU">
 
-  <!ENTITY xorg-intel-driver-version "2.21.3">
+  <!ENTITY xorg-intel-driver-version "2.21.4">
 
   <!ENTITY xorg-intel-driver-download-http "&xorg-download-http;/driver/xf86-video-intel-&xorg-intel-driver-version;.tar.bz2">
   <!ENTITY xorg-intel-driver-download-ftp  "&xorg-download-ftp;/driver/xf86-video-intel-&xorg-intel-driver-version;.tar.bz2">
-  <!ENTITY xorg-intel-driver-md5sum        "362a1d70082f5c0d2410aaf87b5125ba">
+  <!ENTITY xorg-intel-driver-md5sum        "6e45a8684b5a3b4a0ba795aba3b5f0fc">
   <!ENTITY xorg-intel-driver-size          "1.7 MB">
   <!ENTITY xorg-intel-driver-buildsize     "70 MB">
   <!ENTITY xorg-intel-driver-time          "0.6 SBU">

Modified: trunk/BOOK/xsoft/other/thunderbird.xml
==============================================================================
--- trunk/BOOK/xsoft/other/thunderbird.xml	Fri Mar 15 16:11:00 2013	(r11098)
+++ trunk/BOOK/xsoft/other/thunderbird.xml	Sat Mar 16 05:11:58 2013	(r11099)
@@ -8,7 +8,7 @@
            "&mozilla-http;/thunderbird/releases/&thunderbird-version;/source/thunderbird-&thunderbird-version;.source.tar.bz2">
   <!ENTITY thunderbird-download-ftp
            "&mozilla-ftp;/thunderbird/releases/&thunderbird-version;/source/thunderbird-&thunderbird-version;.source.tar.bz2">
-  <!ENTITY thunderbird-md5sum            "180f7768f6419182ea78eeb80da7f588">
+  <!ENTITY thunderbird-md5sum            "d36925feebf6bc55cd2fa288119157e5">
   <!ENTITY thunderbird-size              "109 MB">
   <!ENTITY thunderbird-buildsize         "3.1 GB (47 MB installed)">
   <!ENTITY thunderbird-time              "30 SBU">



More information about the blfs-book mailing list