[blfs-book] r11030 - in trunk/BOOK: . postlfs/security x/lib

krejzi at higgs.linuxfromscratch.org krejzi at higgs.linuxfromscratch.org
Fri Mar 1 02:38:56 PST 2013


Author: krejzi
Date: Fri Mar  1 02:38:56 2013
New Revision: 11030

Log:
Krb5 1.11.1, fix At-Spi2 deps.

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/postlfs/security/mitkrb.xml
   trunk/BOOK/x/lib/at-spi2-atk.xml
   trunk/BOOK/x/lib/at-spi2-core.xml

Modified: trunk/BOOK/general.ent
==============================================================================
--- trunk/BOOK/general.ent	Wed Feb 27 08:08:04 2013	(r11029)
+++ trunk/BOOK/general.ent	Fri Mar  1 02:38:56 2013	(r11030)
@@ -3,13 +3,13 @@
 $Date$
 -->
 
-<!ENTITY day          "27">                   <!-- Always 2 digits -->
-<!ENTITY month        "02">                   <!-- Always 2 digits -->
+<!ENTITY day          "01">                   <!-- Always 2 digits -->
+<!ENTITY month        "03">                   <!-- Always 2 digits -->
 <!ENTITY year         "2013">
 <!ENTITY copyrightdate "2001-&year;">
 <!ENTITY copyholder   "The BLFS Development Team">
 <!ENTITY version      "&year;-&month;-&day;">
-<!ENTITY releasedate  "February 27th, &year;">
+<!ENTITY releasedate  "March 1st, &year;">
 <!ENTITY pubdate      "&year;-&month;-&day;"> <!-- metadata req. by TLDP -->
 <!ENTITY blfs-version "svn">                  <!-- svn|[release #] -->
 <!ENTITY lfs-version  "development">          <!-- version|testing|unstable|development] -->
@@ -185,7 +185,7 @@
 <!ENTITY liboauth-version             "1.0.0">
 <!ENTITY libpwquality-version         "1.2.0">
 <!ENTITY linux-pam-version            "1.1.6">
-<!ENTITY mitkrb-version               "1.11">
+<!ENTITY mitkrb-version               "1.11.1">
 <!ENTITY nettle-version               "2.6">
 <!ENTITY nss-major-version            "14">
 <!ENTITY nss-minor-version            "1">

Modified: trunk/BOOK/postlfs/security/mitkrb.xml
==============================================================================
--- trunk/BOOK/postlfs/security/mitkrb.xml	Wed Feb 27 08:08:04 2013	(r11029)
+++ trunk/BOOK/postlfs/security/mitkrb.xml	Fri Mar  1 02:38:56 2013	(r11030)
@@ -6,10 +6,10 @@
 
   <!ENTITY mitkrb-download-http "http://web.mit.edu/kerberos/www/dist/krb5/1.11/krb5-&mitkrb-version;-signed.tar">
   <!ENTITY mitkrb-download-ftp  " ">
-  <!ENTITY mitkrb-md5sum        "1a13c53899806c4da99a798a04d25545">
+  <!ENTITY mitkrb-md5sum        "76c6bed945c5771674357cfd4a08e3f5">
   <!ENTITY mitkrb-size          "12 MB">
-  <!ENTITY mitkrb-buildsize     "125 MB (Additional 20 MB if running the testsuite)">
-  <!ENTITY mitkrb-time          "1.4 SBU (additional 2.0 SBU if running the testsuite)">
+  <!ENTITY mitkrb-buildsize     "140 MB (Additional 20 MB if running the testsuite)">
+  <!ENTITY mitkrb-time          "1.5 SBU (additional 3.0 SBU if running the testsuite)">
 ]>
 
 <sect1 id="mitkrb" xreflabel="MIT Kerberos V5-&mitkrb-version;">
@@ -80,8 +80,9 @@
     <para role="optional">
       <xref linkend="dejagnu"/> (required to run the testsuite),
       <xref linkend="keyutils"/>,
-      <xref linkend="openldap"/> and
-      <xref linkend="python2"/> (used during the testsuite).
+      <xref linkend="openldap"/>,
+      <xref linkend="python2"/> (used during the testsuite) and
+      <xref linkend="rpcbind"/> (used during the testsuite)
     </para>
 
     <note>
@@ -113,7 +114,7 @@
       After unpacking the distribution tarball and if you have
       <xref linkend="gnupg"/> installed, you can
       authenticate the package.  First, check the contents of the file
-      <filename>krb5-1.10.3.tar.gz.asc</filename>.
+      <filename>krb5-&mitkrb-version;.tar.gz.asc</filename>.
     </para>
 
 <screen><userinput>gpg --verify krb5-&mitkrb-version;.tar.gz.asc krb5-&mitkrb-version;.tar.gz</userinput></screen>
@@ -142,6 +143,12 @@
     </para>
 
 <screen><userinput>cd src &&
+sed -e "s at python2.5/Python.h@& python2.7/Python.h at g" \
+    -e "s at -lpython2.5]@&,\n  AC_CHECK_LIB(python2.7,main,[PYTHON_LIB=-lpython2.7])@g" \
+    -i configure.in &&
+sed -e "s at interp->result at Tcl_GetStringResult(interp)@g" \
+    -i kadmin/testing/util/tcl_kadm5.c &&
+autoconf &&
 ./configure CPPFLAGS="-I/usr/include/et -I/usr/include/ss" \
             --prefix=/usr                                  \
             --localstatedir=/var/lib                       \
@@ -162,8 +169,8 @@
 <screen role="root"><userinput>make install &&
 
 for LIBRARY in gssapi_krb5 gssrpc k5crypto kadm5clnt_mit kadm5srv_mit \
-               kdb5 krb5 krb5support verto ; do
-    chmod -v 755 /usr/lib/lib$LIBRARY.so.*.*
+               kdb5 kdb_ldap krb5 krb5support verto ; do
+    [ -e  /usr/lib/lib$LIBRARY.so.*.* ] && chmod -v 755 /usr/lib/lib$LIBRARY.so.*.*
 done &&
 
 mv -v /usr/lib/libkrb5.so.3*        /lib &&
@@ -193,6 +200,12 @@
     <title>Command Explanations</title>
 
     <para>
+      <command>sed -e ...</command>: First <command>sed</command> fixes
+      <application>Python</application> detection and second one fixes
+      build with <application>Tcl</application> 8.6.
+    </para>
+
+    <para>
       <option>--enable-dns-for-realm</option>: This switch allows
       realms to be resolved using the DNS server.
     </para>
@@ -424,7 +437,7 @@
         <para>
           For additional information consult <ulink
           url="http://web.mit.edu/kerberos/www/krb5-1.10/#documentation">
-          Documentation for krb-&mitkrb-version;</ulink> on which the above
+          Documentation for krb5-&mitkrb-version;</ulink> on which the above
           instructions are based.
         </para>
 

Modified: trunk/BOOK/x/lib/at-spi2-atk.xml
==============================================================================
--- trunk/BOOK/x/lib/at-spi2-atk.xml	Wed Feb 27 08:08:04 2013	(r11029)
+++ trunk/BOOK/x/lib/at-spi2-atk.xml	Fri Mar  1 02:38:56 2013	(r11030)
@@ -76,9 +76,8 @@
 
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required">
-      <xref linkend="at-spi2-core"/>,
-      <xref linkend="atk"/> and
-      <xref linkend="intltool"/>
+      <xref linkend="at-spi2-core"/> and
+      <xref linkend="atk"/>
     </para>
 
     <para condition="html" role="usernotes">User Notes:

Modified: trunk/BOOK/x/lib/at-spi2-core.xml
==============================================================================
--- trunk/BOOK/x/lib/at-spi2-core.xml	Wed Feb 27 08:08:04 2013	(r11029)
+++ trunk/BOOK/x/lib/at-spi2-core.xml	Fri Mar  1 02:38:56 2013	(r11030)
@@ -79,7 +79,8 @@
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required">
       <xref linkend="dbus"/>,
-      <xref linkend="glib2"/> and
+      <xref linkend="glib2"/>,
+      <xref linkend="intltool"/> and
       <xref linkend="xorg7-lib"/>
     </para>
 



More information about the blfs-book mailing list