[blfs-book] r11311 - in branches/systemd: . general/genlib general/genutils general/graphlib general/prog introduction/welcome multimedia/videoutils networking/netprogs networking/netutils postlfs/security pst/typesetting server/major x/installing

krejzi at higgs.linuxfromscratch.org krejzi at higgs.linuxfromscratch.org
Fri Jun 21 04:53:30 PDT 2013


Author: krejzi
Date: Fri Jun 21 04:53:30 2013
New Revision: 11311

Log:
Sync systemd and main branches.

Added:
   branches/systemd/general/prog/lua.xml   (contents, props changed)
Modified:
   branches/systemd/general.ent
   branches/systemd/general/genlib/ptlib.xml
   branches/systemd/general/genutils/graphviz.xml
   branches/systemd/general/graphlib/gegl.xml
   branches/systemd/general/graphlib/jasper.xml
   branches/systemd/general/prog/mercurial.xml
   branches/systemd/general/prog/other-tools.xml
   branches/systemd/general/prog/prog.xml
   branches/systemd/introduction/welcome/changelog.xml
   branches/systemd/multimedia/videoutils/vlc.xml
   branches/systemd/networking/netprogs/wget.xml
   branches/systemd/networking/netutils/nmap.xml
   branches/systemd/networking/netutils/wireshark.xml
   branches/systemd/postlfs/security/openssl.xml
   branches/systemd/pst/typesetting/texlive.xml
   branches/systemd/server/major/apache.xml
   branches/systemd/x/installing/x7driver.xml

Modified: branches/systemd/general.ent
==============================================================================
--- branches/systemd/general.ent	Thu Jun 20 23:56:36 2013	(r11310)
+++ branches/systemd/general.ent	Fri Jun 21 04:53:30 2013	(r11311)
@@ -3,13 +3,13 @@
 $Date$
 -->
 
-<!ENTITY day          "16">                   <!-- Always 2 digits -->
+<!ENTITY day          "21">                   <!-- Always 2 digits -->
 <!ENTITY month        "06">                   <!-- Always 2 digits -->
 <!ENTITY year         "2013">
 <!ENTITY copyrightdate "2001-&year;">
 <!ENTITY copyholder   "The BLFS Development Team">
 <!ENTITY version      "SYSTEMD-&year;-&month;-&day;">
-<!ENTITY releasedate  "June 16th, &year;">
+<!ENTITY releasedate  "June 21st, &year;">
 <!ENTITY pubdate      "&year;-&month;-&day;"> <!-- metadata req. by TLDP -->
 <!ENTITY blfs-version "svn">                  <!-- svn|[release #] -->
 <!ENTITY lfs-version  "development">          <!-- version|testing|unstable|development] -->
@@ -380,6 +380,7 @@
 <!ENTITY junit-version                "4.10">
 <!ENTITY librep-version               "0.92.2.1">
 <!ENTITY llvm-version                 "3.2">
+<!ENTITY lua-version                  "5.2.2">
 <!ENTITY mercurial-version            "2.6.2">
 <!ENTITY NASM-version                 "2.10.07">
 <!ENTITY php-version                  "5.4.11">

Modified: branches/systemd/general/genlib/ptlib.xml
==============================================================================
--- branches/systemd/general/genlib/ptlib.xml	Thu Jun 20 23:56:36 2013	(r11310)
+++ branches/systemd/general/genlib/ptlib.xml	Fri Jun 21 04:53:30 2013	(r11311)
@@ -86,7 +86,7 @@
       <xref linkend="cyrus-sasl"/>,
       <ulink url="http://sourceforge.net/projects/libdc1394/">libdc1394</ulink>,
       <ulink url="http://www.linux1394.org/">libraw1394</ulink>,
-      <ulink url="http://www.lua.org/">Lua</ulink>,
+      <xref linkend="lua"/>,
       <xref linkend="openldap"/>,
       <xref linkend="pulseaudio"/>,
       <xref linkend="sdl"/>,

Modified: branches/systemd/general/genutils/graphviz.xml
==============================================================================
--- branches/systemd/general/genutils/graphviz.xml	Thu Jun 20 23:56:36 2013	(r11310)
+++ branches/systemd/general/genutils/graphviz.xml	Fri Jun 21 04:53:30 2013	(r11311)
@@ -110,7 +110,7 @@
       <xref linkend="guile"/>,
       <xref linkend="openjdk"/>,
       <ulink url="http://www.iolanguage.com/about/">Io</ulink>,
-      <ulink url="http://www.lua.org/">Lua</ulink>,
+      <xref linkend="lua"/> (version 5.1),
       <ulink url="http://www.mono-project.com/Main_Page">Mono</ulink>,
       <ulink url="http://ocaml.org/">OCaml</ulink>,
       <xref linkend="php"/>,

Modified: branches/systemd/general/graphlib/gegl.xml
==============================================================================
--- branches/systemd/general/graphlib/gegl.xml	Thu Jun 20 23:56:36 2013	(r11310)
+++ branches/systemd/general/graphlib/gegl.xml	Fri Jun 21 04:53:30 2013	(r11311)
@@ -94,7 +94,7 @@
       <xref linkend="libpng"/>,
       <xref linkend="librsvg"/>,
       <ulink url="http://libspiro.sourceforge.net/">libspiro</ulink>,
-      <ulink url="http://www.lua.org/">Lua</ulink>,
+      <xref linkend="lua"/>,
       <ulink url="http://www.openexr.org">OpenEXR</ulink>,
       <xref linkend="pango"/>,
       <xref linkend="python2"/>,

Modified: branches/systemd/general/graphlib/jasper.xml
==============================================================================
--- branches/systemd/general/graphlib/jasper.xml	Thu Jun 20 23:56:36 2013	(r11310)
+++ branches/systemd/general/graphlib/jasper.xml	Fri Jun 21 04:53:30 2013	(r11311)
@@ -90,7 +90,7 @@
 </note>
 
 <screen><userinput>patch -Np1 -i ../jasper-&jasper-version;-security_fixes-1.patch &&
-./configure --prefix=/usr --enable-shared &&
+./configure --prefix=/usr --enable-shared --disable-static &&
 make</userinput></screen>
 
     <para>This package does not come with a testsuite.</para>
@@ -111,11 +111,11 @@
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><command>--enable-shared</command>: This command
+    <para><option>--enable-shared</option>: This command
     causes the shared library to be built.</para>
 
-    <para><option>--disable-static</option>: This causes the
-    static library to not be built.</para>
+    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
+      href="../../xincludes/static-libraries.xml"/>
 
     <para><option>--x-includes=DIR --x-libraries=DIR</option>: These tell the
     <command>configure</command> script where to find <application>Xorg</application>
@@ -150,7 +150,7 @@
 
       <seglistitem>
         <seg>imgcmp, imginfo, jasper, jiv, and tmrdemo</seg>
-        <seg>libjasper.{so,a}</seg>
+        <seg>libjasper.so</seg>
         <seg>/usr/include/jasper and /usr/share/doc/jasper-&jasper-version;</seg>
       </seglistitem>
     </segmentedlist>
@@ -212,12 +212,12 @@
       </varlistentry>
 
       <varlistentry id="jasper-lib">
-        <term><filename class='libraryfile'>libjasper.{so,a}</filename></term>
+        <term><filename class='libraryfile'>libjasper.so</filename></term>
         <listitem>
           <para>a library used by programs for reading and writing
           JPEG2000 format files.</para>
           <indexterm zone="jasper jasper-lib">
-            <primary sortas="c-libjasper">libjasper.{so,a}</primary>
+            <primary sortas="c-libjasper">libjasper.so</primary>
           </indexterm>
         </listitem>
       </varlistentry>

Added: branches/systemd/general/prog/lua.xml
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ branches/systemd/general/prog/lua.xml	Fri Jun 21 04:53:30 2013	(r11311)
@@ -0,0 +1,234 @@
+<?xml version="1.0" encoding="ISO-8859-1"?>
+<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
+   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
+  <!ENTITY % general-entities SYSTEM "../../general.ent">
+  %general-entities;
+
+  <!ENTITY lua-download-http "http://www.lua.org/ftp/lua-&lua-version;.tar.gz">
+  <!ENTITY lua-download-ftp  " ">
+  <!ENTITY lua-md5sum        "efbb645e897eae37cad4344ce8b0a614">
+  <!ENTITY lua-size          "246 KB">
+  <!ENTITY lua-buildsize     "3.5 MB">
+  <!ENTITY lua-time          "0.1 SBU">
+]>
+
+<sect1 id="lua" xreflabel="Lua-&lua-version;">
+  <?dbhtml filename="lua.html"?>
+
+  <sect1info>
+    <othername>$LastChangedBy$</othername>
+    <date>$Date$</date>
+  </sect1info>
+
+  <title>Lua-&lua-version;</title>
+
+  <indexterm zone="lua">
+    <primary sortas="a-Lua">Lua</primary>
+  </indexterm>
+
+  <sect2 role="package">
+    <title>Introduction to Lua</title>
+
+    <para>
+      <application>Lua</application> is a powerful light-weight programming
+      language designed for extending applications. It is also frequently used
+      as a general-purpose, stand-alone language. <application>Lua</application>
+      combines simple procedural syntax with powerful data description
+      constructs based on associative arrays and extensible semantics. It is
+      dynamically typed, interpreted from bytecodes, and has automatic memory
+      management with garbage collection, making it ideal for configuration,
+      scripting, and rapid prototyping. A fundamental concept in the design of
+      <application>Lua</application> is to provide meta-mechanisms for
+      implementing features, instead of providing a host of features directly in
+      the language. For example, although <application>Lua</application> is not
+      a pure object-oriented language, it does provide meta-mechanisms for
+      implementing classes and inheritance. <application>Lua</application>'s
+      meta-mechanisms bring an economy of concepts and keep the language small,
+      while allowing the semantics to be extended in unconventional ways.
+      Extensible semantics is a distinguishing feature of
+      <application>Lua</application>. <application>Lua</application> is a
+      language engine that you can embed into your application. This means that,
+      besides syntax and semantics, it has an API that allows the application to
+      exchange data with <application>Lua</application> programs and also to
+      extend <application>Lua</application> with C functions. In this sense, it
+      can be regarded as a language framework for building domain-specific
+      languages. <application>Lua</application> is implemented as a small
+      library of C functions, written in ANSI C, and compiles unmodified in all
+      known platforms. The implementation goals are simplicity, efficiency,
+      portability, and low embedding cost. The result is a fast language engine
+      with small footprint, making it ideal in embedded systems too.
+    </para>
+
+    &lfs73_checked;
+
+    <bridgehead renderas="sect3">Package Information</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>
+          Download (HTTP): <ulink url="&lua-download-http;"/>
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          Download (FTP): <ulink url="&lua-download-ftp;"/>
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          Download MD5 sum: &lua-md5sum;
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          Download size: &lua-size;
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          Estimated disk space required: &lua-buildsize;
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          Estimated build time: &lua-time;
+        </para>
+      </listitem>
+    </itemizedlist>
+
+    <bridgehead renderas="sect3">Additional Downloads</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>
+          Required patch:
+          <ulink url="&patch-root;/lua-&lua-version;-shared_library-1.patch"/>
+        </para>
+      </listitem>
+    </itemizedlist>
+
+    <para condition="html" role="usernotes">User Notes:
+      <ulink url="&blfs-wiki;/lua"/>
+    </para>
+  </sect2>
+
+  <sect2 role="installation">
+    <title>Installation of Lua</title>
+
+    <para>
+      Install <application>Lua</application> by running the following
+      commands:
+    </para>
+
+<screen><userinput>patch -Np1 -i ../lua-&lua-version;-shared_library-1.patch &&
+make linux</userinput></screen>
+
+    <para>
+      To test the results, issue: <command>make test</command>.
+    </para>
+
+    <para>
+      Now, as the <systemitem class="username">root</systemitem> user:
+    </para>
+
+<screen role="root"><userinput>make INSTALL_TOP=/usr TO_LIB="liblua.so liblua.so.5.2 liblua.so.5.2.1" \
+     INSTALL_DATA="cp -d" INSTALL_MAN=/usr/share/man/man1 install &&
+mkdir -pv /usr/share/doc/lua-&lua-version; &&
+cp -v doc/*.{html,css,gif,png} /usr/share/doc/lua-&lua-version;</userinput></screen>
+
+    <para>Some packages check for the <application>pkg-config</application> file
+    for <application>Lua</application>. As the
+    <systemitem class="username">root</systemitem> user:</para>
+
+<screen role="root"><userinput>cat > /usr/lib/pkgconfig/lua.pc << "EOF"
+<literal>V=5.2
+R=&lua-version;
+
+prefix=/usr
+INSTALL_BIN=${prefix}/bin
+INSTALL_INC=${prefix}/include
+INSTALL_LIB=${prefix}/lib
+INSTALL_MAN=${prefix}/man/man1
+INSTALL_LMOD=${prefix}/share/lua/${V}
+INSTALL_CMOD=${prefix}/lib/lua/${V}
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include
+
+Name: Lua
+Description: An Extensible Extension Language
+Version: ${R}
+Requires: 
+Libs: -L${libdir} -llua -lm
+Cflags: -I${includedir}</literal>
+EOF</userinput></screen>
+
+  </sect2>
+
+  <sect2 role="content">
+    <title>Contents</title>
+
+    <segmentedlist>
+      <segtitle>Installed Programs</segtitle>
+      <segtitle>Installed Library</segtitle>
+      <segtitle>Installed Directories</segtitle>
+
+      <seglistitem>
+        <seg>
+          lua and luac
+        </seg>
+        <seg>
+          liblua.so
+        </seg>
+        <seg>
+          /usr/lib/lua,
+          /usr/share/lua and
+          /usr/share/doc/lua-&lua-version;
+        </seg>
+      </seglistitem>
+    </segmentedlist>
+
+    <variablelist>
+      <bridgehead renderas="sect3">Short Descriptions</bridgehead>
+      <?dbfo list-presentation="list"?>
+      <?dbhtml list-presentation="table"?>
+
+      <varlistentry id="lua-prog">
+        <term><command>lua</command></term>
+        <listitem>
+          <para>
+            is the standalone Lua interpreter.
+          </para>
+          <indexterm zone="lua lua-prog">
+            <primary sortas="b-lua">lua</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="luac">
+        <term><command>luac</command></term>
+        <listitem>
+          <para>
+            is the Lua compiler.
+          </para>
+          <indexterm zone="lua luac">
+            <primary sortas="b-luac">luac</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="liblua">
+        <term><filename class="libraryfile">liblua.so</filename></term>
+        <listitem>
+          <para>
+            contains the <application>Lua</application> API functions.
+          </para>
+          <indexterm zone="lua liblua">
+            <primary sortas="b-liblua">liblua.so</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+    </variablelist>
+
+  </sect2>
+
+</sect1>

Modified: branches/systemd/general/prog/mercurial.xml
==============================================================================
--- branches/systemd/general/prog/mercurial.xml	Thu Jun 20 23:56:36 2013	(r11310)
+++ branches/systemd/general/prog/mercurial.xml	Fri Jun 21 04:53:30 2013	(r11311)
@@ -122,6 +122,36 @@
 
   </sect2>
 
+  <sect2 role="configuration">
+    <title>Configuring Mercurial</title>
+
+    <sect3 id="mercurial-config">
+      <title>Config Files</title>
+
+      <para>
+        <filename>/etc/mercurial/hgrc</filename>
+      </para>
+
+      <indexterm zone="mercurial mercurial-config">
+        <primary sortas="e-etc-mercurial-hgrc">/etc/mercurial/hgrc</primary>
+      </indexterm>
+
+      <para>
+        If you have installed the <xref linkend="cacerts"/> and you want
+        <application>Mercurial</application> to use them, as the
+        <systemitem class="username">root</systemitem> user:
+      </para>
+
+<screen role="root"><userinput>install -v -d -m755 /etc/mercurial &&
+cat > /etc/mercurial/hgrc << "EOF"
+<literal>[web]
+cacerts = /etc/ssl/ca-bundle.crt</literal>
+EOF</userinput></screen>
+
+    </sect3>
+
+  </sect2>
+
   <sect2 role="content">
     <title>Contents</title>
 
@@ -133,7 +163,7 @@
       <seglistitem>
         <seg>hg</seg>
         <seg>none</seg>
-        <seg>/usr/lib/python2.7/site-packages/hgext and
+        <seg>/etc/mercurial, /usr/lib/python2.7/site-packages/hgext and
         /usr/lib/python2.7/site-packages/mercurial</seg>
       </seglistitem>
     </segmentedlist>

Modified: branches/systemd/general/prog/other-tools.xml
==============================================================================
--- branches/systemd/general/prog/other-tools.xml	Thu Jun 20 23:56:36 2013	(r11310)
+++ branches/systemd/general/prog/other-tools.xml	Fri Jun 21 04:53:30 2013	(r11311)
@@ -1063,52 +1063,6 @@
     </sect3>
 
     <sect3 role="package">
-      <title>Lua</title>
-
-      <para><application>Lua</application> is a powerful light-weight
-      programming language designed for extending applications. It is also
-      frequently used as a general-purpose, stand-alone language. It is free
-      software. <application>Lua</application> combines simple procedural
-      syntax with powerful data description constructs based on associative
-      arrays and extensible semantics. It is dynamically typed, interpreted
-      from bytecodes, and has automatic memory management with garbage
-      collection, making it ideal for configuration, scripting, and rapid
-      prototyping. A fundamental concept in the design of
-      <application>Lua</application> is to provide meta-mechanisms for
-      implementing features, instead of providing a host of features directly
-      in the language. For example, although <application>Lua</application> is
-      not a pure object-oriented language, it does provide meta-mechanisms for
-      implementing classes and inheritance. <application>Lua</application>'s
-      meta-mechanisms bring an economy of concepts and keep the language small,
-      while allowing the semantics to be extended in unconventional ways.
-      Extensible semantics is a distinguishing feature of
-      <application>Lua</application>. <application>Lua</application> is a
-      language engine that you can embed into your application. This means
-      that, besides syntax and semantics, it has an API that allows the
-      application to exchange data with <application>Lua</application> programs
-      and also to extend <application>Lua</application> with C functions. In
-      this sense, it can be regarded as a language framework for building
-      domain-specific languages. <application>Lua</application> is implemented
-      as a small library of C functions, written in ANSI C, and compiles
-      unmodified in all known platforms. The implementation goals are
-      simplicity, efficiency, portability, and low embedding cost. The result
-      is a fast language engine with small footprint, making it ideal in
-      embedded systems too.</para>
-
-      <itemizedlist spacing="compact">
-        <listitem>
-          <para>Project Home Page: <ulink
-          url="http://www.lua.org/"/></para>
-        </listitem>
-        <listitem>
-          <para>Download Location: <ulink
-          url="http://www.lua.org/download.html"/></para>
-        </listitem>
-      </itemizedlist>
-
-    </sect3>
-
-    <sect3 role="package">
       <title>Mercury</title>
 
       <para><application>Mercury</application> is a new logic/functional

Modified: branches/systemd/general/prog/prog.xml
==============================================================================
--- branches/systemd/general/prog/prog.xml	Thu Jun 20 23:56:36 2013	(r11310)
+++ branches/systemd/general/prog/prog.xml	Fri Jun 21 04:53:30 2013	(r11311)
@@ -39,6 +39,7 @@
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="junit.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="librep.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="llvm.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="lua.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="mercurial.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="nasm.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="perl-modules.xml"/>

Modified: branches/systemd/introduction/welcome/changelog.xml
==============================================================================
--- branches/systemd/introduction/welcome/changelog.xml	Thu Jun 20 23:56:36 2013	(r11310)
+++ branches/systemd/introduction/welcome/changelog.xml	Fri Jun 21 04:53:30 2013	(r11311)
@@ -44,6 +44,23 @@
 
 -->
     <listitem>
+      <para>June 19th, 2013</para>
+      <itemizedlist>
+        <listitem>
+          <para>[igor] - Added Lua-5.2.2.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
+    <listitem>
+      <para>June 18th, 2013</para>
+      <itemizedlist>
+        <listitem>
+          <para>[ken] - patch openssl-1.0.1e and wget-1.14 for perl-5.18.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+    <listitem>
       <para>June 16th, 2013</para>
       <itemizedlist>
         <listitem>

Modified: branches/systemd/multimedia/videoutils/vlc.xml
==============================================================================
--- branches/systemd/multimedia/videoutils/vlc.xml	Thu Jun 20 23:56:36 2013	(r11310)
+++ branches/systemd/multimedia/videoutils/vlc.xml	Fri Jun 21 04:53:30 2013	(r11311)
@@ -204,7 +204,7 @@
       <xref linkend="libnotify"/>,
       <ulink url="http://sourceforge.net/projects/medialibrary/">MediaLibrary</ulink>
       (requires <xref linkend="sqlite"/>) and
-      <ulink url="http://www.lua.org/">Lua (version 5.1)</ulink>
+      <xref linkend="lua"/> (version 5.1)
     </para>
 
     <para condition="html" role="usernotes">
@@ -255,7 +255,7 @@
     </para>
 
     <para>
-      <parameter>--disable-dbus</parameter>: The package fails to install if
+      <option>--disable-dbus</option>: The package fails to install if
       <application>D-Bus</application> is missing. Use this switch if you don't
       have <application>D-Bus</application> installed.
     </para>

Modified: branches/systemd/networking/netprogs/wget.xml
==============================================================================
--- branches/systemd/networking/netprogs/wget.xml	Thu Jun 20 23:56:36 2013	(r11310)
+++ branches/systemd/networking/netprogs/wget.xml	Fri Jun 21 04:53:30 2013	(r11311)
@@ -72,6 +72,16 @@
       </listitem>
     </itemizedlist>
 
+    <bridgehead renderas="sect3">Additional Downloads</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>
+          Required patch:
+          <ulink url="&patch-root;/wget-&wget-version;-texi2pod-1.patch"/>
+        </para>
+      </listitem>
+    </itemizedlist>
+
     <bridgehead renderas="sect3">Wget Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Recommended</bridgehead>
@@ -99,18 +109,13 @@
       Install <application>Wget</application> by running the following commands:
     </para>
 
-<screen><userinput>./configure --prefix=/usr      \
+<screen><userinput>patch -Np1 -i ../wget-&wget-version;-texi2pod-1.patch &&
+
+./configure --prefix=/usr      \
             --sysconfdir=/etc  \
             --with-ssl=openssl &&
 make</userinput></screen>
 
-    <note>
-      <para><command>make</command> will fail if you have installed Perl version 
-      5.18.0 or later as the <command>pod2man</command> script was changed. This
-      is actually only a warning, and not a fatal error. Running
-      <command>make</command> a second time will terminate correctly.</para>
-    </note>
-
     <para>
       To test the results, issue: <command>make check</command>.
     </para>

Modified: branches/systemd/networking/netutils/nmap.xml
==============================================================================
--- branches/systemd/networking/netutils/nmap.xml	Thu Jun 20 23:56:36 2013	(r11310)
+++ branches/systemd/networking/netutils/nmap.xml	Fri Jun 21 04:53:30 2013	(r11311)
@@ -70,12 +70,12 @@
 
     <para role="recommended">
       <xref linkend="libpcap"/>,
-      <xref linkend="pcre"/>,
+      <xref linkend="lua"/>,
+      <xref linkend="pcre"/> and
+      <ulink url="http://www.csie.ntu.edu.tw/~cjlin/liblinear/">liblinear</ulink>
 <!-- This is not recommended, see: http://nmap.org/svn/libdnet-stripped/NMAP_MODIFICATIONS
-      <ulink url="http://code.google.com/p/libdnet/">libdnet</ulink>,
+      <ulink url="http://code.google.com/p/libdnet/">libdnet</ulink>
 -->
-      <ulink url="http://www.csie.ntu.edu.tw/~cjlin/liblinear/">liblinear</ulink> and
-      <ulink url="http://www.lua.org/">Lua</ulink>
     </para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>

Modified: branches/systemd/networking/netutils/wireshark.xml
==============================================================================
--- branches/systemd/networking/netutils/wireshark.xml	Thu Jun 20 23:56:36 2013	(r11310)
+++ branches/systemd/networking/netutils/wireshark.xml	Fri Jun 21 04:53:30 2013	(r11311)
@@ -101,7 +101,7 @@
       <ulink url="http://www.maxmind.com/app/c">GeoIP</ulink>,
       <!-- <ulink url="http://www.net-snmp.org/">Net-SNMP</ulink>, -->
       <ulink url="http://www.gnu.org/software/adns/adns.html">adns</ulink>, and
-      <ulink url="http://www.lua.org/">Lua</ulink>
+      <xref linkend="lua"/>
     </para>
 
     <para condition="html" role="usernotes">User Notes:

Modified: branches/systemd/postlfs/security/openssl.xml
==============================================================================
--- branches/systemd/postlfs/security/openssl.xml	Thu Jun 20 23:56:36 2013	(r11310)
+++ branches/systemd/postlfs/security/openssl.xml	Fri Jun 21 04:53:30 2013	(r11311)
@@ -79,8 +79,10 @@
     <itemizedlist spacing="compact">
       <listitem>
         <para>
-          Required patch:
+          Required patches:
           <ulink url="&patch-root;/openssl-&openssl-version;-fix_parallel_build-1.patch"/>
+          and
+          <ulink url="&patch-root;/openssl-&openssl-version;-fix_pod_syntax-1.patch"/>
         </para>
       </listitem>
     </itemizedlist>
@@ -107,6 +109,7 @@
     </para>
 
 <screen><userinput>patch -Np1 -i ../openssl-&openssl-version;-fix_parallel_build-1.patch &&
+patch -Np1 -i ../openssl-&openssl-version;-fix_pod_syntax-1.patch &&
 
 ./config --prefix=/usr         \
          --openssldir=/etc/ssl \
@@ -128,8 +131,7 @@
       Now, as the <systemitem class="username">root</systemitem> user:
     </para>
 
-<screen role="root"><userinput>
-make MANDIR=/usr/share/man MANSUFFIX=ssl install &&
+<screen role="root"><userinput>make MANDIR=/usr/share/man MANSUFFIX=ssl install &&
 install -dv -m755 /usr/share/doc/openssl-&openssl-version;  &&
 cp -vfr doc/*     /usr/share/doc/openssl-&openssl-version;</userinput></screen>
 

Modified: branches/systemd/pst/typesetting/texlive.xml
==============================================================================
--- branches/systemd/pst/typesetting/texlive.xml	Thu Jun 20 23:56:36 2013	(r11310)
+++ branches/systemd/pst/typesetting/texlive.xml	Fri Jun 21 04:53:30 2013	(r11311)
@@ -102,7 +102,7 @@
       <ulink url="http://www.sfr-fresh.com/linux/misc/t1lib">t1lib</ulink>,
       <ulink url="http://sourceforge.net/projects/zziplib/">ZZIPlib</ulink>,
       <ulink url="http://www.gnu.org/software/clisp/">CLISP</ulink>,
-      <ulink url="http://www.lua.org/">Lua</ulink>,
+      <xref linkend="lua"/>,
       <ulink url="http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&id=TECkitDownloads">TECkit</ulink>, and
       <ulink url="http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&cat_id=RenderingGraphite">
     Graphite</ulink></para>

Modified: branches/systemd/server/major/apache.xml
==============================================================================
--- branches/systemd/server/major/apache.xml	Thu Jun 20 23:56:36 2013	(r11310)
+++ branches/systemd/server/major/apache.xml	Fri Jun 21 04:53:30 2013	(r11311)
@@ -103,7 +103,7 @@
       <xref linkend="pcre"/>,
       <xref linkend="rsync"/>,
       <ulink url="http://www.distcache.org/">Distcache</ulink> and
-      <ulink url="http://www.lua.org/">Lua (5.1)</ulink>
+      <xref linkend="lua"/> (version 5.1)
     </para>
 
     <para condition="html" role="usernotes">

Modified: branches/systemd/x/installing/x7driver.xml
==============================================================================
--- branches/systemd/x/installing/x7driver.xml	Thu Jun 20 23:56:36 2013	(r11310)
+++ branches/systemd/x/installing/x7driver.xml	Fri Jun 21 04:53:30 2013	(r11311)
@@ -1156,9 +1156,12 @@
           For Direct Rendering to work with newer Radeon Cards (r300 and later chipsets),
           you will need to enable building of r300, r600 and radeonsi Gallium drivers in
           <xref linkend="mesalib"/> instructions. Also, some cards will require Firmware
-          to be available when kernel driver is loaded. Firmware can be obtained from
-          <ulink url="git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git">
-          Linux Firmware Repository</ulink>.
+          to be available when the kernel driver is loaded. Firmware can be obtained from
+          <ulink  url="http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/tree/">
+          Linux Firmware</ulink>, either by cloning from
+          git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
+          or by using a Linux Firmware source tarball from a distro. See "Kernel
+          Configuration for additional firmware" below.
         </para>
       </note>
 
@@ -1198,9 +1201,16 @@
 
       <bridgehead renderas="sect4">Xorg ATI Driver Dependencies</bridgehead>
 
-      <bridgehead renderas="sect5">Recommended</bridgehead>
-      <para role="recommended">
-        <xref linkend="glamor-egl"/>
+      <bridgehead renderas="sect5">Required</bridgehead>
+      <para role="required">
+        <xref linkend="xorg-server"/>
+      </para>
+
+      <bridgehead renderas="sect5">Optional</bridgehead>
+      <para role="optional">
+        <xref linkend="glamor-egl"/> (This is <emphasis>required for "South Islands"
+        GPUs</emphasis> but optional for R300 to R700, Evergreen and "Northern Islands"
+        GPUs - see the link under "Glamor Acceleration" below.)
       </para>
 
       <para condition="html" role="usernotes">
@@ -1225,6 +1235,24 @@
       </indexterm>
     </sect3>
 
+    <sect3 role="kernel" id="xorg-ati-firmware-kernel">
+      <title>Kernel Configuration for additional firmware</title>
+
+    <para>
+      If you need to add firmware, install the file(s) and then point to them in the
+      kernel configuration and recompile the kernel if necessary, e.g. (for a specific
+      R600 with a specific network adaptor which also needs firmware) :
+    </para>
+
+<screen><literal>CONFIG_EXTRA_FIRMWARE="radeon/R600_rlc.bin rtl_nic/rtl8168e-3.fw"
+CONFIG_EXTRA_FIRMWARE_DIR="/lib/firmware"
+</literal></screen>
+
+      <indexterm zone="xorg-ati-driver xorg-ati-firmware-kernel">
+        <primary sortas="d-xorg-ati-firmware">xorg-ati-firmware</primary>
+      </indexterm>
+    </sect3>
+
     <sect3 role="installation">
       <title>Installation of Xorg ATI Driver</title>
 
@@ -1252,7 +1280,8 @@
 
       <para>
         <parameter>--enable-glamor</parameter>: This switch enables
-        new GL-based acceleration.
+        new GL-based acceleration. As well as specifying this in the
+        build, it needs to be enabled at run time (see below).
       </para>
 
     </sect3>
@@ -1268,8 +1297,8 @@
         "South Islands" category, read the
         <ulink url="&radeon-marketing-names;">
         Decoder ring for engineering vs marketing names</ulink>. Please note
-        that Glamor acceleration can be used with other chips as well, but
-        it has not been tested recently.
+        that Glamor acceleration can be used with other chips as well, from the
+        R300 onwards, but it has not been tested recently.
       </para>
 
       <para>



More information about the blfs-book mailing list