[blfs-book] r11304 - in trunk/BOOK: . introduction/welcome networking/netprogs postlfs/security

ken at higgs.linuxfromscratch.org ken at higgs.linuxfromscratch.org
Tue Jun 18 16:28:26 PDT 2013


Author: ken
Date: Tue Jun 18 16:28:26 2013
New Revision: 11304

Log:
Patch openssl and wget for perl-5.18. The openssl patch also corrects how one page is rendered by perl-5.16.

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/networking/netprogs/wget.xml
   trunk/BOOK/postlfs/security/openssl.xml

Modified: trunk/BOOK/general.ent
==============================================================================
--- trunk/BOOK/general.ent	Mon Jun 17 03:21:02 2013	(r11303)
+++ trunk/BOOK/general.ent	Tue Jun 18 16:28:26 2013	(r11304)
@@ -3,13 +3,13 @@
 $Date$
 -->
 
-<!ENTITY day          "16">                   <!-- Always 2 digits -->
+<!ENTITY day          "18">                   <!-- Always 2 digits -->
 <!ENTITY month        "06">                   <!-- Always 2 digits -->
 <!ENTITY year         "2013">
 <!ENTITY copyrightdate "2001-&year;">
 <!ENTITY copyholder   "The BLFS Development Team">
 <!ENTITY version      "&year;-&month;-&day;">
-<!ENTITY releasedate  "June 16th, &year;">
+<!ENTITY releasedate  "June 18th, &year;">
 <!ENTITY pubdate      "&year;-&month;-&day;"> <!-- metadata req. by TLDP -->
 <!ENTITY blfs-version "svn">                  <!-- svn|[release #] -->
 <!ENTITY lfs-version  "development">          <!-- version|testing|unstable|development] -->

Modified: trunk/BOOK/introduction/welcome/changelog.xml
==============================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	Mon Jun 17 03:21:02 2013	(r11303)
+++ trunk/BOOK/introduction/welcome/changelog.xml	Tue Jun 18 16:28:26 2013	(r11304)
@@ -44,6 +44,14 @@
 
 -->
     <listitem>
+      <para>June 18th, 2013</para>
+      <itemizedlist>
+        <listitem>
+          <para>[ken] - patch openssl-1.0.1e and wget-1.14 for perl-5.18.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+    <listitem>
       <para>June 16th, 2013</para>
       <itemizedlist>
         <listitem>

Modified: trunk/BOOK/networking/netprogs/wget.xml
==============================================================================
--- trunk/BOOK/networking/netprogs/wget.xml	Mon Jun 17 03:21:02 2013	(r11303)
+++ trunk/BOOK/networking/netprogs/wget.xml	Tue Jun 18 16:28:26 2013	(r11304)
@@ -72,6 +72,16 @@
       </listitem>
     </itemizedlist>
 
+    <bridgehead renderas="sect3">Additional Downloads</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>
+          Required patch:
+          <ulink url="&patch-root;/wget-&wget-version;-texi2pod-1.patch"/>
+        </para>
+      </listitem>
+    </itemizedlist>
+
     <bridgehead renderas="sect3">Wget Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Recommended</bridgehead>
@@ -99,18 +109,13 @@
       Install <application>Wget</application> by running the following commands:
     </para>
 
-<screen><userinput>./configure --prefix=/usr      \
+<screen><userinput>patch -Np1 -i ../wget-&wget-version;-texi2pod-1.patch &&
+
+./configure --prefix=/usr      \
             --sysconfdir=/etc  \
             --with-ssl=openssl &&
 make</userinput></screen>
 
-    <note>
-      <para><command>make</command> will fail if you have installed Perl version 
-      5.18.0 or later as the <command>pod2man</command> script was changed. This
-      is actually only a warning, and not a fatal error. Running
-      <command>make</command> a second time will terminate correctly.</para>
-    </note>
-
     <para>
       To test the results, issue: <command>make check</command>.
     </para>

Modified: trunk/BOOK/postlfs/security/openssl.xml
==============================================================================
--- trunk/BOOK/postlfs/security/openssl.xml	Mon Jun 17 03:21:02 2013	(r11303)
+++ trunk/BOOK/postlfs/security/openssl.xml	Tue Jun 18 16:28:26 2013	(r11304)
@@ -79,8 +79,10 @@
     <itemizedlist spacing="compact">
       <listitem>
         <para>
-          Required patch:
+          Required patches:
           <ulink url="&patch-root;/openssl-&openssl-version;-fix_parallel_build-1.patch"/>
+          and
+          <ulink url="&patch-root;/openssl-&openssl-version;-fix_pod_syntax-1.patch"/>
         </para>
       </listitem>
     </itemizedlist>
@@ -107,6 +109,7 @@
     </para>
 
 <screen><userinput>patch -Np1 -i ../openssl-&openssl-version;-fix_parallel_build-1.patch &&
+patch -Np1 -i ../openssl-&openssl-version;-fix_pod_syntax-1.patch &&
 
 ./config --prefix=/usr         \
          --openssldir=/etc/ssl \



More information about the blfs-book mailing list