[blfs-book] [BLFS Trac] #3771: LibreOffice 4.0

BLFS Trac trac at linuxfromscratch.org
Wed Feb 13 12:13:46 PST 2013


#3771: LibreOffice 4.0
-------------------------+--------------------------------------------------
 Reporter:  rt           |       Owner:  blfs-book@…                   
     Type:  enhancement  |      Status:  new                           
 Priority:  normal       |   Milestone:  current                       
Component:  BOOK         |     Version:  SVN                           
 Severity:  normal       |    Keywords:                                
-------------------------+--------------------------------------------------

Comment(by rt):

 I tried your instructions, with the following modifications:
 I don't have openldap, libwps, libwpg, libwpd, icu, hunspell, graphite,
 cppunit, bluez, gstreamer, gtk3 and gio so I removed those switches.
 Also I had to add --disable-cups and --without-doxygen, and I used --with-
 parallelism=8.
 I get the same build error though:

 {{{
 =============
 (6/11) Building module tail_build
 =============
 Entering /sources/libreoffice-4.0.0.3/tail_build/prj

 gbuild module /sources/libreoffice-4.0.0.3/tail_build: make -f Makefile
 -j8 -rs all slowcheck gb_PARTIALBUILD=T
 /sources/libreoffice-4.0.0.3/Module_tail_build.mk:27:
 /sources/libreoffice-4.0.0.3//dictionaries/Module_dictionaries.mk: No such
 file or directory
 Makefile:17: *** Corrupted module target stack! .  Stop.
 }}}

 I tried removing the --with-system-dicts option, since this error seems
 related to dictionaries, but it didn't help. I also tried downloading the
 dictionaries tarball and extracting it in the directory.
 Any ideas?
 I am confused why it builds on your system and not mine...

-- 
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/3771#comment:6>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch



More information about the blfs-book mailing list