[blfs-book] r10705 - in trunk/BOOK: . general/genutils introduction/welcome

bdubbs at linuxfromscratch.org bdubbs at linuxfromscratch.org
Fri Sep 28 11:38:01 PDT 2012


Author: bdubbs
Date: 2012-09-28 12:37:51 -0600 (Fri, 28 Sep 2012)
New Revision: 10705

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/general/genutils/imagemagick.xml
   trunk/BOOK/introduction/welcome/changelog.xml
Log:
Update to ImageMagick-6.7.9-8

Modified: trunk/BOOK/general/genutils/imagemagick.xml
===================================================================
--- trunk/BOOK/general/genutils/imagemagick.xml	2012-09-28 17:23:30 UTC (rev 10704)
+++ trunk/BOOK/general/genutils/imagemagick.xml	2012-09-28 18:37:51 UTC (rev 10705)
@@ -4,7 +4,7 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY imagemagick-patch-version "6">
+  <!ENTITY imagemagick-patch-version "8">
   <!-- Not sure what to do here as ImageMagick is one of the fastest-moving
        targets in all of open-source. One solution is to always use the last
        version of a specific major-minor from the 'legacy' subdirectory of
@@ -15,9 +15,9 @@
 
   <!ENTITY imagemagick-download-http " ">
   <!ENTITY imagemagick-download-ftp  "ftp://ftp.imagemagick.org/pub/ImageMagick/ImageMagick-&imagemagick-version;-&imagemagick-patch-version;.tar.xz">
-  <!ENTITY imagemagick-md5sum        "1dc4fb3febd1db7e0ab47c877f66eb09">
-  <!ENTITY imagemagick-size          "7.5 MB">
-  <!ENTITY imagemagick-buildsize     "264 MB typical (additional 27MB if you run the testsuite, and additional 68 MB if you run the Image::Magick demo)">
+  <!ENTITY imagemagick-md5sum        "c3084e6de11e440b812479de151642a3">
+  <!ENTITY imagemagick-size          "8.0 MB">
+  <!ENTITY imagemagick-buildsize     "300 MB typical (additional 27MB if you run the testsuite)">
   <!ENTITY imagemagick-time          "3.2 SBU typical (Additional 0.8 SBU to run the test suite)">
 ]>
 
@@ -187,18 +187,14 @@
     <para>Install <application>Imagemagick</application> by running the following
     commands:</para>
 
-<screen><userinput>./configure --prefix=/usr --sysconfdir=/etc \
-  --with-modules &&
+<screen><userinput>
+./configure --prefix=/usr     \
+            --sysconfdir=/etc \
+            --with-modules    \
+            --with-perl       \
+            --without-magick-plus-plus &&
 make</userinput></screen>
 
-    <para>If you wish to build the <application>PerlMagick</application>
-    <application>perl</application> module, use the following commands:</para>
-
-<screen><userinput>cd PerlMagick &&
-perl Makefile.PL &&
-make &&
-cd ..</userinput></screen>
-
      <para>To test the results, issue: <command>make check</command>. Note that
      many of the tests require a working <application>ghostscript</application>.</para>
 
@@ -237,6 +233,13 @@
     <para><parameter>--with-modules</parameter>: Enables support for dynamically
     loadable modules.</para>
 
+    <para><parameter>--with-perl</parameter>: Enables building and install 
+    PerlMagick.</para>
+
+    <para><parameter>--without-magick-plus-plus</parameter>: Disables building 
+    and installing Magick++.  All the test modules and demos for Magick++
+    currently fail.</para>
+
     <para><option>--with-gslib=/usr/lib</option>: Enables support to use the
     Ghostscript shared library.</para>
 
@@ -267,12 +270,14 @@
 
       <seglistitem>
         <seg>animate, compare, composite, conjure, convert, display,
-        identify, import, Magick++-config, Magick-config, MagickCore-config,
+        identify, import, Magick-config, MagickCore-config,
         MagickWand-config, mogrify, montage, stream, and Wand-config</seg>
-        <seg>libMagick.{so,a}, libMagickCore.{so,a} libMagick++.{so,a},
-	libMagickWand.{so,a}, optionally the Magick.so Perl module, and
+
+        <seg>libMagickCore.{so,a}, libMagickWand.{so,a}, and
         numerous plugin modules</seg>
-        <seg>/usr/include/Magick++, /usr/include/magick, /usr/include/wand,
+        
+        <seg>/etc/ImageMagick,
+        /usr/include/ImageMagick, 
         /usr/lib/ImageMagick-&imagemagick-version;,
         /usr/lib/perl5/site_perl/&lfs-perl-version;/auto/Image,
         /usr/lib/perl5/site_perl/&lfs-perl-version;/Image/Magick,
@@ -367,11 +372,10 @@
     </varlistentry>
 
     <varlistentry id="magick-config">
-      <term><command>Magick-config</command> and
-      <command>Magick++-config, MagickCore-config, MagickWand-config</command></term>
+      <term><command>Magick{,Core,Wand}-config</command></term>
       <listitem>
         <para>show information about the installed versions of the
-        <application>ImageMagick</application> Magick++, MagickCore and MagickWand libraries.</para>
+        <application>ImageMagick</application> libraries.</para>
         <indexterm zone="imagemagick magick-config">
           <primary sortas="b-Magick-config">Magick-config</primary>
         </indexterm>

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2012-09-28 17:23:30 UTC (rev 10704)
+++ trunk/BOOK/general.ent	2012-09-28 18:37:51 UTC (rev 10705)
@@ -320,7 +320,7 @@
 <!ENTITY gtk-doc-version              "1.18">
 <!ENTITY hd2u-version                 "1.0.3">
 <!ENTITY icon-naming-utils-version    "0.8.90">
-<!ENTITY imagemagick-version          "6.7.8">
+<!ENTITY imagemagick-version          "6.7.9">
 <!ENTITY intltool-version             "0.50.2">
 <!ENTITY libiodbc-version             "3.52.8">
 <!ENTITY pilot-link-version           "0.12.2">

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2012-09-28 17:23:30 UTC (rev 10704)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2012-09-28 18:37:51 UTC (rev 10705)
@@ -47,6 +47,10 @@
       <para>September 28th, 2012</para>
       <itemizedlist>
         <listitem>
+          <para>[bdubbs] - Update to ImageMagick-6.7.9-8. Fixes
+          <ulink url="&blfs-ticket-root;3525">#3525</ulink>.</para>
+        </listitem>
+        <listitem>
           <para>[bdubbs] - Update to transmission-2.71. Fixes
           <ulink url="&blfs-ticket-root;3580">#3580</ulink>.</para>
         </listitem>




More information about the blfs-book mailing list