[blfs-book] r10362 - in trunk/BOOK: . general/graphlib introduction/welcome

andy at linuxfromscratch.org andy at linuxfromscratch.org
Tue Jun 26 05:57:05 PDT 2012


Author: andy
Date: 2012-06-26 06:57:00 -0600 (Tue, 26 Jun 2012)
New Revision: 10362

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/general/graphlib/poppler.xml
   trunk/BOOK/introduction/welcome/changelog.xml
Log:
poppler-0.20.1

Modified: trunk/BOOK/general/graphlib/poppler.xml
===================================================================
--- trunk/BOOK/general/graphlib/poppler.xml	2012-06-26 12:32:51 UTC (rev 10361)
+++ trunk/BOOK/general/graphlib/poppler.xml	2012-06-26 12:57:00 UTC (rev 10362)
@@ -7,12 +7,11 @@
   <!ENTITY poppler-download-http
     "http://poppler.freedesktop.org/poppler-&poppler-version;.tar.gz">
   <!ENTITY poppler-download-ftp       " ">
-  <!ENTITY poppler-md5sum             "12658f3308597e57f3faff538cc73baf">
-  <!ENTITY poppler-size               "1.9 MB">
-  <!ENTITY poppler-buildsize          "28 MB (excluding the encoding data) and
-    112 MB (including the encoding data)">
-  <!ENTITY poppler-time               "1.3 SBU (includes building with most
-    dependencies)">
+  <!ENTITY poppler-md5sum             "a61e3b844061f5324512a16d6d16984c">
+  <!ENTITY poppler-size               "2.1 MB">
+  <!ENTITY poppler-buildsize          "86 MB (excluding the encoding data) and
+    110 MB (including the encoding data)">
+  <!ENTITY poppler-time               "0.9 SBU">
 
   <!ENTITY poppler-data-version       "0.4.5">
   <!ENTITY poppler-data-download-http
@@ -109,29 +108,16 @@
       <application>Poppler</application> to render CJK and Cyrillic properly.
     </para>
 
-    <bridgehead renderas="sect3">Additional Downloads</bridgehead>
-    <itemizedlist spacing="compact">
-      <listitem>
-        <para>
-          Optional patch (if you want to use <application>Lcms 2</application>):
-          <ulink url="&patch-root;/poppler-&poppler-version;-lcms2-1.patch"/>
-        </para>
-      </listitem>
-    </itemizedlist>
-
     <bridgehead renderas="sect3">Poppler Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required">
-      <xref linkend="fontconfig"/> and
-      <xref linkend="glib2"/>
-    </para>
+    <para role="required"><xref linkend="fontconfig"/></para>
 
     <bridgehead renderas="sect4">Recommended</bridgehead>
     <para role="recommended">
-      <xref linkend="libjpeg"/>,
-      <xref linkend="cairo"/> and
-      <xref linkend="openjpeg"/>.
+      <xref linkend="cairo"/>,
+      <xref linkend="libjpeg"/> and
+      <xref linkend="libpng"/>
     </para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
@@ -140,7 +126,8 @@
       <xref linkend="gtk2"/>,
       <xref linkend="lcms"/> or <xref linkend="lcms2"/>,
       <xref linkend="libtiff"/>,
-      <xref linkend="libxml2"/> and
+      <xref linkend="libxml2"/>,
+      <xref linkend="openjpeg"/> and
       <xref linkend="qt4"/> (the <filename>libpoppler-qt4.so</filename> library
       is needed for PDF support in <application>Okular</application>).
     </para>
@@ -154,33 +141,12 @@
     <title>Installation of Poppler</title>
 
     <para>
-      If you have installed <xref linkend="lcms2"/> and would like
-      <application>Poppler</application> to use it, apply the
-      <application>Lcms 2</application> patch:
-    </para>
-
-<screen><userinput>patch -p1 < ../poppler-&poppler-version;-lcms2-1.patch</userinput></screen>
-
-    <para>
       Install <application>Poppler</application> by running the following
       commands:
     </para>
 
-<!-- Xpdf is no longer in the book
-    <caution>
-      <para>
-        <application>Poppler</application> will overwrite command-line utilities
-        and man pages previously installed by the
-        <application>Xpdf</application> package. If you prefer to keep the
-        <application>Xpdf</application> versions of these files, pass the
-        <option>--disable-utils</option> parameter to the
-        <command>configure</command> command below.
-      </para>
-    </caution>
--->
-
-<screen><userinput>./configure --prefix=/usr --sysconfdir=/etc        \
-            --disable-static --enable-xpdf-headers &&
+<screen><userinput>./configure --prefix=/usr --sysconfdir=/etc --enable-zlib \
+            --disable-static --enable-xpdf-headers    &&
 make</userinput></screen>
 
     <para>
@@ -224,7 +190,7 @@
     </para>
 
     <para>
-      <parameter>-enable-zlib</parameter>: This parameter makes
+      <option>--enable-zlib</option>: This option makes
       <application>Poppler</application> link with the system-installed
       <filename class='libraryfile'>libz</filename> library to enable compressed
       PDF functionality.
@@ -241,16 +207,29 @@
 
       <seglistitem>
         <seg>
-          pdffonts, pdfimages, pdfinfo, pdfseparate, pdftocairo, pdftohtml,
-          pdftoppm, pdftops, pdftotext, pdfunite and poppler-glib-demo
+          pdffonts,
+          pdfimages,
+          pdfinfo,
+          pdfseparate,
+          pdftocairo,
+          pdftohtml,
+          pdftoppm,
+          pdftops,
+          pdftotext,
+          pdfunite and
+          poppler-glib-demo
         </seg>
         <seg>
-          libpoppler.so, libpoppler-cpp.so, libpoppler-glib.so and
+          libpoppler.so,
+          libpoppler-cpp.so,
+          libpoppler-glib.so and
           libpoppler-qt4.so
         </seg>
         <seg>
-          /usr/include/poppler, /usr/share/doc/poppler-&poppler-version;,
-          /usr/share/gtk-doc/html/poppler and /usr/share/poppler
+          /usr/include/poppler,
+          /usr/share/doc/poppler-&poppler-version;,
+          /usr/share/gtk-doc/html/poppler and
+          /usr/share/poppler
         </seg>
       </seglistitem>
     </segmentedlist>

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2012-06-26 12:32:51 UTC (rev 10361)
+++ trunk/BOOK/general.ent	2012-06-26 12:57:00 UTC (rev 10362)
@@ -280,7 +280,7 @@
 <!ENTITY libtiff-version              "4.0.1">
 <!ENTITY openjpeg-version             "1.5.0">
 <!ENTITY pixman-version               "0.26.0">
-<!ENTITY poppler-version              "0.18.4">
+<!ENTITY poppler-version              "0.20.1">
 
 <!-- Removed
 <!ENTITY libungif-version             "4.1.3">

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2012-06-26 12:32:51 UTC (rev 10361)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2012-06-26 12:57:00 UTC (rev 10362)
@@ -52,24 +52,26 @@
         </listitem>
         <listitem>
           <para>[rthomsen] - Upgrade to D-Bus GLib Bindings 0.100.
-	  Fixes <ulink url="&blfs-ticket-root;3436">#3436</ulink>.</para>
+          Fixes <ulink url="&blfs-ticket-root;3436">#3436</ulink>.</para>
         </listitem>
         <listitem>
           <para>[rthomsen] - Upgrade to D-Bus Python Bindings 1.1.1.
-	  Fixes <ulink url="&blfs-ticket-root;3415">#3415</ulink>.</para>
+          Fixes <ulink url="&blfs-ticket-root;3415">#3415</ulink>.</para>
         </listitem>
         <listitem>
           <para>[rthomsen] - Upgrade to D-Bus 1.6.0.
-	  Fixes <ulink url="&blfs-ticket-root;3403">#3403</ulink>.</para>
+          Fixes <ulink url="&blfs-ticket-root;3403">#3403</ulink>.</para>
         </listitem>
         <listitem>
           <para>[rthomsen] - Upgrade to libdbusmenu-qt 0.9.2.
-	  Fixes <ulink url="&blfs-ticket-root;3434">#3434</ulink>.</para>
+          Fixes <ulink url="&blfs-ticket-root;3434">#3434</ulink>.</para>
         </listitem>
         <listitem>
           <para>[rthomsen] - Upgrade to Qt 4.8.2.
-	  Fixes <ulink url="&blfs-ticket-root;3432">#3432</ulink>.</para>
+          Fixes <ulink url="&blfs-ticket-root;3432">#3432</ulink>.</para>
         </listitem>
+          <para>[abenton] - Upgrade Poppler to 0.20.1</para>
+        </listitem>
       </itemizedlist>
     </listitem>
 




More information about the blfs-book mailing list