[blfs-book] r10464 - trunk/BOOK/x/lib

krejzi at linuxfromscratch.org krejzi at linuxfromscratch.org
Tue Jul 24 09:17:49 PDT 2012


Author: krejzi
Date: 2012-07-24 10:17:44 -0600 (Tue, 24 Jul 2012)
New Revision: 10464

Modified:
   trunk/BOOK/x/lib/atk.xml
   trunk/BOOK/x/lib/atkmm.xml
   trunk/BOOK/x/lib/cairo.xml
   trunk/BOOK/x/lib/cairomm.xml
   trunk/BOOK/x/lib/clutter-gtk.xml
   trunk/BOOK/x/lib/cogl.xml
   trunk/BOOK/x/lib/gdk-pixbuf.xml
   trunk/BOOK/x/lib/gtk+2.xml
   trunk/BOOK/x/lib/gtk+3.xml
   trunk/BOOK/x/lib/gtk-vnc.xml
   trunk/BOOK/x/lib/gtkmm2.xml
   trunk/BOOK/x/lib/gtkmm3.xml
   trunk/BOOK/x/lib/libnotify.xml
   trunk/BOOK/x/lib/libxklavier.xml
   trunk/BOOK/x/lib/mx.xml
   trunk/BOOK/x/lib/notification-daemon.xml
   trunk/BOOK/x/lib/pango.xml
   trunk/BOOK/x/lib/pangomm.xml
   trunk/BOOK/x/lib/webkitgtk.xml
Log:
XML Polishing, Part 2. Set libpng (again) as required for Cairo, since it requires too many switches if it is not present, thus making it realy required.

Modified: trunk/BOOK/x/lib/atk.xml
===================================================================
--- trunk/BOOK/x/lib/atk.xml	2012-07-24 16:16:08 UTC (rev 10463)
+++ trunk/BOOK/x/lib/atk.xml	2012-07-24 16:17:44 UTC (rev 10464)
@@ -12,7 +12,7 @@
   <!ENTITY atk-time          "0.1 SBU">
 ]>
 
-<sect1 id="atk" xreflabel="atk-&atk-version;">
+<sect1 id="atk" xreflabel="ATK-&atk-version;">
   <?dbhtml filename="atk.html" ?>
 
   <sect1info>
@@ -20,41 +20,55 @@
     <date>$Date$</date>
   </sect1info>
 
-  <title>atk-&atk-version;</title>
+  <title>ATK-&atk-version;</title>
 
   <indexterm zone="atk">
-    <primary sortas="a-atk">atk</primary>
+    <primary sortas="a-ATK">ATK</primary>
   </indexterm>
 
   <sect2 role="package">
     <title>Introduction to ATK</title>
 
-    <para><application>ATK</application> provides the set of accessibility
-    interfaces that are implemented by other toolkits and applications. 
-    Using the <application>ATK</application> interfaces, accessibility tools 
-    have full access to view and control running applications.</para>
+    <para>
+      <application>ATK</application> provides the set of accessibility
+      interfaces that are implemented by other toolkits and applications. 
+      Using the <application>ATK</application> interfaces, accessibility
+      tools have full access to view and control running applications.
+    </para>
 
     &lfs71_checked;
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
-        <para>Download (HTTP): <ulink url="&atk-download-http;"/></para>
+        <para>
+          Download (HTTP): <ulink url="&atk-download-http;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download (FTP): <ulink url="&atk-download-ftp;"/></para>
+        <para>
+          Download (FTP): <ulink url="&atk-download-ftp;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download MD5 sum: &atk-md5sum;</para>
+        <para>
+          Download MD5 sum: &atk-md5sum;
+        </para>
       </listitem>
       <listitem>
-        <para>Download size: &atk-size;</para>
+        <para>
+          Download size: &atk-size;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated disk space required: &atk-buildsize;</para>
+        <para>
+          Estimated disk space required: &atk-buildsize;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated build time: &atk-time;</para>
+        <para>
+          Estimated build time: &atk-time;
+        </para>
       </listitem>
     </itemizedlist>
 
@@ -76,22 +90,28 @@
     </para>
 
     <para condition="html" role="usernotes">User Notes:
-    <ulink url="&blfs-wiki;/atk"/></para>
-
+      <ulink url="&blfs-wiki;/atk"/>
+    </para>
   </sect2>
 
   <sect2 role="installation">
     <title>Installation of ATK</title>
 
-    <para>Install <application>atk</application> by running
-    the following commands:</para>
+    <para>
+      Install <application>ATK</application> by running
+      the following commands:
+    </para>
 
 <screen><userinput>./configure --prefix=/usr &&
 make</userinput></screen>
 
-    <para>To test the results, issue: <command>make check</command>.</para>
+    <para>
+      To test the results, issue: <command>make check</command>.
+    </para>
 
-    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+    <para>
+      Now, as the <systemitem class="username">root</systemitem> user:
+    </para>
 
 <screen role="root"><userinput>make install</userinput></screen>
 
@@ -101,7 +121,7 @@
     <title>Command Explanations</title>
 
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-    href="../../xincludes/gtk-doc-rebuild.xml"/>
+      href="../../xincludes/gtk-doc-rebuild.xml"/>
 
   </sect2>
 
@@ -117,7 +137,8 @@
           libatk-1.0.so
         </seg>
         <seg>
-          /usr/include/atk-1.0 and /usr/share/gtk-doc/html/atk
+          /usr/include/atk-1.0 and
+          /usr/share/gtk-doc/html/atk
         </seg>
       </seglistitem>
     </segmentedlist>
@@ -130,8 +151,10 @@
       <varlistentry id="libatk">
         <term><filename class='libraryfile'>libatk-1.0.so</filename></term>
         <listitem>
-          <para>contains functions that are used by assistive technologies
-          to interact with the desktop applications.</para>
+          <para>
+            contains functions that are used by assistive technologies
+            to interact with the desktop applications.
+          </para>
           <indexterm zone="atk libatk">
             <primary sortas="c-libatk">libatk-1.0.so</primary>
           </indexterm>

Modified: trunk/BOOK/x/lib/atkmm.xml
===================================================================
--- trunk/BOOK/x/lib/atkmm.xml	2012-07-24 16:16:08 UTC (rev 10463)
+++ trunk/BOOK/x/lib/atkmm.xml	2012-07-24 16:17:44 UTC (rev 10464)
@@ -12,7 +12,7 @@
   <!ENTITY atkmm-time          "0.2 SBU">
 ]>
 
-<sect1 id="atkmm" xreflabel="atkmm-&atkmm-version;">
+<sect1 id="atkmm" xreflabel="Atkmm-&atkmm-version;">
   <?dbhtml filename="atkmm.html"?>
 
   <sect1info>
@@ -20,67 +20,87 @@
     <date>$Date$</date>
   </sect1info>
 
-  <title>atkmm-&atkmm-version;</title>
+  <title>Atkmm-&atkmm-version;</title>
 
   <indexterm zone="atkmm">
-    <primary sortas="a-atkmm">atkmm</primary>
+    <primary sortas="a-Atkmm">Atkmm</primary>
   </indexterm>
 
   <sect2 role="package">
-    <title>Introduction to atkmm</title>
+    <title>Introduction to Atkmm</title>
 
-    <para><application>Atkmm</application> is the official C++ interface for the
-    ATK accessibility toolkit library.</para>
+    <para>
+      <application>Atkmm</application> is the official C++ interface for the
+      ATK accessibility toolkit library.
+    </para>
 
     &lfs70_checked;
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
-        <para>Download (HTTP): <ulink url="&atkmm-download-http;"/></para>
+        <para>
+          Download (HTTP): <ulink url="&atkmm-download-http;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download (FTP): <ulink url="&atkmm-download-ftp;"/></para>
+        <para>
+          Download (FTP): <ulink url="&atkmm-download-ftp;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download MD5 sum: &atkmm-md5sum;</para>
+        <para>
+          Download MD5 sum: &atkmm-md5sum;
+        </para>
       </listitem>
       <listitem>
-        <para>Download size: &atkmm-size;</para>
+        <para>
+          Download size: &atkmm-size;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated disk space required: &atkmm-buildsize;</para>
+        <para>
+          Estimated disk space required: &atkmm-buildsize;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated build time: &atkmm-time;</para>
+        <para>
+          Estimated build time: &atkmm-time;
+        </para>
       </listitem>
     </itemizedlist>
 
-    <bridgehead renderas="sect3">atkmm Dependencies</bridgehead>
+    <bridgehead renderas="sect3">Atkmm Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required">
-      <xref linkend="glibmm"/> and
-      <xref linkend="atk"/>
+      <xref linkend="atk"/> and
+      <xref linkend="glibmm"/>
     </para>
 
     <para condition="html" role="usernotes">User Notes:
-    <ulink url="&blfs-wiki;/atkmm"/></para>
-
+      <ulink url="&blfs-wiki;/atkmm"/>
+    </para>
   </sect2>
 
   <sect2 role="installation">
-    <title>Installation of atkmm</title>
+    <title>Installation of Atkmm</title>
 
-    <para>Install <application>atkmm</application> by running the following
-    commands:</para>
+    <para>
+      Install <application>Atkmm</application> by running the following
+      commands:
+    </para>
 
 <screen><userinput>./configure --prefix=/usr &&
 make</userinput></screen>
 
-    <para>This package does not have a testsuite.</para>
+    <para>
+      This package does not come with a testsuite.
+    </para>
 
-    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+    <para>
+      Now, as the <systemitem class="username">root</systemitem> user:
+    </para>
 
 <screen role="root"><userinput>make install</userinput></screen>
 
@@ -114,7 +134,9 @@
       <varlistentry id="libatkmm-1">
         <term><filename class='libraryfile'>libatkmm-1.6.so</filename></term>
         <listitem>
-          <para>contains the <application>ATK</application> API classes.</para>
+          <para>
+            contains the <application>ATK</application> API classes.
+          </para>
           <indexterm zone="atkmm libatkmm-1">
             <primary sortas="c-libatkmm-1">libatkmm-1.6.so</primary>
           </indexterm>

Modified: trunk/BOOK/x/lib/cairo.xml
===================================================================
--- trunk/BOOK/x/lib/cairo.xml	2012-07-24 16:16:08 UTC (rev 10463)
+++ trunk/BOOK/x/lib/cairo.xml	2012-07-24 16:17:44 UTC (rev 10464)
@@ -4,8 +4,7 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY cairo-download-http
-    "http://cairographics.org/releases/cairo-&cairo-version;.tar.xz">
+  <!ENTITY cairo-download-http "http://cairographics.org/releases/cairo-&cairo-version;.tar.xz">
   <!ENTITY cairo-download-ftp  " ">
   <!ENTITY cairo-md5sum        "87649eb75789739d517c743e94879e51">
   <!ENTITY cairo-size          "41 MB">
@@ -13,7 +12,7 @@
   <!ENTITY cairo-time          "1.1 SBU">
 ]>
 
-<sect1 id="cairo" xreflabel="cairo-&cairo-version;">
+<sect1 id="cairo" xreflabel="Cairo-&cairo-version;">
   <?dbhtml filename="cairo.html"?>
 
   <sect1info>
@@ -21,10 +20,10 @@
     <date>$Date$</date>
   </sect1info>
 
-  <title>cairo-&cairo-version;</title>
+  <title>Cairo-&cairo-version;</title>
 
   <indexterm zone="cairo">
-    <primary sortas="a-cairo">cairo</primary>
+    <primary sortas="a-Cairo">Cairo</primary>
   </indexterm>
 
   <sect2 role="package">
@@ -98,6 +97,15 @@
 
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required">
+      <!-- Just a note: png is REQUIRED, since something that isn't REQUIRED
+      does not need bunch of DISABLE switches. You are breaking the package
+      for those that don't want to install recommended deps, and I've seen
+      lot of people like that. Leave it, it is not a big dep, and I suspect
+      that someone will install cairo just to test gobject-introspection, since
+      I doubt someone will need that unless building gnome stuff, and it is 
+      really wrong way of thinking that someone might need cairo JUST to test
+      introspection. No offense. -->
+      <xref linkend="libpng"/>,
       <xref linkend="glib2"/> and
       <xref linkend="pixman"/>
     </para>
@@ -105,11 +113,7 @@
     <bridgehead renderas="sect4">Recommended (Required if building GTK+)</bridgehead>
     <para role="recommended">
       <xref linkend="fontconfig"/>,
-      <xref linkend="libpng"/> (if you want to build
-      <application>Cairo</application> without <application>Libpng</application>
-      you will need to add --disable-png --disable-svg to the configure options
-      and remove --enable-tee) and
-      <xref linkend="xorg7-lib"/>.
+      <xref linkend="xorg7-lib"/>
     </para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
@@ -133,7 +137,7 @@
     <note>
       <para>
         There is a reciprocal dependency with the
-        <application>Gtk 2</application>, <application>Librsvg</application> and
+        <application>GTK+ 2</application>, <application>librsvg</application> and
         <application>Poppler</application> packages. As the test suite is
         currently unreliable, it is best to simply skip it at this time.
       </para>
@@ -159,12 +163,8 @@
 
     <para>
       Note that the tests take a long time to run, many of them fail for unknown
-      reasons and it has been known to cause a kernel panic. <!-- I suspect that
-      the panic was due to a bug in the xf86-video-ati driver but I can't be
-      sure as the system locked up hard. cairo-1.12.0 has exposed bugs in other
-      parts of Xorg https://bugs.freedesktop.org/show_bug.cgi?id=47266 Andy
-      2012-04-22 --> If you want to run the tests issue:
-      <command>make -k check</command>.
+      reasons and it has been known to cause a kernel panic. If you want to run
+      the tests issue: <command>make -k check</command>.
     </para>
 
     <para>
@@ -220,7 +220,8 @@
       href="../../xincludes/static-libraries.xml"/>
 
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-    href="../../xincludes/gtk-doc-rebuild.xml"/>
+      href="../../xincludes/gtk-doc-rebuild.xml"/>
+
   </sect2>
 
   <sect2 role="content">
@@ -240,7 +241,8 @@
           libcairo-script-interpreter.so
         </seg>
         <seg>
-          /usr/include/cairo, /usr/lib/cairo and
+          /usr/include/cairo,
+          /usr/lib/cairo and
           /usr/share/gtk-doc/html/cairo
         </seg>
       </seglistitem>
@@ -303,6 +305,9 @@
           </indexterm>
         </listitem>
       </varlistentry>
+
     </variablelist>
+
   </sect2>
+
 </sect1>

Modified: trunk/BOOK/x/lib/cairomm.xml
===================================================================
--- trunk/BOOK/x/lib/cairomm.xml	2012-07-24 16:16:08 UTC (rev 10463)
+++ trunk/BOOK/x/lib/cairomm.xml	2012-07-24 16:17:44 UTC (rev 10464)
@@ -12,7 +12,7 @@
   <!ENTITY cairomm-time          "0.1 SBU">
 ]>
 
-<sect1 id="cairomm" xreflabel="cairomm-&cairomm-version;">
+<sect1 id="cairomm" xreflabel="Cairomm-&cairomm-version;">
   <?dbhtml filename="cairomm.html"?>
 
   <sect1info>
@@ -20,43 +20,57 @@
     <date>$Date$</date>
   </sect1info>
 
-  <title>cairomm-&cairomm-version;</title>
+  <title>Cairomm-&cairomm-version;</title>
 
   <indexterm zone="cairomm">
-    <primary sortas="a-cairomm">cairomm</primary>
+    <primary sortas="a-Cairomm">Cairomm</primary>
   </indexterm>
 
   <sect2 role="package">
-    <title>Introduction to cairomm</title>
+    <title>Introduction to Cairomm</title>
 
-    <para>The <application>cairomm</application> package provides a C++
-    interface to <application>cairo</application>.</para>
+    <para>
+      The <application>Cairomm</application> package provides a C++
+      interface to <application>Cairo</application>.
+    </para>
 
     &lfs70_checked;
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
-        <para>Download (HTTP): <ulink url="&cairomm-download-http;"/></para>
+        <para>
+          Download (HTTP): <ulink url="&cairomm-download-http;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download (FTP): <ulink url="&cairomm-download-ftp;"/></para>
+        <para>
+          Download (FTP): <ulink url="&cairomm-download-ftp;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download MD5 sum: &cairomm-md5sum;</para>
+        <para>
+          Download MD5 sum: &cairomm-md5sum;
+        </para>
       </listitem>
       <listitem>
-        <para>Download size: &cairomm-size;</para>
+        <para>
+          Download size: &cairomm-size;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated disk space required: &cairomm-buildsize;</para>
+        <para>
+          Estimated disk space required: &cairomm-buildsize;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated build time: &cairomm-time;</para>
+        <para>
+          Estimated build time: &cairomm-time;
+        </para>
       </listitem>
     </itemizedlist>
 
-    <bridgehead renderas="sect3">cairomm Dependencies</bridgehead>
+    <bridgehead renderas="sect3">Cairomm Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required">
@@ -71,22 +85,28 @@
     </para>
 
     <para condition="html" role="usernotes">User Notes:
-    <ulink url="&blfs-wiki;/cairomm"/></para>
-
+      <ulink url="&blfs-wiki;/cairomm"/>
+    </para>
   </sect2>
 
   <sect2 role="installation">
-    <title>Installation of cairomm</title>
+    <title>Installation of Cairomm</title>
 
-    <para>Install <application>cairomm</application> by running the following
-    commands:</para>
+    <para>
+      Install <application>Cairomm</application> by running the following
+      commands:
+    </para>
 
 <screen><userinput>./configure --prefix=/usr &&
 make</userinput></screen>
 
-    <para>This package does not come with a test suite.</para>
+    <para>
+      This package does not come with a test suite.
+    </para>
 
-    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+    <para>
+      Now, as the <systemitem class="username">root</systemitem> user:
+    </para>
 
 <screen role="root"><userinput>make install</userinput></screen>
 
@@ -120,9 +140,11 @@
       <varlistentry id="libcairomm-1.0">
         <term><filename class='libraryfile'>libcairomm-1.0.so</filename></term>
         <listitem>
-          <para>contains the <application>Cairo</application> API classes.</para>
+          <para>
+            contains the <application>Cairo</application> API classes.
+          </para>
           <indexterm zone="cairomm libcairomm-1.0">
-            <primary sortas="c-libcairomm-1.0">libcairomm-1.0.{so,a}</primary>
+            <primary sortas="c-libcairomm-1.0">libcairomm-1.0.so</primary>
           </indexterm>
         </listitem>
       </varlistentry>

Modified: trunk/BOOK/x/lib/clutter-gtk.xml
===================================================================
--- trunk/BOOK/x/lib/clutter-gtk.xml	2012-07-24 16:16:08 UTC (rev 10463)
+++ trunk/BOOK/x/lib/clutter-gtk.xml	2012-07-24 16:17:44 UTC (rev 10464)
@@ -29,37 +29,51 @@
   </indexterm>
 
   <sect2 role="package">
-    <title>Introduction to clutter-gtk</title>
+    <title>Introduction to Clutter Gtk</title>
 
-    <para>The <application>clutter-gtk</application> package is a library
-    providing facilities to integrate <application>Clutter</application> into
-    <application>GTK+</application> applications.</para>
+    <para>
+      The <application>Clutter Gtk</application> package is a library
+      providing facilities to integrate <application>Clutter</application>
+      into <application>GTK+</application> applications.
+    </para>
 
     &lfs70_checked;
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
-        <para>Download (HTTP): <ulink url="&clutter-gtk-download-http;"/></para>
+        <para>
+          Download (HTTP): <ulink url="&clutter-gtk-download-http;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download (FTP): <ulink url="&clutter-gtk-download-ftp;"/></para>
+        <para>
+          Download (FTP): <ulink url="&clutter-gtk-download-ftp;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download MD5 sum: &clutter-gtk-md5sum;</para>
+        <para>
+          Download MD5 sum: &clutter-gtk-md5sum;
+        </para>
       </listitem>
       <listitem>
-        <para>Download size: &clutter-gtk-size;</para>
+        <para>
+          Download size: &clutter-gtk-size;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated disk space required: &clutter-gtk-buildsize;</para>
+        <para>
+          Estimated disk space required: &clutter-gtk-buildsize;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated build time: &clutter-gtk-time;</para>
+        <para>
+          Estimated build time: &clutter-gtk-time;
+        </para>
       </listitem>
     </itemizedlist>
 
-    <bridgehead renderas="sect3">clutter-gtk Dependencies</bridgehead>
+    <bridgehead renderas="sect3">Clutter Gtk Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required">
@@ -78,22 +92,28 @@
     </para>
 
     <para condition="html" role="usernotes">User Notes:
-    <ulink url="&blfs-wiki;/clutter-gtk"/></para>
-
+      <ulink url="&blfs-wiki;/clutter-gtk"/>
+    </para>
   </sect2>
 
   <sect2 role="installation">
-    <title>Installation of clutter-gtk</title>
+    <title>Installation of Clutter Gtk</title>
 
-    <para>Install <application>clutter-gtk</application> by running the following
-    commands:</para>
+    <para>
+      Install <application>Clutter Gtk</application> by running the following
+      commands:
+    </para>
 
 <screen><userinput>./configure --prefix=/usr &&
 make</userinput></screen>
 
-    <para>This package does not come with a test suite.</para>
+    <para>
+      This package does not come with a test suite.
+    </para>
 
-    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+    <para>
+      Now, as the <systemitem class="username">root</systemitem> user:
+    </para>
 
 <screen role="root"><userinput>make install</userinput></screen>
 
@@ -103,7 +123,7 @@
     <title>Command Explanations</title>
 
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-    href="../../xincludes/gtk-doc-rebuild.xml"/>
+      href="../../xincludes/gtk-doc-rebuild.xml"/>
 
   </sect2>
 
@@ -134,7 +154,9 @@
         <term><filename
         class='libraryfile'>libclutter-gtk-1.0.so</filename></term>
         <listitem>
-          <para>contains the clutter-gtk API functions.</para>
+          <para>
+            contains the <application>Clutter Gtk</application> API functions.
+          </para>
           <indexterm zone="clutter-gtk libclutter-gtk-1">
             <primary sortas="c-libclutter-gtk-1">libclutter-gtk-1.0.so</primary>
           </indexterm>

Modified: trunk/BOOK/x/lib/cogl.xml
===================================================================
--- trunk/BOOK/x/lib/cogl.xml	2012-07-24 16:16:08 UTC (rev 10463)
+++ trunk/BOOK/x/lib/cogl.xml	2012-07-24 16:17:44 UTC (rev 10464)
@@ -29,32 +29,46 @@
   <sect2 role="package">
     <title>Introduction to Cogl</title>
 
-    <para><application>Cogl</application> is a modern 3D graphics API with
-    associated utility APIs designed to expose the features of 3D graphics hardware
-    using a direct state access API design, as opposed to the state-machine style
-    of OpenGL.</para>
+    <para>
+      <application>Cogl</application> is a modern 3D graphics API with associated
+      utility APIs designed to expose the features of 3D graphics hardware using
+      a direct state access API design, as opposed to the state-machine style
+      of OpenGL.
+    </para>
 
     &lfs70_checked;
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
-        <para>Download (HTTP): <ulink url="&cogl-download-http;"/></para>
+        <para>
+          Download (HTTP): <ulink url="&cogl-download-http;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download (FTP): <ulink url="&cogl-download-ftp;"/></para>
+        <para>
+          Download (FTP): <ulink url="&cogl-download-ftp;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download MD5 sum: &cogl-md5sum;</para>
+        <para>
+          Download MD5 sum: &cogl-md5sum;
+        </para>
       </listitem>
       <listitem>
-        <para>Download size: &cogl-size;</para>
+        <para>
+          Download size: &cogl-size;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated disk space required: &cogl-buildsize;</para>
+        <para>
+          Estimated disk space required: &cogl-buildsize;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated build time: &cogl-time;</para>
+        <para>
+          Estimated build time: &cogl-time;
+        </para>
       </listitem>
     </itemizedlist>
 
@@ -78,22 +92,28 @@
     </para>
 
     <para condition="html" role="usernotes">User Notes:
-    <ulink url="&blfs-wiki;/cogl"/></para>
-
+      <ulink url="&blfs-wiki;/cogl"/>
+    </para>
   </sect2>
 
   <sect2 role="installation">
     <title>Installation of Cogl</title>
 
-    <para>Install <application>Cogl</application> by running the following
-    commands:</para>
+    <para>
+      Install <application>Cogl</application> by running the following
+      commands:
+    </para>
 
 <screen><userinput>./configure --prefix=/usr &&
 make</userinput></screen>
 
-    <para>To test the results, issue: <command>make check</command>.</para>
+    <para>
+      To test the results, issue: <command>make check</command>.
+    </para>
 
-    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+    <para>
+      Now, as the <systemitem class="username">root</systemitem> user:
+    </para>
 
 <screen role="root"><userinput>make install</userinput></screen>
 
@@ -103,7 +123,7 @@
     <title>Command Explanations</title>
 
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-    href="../../xincludes/gtk-doc-rebuild.xml"/>
+      href="../../xincludes/gtk-doc-rebuild.xml"/>
 
   </sect2>
 
@@ -134,7 +154,10 @@
       <varlistentry id="libcogl-pango">
         <term><filename class='libraryfile'>libcogl-pango.so</filename></term>
         <listitem>
-          <para>is Pango integration library for Cogl.</para>
+          <para>
+            is the <application>Pango</application> integration library
+            for <application>Cogl</application>.
+          </para>
           <indexterm zone="cogl libcogl-pango">
             <primary sortas="c-libcogl-pango">libcogl-pango.so</primary>
           </indexterm>
@@ -144,7 +167,9 @@
       <varlistentry id="libcogl">
         <term><filename class='libraryfile'>libcogl.so</filename></term>
         <listitem>
-          <para>is an object oriented GL/GLES Abstraction/Utility Layer library.</para>
+          <para>
+            is an object oriented GL/GLES Abstraction/Utility Layer library.
+          </para>
           <indexterm zone="cogl libcogl">
             <primary sortas="c-libcogl">libcogl.so</primary>
           </indexterm>

Modified: trunk/BOOK/x/lib/gdk-pixbuf.xml
===================================================================
--- trunk/BOOK/x/lib/gdk-pixbuf.xml	2012-07-24 16:16:08 UTC (rev 10463)
+++ trunk/BOOK/x/lib/gdk-pixbuf.xml	2012-07-24 16:17:44 UTC (rev 10464)
@@ -5,9 +5,9 @@
   %general-entities;
 
   <!ENTITY gdk-pixbuf-download-http 
-    "&gnome-download-http;/gdk-pixbuf/2.26/gdk-pixbuf-&gdk-pixbuf-version;.tar.xz">
+           "&gnome-download-http;/gdk-pixbuf/2.26/gdk-pixbuf-&gdk-pixbuf-version;.tar.xz">
   <!ENTITY gdk-pixbuf-download-ftp  
-    "&gnome-download-ftp;/gdk-pixbuf/2.26/gdk-pixbuf-&gdk-pixbuf-version;.tar.xz">
+           "&gnome-download-ftp;/gdk-pixbuf/2.26/gdk-pixbuf-&gdk-pixbuf-version;.tar.xz">
   <!ENTITY gdk-pixbuf-md5sum        "82197921c651a81ae28178aa9adfc0e6">
   <!ENTITY gdk-pixbuf-size          "1.2 MB">
   <!ENTITY gdk-pixbuf-buildsize     "25 MB">
@@ -29,15 +29,15 @@
   </indexterm>
 
   <sect2 role="package">
-    <title>Introduction to Gdk-Pixbuf</title>
+    <title>Introduction to Gdk Pixbuf</title>
 
     <para>
-      The <application>Gdk-Pixbuf</application> library is a toolkit for image
+      The <application>Gdk Pixbuf</application> is a toolkit for image
       loading and pixel buffer manipulation. It is used by
-      <application>Gtk 2</application> and <application>Gtk 3</application> to
+      <application>GTK+ 2</application> and <application>GTK+ 3</application> to
       load and manipulate images. In the past it was distributed as part of
-      <application>Gtk 2</application> but it was split off into a separate
-      package in preparation for the change to <application>Gtk 3</application>.
+      <application>GTK+ 2</application> but it was split off into a separate
+      package in preparation for the change to <application>GTK+ 3</application>.
     </para>
 
     &lfs71_checked;
@@ -88,9 +88,9 @@
 
     <bridgehead renderas="sect4">Recommended</bridgehead>
     <para role="recommended">
-      <xref linkend="xorg7-lib"/>. <emphasis>Many</emphasis>
-      <application>Gtk</application> applications <emphasis>require</emphasis>
-      gdk-pixbuf-xlib.
+      <xref linkend="xorg7-lib"/>
+      <emphasis>Many</emphasis> <application>GTK+</application>
+      applications <emphasis>require</emphasis> gdk-pixbuf-xlib.
     </para>
 
     <bridgehead renderas="sect4">Optional (Required if building GNOME)</bridgehead>
@@ -110,10 +110,10 @@
   </sect2>
 
   <sect2 role="installation">
-    <title>Installation of Gdk-Pixbuf</title>
+    <title>Installation of Gdk Pixbuf</title>
 
     <para>
-      Install <application>Gdk-Pixbuf</application> by running the following
+      Install <application>Gdk Pixbuf</application> by running the following
       commands:
     </para>
 
@@ -147,19 +147,20 @@
 
     <para>
       <option>--with-x11</option>: This switch enables building of the
-      <application>Gdk-Pixbuf</application> <application>X11</application>
+      <application>Gdk Pixbuf</application> <application>X11</application>
       library which is needed for <emphasis>many</emphasis> packages.
     </para>
 
     <para>
       <option>--with-libjasper</option>: If you've installed
       <xref linkend="jasper"/> and you want
-      <application>Gdk-Pixbuf</application> to use it to compile a JPEG2000
-      image loader, pass this option to configure.
+      <application>Gdk-Pixbuf</application> to use it to compile a
+      JPEG2000 image loader, pass this option to configure.
     </para>
 
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-    href="../../xincludes/gtk-doc-rebuild.xml"/>
+      href="../../xincludes/gtk-doc-rebuild.xml"/>
+
   </sect2>
 
   <sect2 role="content">
@@ -172,18 +173,15 @@
 
       <seglistitem>
         <seg>
-          gdk-pixbuf-csource,
-          gdk-pixbuf-pixdata and
-          gdk-pixbuf-query-loaders.
+          gdk-pixbuf-csource, gdk-pixbuf-pixdata and gdk-pixbuf-query-loaders
         </seg>
         <seg>
-          libgdk_pixbuf-2.0.so and
-          libgdk_pixbuf_xlib-2.0.so.
+          libgdk_pixbuf-2.0.so and libgdk_pixbuf_xlib-2.0.so
         </seg>
         <seg>
           /usr/include/gdk-pixbuf-2.0,
           /usr/lib/gdk-pixbuf-2.0 and
-          /usr/share/gtk-doc/html/gdk-pixbuf.
+          /usr/share/gtk-doc/html/gdk-pixbuf
         </seg>
       </seglistitem>
     </segmentedlist>
@@ -210,8 +208,9 @@
         <term><command>gdk-pixbuf-query-loaders</command></term>
         <listitem>
           <para>
-            collects information about loadable modules for gdk-pixbuf and
-            writes it to the default cache file location, or to stdout.
+            collects information about loadable modules for 
+            <application>Gdk Pixbuf</application> and writes it
+            to the default cache file location, or to stdout.
           </para>
           <indexterm zone="gdk-pixbuf gdk-pixbuf-query-loaders">
             <primary sortas="b-gdk-pixbuf-query-loaders">gdk-pixbuf-query-loaders</primary>
@@ -243,6 +242,9 @@
           </indexterm>
         </listitem>
       </varlistentry>
+
     </variablelist>
+
   </sect2>
+
 </sect1>

Modified: trunk/BOOK/x/lib/gtk+2.xml
===================================================================
--- trunk/BOOK/x/lib/gtk+2.xml	2012-07-24 16:16:08 UTC (rev 10463)
+++ trunk/BOOK/x/lib/gtk+2.xml	2012-07-24 16:17:44 UTC (rev 10464)
@@ -4,17 +4,15 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gtk2-download-http
-  "&gnome-download-http;/gtk+/2.24/gtk+-&gtk2-version;.tar.xz">
-  <!ENTITY gtk2-download-ftp
-  "&gnome-download-ftp;/gtk+/2.24/gtk+-&gtk2-version;.tar.xz">
+  <!ENTITY gtk2-download-http "&gnome-download-http;/gtk+/2.24/gtk+-&gtk2-version;.tar.xz">
+  <!ENTITY gtk2-download-ftp  "&gnome-download-ftp;/gtk+/2.24/gtk+-&gtk2-version;.tar.xz">
   <!ENTITY gtk2-md5sum        "7fdcb407dd174010a695b555bf9b65e2">
   <!ENTITY gtk2-size          "12.6 MB">
   <!ENTITY gtk2-buildsize     "350 MB">
   <!ENTITY gtk2-time          "3.5 SBU">
 ]>
 
-<sect1 id="gtk2" xreflabel="gtk+-&gtk2-version;">
+<sect1 id="gtk2" xreflabel="GTK+-&gtk2-version;">
   <?dbhtml filename="gtk2.html" ?>
 
   <sect1info>
@@ -22,19 +20,19 @@
     <date>$Date$</date>
   </sect1info>
 
-  <title>Gtk+-&gtk2-version;</title>
+  <title>GTK+-&gtk2-version;</title>
 
   <indexterm zone="gtk2">
     <primary sortas="a-gtk2">gtk2</primary>
   </indexterm>
 
   <sect2 role="package">
-    <title>Introduction to Gtk+ 2</title>
+    <title>Introduction to GTK+ 2</title>
 
     <para>
-      The <application>Gtk+ 2</application> package contains
-      <application>|Gtk+ 2</application> libraries. These are useful for
-      creating graphical user interfaces for applications.
+      The <application>GTK+ 2</application> package contains
+      libraries used for creating graphical user interfaces
+      for applications.
     </para>
 
     &lfs71_checked;
@@ -73,16 +71,15 @@
       </listitem>
     </itemizedlist>
 
-    <bridgehead renderas="sect3">Gtk+ 2 Dependencies</bridgehead>
+    <bridgehead renderas="sect3">GTK+ 2 Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required">
-      <xref linkend="cairo"/> (compiled with libX11 support),
+      <xref linkend="atk"/>,
+      <xref linkend="cairo"/>,
       <xref linkend="gdk-pixbuf"/>,
-      the <xref linkend="x-window-system"/> (specifically, libX11, libXext and
-      libXrender),
       <xref linkend="pango"/> and
-      <xref linkend="atk"/>
+      <xref linkend="xorg7-lib"/>
     </para>
 
     <bridgehead renderas="sect4">Recommended</bridgehead>
@@ -90,20 +87,12 @@
       <xref linkend="hicolor-icon-theme"/>
     </para>
 
-    <!-- hicolor-icon-theme is required for the test suite -->
-
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional">
       <xref linkend="cups"/>,
       <xref linkend="docbook-utils"/>,
-      <!-- <ulink url="http://beagle-project.org/Main_Page">libbeagle</ulink>,
-      This beagle page appears to be just adverts -->
-      <!-- <ulink url="http://sourceforge.net/projects/openprinting/">papi</ulink>,
-      I think papi is just for solaris. It was a bugger to compile... -->
-      <!-- <ulink url="http://www.tracker-project.org/">Tracker</ulink>
-      This tracker page is a dead link -->
       <xref linkend="gobject-introspection"/> and
-      <xref linkend="gtk-doc"/>.
+      <xref linkend="gtk-doc"/>
     </para>
 
     <para condition="html" role="usernotes">
@@ -112,10 +101,10 @@
   </sect2>
 
   <sect2 role="installation">
-    <title>Installation of Gtk+ 2</title>
+    <title>Installation of GTK+ 2</title>
 
     <para>
-      Install <application>Gtk+ 2</application> by running the following
+      Install <application>GTK+ 2</application> by running the following
       commands:
     </para>
 
@@ -167,18 +156,19 @@
     </para>
 
     <para>
-      <command>sed -i 's#.*@man_#man_#'
-      docs/reference/gtk/Makefile.in</command>: this sed fixes one of the
-      <filename>Makefile</filename>s so it installs the man pages for
-      gtk-builder-convert, gtk-query-immodules-2.0 and gtk-update-icon-cache.
+      <command>sed -i 's#.*@man_#man_#' docs/reference/gtk/Makefile.in</command>:
+      This sed fixes one of the <filename>Makefile</filename>s so it installs the
+      man pages for gtk-builder-convert, gtk-query-immodules-2.0 and
+      gtk-update-icon-cache.
     </para>
 
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
       href="../../xincludes/gtk-doc-rebuild.xml"/>
+
   </sect2>
 
   <sect2 role="configuration">
-    <title>Configuring Gtk+ 2</title>
+    <title>Configuring GTK+ 2</title>
 
     <sect3 id="gtk2-config">
       <title>Config Files</title>
@@ -199,14 +189,14 @@
     <sect3><title>Configuration Information</title>
 
       <para>
-        <application>Gtk+ 2</application> themes change the way a
-        <application>Gtk+ 2</application> application looks. A
-        <application>Gtk+ 2</application> icon theme can be used to change the
+        <application>GTK+ 2</application> themes change the way a
+        <application>GTK+ 2</application> application looks. A
+        <application>GTK+ 2</application> icon theme can be used to change the
         icons that appear on the application's toolbar. If you have installed a
-        <application>Gtk+ 2</application> theme (such as <ulink
+        <application>GTK+ 2</application> theme (such as <ulink
         url="http://ftp.gnome.org/pub/gnome/sources/gnome-themes/2.32/">gnome-themes</ulink>
         (requires <xref linkend="gtk-engines"/>)) or a
-        <application>Gtk+ 2</application> icon theme (such as
+        <application>GTK+ 2</application> icon theme (such as
         <xref linkend="gnome-icon-theme"/>) you can set your preferences in
         <filename>~/.gtkrc-2.0</filename>:
       </para>
@@ -235,7 +225,7 @@
 
       <para>
         <ulink url="http://sourceforge.net/projects/lxde/files/LXAppearance/">
-        LXAppearance</ulink> is a <application>Gtk+ 2</application> application
+        LXAppearance</ulink> is a <application>GTK+ 2</application> application
         that can help you choose the themes you like.
       </para>
     </sect3>
@@ -255,20 +245,20 @@
           gtk-update-icon-cache
         </seg>
         <seg>
-          libpixmap.so, im-am-et.so, im-cedilla.so, im-cyrillic-translit.so,
-          im-inuktitut.so, im-ipa.so, im-multipress.so, im-thai.so, im-ti-er.so,
-          im-ti-et.so, im-viqr.so, im-xim.so, libprintbackend-cups.so
-          libprintbackend-file.so, libprintbackend-lpr.so,
-          libferret.so, libgail.so, libgailutil.so, libgdk-x11-2.0.so and
+          libgailutil.so, libgdk-x11-2.0.so and
           libgtk-x11-2.0.so
         </seg>
         <seg>
-          /etc/gtk-2.0, /usr/include/gail-1.0, /usr/include/gtk-2.0,
-          /usr/include/gtk-unix-print-2.0, /usr/lib/gtk-2.0,
+          /etc/gtk-2.0,
+          /usr/include/gail-1.0,
+          /usr/include/gtk-2.0,
+          /usr/include/gtk-unix-print-2.0,
+          /usr/lib/gtk-2.0,
           /usr/share/doc/gtk+-&gtk2-version;,
           /usr/share/gtk-doc/html/gail-libgail-util,
-          /usr/share/gtk-doc/html/gdk-pixbuf, /usr/share/gtk-doc/html/gtk,
-          /usr/share/themes/Default, /usr/share/themes/Emacs and
+          /usr/share/gtk-doc/html/gtk,
+          /usr/share/themes/Default,
+          /usr/share/themes/Emacs and
           /usr/share/themes/Raleigh
         </seg>
       </seglistitem>
@@ -297,7 +287,7 @@
         <term><command>gtk-demo</command></term>
         <listitem>
           <para>
-            demonstrates <application>Gtk+ 2</application> functionality and
+            demonstrates <application>GTK+ 2</application> functionality and
             provides code for the examples.
           </para>
           <indexterm zone="gtk2 gtk-demo">
@@ -312,7 +302,7 @@
         <listitem>
           <para>
             collects information about loadable input method modules for
-            <application>Gtk+ 2</application> and writes it to standard output.
+            <application>GTK+ 2</application> and writes it to standard output.
           </para>
           <indexterm zone="gtk2 gtk-query-immodules-2.0">
             <primary
@@ -334,16 +324,19 @@
       </varlistentry>
 
       <varlistentry id="gtk2libs">
-        <term>Gtk+ 2 Libraries</term>
+        <term>GTK+ 2 Libraries</term>
         <listitem>
           <para>
             provide an API to implement graphical user interfaces.
           </para>
           <indexterm zone="gtk2 gtk2libs">
-            <primary sortas="c-gtk2libs">Gtk+ 2 Libraries</primary>
+            <primary sortas="c-gtk2libs">GTK+ 2 Libraries</primary>
           </indexterm>
         </listitem>
       </varlistentry>
+
     </variablelist>
+
   </sect2>
+
 </sect1>

Modified: trunk/BOOK/x/lib/gtk+3.xml
===================================================================
--- trunk/BOOK/x/lib/gtk+3.xml	2012-07-24 16:16:08 UTC (rev 10463)
+++ trunk/BOOK/x/lib/gtk+3.xml	2012-07-24 16:17:44 UTC (rev 10464)
@@ -12,7 +12,7 @@
   <!ENTITY gtk3-time          "2.8 SBU">
 ]>
 
-<sect1 id="gtk3" xreflabel="Gtk+-&gtk3-version;">
+<sect1 id="gtk3" xreflabel="GTK+-&gtk3-version;">
   <?dbhtml filename="gtk3.html"?>
 
   <sect1info>
@@ -20,19 +20,19 @@
     <date>$Date$</date>
   </sect1info>
 
-  <title>Gtk+-&gtk3-version;</title>
+  <title>GTK+-&gtk3-version;</title>
 
   <indexterm zone="gtk3">
-    <primary sortas="a-gtk3">gtk+-3</primary>
+    <primary sortas="a-gtk3">gtk3</primary>
   </indexterm>
 
   <sect2 role="package">
-    <title>Introduction to Gtk+ 3</title>
+    <title>Introduction to GTK+ 3</title>
 
     <para>
-      The <application>Gtk+ 3</application> package contains
-      <application>Gtk+ 3</application> libraries used for creating
-      graphical user interfaces for applications.
+      The <application>GTK+ 3</application> package contains the
+      libraries used for creating graphical user interfaces for
+      applications.
     </para>
 
     &lfs71_checked;
@@ -71,11 +71,12 @@
       </listitem>
     </itemizedlist>
 
-    <bridgehead renderas="sect3">Gtk+ 3 Dependencies</bridgehead>
+    <bridgehead renderas="sect3">GTK+ 3 Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required">
       <xref linkend="atk"/>,
+      <xref linkend="cairo"/>,
       <xref linkend="gdk-pixbuf"/> and
       <xref linkend="pango"/>
     </para>
@@ -99,24 +100,24 @@
   </sect2>
 
   <sect2 role="installation">
-    <title>Installation of Gtk+ 3</title>
+    <title>Installation of GTK+ 3</title>
 
     <note>
       <para>
-        <application>Gtk+ 3</application> will overwrite
+        <application>GTK+ 3</application> will overwrite
         <command>gtk-update-icon-cache</command> from
         <xref linkend="gtk2"/> if it is installed. 
         There is nothing wrong about that assuming
         that both programs provide same functionality. 
         If you wish to keep one from
-        <application>Gtk+ 2</application> you can add
+        <application>GTK+ 2</application> you can add
         <option>--enable-gtk2-dependency</option> to the
         <command>configure</command> command.
       </para>
     </note>
 
     <para>
-      Install <application>Gtk+ 3</application> by running the following
+      Install <application>GTK+ 3</application> by running the following
       commands:
     </para>
 
@@ -166,7 +167,7 @@
   </sect2>
 
   <sect2 role="configuration">
-    <title>Configuring Gtk+ 3</title>
+    <title>Configuring GTK+ 3</title>
 
     <sect3 id="gtk3-config">
       <title>Config Files</title>
@@ -187,10 +188,10 @@
     <sect3><title>Configuration Information</title>
 
       <para>
-        <application>Gtk+ 3</application> themes change the way a
-        <application>Gtk+</application> application looks. An icon theme can be
+        <application>GTK+ 3</application> themes change the way a
+        <application>GTK+ 3</application> application looks. An icon theme can be
         used to change the icons that appear on the application's toolbar. If
-        you have installed a <application>Gtk+ 3</application> theme (eg
+        you have installed a <application>GTK+ 3</application> theme (eg
         <xref linkend="gnome-themes-standard"/> or an icon theme (such as
         <xref linkend="gnome-icon-theme"/>) you can set your prefences in
         <filename>~/.config/gtk-3.0/settings.ini</filename>. Eg:
@@ -256,7 +257,7 @@
         <listitem>
           <para>
             is a simple program that demonstrates some of the things that can be
-            done with <application>Gtk+ 3</application>
+            done with <application>GTK+ 3</application>
           </para>
           <indexterm zone="gtk3 gtk3-demo">
             <primary sortas="b-gtk3-demo">gtk3-demo</primary>
@@ -269,7 +270,7 @@
         <listitem>
           <para>
             collects information about loadable input method modules for
-            <application>Gtk+ 3</application> and writes it to the default cache
+            <application>GTK+ 3</application> and writes it to the default cache
             file location, or to standard output.
           </para>
           <indexterm zone="gtk3 gtk-query-immodules-3.0">
@@ -296,7 +297,7 @@
         <listitem>
           <para>
             contains functions that implements the accessibility interfaces
-            defined by the GNOME Accessibility Toolkit
+            defined by the GNOME Accessibility Toolkit.
           </para>
           <indexterm zone="gtk3 libgailutil">
             <primary sortas="c-libgailutil">libgailutil.so</primary>
@@ -330,6 +331,7 @@
           </indexterm>
         </listitem>
       </varlistentry>
+
     </variablelist>
 
   </sect2>

Modified: trunk/BOOK/x/lib/gtk-vnc.xml
===================================================================
--- trunk/BOOK/x/lib/gtk-vnc.xml	2012-07-24 16:16:08 UTC (rev 10463)
+++ trunk/BOOK/x/lib/gtk-vnc.xml	2012-07-24 16:17:44 UTC (rev 10464)
@@ -27,12 +27,12 @@
   </indexterm>
 
   <sect2 role="package">
-    <title>Introduction to gtk-vnc</title>
+    <title>Introduction to Gtk Vnc</title>
 
     <para>
-      The <application>gtk-vnc</application> package is a VNC viewer widget
-      for <application>GTK</application>. It is built using coroutines allowing it
-      to be completely asynchronous while remaining single threaded.
+      The <application>Gtk Vnc</application> package is a VNC viewer widget
+      for <application>GTK+</application>. It is built using coroutines allowing
+      it to be completely asynchronous while remaining single threaded.
     </para>
 
     &lfs70_checked;
@@ -71,7 +71,7 @@
       </listitem>
     </itemizedlist>
 
-    <bridgehead renderas="sect3">gtk-vnc Dependencies</bridgehead>
+    <bridgehead renderas="sect3">Gtk Vnc Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required">
@@ -91,19 +91,19 @@
       <xref linkend="cyrus-sasl"/>,
       <xref linkend="nspr"/>,
       <xref linkend="pulseaudio"/> and
-      <ulink url="https://developer.mozilla.org/en/XULRunner">Xulrunner</ulink>
+      <xref linkend="xulrunner"/>
     </para>
 
     <para condition="html" role="usernotes">User Notes:
-    <ulink url="&blfs-wiki;/gtk-vnc"/></para>
-
+      <ulink url="&blfs-wiki;/gtk-vnc"/>
+    </para>
   </sect2>
 
   <sect2 role="installation">
-    <title>Installation of gtk-vnc</title>
+    <title>Installation of Gtk Vnc</title>
 
     <para>
-      Install <application>gtk-vnc</application> by running the following
+      Install <application>Gtk Vnc</application> by running the following
       commands:
     </para>
 
@@ -114,8 +114,7 @@
 make</userinput></screen>
 
     <para>
-      This package's testsuite is only intended to be used by the
-      maintainer to check the i18n files.
+      This package does not come with a testsuite.
     </para>
 
     <para>
@@ -130,9 +129,9 @@
     <title>Command Explanations</title>
 
     <para>
-      <parameter>--with-gtk=3.0</parameter>: This parameter enables building of
-      <application>GTK+3</application> library instead of 
-      <application>GTK+2</application> one.
+      <parameter>--with-gtk=3.0</parameter>: This parameter enables
+      building of <application>GTK+ 3</application> library instead
+      of <application>GTK+ 2</application> one.
     </para>
 
     <para>
@@ -143,9 +142,9 @@
 
     <para>
       <option>--without-sasl</option>: This parameter disables the use of 
-      <application>Cyrus SASL</application> for authentication. Remove it if you have 
-      <application>Cyrus SASL</application> installed and wish to enable it for 
-      authentication.
+      <application>Cyrus SASL</application> for authentication. Remove it if you
+      have installed <application>Cyrus SASL</application> and wish to enable it
+      for  authentication.
     </para>
 
     <para>
@@ -196,7 +195,8 @@
         <term><filename class="libraryfile">libgtk-vnc-2.0.so</filename></term>
         <listitem>
           <para>
-            contains GTK+3 bindings for GTK VNC.
+            contains <application>GTK+ 3</application> bindings for 
+            <application>Gtk Vnc</application>.
           </para>
           <indexterm zone="gtk-vnc libgtk-vnc-2.0">
             <primary sortas="c-libgtk-vnc-2.0">libgtk-vnc-2.0.so</primary>
@@ -208,7 +208,7 @@
         <term><filename class="libraryfile">libgvnc-1.0.so</filename></term>
         <listitem>
           <para>
-            contains GObject bindings for GTK VNC.
+            contains GObject bindings for <application>Gtk Vnc</application>.
           </para>
           <indexterm zone="gtk-vnc libgvnc-1.0">
             <primary sortas="c-libgvnc-1.0">libgvnc-1.0.so</primary>
@@ -220,7 +220,8 @@
         <term><filename class="libraryfile">libgvncpulse-1.0.so</filename></term>
         <listitem>
           <para>
-            is Pulseaudio bridge for GTK VNC.
+            is the <application>PulseAudio</application> bridge for 
+            <application>Gtk Vnc</application>.
           </para>
           <indexterm zone="gtk-vnc libgvncpulse-1.0">
             <primary sortas="c-libgvncpulse-1.0">libgvncpulse-1.0.so</primary>

Modified: trunk/BOOK/x/lib/gtkmm2.xml
===================================================================
--- trunk/BOOK/x/lib/gtkmm2.xml	2012-07-24 16:16:08 UTC (rev 10463)
+++ trunk/BOOK/x/lib/gtkmm2.xml	2012-07-24 16:17:44 UTC (rev 10464)
@@ -4,10 +4,8 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gtkmm2-download-http
-    "&gnome-download-http;/gtkmm/2.24/gtkmm-&gtkmm2-version;.tar.xz">
-  <!ENTITY gtkmm2-download-ftp
-     "&gnome-download-ftp;/gtkmm/2.24/gtkmm-&gtkmm2-version;.tar.xz">
+  <!ENTITY gtkmm2-download-http "&gnome-download-http;/gtkmm/2.24/gtkmm-&gtkmm2-version;.tar.xz">
+  <!ENTITY gtkmm2-download-ftp  "&gnome-download-ftp;/gtkmm/2.24/gtkmm-&gtkmm2-version;.tar.xz">
   <!ENTITY gtkmm2-md5sum        "388a63ffc40cc8e208df9a1732a67d2d">
   <!ENTITY gtkmm2-size          "10.3 MB">
   <!ENTITY gtkmm2-buildsize     "270 MB">
@@ -38,7 +36,7 @@
       with no namespace conflicts.
     </para>
 
-    &lfs71_built;
+    &lfs71_checked;
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
@@ -138,8 +136,8 @@
       <varlistentry id="libgdkmm-2.4">
         <term><filename class='libraryfile'>libgdkmm-2.4.so</filename></term>
         <listitem>
-          <para>
-        contains the GDK API classes.
+        <para>
+          contains the GDK API classes.
         </para>
           <indexterm zone="gtkmm2 libgdkmm-2.4">
             <primary sortas="c-libgdkmm-2.4">libgdkmm-2.4.so</primary>
@@ -150,14 +148,17 @@
       <varlistentry id="libgtkmm-2.4">
         <term><filename class='libraryfile'>libgtkmm-2.4.so</filename></term>
         <listitem>
-          <para>
-        contains the <application>GTK+</application> API classes.
+        <para>
+          contains the <application>GTK+</application> API classes.
         </para>
           <indexterm zone="gtkmm2 libgtkmm-2.4">
             <primary sortas="c-libgtkmm-2.4">libgtkmm-2.4.so</primary>
           </indexterm>
         </listitem>
       </varlistentry>
+
     </variablelist>
+
   </sect2>
+
 </sect1>

Modified: trunk/BOOK/x/lib/gtkmm3.xml
===================================================================
--- trunk/BOOK/x/lib/gtkmm3.xml	2012-07-24 16:16:08 UTC (rev 10463)
+++ trunk/BOOK/x/lib/gtkmm3.xml	2012-07-24 16:17:44 UTC (rev 10464)
@@ -4,10 +4,8 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gtkmm3-download-http
-    "&gnome-download-http;/gtkmm/3.4/gtkmm-&gtkmm3-version;.tar.xz">
-  <!ENTITY gtkmm3-download-ftp
-     "&gnome-download-ftp;/gtkmm/3.4/gtkmm-&gtkmm3-version;.tar.xz">
+  <!ENTITY gtkmm3-download-http "&gnome-download-http;/gtkmm/3.4/gtkmm-&gtkmm3-version;.tar.xz">
+  <!ENTITY gtkmm3-download-ftp  "&gnome-download-ftp;/gtkmm/3.4/gtkmm-&gtkmm3-version;.tar.xz">
   <!ENTITY gtkmm3-md5sum        "cae0fa7143ad8d9df678859bf8bdc1cb">
   <!ENTITY gtkmm3-size          "8.8 MB">
   <!ENTITY gtkmm3-buildsize     "240 MB">
@@ -33,7 +31,7 @@
 
     <para>
       The <application>Gtkmm</application> package provides a C++ interface to
-      <application>GTK+-3</application>.
+      <application>GTK+ 3</application>.
     </para>
 
     &lfs70_checked;
@@ -117,13 +115,13 @@
 
       <seglistitem>
         <seg>
-          libgdkmm-3.0.so and libgtkmm-3.0.so.
+          libgdkmm-3.0.so and libgtkmm-3.0.so
         </seg>
         <seg>
           /usr/include/{gdkmm-3.0,gtkmm-3.0},
           /usr/lib/{gdkmm-3.0,gtkmm-3.0},
           /usr/share/devhelp/books/gtkmm-3.0 and
-          /usr/share/doc/gtkmm-3.0.
+          /usr/share/doc/gtkmm-3.0
         </seg>
       </seglistitem>
     </segmentedlist>
@@ -136,8 +134,8 @@
       <varlistentry id="libgdkmm-3.0">
         <term><filename class='libraryfile'>libgdkmm-3.0.so</filename></term>
         <listitem>
-          <para>
-        contains the GDK API classes.
+        <para>
+          contains the GDK API classes.
         </para>
           <indexterm zone="gtkmm3 libgdkmm-3.0">
             <primary sortas="c-libgdkmm-3.0">libgdkmm-3.0.so</primary>
@@ -148,14 +146,17 @@
       <varlistentry id="libgtkmm-3.0">
         <term><filename class='libraryfile'>libgtkmm-3.0.so</filename></term>
         <listitem>
-          <para>
-        contains the <application>GTK+3</application> API classes.
+        <para>
+          contains the <application>GTK+ 3</application> API classes.
         </para>
           <indexterm zone="gtkmm3 libgtkmm-3.0">
             <primary sortas="c-libgtkmm-3.0">libgtkmm-3.0.so</primary>
           </indexterm>
         </listitem>
       </varlistentry>
+
     </variablelist>
+
   </sect2>
+
 </sect1>

Modified: trunk/BOOK/x/lib/libnotify.xml
===================================================================
--- trunk/BOOK/x/lib/libnotify.xml	2012-07-24 16:16:08 UTC (rev 10463)
+++ trunk/BOOK/x/lib/libnotify.xml	2012-07-24 16:17:44 UTC (rev 10464)
@@ -29,33 +29,47 @@
   <sect2 role="package">
     <title>Introduction to libnotify</title>
 
-    <para>The <application>libnotify</application> library is used to send
-    desktop notifications to a notification daemon, as defined in the Desktop
-    Notifications spec. These notifications can be used to inform the user about
-    an event or display some form of information without getting in the user's
-    way.</para>
+    <para>
+      The <application>libnotify</application> library is used to send desktop
+      notifications to a notification daemon, as defined in the Desktop
+      Notifications spec. These notifications can be used to inform the user about
+      an event or display some form of information without getting in the user's
+      way.
+    </para>
 
     &lfs71_checked;
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
-        <para>Download (HTTP): <ulink url="&libnotify-download-http;"/></para>
+        <para>
+          Download (HTTP): <ulink url="&libnotify-download-http;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download (FTP): <ulink url="&libnotify-download-ftp;"/></para>
+        <para>
+          Download (FTP): <ulink url="&libnotify-download-ftp;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download MD5 sum: &libnotify-md5sum;</para>
+        <para>
+          Download MD5 sum: &libnotify-md5sum;
+        </para>
       </listitem>
       <listitem>
-        <para>Download size: &libnotify-size;</para>
+        <para>
+          Download size: &libnotify-size;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated disk space required: &libnotify-buildsize;</para>
+        <para>
+          Estimated disk space required: &libnotify-buildsize;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated build time: &libnotify-time;</para>
+        <para>
+          Estimated build time: &libnotify-time;
+        </para>
       </listitem>
     </itemizedlist>
 
@@ -77,22 +91,28 @@
     </para>
 
     <para condition="html" role="usernotes">User Notes:
-    <ulink url="&blfs-wiki;/libnotify"/></para>
-
+      <ulink url="&blfs-wiki;/libnotify"/>
+    </para>
   </sect2>
 
   <sect2 role="installation">
     <title>Installation of libnotify</title>
 
-    <para>Install <application>libnotify</application> by running the following
-    commands:</para>
+    <para>
+      Install <application>libnotify</application> by running the following
+      commands:
+    </para>
 
 <screen><userinput>./configure --prefix=/usr --disable-static &&
 make</userinput></screen>
 
-    <para>This package does not come with a test suite.</para>
+    <para>
+      This package does not come with a test suite.
+    </para>
 
-    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+    <para>
+      Now, as the <systemitem class="username">root</systemitem> user:
+    </para>
 
 <screen role="root"><userinput>make install</userinput></screen>
 
@@ -102,10 +122,10 @@
     <title>Command Explanations</title>
 
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-    href="../../xincludes/gtk-doc-rebuild.xml"/>
+      href="../../xincludes/static-libraries.xml"/>
 
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-    href="../../xincludes/static-libraries.xml"/>
+      href="../../xincludes/gtk-doc-rebuild.xml"/>
 
   </sect2>
 
@@ -125,7 +145,8 @@
           libnotify.so
         </seg>
         <seg>
-         /usr/include/libnotify and /usr/share/gtk-doc/html/libnotify
+         /usr/include/libnotify and
+         /usr/share/gtk-doc/html/libnotify
         </seg>
       </seglistitem>
     </segmentedlist>
@@ -138,7 +159,9 @@
       <varlistentry id="notify-send">
         <term><command>notify-send</command></term>
         <listitem>
-          <para>is a command to send notifications.</para>
+          <para>
+            is a command used to send notifications.
+          </para>
           <indexterm zone="libnotify notify-send">
             <primary sortas="b-notify-send">notify-send</primary>
           </indexterm>
@@ -148,7 +171,9 @@
       <varlistentry id="libnotify-lib">
         <term><filename class='libraryfile'>libnotify.so</filename></term>
         <listitem>
-          <para>contains the notify API functions.</para>
+          <para>
+            contains the <application>libnotify</application> API functions.
+          </para>
           <indexterm zone="libnotify libnotify">
             <primary sortas="c-libnotify">libnotify.so</primary>
           </indexterm>

Modified: trunk/BOOK/x/lib/libxklavier.xml
===================================================================
--- trunk/BOOK/x/lib/libxklavier.xml	2012-07-24 16:16:08 UTC (rev 10463)
+++ trunk/BOOK/x/lib/libxklavier.xml	2012-07-24 16:17:44 UTC (rev 10464)
@@ -31,30 +31,44 @@
   <sect2 role="package">
     <title>Introduction to libxklavier</title>
 
-    <para>The <application>libxklavier</application> package contains a
-    utility library for <application>X</application> keyboard.</para>
+    <para>
+      The <application>libxklavier</application> package contains an
+      utility library for <application>X</application> keyboard.
+    </para>
 
     &lfs70_checked;
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
-        <para>Download (HTTP): <ulink url="&libxklavier-download-http;"/></para>
+        <para>
+          Download (HTTP): <ulink url="&libxklavier-download-http;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download (FTP): <ulink url="&libxklavier-download-ftp;"/></para>
+        <para>
+          Download (FTP): <ulink url="&libxklavier-download-ftp;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download MD5 sum: &libxklavier-md5sum;</para>
+        <para>
+          Download MD5 sum: &libxklavier-md5sum;
+        </para>
       </listitem>
       <listitem>
-        <para>Download size: &libxklavier-size;</para>
+        <para>
+          Download size: &libxklavier-size;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated disk space required: &libxklavier-buildsize;</para>
+        <para>
+          Estimated disk space required: &libxklavier-buildsize;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated build time: &libxklavier-time;</para>
+        <para>
+          Estimated build time: &libxklavier-time;
+        </para>
       </listitem>
     </itemizedlist>
 
@@ -79,22 +93,28 @@
     </para>
 
     <para condition="html" role="usernotes">User Notes:
-    <ulink url="&blfs-wiki;/libxklavier"/></para>
-
+      <ulink url="&blfs-wiki;/libxklavier"/>
+    </para>
   </sect2>
 
   <sect2 role="installation">
     <title>Installation of libxklavier</title>
 
-    <para>Install <application>libxklavier</application> by running the
-    following commands:</para>
+    <para>
+      Install <application>libxklavier</application> by running the
+      following commands:
+    </para>
 
 <screen><userinput>./configure --prefix=/usr --disable-static &&
 make</userinput></screen>
 
-    <para>This package does not come with a test suite.</para>
+    <para>
+      This package does not come with a test suite.
+    </para>
 
-    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+    <para>
+      Now, as the <systemitem class="username">root</systemitem> user:
+    </para>
 
 <screen role="root"><userinput>make install</userinput></screen>
 
@@ -103,15 +123,17 @@
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><option>--with-xkb-base=$XORG_PREFIX/share/X11/xkb</option>:
-    Use this parameter if the $XORG_PREFIX is anything other than
-    <filename class='directory'>/usr</filename>.</para>
+    <para>
+      <parameter>--with-xkb-base=$XORG_PREFIX/share/X11/xkb</parameter>:
+      Use this parameter if the $XORG_PREFIX is anything other than
+      <filename class="directory">/usr</filename>.
+    </para>
 
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-    href="../../xincludes/gtk-doc-rebuild.xml"/>
+      href="../../xincludes/static-libraries.xml"/>
 
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-    href="../../xincludes/static-libraries.xml"/>
+      href="../../xincludes/gtk-doc-rebuild.xml"/>
 
   </sect2>
 
@@ -127,7 +149,8 @@
           libxklavier.so
         </seg>
         <seg>
-          /usr/include/libxklavier and /usr/share/gtk-doc/html/libxklavier
+          /usr/include/libxklavier and
+          /usr/share/gtk-doc/html/libxklavier
         </seg>
       </seglistitem>
     </segmentedlist>
@@ -140,7 +163,9 @@
       <varlistentry id="libxklavier-lib">
         <term><filename class='libraryfile'>libxklavier.so</filename></term>
         <listitem>
-          <para>contains XKB utility functions.</para>
+          <para>
+            contains XKB utility functions.
+          </para>
           <indexterm zone="libxklavier libxklavier-lib">
             <primary sortas="c-libxklavier">libxklavier.so</primary>
           </indexterm>

Modified: trunk/BOOK/x/lib/mx.xml
===================================================================
--- trunk/BOOK/x/lib/mx.xml	2012-07-24 16:16:08 UTC (rev 10463)
+++ trunk/BOOK/x/lib/mx.xml	2012-07-24 16:17:44 UTC (rev 10464)
@@ -12,7 +12,7 @@
   <!ENTITY mx-time          "0.8 SBU">
 ]>
 
-<sect1 id="mx" xreflabel="mx-&mx-version;">
+<sect1 id="mx" xreflabel="Mx-&mx-version;">
   <?dbhtml filename="mx.html"?>
 
   <sect1info>
@@ -20,44 +20,59 @@
     <date>$Date$</date>
   </sect1info>
 
-  <title>mx-&mx-version;</title>
+  <title>Mx-&mx-version;</title>
 
   <indexterm zone="mx">
-    <primary sortas="a-mx">mx</primary>
+    <primary sortas="a-Mx">Mx</primary>
   </indexterm>
 
   <sect2 role="package">
-    <title>Introduction to mx</title>
+    <title>Introduction to Mx</title>
 
-    <para><application>Mx</application> is a traditional GUI toolkit built upon
-    Clutter technology. It enables smooth animations and special effects through
-    hardware accelerated graphics (OpenGL).</para>
+    <para>
+      <application>Mx</application> is a traditional GUI toolkit built upon
+      <application>Clutter</application> technology. It enables smooth
+      animations and special effects through hardware accelerated graphics
+      (OpenGL).
+    </para>
 
     &lfs70_checked;
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
-        <para>Download (HTTP): <ulink url="&mx-download-http;"/></para>
+        <para>
+          Download (HTTP): <ulink url="&mx-download-http;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download (FTP): <ulink url="&mx-download-ftp;"/></para>
+        <para>
+          Download (FTP): <ulink url="&mx-download-ftp;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download MD5 sum: &mx-md5sum;</para>
+        <para>
+          Download MD5 sum: &mx-md5sum;
+        </para>
       </listitem>
       <listitem>
-        <para>Download size: &mx-size;</para>
+        <para>
+          Download size: &mx-size;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated disk space required: &mx-buildsize;</para>
+        <para>
+          Estimated disk space required: &mx-buildsize;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated build time: &mx-time;</para>
+        <para>
+          Estimated build time: &mx-time;
+        </para>
       </listitem>
     </itemizedlist>
 
-    <bridgehead renderas="sect3">mx Dependencies</bridgehead>
+    <bridgehead renderas="sect3">Mx Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required">
@@ -79,22 +94,28 @@
     </para>
 
     <para condition="html" role="usernotes">User Notes:
-    <ulink url="&blfs-wiki;/mx"/></para>
-
+      <ulink url="&blfs-wiki;/mx"/>
+    </para>
   </sect2>
 
   <sect2 role="installation">
-    <title>Installation of mx</title>
+    <title>Installation of Mx</title>
 
-    <para>Install <application>mx</application> by running the following
-    commands:</para>
+    <para>
+      Install <application>Mx</application> by running the following
+      commands:
+    </para>
 
 <screen><userinput>./configure --prefix=/usr &&
 make</userinput></screen>
 
-    <para>This package does not come with a test suite. </para>
+    <para>
+      This package does not come with a test suite.
+    </para>
 
-    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+    <para>
+      Now, as the <systemitem class="username">root</systemitem> user:
+    </para>
 
 <screen role="root"><userinput>make install</userinput></screen>
 
@@ -139,7 +160,9 @@
       <varlistentry id="libmx-1">
         <term><filename class='libraryfile'>libmx-1.0.so</filename></term>
         <listitem>
-          <para>contains the MX API functions.</para>
+          <para>
+            contains the <application>Mx</application> API functions.
+          </para>
           <indexterm zone="mx libmx-1">
             <primary sortas="c-libmx-1">libmx-1.0.so</primary>
           </indexterm>
@@ -149,7 +172,10 @@
       <varlistentry id="libmx-gtk-1">
         <term><filename class='libraryfile'>libmx-gtk-1.0.so</filename></term>
         <listitem>
-          <para>contains the GTK+ Bindings to MX.</para>
+          <para>
+            contains the <application>Mx</application>
+            <application>GTK+</application> bindings.
+          </para>
           <indexterm zone="mx libmx-gtk-1">
             <primary sortas="c-libmx-gtk-1">libmx-gtk-1.0.so</primary>
           </indexterm>

Modified: trunk/BOOK/x/lib/notification-daemon.xml
===================================================================
--- trunk/BOOK/x/lib/notification-daemon.xml	2012-07-24 16:16:08 UTC (rev 10463)
+++ trunk/BOOK/x/lib/notification-daemon.xml	2012-07-24 16:17:44 UTC (rev 10464)
@@ -95,7 +95,8 @@
       the following commands:
     </para>
 
-<screen><userinput>./configure --prefix=/usr --sysconfdir=/etc \
+<screen><userinput>./configure --prefix=/usr \
+            --sysconfdir=/etc \
             --libexecdir=/usr/lib/notification-daemon &&
 make</userinput></screen>
 
@@ -150,7 +151,7 @@
         <term><command>notification-daemon</command></term>
         <listitem>
           <para>
-            is the Notification Daemon itself.
+            is the <application>Notification Daemon</application> itself.
           </para>
           <indexterm zone="notification-daemon notification-daemon-prog">
             <primary sortas="b-notification-daemon">notification-daemon</primary>

Modified: trunk/BOOK/x/lib/pango.xml
===================================================================
--- trunk/BOOK/x/lib/pango.xml	2012-07-24 16:16:08 UTC (rev 10463)
+++ trunk/BOOK/x/lib/pango.xml	2012-07-24 16:17:44 UTC (rev 10464)
@@ -41,40 +41,46 @@
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
-        <para>Download (HTTP): <ulink url="&pango-download-http;"/></para>
+        <para>
+          Download (HTTP): <ulink url="&pango-download-http;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download (FTP): <ulink url="&pango-download-ftp;"/></para>
+        <para>
+          Download (FTP): <ulink url="&pango-download-ftp;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download MD5 sum: &pango-md5sum;</para>
+        <para>
+          Download MD5 sum: &pango-md5sum;
+        </para>
       </listitem>
       <listitem>
-        <para>Download size: &pango-size;</para>
+        <para>
+          Download size: &pango-size;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated disk space required: &pango-buildsize;</para>
+        <para>
+          Estimated disk space required: &pango-buildsize;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated build time: &pango-time;</para>
+        <para>
+          Estimated build time: &pango-time;
+        </para>
       </listitem>
     </itemizedlist>
 
     <bridgehead renderas="sect3">Pango Dependencies</bridgehead>
 
-    <bridgehead renderas="sect4">Required, one of:</bridgehead>
+    <!-- FreeType2 and Fontconfig pulled by Xorg Libraries -->
+    <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required">
-      <xref linkend="cairo"/>
-      <xref linkend="freetype2"/> or
+      <xref linkend="cairo"/> and
       <xref linkend="xorg7-lib"/>
-      (all 3 are required if you intend to install Gtk+)
     </para>
 
-    <bridgehead renderas="sect4">Recommended</bridgehead>
-    <para role="recommended">
-      <xref linkend="fontconfig"/>
-    </para>
-
     <bridgehead renderas="sect4">Optional (Required if building GNOME)</bridgehead>
     <para role="optional">
       <xref linkend="gobject-introspection"/>
@@ -177,15 +183,14 @@
       <segtitle>Installed Directories</segtitle>
 
       <seglistitem>
-        <seg>pango-querymodules and pango-view</seg>
         <seg>
-          libpango-1.0.so,
-          libpangocairo-1.0.so,
-          libpangoft2-1.0.so,
-          libpangox-1.0.so and
-          libpangoxft-1.0.so
+          pango-querymodules and pango-view
         </seg>
         <seg>
+          libpango-1.0.so, libpangocairo-1.0.so, libpangoft2-1.0.so,
+          libpangox-1.0.so and libpangoxft-1.0.so
+        </seg>
+        <seg>
           /etc/pango,
           /usr/include/pango-1.0,
           /usr/lib/pango and
@@ -238,6 +243,9 @@
           </indexterm>
         </listitem>
       </varlistentry>
+
     </variablelist>
+
   </sect2>
+
 </sect1>

Modified: trunk/BOOK/x/lib/pangomm.xml
===================================================================
--- trunk/BOOK/x/lib/pangomm.xml	2012-07-24 16:16:08 UTC (rev 10463)
+++ trunk/BOOK/x/lib/pangomm.xml	2012-07-24 16:17:44 UTC (rev 10464)
@@ -12,7 +12,7 @@
   <!ENTITY pangomm-time          "0.3 SBU">
 ]>
 
-<sect1 id="pangomm" xreflabel="pangomm-&pangomm-version;">
+<sect1 id="pangomm" xreflabel="Pangomm-&pangomm-version;">
   <?dbhtml filename="pangomm.html"?>
 
   <sect1info>
@@ -20,43 +20,57 @@
     <date>$Date$</date>
   </sect1info>
 
-  <title>pangomm-&pangomm-version;</title>
+  <title>Pangomm-&pangomm-version;</title>
 
   <indexterm zone="pangomm">
-    <primary sortas="a-pangomm">pangomm</primary>
+    <primary sortas="a-Pangomm">Pangomm</primary>
   </indexterm>
 
   <sect2 role="package">
-    <title>Introduction to pangomm</title>
+    <title>Introduction to Pangomm</title>
 
-    <para>The <application>pangomm</application> package provides a C++
-    interface to <application>Pango</application>.</para>
+    <para>
+      The <application>Pangomm</application> package provides a C++
+      interface to <application>Pango</application>.
+    </para>
 
     &lfs70_checked;
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
-        <para>Download (HTTP): <ulink url="&pangomm-download-http;"/></para>
+        <para>
+          Download (HTTP): <ulink url="&pangomm-download-http;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download (FTP): <ulink url="&pangomm-download-ftp;"/></para>
+        <para>
+          Download (FTP): <ulink url="&pangomm-download-ftp;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download MD5 sum: &pangomm-md5sum;</para>
+        <para>
+          Download MD5 sum: &pangomm-md5sum;
+        </para>
       </listitem>
       <listitem>
-        <para>Download size: &pangomm-size;</para>
+        <para>
+          Download size: &pangomm-size;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated disk space required: &pangomm-buildsize;</para>
+        <para>
+          Estimated disk space required: &pangomm-buildsize;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated build time: &pangomm-time;</para>
+        <para>
+          Estimated build time: &pangomm-time;
+        </para>
       </listitem>
     </itemizedlist>
 
-    <bridgehead renderas="sect3">pangomm Dependencies</bridgehead>
+    <bridgehead renderas="sect3">Pangomm Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required">
@@ -66,22 +80,28 @@
     </para>
 
     <para condition="html" role="usernotes">User Notes:
-    <ulink url="&blfs-wiki;/pangomm"/></para>
-
+      <ulink url="&blfs-wiki;/pangomm"/>
+    </para>
   </sect2>
 
   <sect2 role="installation">
-    <title>Installation of pangomm</title>
+    <title>Installation of Pangomm</title>
 
-    <para>Install <application>pangomm</application> by running the following
-    commands:</para>
+    <para>
+      Install <application>Pangomm</application> by running the following
+      commands:
+    </para>
 
 <screen><userinput>./configure --prefix=/usr &&
 make</userinput></screen>
 
-    <para>This package does not come with a test suite.</para>
+    <para>
+      This package does not come with a test suite.
+    </para>
 
-    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+    <para>
+      Now, as the <systemitem class="username">root</systemitem> user:
+    </para>
 
 <screen role="root"><userinput>make install</userinput></screen>
 
@@ -115,7 +135,9 @@
       <varlistentry id="libpangomm-1.4">
         <term><filename class='libraryfile'>libpangomm-1.4.so</filename></term>
         <listitem>
-          <para>contains the <application>Pango</application> API classes.</para>
+          <para>
+            contains the <application>Pango</application> API classes.
+          </para>
           <indexterm zone="pangomm libpangomm-1.4">
             <primary sortas="c-libpangomm-1.4">libpangomm-1.4.so</primary>
           </indexterm>

Modified: trunk/BOOK/x/lib/webkitgtk.xml
===================================================================
--- trunk/BOOK/x/lib/webkitgtk.xml	2012-07-24 16:16:08 UTC (rev 10463)
+++ trunk/BOOK/x/lib/webkitgtk.xml	2012-07-24 16:17:44 UTC (rev 10464)
@@ -85,7 +85,7 @@
       <xref linkend="gst-plugins-base"/>,
       <xref linkend="geoclue"/>,
       <xref linkend="which"/> and
-      <xref linkend="sqlite"/>.
+      <xref linkend="sqlite"/>
     </para>
 
     <bridgehead renderas="sect4">Optional (Required if building GNOME)</bridgehead>
@@ -98,7 +98,7 @@
       <xref linkend="curl"/>,
       <xref linkend="enchant"/>,
       <xref linkend="gtk-doc"/> and
-      <ulink url="http://xsltml.sourceforge.net/">MathML</ulink>.
+      <ulink url="http://xsltml.sourceforge.net/">MathML</ulink>
     </para>
 
     <para condition="html" role="usernotes">
@@ -114,7 +114,6 @@
       fix a bug in the configure script that will stop it detecting
       <application>Gstreamer</application> correctly: 
     </para>
-    <!-- https://bugs.webkit.org/show_bug.cgi?id=82580 -->
 
 <screen><userinput>sed -i 's#=GST#=$GST#' configure</userinput></screen>
 
@@ -160,13 +159,6 @@
     <para>
       This package does not have a working testsuite.
     </para>
-<!--
-    <para>
-      To test the results, issue: <command>make check</command> (you must be in
-      an xterm or similar to do this, because it launches some windows).
-      Requires <xref linkend="pygobject2"/>.
-    </para>
--->
 
     <para>
       Now, as the <systemitem class="username">root</systemitem> user:
@@ -180,9 +172,9 @@
 
     <para>
       <option>--enable-introspection</option>: This option enables support for
-      <application>Gobject-Introspection</application> and is required for a
-      <application>GNOME</application> desktop. If you don't have
-      <application>Gobject-Introspection</application> installed and don't want
+      <application>Gobject Introspection</application> and is required for a
+      <application>GNOME</application> Desktop. If you don't have
+      <application>Gobject Introspection</application> installed and don't want
       to install <application>GNOME</application> remove this option.
     </para>
 
@@ -203,12 +195,12 @@
 
     <para>
       <option>--with-gtk=2.0</option>: This option forces
-      <application>Webkit</application> to compile against
-      <application>Gtk+-2</application>, even if
-      <application>Gtk+-3</application> is also installed. With
-      <application>Gtk+-2</application>, everything
+      <application>WebKit</application> to compile against
+      <application>GTK+ 2</application>, even if
+      <application>GTK+ 3</application> is also installed. With
+      <application>GTK+ 2</application>, everything
       <application>Webkit</application> installs is suffixed with 1.0. When it
-      is compiled against <application>Gtk+-3</application> everything it
+      is compiled against <application>GTK+ 3</application> everything it
       installs is suffixed with 3.0. Both versions can be installed alongside
       one another with no namespace conflicts.
     </para>
@@ -234,15 +226,15 @@
         <seg>
           libwebkit-1.0.so and libjavascriptcoregtk-1.0.so or libwebkit-3.0.so
           and libjavascriptcoregtk-3.0.so (depending on whether you installed
-          the <application>Gtk+-2</application> or
-          <application>Gtk+-3</application> version of
+          the <application>GTK+ 2</application> or
+          <application>GTK+ 3</application> version of
           <application>WebKit</application>).
         </seg>
         <seg>
           /usr/include/webkit-1.0 and /usr/share/webkit-1.0 or
           /usr/include/webkit-3.0 and /usr/share/webkit-3.0 (depending on
-          whether you installed the <application>Gtk+-2</application> or
-          <application>Gtk+-3</application> version of
+          whether you installed the <application>GTK+ 2</application> or
+          <application>GTK+ 3</application> version of
           <application>WebKit</application>).
         </seg>
       </seglistitem>
@@ -271,7 +263,7 @@
         <listitem>
           <para>
             contains the <application>WebKit</application> API functions for
-            <application>gtk+-2</application>.
+            <application>GTK+ 2</application>.
           </para>
           <indexterm zone="webkitgtk libwebkit-1.0">
             <primary sortas="c-libwebkit-1.0">libwebkit-1.0.so</primary>
@@ -284,7 +276,7 @@
         <listitem>
           <para>
             contains the <application>WebKit</application> API functions for
-            <application>gtk+-3</application>.
+            <application>GTK+ 3</application>.
           </para>
           <indexterm zone="webkitgtk libwebkit-3.0">
             <primary sortas="c-libwebkit-3.0">libwebkit-3.0.so</primary>
@@ -317,6 +309,9 @@
           </indexterm>
         </listitem>
       </varlistentry>
+
     </variablelist>
+
   </sect2>
+
 </sect1>




More information about the blfs-book mailing list