[blfs-book] r9543 - in trunk/BOOK: . general/genlib introduction/welcome template xsoft/office

andy at linuxfromscratch.org andy at linuxfromscratch.org
Tue Feb 28 05:50:39 PST 2012


Author: andy
Date: 2012-02-28 06:50:35 -0700 (Tue, 28 Feb 2012)
New Revision: 9543

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/general/genlib/genlib.xml
   trunk/BOOK/general/genlib/slib.xml
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/template/template.xml
   trunk/BOOK/xsoft/office/gnucash.xml
   trunk/BOOK/xsoft/office/office.xml
Log:
The zombie is still moving
gnucash and slib are back in the book

Modified: trunk/BOOK/general/genlib/genlib.xml
===================================================================
--- trunk/BOOK/general/genlib/genlib.xml	2012-02-28 02:21:38 UTC (rev 9542)
+++ trunk/BOOK/general/genlib/genlib.xml	2012-02-28 13:50:35 UTC (rev 9543)
@@ -63,7 +63,7 @@
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="libesmtp.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="aspell.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="enchant.xml"/>
-  <!-- <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="slib.xml"/> -->
+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="slib.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="lzo.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="libusb.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="libusb-compat.xml"/>

Modified: trunk/BOOK/general/genlib/slib.xml
===================================================================
--- trunk/BOOK/general/genlib/slib.xml	2012-02-28 02:21:38 UTC (rev 9542)
+++ trunk/BOOK/general/genlib/slib.xml	2012-02-28 13:50:35 UTC (rev 9543)
@@ -4,7 +4,8 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY slib-download-http "http://swiss.csail.mit.edu/ftpdir/scm/OLD/slib-&slib-version;.tar.gz">
+  <!ENTITY slib-download-http
+  "http://groups.csail.mit.edu/mac/ftpdir/scm/slib-&slib-version;.tar.gz">
   <!ENTITY slib-download-ftp  " ">
   <!ENTITY slib-md5sum        "850f48ad933e2fe8bb03b1e994ed4407">
   <!ENTITY slib-size          "948 KB">
@@ -40,6 +41,8 @@
     PLT Scheme (DrScheme and MzScheme), Pocket Scheme, RScheme, scheme->C,
     Scheme48, SCM, SCM Mac, scsh, Stk, T3.1, umb-scheme, and VSCM.</para>
 
+    &lfs70_built;
+
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
@@ -62,26 +65,22 @@
       </listitem>
     </itemizedlist>
 
-    <!-- <bridgehead renderas="sect3">Additional Downloads</bridgehead>
-    <itemizedlist spacing='compact'>
-      <listitem>
-        <para>Required Patch: <ulink
-        url="&patch-root;/slib-&slib-version;-guile_fixes-1.patch"/></para>
-      </listitem>
-    </itemizedlist> -->
-
     <bridgehead renderas="sect3">SLIB Dependencies</bridgehead>
 
+    <!--
     <para>There are no build dependencies as this package is nothing but many
     text script files which are copied to the system. If you are installing
     this package to support a <application>GnuCash</application> installation,
     you should ensure that <xref linkend="guile"/> is installed so the
     <application>SLIB</application> catalog for <application>Guile</application>
     can be created.</para>
+    -->
 
+    <bridgehead renderas="sect4">Required</bridgehead>
+    <para role="required"><xref linkend="guile"/>.</para>
+
     <para condition="html" role="usernotes">User Notes:
     <ulink url="&blfs-wiki;/slib"/></para>
-
   </sect2>
 
   <sect2 role="installation">
@@ -90,46 +89,36 @@
     <para>Install <application>SLIB</application> by issuing the following
     commands:</para>
 
-<screen><userinput>sed -i 's|usr/lib|usr/share|' RScheme.init        &&
-makeinfo -o slib.txt  --plaintext       slib.texi &&
+<screen><userinput>sed -i 's|usr/lib|usr/share|' RScheme.init &&
+./configure --prefix=/usr --libdir=/usr/share &&
+sed -i 's# scm$# guile#;s#ginstall-info#install-info#' Makefile &&
+makeinfo -o slib.txt --plaintext slib.texi &&
 makeinfo -o slib.html --html --no-split slib.texi</userinput></screen>
 
-    <para>If you have <!--<xref linkend="tetex"/> or--> <xref linkend="texlive"/>
-    installed and wish to build PDF or Postscript documentation, issue any or
-    all of the following commands:</para>
+    <para>If you have <xref linkend="texlive"/> installed and wish to build PDF
+    or Postscript documentation, issue any or all of the following
+    commands:</para>
 
-<screen><userinput>texi2pdf  slib.texi &&
-texi2dvi  slib.texi &&
-dvips  -o slib.ps   slib.dvi</userinput></screen>
+<screen><userinput>texi2pdf slib.texi &&
+texi2dvi slib.texi &&
+dvips -o slib.ps slib.dvi</userinput></screen>
 
     <para>This package does not come with a functional test suite.</para>
 
-    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+    <para>Now, as the <systemitem class="username">root</systemitem>
+    user:</para>
 
-<screen role="root"><userinput>make prefix=/usr/ \
-     libdir=/usr/share/ \
-     man1dir=/usr/share/man/man1 \
-     infodir=/usr/share/info/ \
-  install installinfo &&
+<screen role="root"><userinput>make install &&
+ln -v -s ../slib /usr/share/guile &&
+guile -c "(use-modules (ice-9 slib)) (require 'printf)" &&
+install -v -m755 -d /usr/share/doc/slib-&slib-version; &&
+install -v -m644 ANNOUNCE FAQ README slib.{txt,html} /usr/share/doc/slib-&slib-version;</userinput></screen>
 
-install -v -m755 -d /usr/share/doc/slib-&slib-version;  &&
-install -v -m644    ANNOUNCE FAQ README slib.{txt,html} \
-                    /usr/share/doc/slib-&slib-version;</userinput></screen>
-
-    <para>If you have <xref linkend="guile"/> installed, create the following
-    symbolic link as the <systemitem class="username">root</systemitem> user to
-    satisfy <application>Guile</application>'s default
-    <quote>Implementation Vicinity</quote> directory.</para>
-
-<screen role="root"><userinput>ln -v -s ../slib /usr/share/guile</userinput></screen>
-
     <para>If you built any of the optional documentation, install it using the
     following command as the <systemitem class="username">root</systemitem>
     user:</para>
 
-<screen role="root"><userinput>install -v -m644 slib.{pdf,dvi,ps} \
-                 /usr/share/doc/slib-&slib-version;</userinput></screen>
-
+<screen role="root"><userinput>install -v -m644 slib.{pdf,dvi,ps} /usr/share/doc/slib-&slib-version;</userinput></screen>
   </sect2>
 
   <sect2 role="commands">
@@ -137,37 +126,26 @@
 
     <para><command>sed -i 's|usr/lib|usr/share|' RScheme.init</command>:
     This command is used to change the <envar>libdir</envar> variable embedded
-    in the script to match the installation variable.</para>
+    in the script to match the installation.</para>
 
+    <para><option>--libdir=/usr/share</option>: This option puts the installed
+    in files <filename class="directory">/usr/share/slib</filename> instead of
+    <filename class="directory">/usr/lib/slib</filename>.</para>
+
+    <para><command>ln -v -s ../slib /usr/share/guile</command>: This command
+    puts a symbolic link to the <application>slib</application> files in
+    <application>Guile</application>'s default <quote>Implementation
+    Vicinity</quote>.</para>
+
+    <para><command>guile -c "(use-modules (ice-9 slib)) (require
+    'printf)"</command>: This command creates a guile catalog of the
+    <application>slib</application> files.</para>
+
     <para><command>make ... install installinfo</command>: This command
     installs the package and the <command>info</command> documentation into the
     indicated directories.</para>
-
   </sect2>
 
-  <sect2 role="configuration" id="slib-config">
-    <title>Configuring SLIB</title>
-
-    <para>For many of the Scheme implementations, an
-    <application>SLIB</application> Scheme implementation catalog  must be
-    created. If you have <xref linkend="guile"/> installed to support a
-    <application>GnuCash</application> installation, you must create a
-    catalog. You can use the <command>make catalogs</command> command, but
-    there will be many warnings and confusing messages as it tries to create
-    a catalog for many of the possible Scheme implementations which are
-    probably not installed on the system. To create a single catalog just
-    for the <application>Guile</application> installation, issue the following
-    command as the <systemitem class="username">root</systemitem> user:</para>
-
-<screen role="root"><userinput>guile -l guile.init \
-      -c "(use-modules (ice-9 slib)) (require 'new-catalog)"</userinput></screen>
-
-    <para>If there was no output from the previous command, and the file
-    <filename>/usr/share/guile/1.8/slibcat</filename> now exists, the catalog
-    was properly created.</para>
-
-  </sect2>
-
   <sect2 role="content">
     <title>Contents</title>
 
@@ -201,9 +179,6 @@
           </indexterm>
         </listitem>
       </varlistentry>
-
     </variablelist>
-
   </sect2>
-
 </sect1>

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2012-02-28 02:21:38 UTC (rev 9542)
+++ trunk/BOOK/general.ent	2012-02-28 13:50:35 UTC (rev 9543)
@@ -184,7 +184,7 @@
 <!ENTITY libesmtp-version             "1.0.4">
 <!ENTITY aspell-version               "0.60.6">
 <!ENTITY enchant-version              "1.6.0">
-<!-- <!ENTITY slib-version                 "3b2"> -->
+<!ENTITY slib-version                 "3b3">
 <!ENTITY LZO-version                  "2.03">
 <!ENTITY libusb-version               "1.0.8">
 <!ENTITY libusb-compat-version        "0.1.3">
@@ -878,7 +878,7 @@
 <!-- Chapter 35 -->
 <!ENTITY AbiWord-version              "2.8.6">
 <!ENTITY gnumeric-version             "1.10.17">
-<!-- <!ENTITY gnucash-version              "2.2.4"> -->
+<!ENTITY gnucash-version              "2.4.10">
 <!ENTITY evolution-version            "3.2.2">
 
 <!-- Chapter 36 -->

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2012-02-28 02:21:38 UTC (rev 9542)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2012-02-28 13:50:35 UTC (rev 9543)
@@ -77,6 +77,9 @@
         <listitem>
           <para>[ken] - added nemiver-0.9.0 from Wayne.</para>
         </listitem>
+        <listitem>
+          <para>[abenton] - Gnucash-2.4.10 and Slib-3b3.</para>
+        </listitem>
       </itemizedlist>
     </listitem>
 

Modified: trunk/BOOK/template/template.xml
===================================================================
--- trunk/BOOK/template/template.xml	2012-02-28 02:21:38 UTC (rev 9542)
+++ trunk/BOOK/template/template.xml	2012-02-28 13:50:35 UTC (rev 9543)
@@ -48,6 +48,12 @@
     <para>The <application>TEMPLATE</application> package contains...
     This is useful for...</para>
 
+    <!-- if it builds but hasn't been tested: -->
+    &lfs70_built;
+    <!-- if it works: -->
+    &lfs70_checked;
+
+
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>

Modified: trunk/BOOK/xsoft/office/gnucash.xml
===================================================================
--- trunk/BOOK/xsoft/office/gnucash.xml	2012-02-28 02:21:38 UTC (rev 9542)
+++ trunk/BOOK/xsoft/office/gnucash.xml	2012-02-28 13:50:35 UTC (rev 9543)
@@ -4,18 +4,21 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gnucash-download-http  "http://www.gnucash.org/pub/gnucash/sources/stable/gnucash-&gnucash-version;.tar.bz2">
-  <!ENTITY gnucash-download-ftp   "ftp://ftp.at.gnucash.org/pub/gnucash/sources/stable/2.2.4/gnucash-&gnucash-version;.tar.bz2">
-  <!ENTITY gnucash-src-md5sum     "f521cea858ee7223325114ec98de86ca">
-  <!ENTITY gnucash-size           "6.8 MB">
-  <!ENTITY gnucash-buildsize      "163 MB (additional 50 MB if running test suite; additional 124 MB for API docs)">
-  <!ENTITY gnucash-time           "3.1 SBU (additional 1.8 SBU to run the test suite; additional 0.3 SBU for docs)">
-  <!ENTITY gnucash-docs-version   "2.2.0">
-  <!ENTITY gnucash-docs-download  "http://www.gnucash.org/pub/gnucash/sources/stable/gnucash-docs-&gnucash-docs-version;.tar.gz">
-  <!ENTITY gnucash-docs-md5sum    "97a29e499baca1807a3944ae3c0ad61e">
-  <!ENTITY gnucash-docs-size      "10.0 MB">
-  <!ENTITY gnucash-docs-buildsize "27 MB (additional 41 MB for html and pdf)">
-  <!ENTITY gnucash-docs-time      "less than 0.1 SBU (additional 0.4 SBU for html and pdf)">
+  <!ENTITY gnucash-download-http
+  "&sourceforge-repo;/gnucash/gnucash-&gnucash-version;.tar.bz2">
+  <!ENTITY gnucash-download-ftp
+  " ">
+  <!ENTITY gnucash-src-md5sum     "eebcf231beffe39a9c1b5f09625bb38e">
+  <!ENTITY gnucash-size           "8.9 MB">
+  <!ENTITY gnucash-buildsize      "234 MB">
+  <!ENTITY gnucash-time           "2.2 SBU">
+  <!ENTITY gnucash-docs-version   "2.4.1">
+  <!ENTITY gnucash-docs-download
+  "&sourceforge-repo;/gnucash/gnucash-docs-&gnucash-docs-version;.tar.gz">
+  <!ENTITY gnucash-docs-md5sum    "38daeb3b15f296726ee8124122040f08">
+  <!ENTITY gnucash-docs-size      "32.5 MB">
+  <!ENTITY gnucash-docs-buildsize "27 MB">
+  <!ENTITY gnucash-docs-time      "0.5 SBU">
 ]>
 
 <sect1 id="gnucash" xreflabel="GnuCash-&gnucash-version;">
@@ -41,73 +44,110 @@
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
-        <para>Download (HTTP): <ulink url="&gnucash-download-http;"/></para>
+        <para>
+          Download (HTTP): <ulink url="&gnucash-download-http;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download (FTP): <ulink url="&gnucash-download-ftp;"/></para>
+        <para>
+          Download (FTP): <ulink url="&gnucash-download-ftp;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download MD5 sum: &gnucash-src-md5sum;</para>
+        <para>
+          Download MD5 sum: &gnucash-src-md5sum;
+        </para>
       </listitem>
       <listitem>
-        <para>Download size: &gnucash-size;</para>
+        <para>
+          Download size: &gnucash-size;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated disk space required: &gnucash-buildsize;</para>
+        <para>
+          Estimated disk space required: &gnucash-buildsize;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated build time: &gnucash-time;</para>
+        <para>
+          Estimated build time: &gnucash-time;
+        </para>
       </listitem>
     </itemizedlist>
 
     <bridgehead renderas="sect3">Additional Downloads</bridgehead>
-    <itemizedlist spacing='compact'>
+    <itemizedlist spacing="compact">
       <listitem>
-        <para>Help documentation: <ulink url="&gnucash-docs-download;"/></para>
+        <para>
+          Required patch:
+          <ulink url="&patch-root;/gnucash-&gnucash-version;-guile-2_fixes-1.patch"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download MD5 sum: &gnucash-docs-md5sum;</para>
+        <para>
+          Optional Help documentation: <ulink url="&gnucash-docs-download;"/>
+        </para>
       </listitem>
       <listitem>
-        <para>Download size: &gnucash-docs-size;</para>
+        <para>
+          Download MD5 sum: &gnucash-docs-md5sum;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated disk space required: &gnucash-docs-buildsize;</para>
+        <para>
+          Download size: &gnucash-docs-size;
+        </para>
       </listitem>
       <listitem>
-        <para>Estimated build time: &gnucash-docs-time;</para>
+        <para>
+          Estimated disk space required: &gnucash-docs-buildsize;
+        </para>
       </listitem>
+      <listitem>
+        <para>
+          Estimated build time: &gnucash-docs-time;
+        </para>
+      </listitem>
     </itemizedlist>
 
     <bridgehead renderas="sect3">GnuCash Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="guile"/>,
-    <xref linkend="slib"/>,
-    <xref linkend="goffice"/>, and
-    <xref linkend="gtkhtml"/></para>
+    <para role="required">
+      <xref linkend="guile"/>,
+      <xref linkend="libgnomeui"/>,
+      <xref linkend="gnome-vfs"/>,
+      <xref linkend="slib"/> and
+      <xref linkend="goffice"/>.
+      <xref linkend="gtkhtml"/> or
+      <xref linkend="webkitgtk"/> (configured <option>--with-gtk=2.0</option>).
+    </para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
-    <para role="optional"><xref linkend="postgresql"/>,
-    <ulink url="ftp://ftp.gnu.org/pub/gnu/guile/">Guile-www</ulink>, and
-    <ulink url="http://perens.com/FreeSoftware/">Electric Fence</ulink></para>
+    <para role="optional">
+      <ulink url="http://libdbi.sourceforge.net/">libdbi</ulink> and
+      <ulink url="ftp://ftp.gnu.org/pub/gnu/guile/">Guile-www</ulink>
+    </para>
 
     <bridgehead renderas="sect4">Optional (Required for the Help System)</bridgehead>
-    <para role="optional"><xref linkend="scrollkeeper"/> and
-    <xref linkend="yelp"/> (run-time requirement to view the Help documents)</para>
+    <para role="optional">
+      <xref linkend="rarian"/> and
+      <xref linkend="yelp"/> (run-time requirement to view the Help documents).
+    </para>
 
     <bridgehead renderas="sect4">Optional (for On-Line Banking)</bridgehead>
-    <para role="optional"><ulink
-    url="http://libofx.sourceforge.net/">LibOFX</ulink>
-    (requires <xref linkend="opensp"/> and <xref linkend="curl"/>),
-    <ulink url="http://sourceforge.net/projects/ktoblzcheck">KtoBlzCheck</ulink>,
-    and <ulink url="http://www.aquamaniac.de/aqbanking/">AqBanking</ulink>
-    (requires <ulink
-    url="http://gwenhywfar.sourceforge.net/">Gwenhywfar</ulink>
-    and <ulink url="http://www.libchipcard.de/">libchipcard3</ulink>)</para>
+    <para role="optional">
+      <ulink url="http://libofx.sourceforge.net/">LibOFX</ulink> (requires
+      <xref linkend="opensp"/> and <xref linkend="curl"/>),
+      <ulink url="http://sourceforge.net/projects/ktoblzcheck">KtoBlzCheck</ulink> and
+      <ulink url="http://www.aquamaniac.de/aqbanking/">AqBanking</ulink> (requires
+      <ulink url="http://gwenhywfar.sourceforge.net/">Gwenhywfar</ulink> and
+      <ulink url="http://www.libchipcard.de/">libchipcard3</ulink>)
+    </para>
 
-    <para condition="html" role="usernotes">User Notes:
-    <ulink url="&blfs-wiki;/gnucash"/></para>
+    <para condition="html" role="usernotes">
+      User Notes: <ulink url="&blfs-wiki;/gnucash"/>
+    </para>
 
   </sect2>
 
@@ -117,147 +157,89 @@
     <para>Install <application>GnuCash</application> by running the following
     commands:</para>
 
-<screen><userinput>sed -i 's|xml::${sysconfdir}|xml::${GNOME_SYSCONFDIR}|' configure &&
-
-./configure \
-    --prefix=/usr \
-    --sysconfdir=/etc \
-    --libexecdir=/usr/lib \
-    --with-gconf-schema-file-dir=$GNOME_SYSCONFDIR/gconf/schemas &&
+<screen><userinput>patch -p1 < ../gnucash-&gnucash-version;-guile-2_fixes-1.patch &&
+./configure --prefix=${GNOME_PREFIX} --sysconfdir=${GNOME_SYSCONFDIR} &&
 make</userinput></screen>
 
-    <para>If you wish to create the API documentation in HTML format, you must
-    have <xref linkend="doxygen"/> and <xref linkend="graphviz"/> installed,
-    then issue: <command>make doc</command>. If you wish to create the API
-    Design Guide in several formats, you must have <!--<xref linkend="tetex"/> or-->
-    <xref linkend="texlive"/> installed and issue:
-    <command>make -C src/doc/design html pdf ps</command>.</para>
+    <para>
+      If you wish to create the API documentation in HTML format, you must
+      have <xref linkend="doxygen"/> and <xref linkend="graphviz"/> installed,
+      then issue: <command>make doc</command>. If you wish to create the API
+      Design Guide in several formats, you must have <xref linkend="texlive"/>
+      installed and issue: <command>make -C src/doc/design html pdf
+      ps</command>.
+    </para>
 
-    <para>To test the results, issue: <command>make check</command>. All tests
-    should pass. An easy way to look at the results of the tests is to issue
-    <command>grep -A1 ============== check.log</command> (this is assuming you
-    redirected the output from the tests to the indicated filename).</para>
+    <para>
+      To test the results, issue: <command>make check</command>.
+    </para>
 
-    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+    <para>
+      Now, as the <systemitem class="username">root</systemitem> user:
+    </para>
 
-<screen role='root'><userinput>make install &&
+<screen role="root"><userinput>make install</userinput></screen>
 
-mv -v /usr/share/gnucash/doc /usr/share/doc/gnucash-&gnucash-version; &&
-ln -v -s ../doc/gnucash-&gnucash-version; /usr/share/gnucash/doc &&
+    <para>
+      If you want to install the Help documentation system, you must have
+      <xref linkend="yelp"/> and <xref linkend="rarian"/> installed in order to
+      view the Help documents. Unpack the additional tarball, change into the
+      <filename class="directory">gnucash-docs-&gnucash-docs-version;</filename>
+      source directory and issue the following commands as an unprivileged
+      user:
+    </para>
 
-for FILENAME in doc/{misc*,gnome*,generic*,build*}.txt \
-                doc/{gtkrc*,TRANSLATION_HOWTO,README.translator.txt} \
-                doc/README.{build-system,OFX,HBCI}
-do
-    install -v -m644 ${FILENAME} /usr/share/doc/gnucash-&gnucash-version;
-done &&
-
-install -v -m755 -d /usr/share/doc/gnucash-&gnucash-version;/api/engine &&
-install -v -m644    src/doc/{TODO*,*.txt,*.html} \
-                    /usr/share/doc/gnucash-&gnucash-version;/api &&
-install -v -m644    src/engine/*.txt \
-                    /usr/share/doc/gnucash-&gnucash-version;/api/engine</userinput></screen>
-
-    <para>If you built the API HTML or Design Guide documentation, issue the
-    following commands (modified as necessary, depending on what docs are
-    being installed) as the <systemitem class="username">root</systemitem>
-    user:</para>
-
-<screen role='root'><userinput>install -v -m755 -d /usr/share/doc/gnucash-&gnucash-version;/{design,api}/html &&
-install -v -m644    src/doc/design/gnucash-design.html/* \
-                    /usr/share/doc/gnucash-&gnucash-version;/design/html &&
-install -v -m644    src/doc/design/gnucash-design.{pdf,ps,dvi} \
-                    /usr/share/doc/gnucash-&gnucash-version;/design &&
-install -v -m644    src/doc/html/* \
-                    /usr/share/doc/gnucash-&gnucash-version;/api/html</userinput></screen>
-
-    <para>If you want to install the Help documentation system, you must have
-    <xref linkend="scrollkeeper"/> installed. Then unpack the additional
-    tarball, change into the
-    <filename class='directory'>gnucash-docs-&gnucash-docs-version;</filename>
-    source directory and issue the following commands as an unprivileged
-    user:</para>
-
-<screen><userinput>./configure --prefix=/usr \
-            --localstatedir=/var/lib &&
+<screen><userinput>./configure --prefix=${GNOME_PREFIX} &&
 make</userinput></screen>
 
-    <para>HTML versions of the Help Manual and Users Guide can be created if
-    the DocBook XML tools are installed (<xref linkend="libxslt"/>,
-    <xref linkend="DocBook"/> and <xref linkend="docbook-xsl"/>). A PDF version
-    of the Users Guide can be created if you have <xref linkend="docbook-utils"/>
-    and <xref linkend="jadetex"/> installed. Issue the following commands to
-    create the documentation (modify as appropriate for your desires):</para>
+    <para>
+      HTML versions of the Users Guide can be created if the DocBook XML tools
+      are installed (<xref linkend="libxslt"/>, <xref linkend="DocBook"/> and
+      <xref linkend="docbook-xsl"/>). A PDF version of the Users Guide can be
+      created if you have <xref linkend="docbook-utils"/>,
+      <xref linkend="jadetex"/> and <xref linkend="fop"/> installed.
+      Issue the following commands to create the documentation:
+    </para>
 
-<screen><userinput>make -C help  html &&
-make -C guide html &&
+<screen><userinput>make -C guide html &&
 make -C guide pdf</userinput></screen>
 
-    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+    <para>
+      Now, as the <systemitem class="username">root</systemitem> user:
+    </para>
 
-<screen role='root'><userinput>make install</userinput></screen>
+<screen role="root"><userinput>make install</userinput></screen>
 
-    <para>If you built the Help Manual or Users Guide, install them using the
-    following commands as the <systemitem class="username">root</systemitem>
-    user (modify as necessary):</para>
+    <para>
+      If you built the Users Guide, install it as the
+      <systemitem class="username">root</systemitem> user:
+    </para>
 
-<screen role='root'><userinput>install -v -m755 -d /usr/share/doc/gnucash-&gnucash-docs-version;/{users_guide,help} &&
-cp -v -R            help/C/gnucash-help/* \
-                    /usr/share/doc/gnucash-&gnucash-docs-version;/help &&
-cp -v -R            guide/C/gnucash-guide/* \
-                    /usr/share/doc/gnucash-&gnucash-docs-version;/users_guide &&
-install -v -m644    guide/C/gnucash-guide.pdf \
-                    /usr/share/doc/gnucash-&gnucash-docs-version;</userinput></screen>
-
-    <para>Note that you must have <xref linkend="yelp"/> installed in order to
-    view the Help documents using the default
-    <application>GnuCash</application> method.</para>
-
+<screen role="root"><userinput>mkdir -p ${GNOME_PREFIX}/share/doc/gnucash-&gnucash-docs-version; &&
+cp -v -R guide/C/gnucash-guide/* ${GNOME_PREFIX}/share/doc/gnucash-&gnucash-docs-version; &&
+cp -v guide/C/gnucash-guide.pdf ${GNOME_PREFIX}/share/doc/gnucash-&gnucash-docs-version;</userinput></screen>
   </sect2>
 
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><command>sed -i 's|xml::${sysconfdir}|xml::${GNOME_SYSCONFDIR}|'
-    configure</command>: This command is used because the location of the
-    <application>GConf</application> source database is hard-coded into
-    the <command>configure</command> script as
-    <filename class='directory'><envar>$sysconfdir</envar>/gconf</filename>
-    (rendering the <option>--with-gconf-source</option> parameter useless).
-    The modification ensures that the <application>GConf</application> database
-    is properly updated while still allowing the package configuration files
-    to be installed in
-    <filename class='directory'>/etc/gnucash</filename>.</para>
+    <para>
+      <parameter>--sysconfdir=${GNOME_SYSCONFDIR}</parameter>: This installs
+      configuration files in
+      <filename class="directory">${GNOME_SYSCONFDIR}/gnucash</filename> instead
+      of <filename class="directory">/usr/etc/gnucash</filename>.
+    </para>
 
-    <para><parameter>--sysconfdir=/etc</parameter>: This installs configuration
-    files in <filename class='directory'>/etc/gnucash</filename> instead of
-    <filename class='directory'>/usr/etc/gnucash</filename>.</para>
+    <para>
+      <option>--with-html-engine=webkit</option>: Add this option to use
+      <xref linkend="webkitgtk"/> (configured <option>--with-gtk=2.0</option>)
+      instead of <xref linkend="gtkhtml"/>.
+    </para>
 
-    <para><parameter>--with-gconf-schema-file-dir=$GNOME_SYSCONFDIR/gconf/schemas</parameter>:
-    This parameter ensures that the <application>GConf</application> schema
-    files are installed in the proper location instead of
-    <filename class='directory'>/etc/gconf</filename>.</para>
-
-    <para><command>mv -v /usr/share/gnucash/doc
-    /usr/share/doc/gnucash-&gnucash-version;</command> and
-    <command>ln -v -s ../doc/gnucash-&gnucash-version;
-    /usr/share/gnucash/doc</command>: These commands are used to relocate the
-    documentation files to the customary location and create a symbolic link
-    to the original location.</para>
-
-    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-    href="../../xincludes/scrollkeeper-dir.xml"/>
-
-    <para><option>--enable-sql</option>: This parameter is required if you want
-    to build in SQL support using <application>PostgreSQL</application>.</para>
-
-    <para><option>--enable-hbci</option>: This parameter is required if you
-    want to build in on-line banking support using
-    <application>AqBanking</application>. See
-    <filename>doc/README.HBCI</filename> in the
-    <application>GnuCash</application> source tree for complete
-    information.</para>
-
+    <para>
+      <option>--disable-dbi</option>: Add this option if you've not installed
+      <application>libdbi</application>.
+    </para>
   </sect2>
 
   <sect2 role="configuration">
@@ -266,20 +248,19 @@
     <sect3>
       <title>Configuration Information</title>
 
-      <para>If you wish to use <application>GnuCash</application> to retrieve
-      stock price quotes, you'll need to
-      install the following <application>Perl</application> modules:
-      <xref linkend="perl-lwp"/>,
-      <xref linkend="perl-date-manip"/>,
-      <xref linkend="perl-html-parser"/>,
-      <xref linkend="perl-html-tableextract"/>,
-      <xref linkend="perl-crypt-ssleay"/>, and
-      <xref linkend="perl-finance-quote"/>. Alternatively, you can run the
-      <command>/usr/bin/gnc-fq-update</command> script as the
-      <systemitem class="username">root</systemitem> user.</para>
-
+      <para>
+        If you wish to use <application>GnuCash</application> to retrieve
+        stock price quotes, you'll need to
+        install the following <application>Perl</application> modules:
+        <xref linkend="perl-lwp"/>, <xref linkend="perl-date-manip"/>,
+        <xref linkend="perl-html-parser"/>,
+        <xref linkend="perl-html-tableextract"/>,
+        <xref linkend="perl-crypt-ssleay"/>, and
+        <xref linkend="perl-finance-quote"/>. Alternatively, you can run the
+        <command>gnc-fq-update</command> script as the
+        <systemitem class="username">root</systemitem> user.
+      </para>
     </sect3>
-
   </sect2>
 
   <sect2 role="content">
@@ -291,23 +272,22 @@
       <segtitle>Installed Directories</segtitle>
 
       <seglistitem>
-        <seg>gnc-fq-check, gnc-fq-dump, gnc-fq-helper, gnc-fq-update,
-        gnc-test-env, gnucash, gnucash-bin, gnucash-env, gnucash-make-guids,
-        gnucash-valgrind, and update-gnucash-gconf</seg>
-        <seg>libgnc-backend-file-utils.so, libgnc-backend-postgres.so,
-        libgnc-business-ledger.so,libgnc-core-utils.so, libgnc-gnome.so,
-        libgnc-module.so, libgnc-qof.so and numerous support libraries
-        installed in
-        <filename class='directory'>/usr/lib/gnucash</filename></seg>
-        <seg>/etc/gnucash,
-        /usr/include/gnucash,
-        /usr/lib/gnucash,
-        and the following subdirectories of /usr/share/:
-        doc/gnucash-&gnucash-version;,
-        gnome/help/gnucash,
-        gnucash,
-        omf/gnucash-docs, and
-        /xml/gnucash</seg>
+        <seg>
+          gnc-fq-check, gnc-fq-dump, gnc-fq-helper, gnc-fq-update,
+          gnucash, gnucash-env, gnucash-make-guids, gnucash-valgrind and
+          update-gnucash-gconf
+        </seg>
+        <seg>
+          libgnc-backend-sql.so, libgnc-backend-xml-utils.so,
+          libgnc-business-ledger.so,libgnc-core-utils.so, libgnc-gnome.so,
+          libgnc-module.so, libgnc-qof.so and numerous support libraries
+          installed in <filename class="directory">/usr/lib/gnucash</filename>
+        </seg>
+        <seg>
+          ${GNOME_SYSCONFDIR}/gnucash, ${GNOME_PREFIX}/include/gnucash,
+          ${GNOME_PREFIX}/lib/gnucash, ${GNOME_PREFIX}/libexec/gnucash and
+          ${GNOME_PREFIX}/share/doc/gnucash-&gnucash-version;.
+        </seg>
       </seglistitem>
     </segmentedlist>
 
@@ -325,9 +305,6 @@
           </indexterm>
         </listitem>
       </varlistentry>
-
     </variablelist>
-
   </sect2>
-
 </sect1>

Modified: trunk/BOOK/xsoft/office/office.xml
===================================================================
--- trunk/BOOK/xsoft/office/office.xml	2012-02-28 02:21:38 UTC (rev 9542)
+++ trunk/BOOK/xsoft/office/office.xml	2012-02-28 13:50:35 UTC (rev 9543)
@@ -22,7 +22,7 @@
 
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="abiword.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="gnumeric.xml"/>
-  <!-- <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="gnucash.xml"/> -->
+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="gnucash.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="evolution.xml"/>
 
 </chapter>




More information about the blfs-book mailing list