[blfs-book] r9496 - in trunk/BOOK: . gnome/add introduction/welcome server/databases xsoft/office

ken at linuxfromscratch.org ken at linuxfromscratch.org
Wed Feb 22 14:11:18 PST 2012


Author: ken
Date: 2012-02-22 15:11:13 -0700 (Wed, 22 Feb 2012)
New Revision: 9496

Added:
   trunk/BOOK/gnome/add/libgda.xml
Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/gnome/add/add.xml
   trunk/BOOK/gnome/add/anjuta.xml
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/server/databases/sqlite.xml
   trunk/BOOK/xsoft/office/gnumeric.xml
Log:
 Add libgda, with minor consequential changes to sqlite and gnumeric.


Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2012-02-22 19:20:15 UTC (rev 9495)
+++ trunk/BOOK/general.ent	2012-02-22 22:11:13 UTC (rev 9496)
@@ -764,6 +764,7 @@
 <!ENTITY gnome-applets-version        "3.2.1">
 <!ENTITY gtkhtml-version              "3.30.2">
 <!ENTITY gtksourceview-version        "3.2.3">
+<!ENTITY libgda-version               "4.2.4">
 <!ENTITY mobile-broadband-provider-info-version "20110511">
 
 <!-- Additional Utilities -->

Modified: trunk/BOOK/gnome/add/add.xml
===================================================================
--- trunk/BOOK/gnome/add/add.xml	2012-02-22 19:20:15 UTC (rev 9495)
+++ trunk/BOOK/gnome/add/add.xml	2012-02-22 22:11:13 UTC (rev 9496)
@@ -28,6 +28,7 @@
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="gnome-applets.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="gtkhtml.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="gtksourceview.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="libgda.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="mobile-broadband-provider-info.xml"/>
 
   <!-- This is used as a TOC separator -->

Modified: trunk/BOOK/gnome/add/anjuta.xml
===================================================================
--- trunk/BOOK/gnome/add/anjuta.xml	2012-02-22 19:20:15 UTC (rev 9495)
+++ trunk/BOOK/gnome/add/anjuta.xml	2012-02-22 22:11:13 UTC (rev 9496)
@@ -65,9 +65,7 @@
     <para role="required"><xref linkend="gdl"/>,
     <xref linkend="gtk3"/>,
     <xref linkend="vte"/>,
-    <!-- FIXME:ken
-    <xref linkend="libgda"/>, and-->
-    libgda-4.2.4, and
+    <xref linkend="libgda"/>, and
     <xref linkend="gtksourceview"/></para>
 
     <bridgehead renderas="sect4">Recommended</bridgehead>

Added: trunk/BOOK/gnome/add/libgda.xml
===================================================================
--- trunk/BOOK/gnome/add/libgda.xml	                        (rev 0)
+++ trunk/BOOK/gnome/add/libgda.xml	2012-02-22 22:11:13 UTC (rev 9496)
@@ -0,0 +1,338 @@
+<?xml version="1.0" encoding="ISO-8859-1"?>
+<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
+   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
+  <!ENTITY % general-entities SYSTEM "../../general.ent">
+  %general-entities;
+
+  <!ENTITY libgda-download-http "&gnome-download-http;/libgda/4.2/libgda-&libgda-version;.tar.bz2">
+  <!ENTITY libgda-download-ftp  "&gnome-download-ftp;/libgda/4.2/libgda-&libgda-version;.tar.bz2">
+  <!ENTITY libgda-md5sum        "dbff943b8c7c14fc22e0cb85cc8216e6">
+  <!ENTITY libgda-size          "15 MB">
+  <!ENTITY libgda-buildsize     "296 MB">
+  <!ENTITY libgda-time          "4.3 SBU">
+]>
+
+<sect1 id="libgda" xreflabel="libgda-&libgda-version;">
+  <?dbhtml filename="libgda.html"?>
+
+  <sect1info>
+    <othername>$LastChangedBy$</othername>
+    <date>$Date$</date>
+  </sect1info>
+
+  <title>libgda-&libgda-version;</title>
+
+  <indexterm zone="libgda">
+    <primary sortas="a-libgda">libgda</primary>
+  </indexterm>
+
+  <sect2 role="package">
+    <title>Introduction to libgda</title>
+
+    <para>The <application>libgda</application> package provides a database access
+    library for the <application>GNOME</application> project.</para>
+
+    &lfs70_built;
+
+    <bridgehead renderas="sect3">Package Information</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>Download (HTTP): <ulink url="&libgda-download-http;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download (FTP): <ulink url="&libgda-download-ftp;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download MD5 sum: &libgda-md5sum;</para>
+      </listitem>
+      <listitem>
+        <para>Download size: &libgda-size;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated disk space required: &libgda-buildsize;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated build time: &libgda-time;</para>
+      </listitem>
+    </itemizedlist>
+
+    <bridgehead renderas="sect3">libgda Dependencies</bridgehead>
+
+    <bridgehead renderas="sect4">Required</bridgehead>
+    <para role="required"><xref linkend="glib2"/> and
+    <xref linkend="libxml2"/></para>
+
+    <bridgehead renderas="sect4">Optional</bridgehead>
+    <para role="optional"><xref linkend="db"/>,
+    <ulink url="http://www.firebirdsql.org/">firebird</ulink>,
+    <xref linkend="gtksourceview"/>,
+    <xref linkend="icedtea6"/> or <xref linkend="jdk"/>,
+    <xref linkend="libgnome-keyring"/>,
+    <xref linkend="libsoup"/>,
+    <xref linkend="libunique"/>,
+    <xref linkend="mysql"/>,
+    <xref linkend="postgresql"/>, and
+    <xref linkend="sqlite"/></para>
+
+    <para condition="html" role="usernotes">User Notes:
+    <ulink url="&blfs-wiki;/libgda"/></para>
+
+  </sect2>
+
+  <sect2 role="installation">
+    <title>Installation of libgda</title>
+
+    <para>Install <application>libgda</application> by running the following
+    commands:</para>
+
+<screen><userinput>./configure --prefix=$GNOME_PREFIX \
+            --sysconfdir=$GNOME_SYSCONFDIR && \
+            --enable-system-sqlite &&
+make</userinput></screen>
+
+    <para>To test the results, issue: <command>make check</command>. Note that
+    the output is voluminous, and some tests appear to need the package to have been
+    installed.</para>
+
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role="root"><userinput>make install</userinput></screen>
+
+  </sect2>
+
+  <sect2 role="commands">
+    <title>Command Explanations</title>
+
+    <para><parameter>--sysconfdir=$GNOME_SYSCONFDIR</parameter>: This parameter
+    ensures that the config file and test database are located consistently with
+    the rest of a <application>GNOME</application> desktop, particularly where
+    GNOME_PREFIX is <filename class="directory">/usr</filename>.</para>
+
+    <para><option>--enable-static=no</option>: This switch prevents the static
+    libraries being installed.</para>
+
+    <para><option>--enable-system-sqlite</option> : use the system version of
+    <application>sqlite3</application>.  Note that you must have compiled
+    <application>sqlite</application> with -DSQLITE_ENABLE_COLUMN_METADATA
+    otherwise the internal version will be used.</para>
+
+  </sect2>
+
+  <sect2 role="content">
+    <title>Contents</title>
+
+    <segmentedlist>
+      <segtitle>Installed Programs</segtitle>
+      <segtitle>Installed Libraries</segtitle>
+      <segtitle>Installed Directories</segtitle>
+
+      <seglistitem>
+        <seg>color.py, gda-browser-4.0, gda-control-center-4.0, gda-list-config (symlink to) gda-list-config-4.0, gda-list-server-op (symlink to) gda-list-server-op-4.0, gda-sql (symlink to) gda-sql-4.0, gda-test-connection-4.0, gdaui-demo-4.0, trml2html.py, and trml2pdf.py</seg>
+        <seg>libgda-4.0.{so,a}, libgda-bdb.{so,a}, libgda-report-4.0.{so,a}, libgda-sqlcipher.{so,a}, libgda-sqlite.{so,a}, libgda-ui-4.0.{so,a}, libgda-ui-plugins.{so,a}, libgda-web.{so,a}, and libgda-xslt-4.0.{so,a}</seg>
+        <seg><envar>$GNOME_SYSCONFDIR</envar>/libgda-4.0, <envar>$GNOME_SYSCONFDIR</envar>/{bin/{gda_trml2html,gda_trml2pdf},include/libgda-4.0/{libgda-report,libgda-ui,libgda-xslt,libgda/{handlers,providers-support,sql-parser,sqlite,thread-wrapper,virtual}},lib/libgda-4.0/{plugins,providers},share/{gnome/help/gda-browser/{C/figures,de/figures,es/figures,sl/figures},gtk-doc/html/{gda-browser,libgda-4.0},libgda-4.0/{demo,dtd,icons/hicolor/{16x16/actions,22x22/actions,24x24/actions,32x32/actions,scalable/actions},language-specs,php,pixmaps,ui,web},locale/sr at Latn/LC_MESSAGES}}</seg>
+      </seglistitem>
+    </segmentedlist>
+
+    <variablelist>
+      <bridgehead renderas="sect3">Short Descriptions</bridgehead>
+      <?dbfo list-presentation="list"?>
+      <?dbhtml list-presentation="table"?>
+
+      <!--<varlistentry id="color.py">
+        <term><command>color.py</command></term>
+        <listitem>
+          <para>does this .....</para>
+          <indexterm zone="libgda color.py">
+            <primary sortas="b-color.py">color.py</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>-->
+
+      <varlistentry id="gda-browser-4.0">
+        <term><command>gda-browser-4.0</command></term>
+        <listitem>
+          <para>is a graphical tool to provide a quick access to a database's
+          structure and contents.</para>
+          <indexterm zone="libgda gda-browser-4.0">
+            <primary sortas="b-gda-browser-4.0">gda-browser-4.0</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="gda-control-center-4.0">
+        <term><command>gda-control-center-4.0</command></term>
+        <listitem>
+          <para>is a configuration tool for libgda.</para>
+          <indexterm zone="libgda gda-control-center-4.0">
+            <primary sortas="b-gda-control-center-4.0">gda-control-center-4.0</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="gda-list-config-4.0">
+        <term><command>gda-list-config-4.0</command></term>
+        <listitem>
+          <para>lists all the declared data sources and all the installed
+          providers.</para>
+          <indexterm zone="libgda gda-list-config-4.0">
+            <primary sortas="b-gda-list-config-4.0">gda-list-config-4.0</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="gda-list-server-op-4.0">
+        <term><command>gda-list-server-op-4.0</command></term>
+        <listitem>
+          <para>lists available DDL operations for one or all of the installed
+          providers.</para>
+          <indexterm zone="libgda gda-list-server-op-4.0">
+            <primary sortas="b-gda-list-server-op-4.0">gda-list-server-op-4.0</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="gda-sql-4.0">
+        <term><command>gda-sql-4.0</command></term>
+        <listitem>
+          <para>is an interactive commandline tool to run SQL commands.</para>
+          <indexterm zone="libgda gda-sql-4.0">
+            <primary sortas="b-gda-sql-4.0">gda-sql-4.0</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="gda-test-connection-4.0">
+        <term><command>gda-test-connection-4.0</command></term>
+        <listitem>
+          <para>is a 'ping' like tool to test connectivity to databases.</para>
+          <indexterm zone="libgda gda-test-connection-4.0">
+            <primary sortas="b-gda-test-connection-4.0">gda-test-connection-4.0</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <!--<varlistentry id="gdaui-demo-4.0">
+        <term><command>gdaui-demo-4.0</command></term>
+        <listitem>
+          <para>does this .....</para>
+          <indexterm zone="libgda gdaui-demo-4.0">
+            <primary sortas="b-gdaui-demo-4.0">gdaui-demo-4.0</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>-->
+
+      <!--<varlistentry id="trml2html.py">
+        <term><command>trml2html.py</command></term>
+        <listitem>
+          <para>does this .....</para>
+          <indexterm zone="libgda trml2html.py">
+            <primary sortas="b-trml2html.py">trml2html.py</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="trml2pdf.py">
+        <term><command>trml2pdf.py</command></term>
+        <listitem>
+          <para>does this .....</para>
+          <indexterm zone="libgda trml2pdf.py">
+            <primary sortas="b-trml2pdf.py">trml2pdf.py</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>-->
+
+      <!--<varlistentry id="libgda-4">
+        <term><filename class='libraryfile'>libgda-4.0.{so,a}</filename></term>
+        <listitem>
+          <para>contains functions that .....</para>
+          <indexterm zone="libgda libgda-4">
+            <primary sortas="c-libgda-4">libgda-4.0.{so,a}</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="libgda-bdb">
+        <term><filename class='libraryfile'>libgda-bdb.{so,a}</filename></term>
+        <listitem>
+          <para>contains functions that .....</para>
+          <indexterm zone="libgda libgda-bdb">
+            <primary sortas="c-libgda-bdb">libgda-bdb.{so,a}</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="libgda-report-4">
+        <term><filename class='libraryfile'>libgda-report-4.0.{so,a}</filename></term>
+        <listitem>
+          <para>contains functions that .....</para>
+          <indexterm zone="libgda libgda-report-4">
+            <primary sortas="c-libgda-report-4">libgda-report-4.0.{so,a}</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="libgda-sqlcipher">
+        <term><filename class='libraryfile'>libgda-sqlcipher.{so,a}</filename></term>
+        <listitem>
+          <para>contains functions that .....</para>
+          <indexterm zone="libgda libgda-sqlcipher">
+            <primary sortas="c-libgda-sqlcipher">libgda-sqlcipher.{so,a}</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="libgda-sqlite">
+        <term><filename class='libraryfile'>libgda-sqlite.{so,a}</filename></term>
+        <listitem>
+          <para>contains functions that .....</para>
+          <indexterm zone="libgda libgda-sqlite">
+            <primary sortas="c-libgda-sqlite">libgda-sqlite.{so,a}</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="libgda-ui-4">
+        <term><filename class='libraryfile'>libgda-ui-4.0.{so,a}</filename></term>
+        <listitem>
+          <para>contains functions that .....</para>
+          <indexterm zone="libgda libgda-ui-4">
+            <primary sortas="c-libgda-ui-4">libgda-ui-4.0.{so,a}</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="libgda-ui-plugins">
+        <term><filename class='libraryfile'>libgda-ui-plugins.{so,a}</filename></term>
+        <listitem>
+          <para>contains functions that .....</para>
+          <indexterm zone="libgda libgda-ui-plugins">
+            <primary sortas="c-libgda-ui-plugins">libgda-ui-plugins.{so,a}</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="libgda-web">
+        <term><filename class='libraryfile'>libgda-web.{so,a}</filename></term>
+        <listitem>
+          <para>contains functions that .....</para>
+          <indexterm zone="libgda libgda-web">
+            <primary sortas="c-libgda-web">libgda-web.{so,a}</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="libgda-xslt-4">
+        <term><filename class='libraryfile'>libgda-xslt-4.0.{so,a}</filename></term>
+        <listitem>
+          <para>contains functions that .....</para>
+          <indexterm zone="libgda libgda-xslt-4">
+            <primary sortas="c-libgda-xslt-4">libgda-xslt-4.0.{so,a}</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>-->
+
+    </variablelist>
+
+  </sect2>
+
+</sect1>


Property changes on: trunk/BOOK/gnome/add/libgda.xml
___________________________________________________________________
Added: svn:keywords
   + Date LastChangedBy

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2012-02-22 19:20:15 UTC (rev 9495)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2012-02-22 22:11:13 UTC (rev 9496)
@@ -56,6 +56,9 @@
         <listitem>
           <para>[ken] - add glade-3.10.2 from Wayne.</para>
         </listitem>
+        <listitem>
+          <para>[ken] - add libgda-4.2.4 from Wayne.</para>
+        </listitem>
       </itemizedlist>
     </listitem>
 

Modified: trunk/BOOK/server/databases/sqlite.xml
===================================================================
--- trunk/BOOK/server/databases/sqlite.xml	2012-02-22 19:20:15 UTC (rev 9495)
+++ trunk/BOOK/server/databases/sqlite.xml	2012-02-22 22:11:13 UTC (rev 9496)
@@ -131,6 +131,11 @@
 
     <para><parameter>--disable-static</parameter>: This parameter stops it
     installing a static version of libsqlite3.</para>
+
+    <para><option>-DSQLITE_ENABLE_COLUMN_METADATA</option> : include this in
+    the CFLAGS if you want to use this as a system version for
+    <xref linkend="libgda"/>.</para>
+
   </sect2>
 
   <sect2 role="content">

Modified: trunk/BOOK/xsoft/office/gnumeric.xml
===================================================================
--- trunk/BOOK/xsoft/office/gnumeric.xml	2012-02-22 19:20:15 UTC (rev 9495)
+++ trunk/BOOK/xsoft/office/gnumeric.xml	2012-02-22 22:11:13 UTC (rev 9496)
@@ -70,15 +70,14 @@
     <filename class='libraryfile'>libgsf-gnome-1</filename> library from the
     <xref linkend="libgsf"/> package, for a GNOME-2 desktop),
     <ulink url="http://dblatex.sourceforge.net/">dblatex (for PDF docs)</ulink>,
-    <ulink url="http://packages.ubuntu.com/warty/libdevel/libgb-dev">Gnome
-    Basic</ulink> (this package is no longer under active development),
-    <ulink url="http://www.gnome-db.org/">libgnomedb</ulink>*
-    (requires <ulink url="http://www.gnome-db.org/">libgda</ulink>),
+    <xref linkend="libgda"/>,
     <ulink url="http://pxlib.sourceforge.net/">pxlib</ulink>,
     <ulink url="http://www.frodol.dds.nl/psiconv/index.html">Psiconv</ulink> and
     <xref linkend="pygtk"/>
     </para>
 
+    <!-- gnumeric now uses current libgda, abiword would use ancient libgnomedb
+    and ancient libgda, so hopefully no conflict.
     <para>* The
     <application>libgda</application>/<application>libgnomedb</application>
     stack required for <application>Gnumeric</application> database
@@ -86,7 +85,7 @@
     <xref linkend="abiword"/> database plugin. Though the libraries
     themselves pose no conflict, the executables and support files may
     overwrite one another. Note that the current (version 4.1.x) stack does not
-    support <application>AbiWord</application> database access.</para>
+    support <application>AbiWord</application> database access.</para>-->
 
     <note>
       <para>Though only a run-time dependency, if you don't install the




More information about the blfs-book mailing list