[blfs-book] r9388 - in trunk/BOOK: . xsoft/graphweb

andy at linuxfromscratch.org andy at linuxfromscratch.org
Sun Feb 12 13:14:41 PST 2012


Author: andy
Date: 2012-02-12 14:14:37 -0700 (Sun, 12 Feb 2012)
New Revision: 9388

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/xsoft/graphweb/firefox.xml
   trunk/BOOK/xsoft/graphweb/seamonkey.xml
Log:
seamonkey-2.7.1

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2012-02-12 21:10:29 UTC (rev 9387)
+++ trunk/BOOK/general.ent	2012-02-12 21:14:37 UTC (rev 9388)
@@ -845,7 +845,7 @@
 <!ENTITY openoffice-version           "3.2.1">
 
 <!-- Chapter 37 -->
-<!ENTITY seamonkey-version            "2.7">
+<!ENTITY seamonkey-version            "2.7.1">
 <!ENTITY firefox-version              "10.0.1">
 
 <!-- Obsolete

Modified: trunk/BOOK/xsoft/graphweb/firefox.xml
===================================================================
--- trunk/BOOK/xsoft/graphweb/firefox.xml	2012-02-12 21:10:29 UTC (rev 9387)
+++ trunk/BOOK/xsoft/graphweb/firefox.xml	2012-02-12 21:14:37 UTC (rev 9388)
@@ -11,7 +11,7 @@
   <!ENTITY firefox-md5sum        "265c53120fd923c742164b0002ebbf6c">
   <!ENTITY firefox-size          "72 MB">
   <!ENTITY firefox-buildsize     "3 GB (33 MB installed)">
-  <!ENTITY firefox-time          "24 SBU (or 0.3 SBU if you're building against
+  <!ENTITY firefox-time          "24 SBU (or 0.3 SBU if you're building against
     an installed Xulrunner)">
 ]>
 
@@ -68,7 +68,7 @@
     <para>Note: <application>libjpeg</application> and
     <application>libpng</application> (patched for apng support) should have
     been installed before <application>gdk-pixbuf</application> and should
-    exist on your system. If for some strange reason you haven't installed
+    exist on your system. If for some strange reason you haven't installed
     them, you should remove the <option>--with-system-jpeg</option> and
     <option>--with-system-png</option> options from the
     <filename>mozconfig</filename> file created below.</para>
@@ -142,7 +142,7 @@
 ac_add_options --enable-official-branding
 ac_add_options --prefix=/usr
 
-# The rest of these options have no effect if you're
+# The rest of these options have no effect if you're
 # building against an already installed xulrunner:
 ac_add_options --with-pthreads
 ac_add_options --enable-system-ffi
@@ -207,9 +207,9 @@
     <title>Command Explanations</title>
 
     <para><command>sed -i 's#VPX_CODEC_USE ...</command>: This fixes
-    <application>Firefox's</application> <command>configure</command>
+    <application>Firefox's</application> <command>configure</command>
     script to properly detect libvpx-v1.0.0. It is not needed if you have
-    libvpx-v0.9.7 or earlier installed or if you've not installed
+    libvpx-v0.9.7 or earlier installed or if you've not installed
     <xref linkend="libvpx"/>.</para>
 
     <para><command>sed -i 's# ""##' browser/base/Makefile.in</command>: This
@@ -227,11 +227,11 @@
     <para><command>tar -xfv firefox-build-dir/dist ...</command>: This untars
     <application>Firefox</application> in /usr/lib. The
     <option>--strip-components=1</option> option removes the leading
-    'firefox' directory from the filenames, allowing us to untar it
+    'firefox' directory from the filenames, allowing us to untar it
     into a versioned directory. Untaring it (instead of running make install)
     prevents it installing /usr/lib/firefox-devel-&firefox-version; which
     contains about 430 MB of files. If you need any of those files,
-    they're in <xref linkend="xulrunner"/></para>
+    they're in <xref linkend="xulrunner"/></para>
 
     <para><command>make -C firefox-build-dir install</command>: This runs
     <command>make install</command> in firefox-build-dir.</para>
@@ -256,13 +256,12 @@
     can play most YouTube videos without the need for the flash plugin. To
     enable this, go to <ulink
     url="http://www.youtube.com/html5">http://www.youtube.com/html5</ulink>
-    and click on 'Join the HTML5 Trial' (needs cookies
-    enabled).</para>
+    and click on 'Join the HTML5 Trial' (needs cookies enabled).</para>
 
     <para>If you use a desktop environment like <application>Gnome</application>
     or <application>KDE</application> you may like to create a firefox.desktop
-    file so that <application>Firefox</application> appears in the panel's
-    menus. If you didn't enable startup-notification in your mozconfig
+    file so that <application>Firefox</application> appears in the panel's
+    menus. If you didn't enable startup-notification in your mozconfig
     change the StartupNotify line to false. As the
     <systemitem class="username">root</systemitem> user:</para>
 

Modified: trunk/BOOK/xsoft/graphweb/seamonkey.xml
===================================================================
--- trunk/BOOK/xsoft/graphweb/seamonkey.xml	2012-02-12 21:10:29 UTC (rev 9387)
+++ trunk/BOOK/xsoft/graphweb/seamonkey.xml	2012-02-12 21:14:37 UTC (rev 9388)
@@ -4,9 +4,11 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY seamonkey-download-http "http://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/&seamonkey-version;/source/seamonkey-&seamonkey-version;.source.tar.bz2">
-  <!ENTITY seamonkey-download-ftp  "ftp://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/&seamonkey-version;/source//seamonkey-&seamonkey-version;.source.tar.bz2">
-  <!ENTITY seamonkey-md5sum        "a566e49ab96ba93ceea1a3c636757435">
+  <!ENTITY seamonkey-download-http
+  "http://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/&seamonkey-version;/source/seamonkey-&seamonkey-version;.source.tar.bz2">
+  <!ENTITY seamonkey-download-ftp
+  "ftp://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/&seamonkey-version;/source//seamonkey-&seamonkey-version;.source.tar.bz2">
+  <!ENTITY seamonkey-md5sum        "a16764e55ef8e59c469dc44b63459ad6">
   <!ENTITY seamonkey-size          "93.5 MB">
   <!ENTITY seamonkey-buildsize     "3 GB (46 MB installed)">
   <!ENTITY seamonkey-time          "26.6 SBU">
@@ -35,7 +37,7 @@
     follow-on to the Mozilla browser suite.</para>
 
     <para>The Mozilla project also hosts two subprojects that aim to satisfy
-    the needs of users who don't need the complete browser suite or prefer
+    the needs of users who don't need the complete browser suite or prefer
     to have separate applications for browsing and e-mail. These subprojects
     are <xref linkend="firefox"/> and <xref linkend="thunderbird"/>. Both are
     based on the <application>Mozilla</application> source code.
@@ -47,9 +49,9 @@
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
-      <!-- http link isn't working today 2nd of feb <listitem>
+      <listitem>
         <para>Download (HTTP): <ulink url="&seamonkey-download-http;"/></para>
-      </listitem> -->
+      </listitem>
       <listitem>
         <para>Download (FTP): <ulink url="&seamonkey-download-ftp;"/></para>
       </listitem>
@@ -77,7 +79,7 @@
       <para><application>libjpeg</application> and
       <application>libpng</application> (patched for apng support) should have
       been installed before <application>gdk-pixbuf</application> and should
-      exist on your system. If for some strange reason you haven't
+      exist on your system. If for some strange reason you haven't
       installed them, you should remove the <option>--with-system-jpeg</option>
       and <option>--with-system-png</option> options from the
       <filename>mozconfig</filename> file created below.</para>
@@ -185,9 +187,9 @@
     <title>Command Explanations</title>
 
     <para><command>sed -i 's#VPX_CODEC_USE ...</command>: This fixes
-    mozilla's <command>configure</command> script to properly detect
+    mozilla's <command>configure</command> script to properly detect
     libvpx-v1.0.0. This sed is not needed if you have libvpx-v0.9.7 or earlier
-    installed or if you've not installed <xref linkend="libvpx"/>.</para>
+    installed or if you've not installed <xref linkend="libvpx"/>.</para>
 
     <para><command>make -f client.mk</command>: Mozilla products are
     packaged to allow the use of a configuration file which can be used to
@@ -214,18 +216,17 @@
     can play most youtube videos without the need for the flash plugin. To
     enable this, go to <ulink
     url="http://www.youtube.com/html5">http://www.youtube.com/html5</ulink>
-    and click on 'Join the HTML5 Trial' (needs cookies
-    enabled).</para>
+    and click on 'Join the HTML5 Trial' (needs cookies enabled).</para>
 
     <para>For installing various <application>SeaMonkey</application> plugins,
-    refer to <ulink url="http://plugindoc.mozdev.org/linux.html">Mozdev's
+    refer to <ulink url="http://plugindoc.mozdev.org/linux.html">Mozdev's
     PluginDoc Project</ulink>.</para>
 
     <para>Along with using the <quote>Preferences</quote> menu to configure
-    <application>SeaMonkey</application>'s options and preferences to suit
+    <application>SeaMonkey</application>'s options and preferences to suit
     individual tastes, finer grain control of many options is only available
     using a tool not available from the general menu system. To access this
-    tool, you'll need to open a browser window and enter
+    tool, you'll need to open a browser window and enter
     <systemitem role="url">about:config</systemitem> in the
     address bar. This will display a list of the configuration preferences and
     information related to each one. You can use the <quote>Filter:</quote> bar
@@ -248,7 +249,7 @@
     <para>If you use a desktop environment like <application>Gnome</application>
     or <application>KDE</application> you may wish to create a
     seamonkey.desktop file so that <application>Seamonkey</application>
-    appears in the panel's menus. If you didn't enable
+    appears in the panel's menus. If you didn't enable
     startup-notification in your mozconfig change the StartupNotify line to
     false. As the <systemitem class="username">root</systemitem> user:</para>
 




More information about the blfs-book mailing list