[blfs-book] r9326 - in trunk/BOOK: . introduction/welcome x/lib

ken at linuxfromscratch.org ken at linuxfromscratch.org
Wed Feb 8 17:29:43 PST 2012


Author: ken
Date: 2012-02-08 18:29:39 -0700 (Wed, 08 Feb 2012)
New Revision: 9326

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/x/lib/gtk-vnc.xml
Log:
Update to gtk-vnc-0.4.3.

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2012-02-09 01:04:55 UTC (rev 9325)
+++ trunk/BOOK/general.ent	2012-02-09 01:29:39 UTC (rev 9326)
@@ -613,7 +613,7 @@
 <!ENTITY libsexy-version              "0.1.11">
 <!ENTITY libnotify-version            "0.4.5">
 <!ENTITY notification-daemon-version  "0.4.0">
-<!ENTITY gtk-vnc-version              "0.3.10">
+<!ENTITY gtk-vnc-version              "0.4.3">
 <!ENTITY cogl-version                 "1.8.2">
 
 <!-- Chapter 25 -->

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2012-02-09 01:04:55 UTC (rev 9325)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2012-02-09 01:29:39 UTC (rev 9326)
@@ -53,6 +53,9 @@
         <listitem>
           <para>[ken] - merge gtkmm-3.2.0 from Wayne.</para>
         </listitem>
+        <listitem>
+          <para>[ken] - merge gtk-vnc-0.4.3 from Wayne.</para>
+        </listitem>
       </itemizedlist>
     </listitem>
 

Modified: trunk/BOOK/x/lib/gtk-vnc.xml
===================================================================
--- trunk/BOOK/x/lib/gtk-vnc.xml	2012-02-09 01:04:55 UTC (rev 9325)
+++ trunk/BOOK/x/lib/gtk-vnc.xml	2012-02-09 01:29:39 UTC (rev 9326)
@@ -4,12 +4,12 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gtk-vnc-download-http "&gnome-download-http;/gtk-vnc/0.3/gtk-vnc-&gtk-vnc-version;.tar.bz2">
-  <!ENTITY gtk-vnc-download-ftp  "&gnome-download-ftp;/gtk-vnc/0.3/gtk-vnc-&gtk-vnc-version;.tar.bz2">
-  <!ENTITY gtk-vnc-md5sum        "9aa9d830b219255c8d6753ef55802932">
-  <!ENTITY gtk-vnc-size          "484 KB">
-  <!ENTITY gtk-vnc-buildsize     "8 MB">
-  <!ENTITY gtk-vnc-time          "0.6 SBU">
+  <!ENTITY gtk-vnc-download-http "&gnome-download-http;/gtk-vnc/0.4/gtk-vnc-&gtk-vnc-version;.tar.bz2">
+  <!ENTITY gtk-vnc-download-ftp  "&gnome-download-ftp;/gtk-vnc/0.4/gtk-vnc-&gtk-vnc-version;.tar.bz2">
+  <!ENTITY gtk-vnc-md5sum        "38d3fbacb5d00e630f939e88858206f1">
+  <!ENTITY gtk-vnc-size          "437 KB">
+  <!ENTITY gtk-vnc-buildsize     "7.6 MB">
+  <!ENTITY gtk-vnc-time          "0.2 SBU">
 ]>
 
 <sect1 id="gtk-vnc" xreflabel="gtk-vnc-&gtk-vnc-version;">
@@ -35,7 +35,7 @@
     core C library, and bindings for <application>Python</application>
     (<application>PyGTK</application>)</para>
 
-    &lfs65_built;
+    &lfs70_built;
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
@@ -62,14 +62,15 @@
     <bridgehead renderas="sect3">gtk-vnc Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="gtk2"/>,
+    <para role="required"><xref linkend="gtk3"/>,
     <xref linkend="gnutls"/>, and
     <xref linkend="intltool"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="cyrus-sasl"/>,
-    <xref linkend="nspr"/>,
-    <xref linkend="pygtk"/>, and
+    <xref linkend="nspr"/>, and
+    <!-- pygtk is not used with gtk+-3
+    <xref linkend="pygtk"/>, and -->
     <xref linkend="xulrunner"/></para>
 
     <para condition="html" role="usernotes">User Notes:
@@ -84,11 +85,12 @@
     commands:</para>
 
 <screen><userinput>./configure --prefix=/usr \
-            --with-python=no \
+            --with-gtk=3.0 \
             --with-sasl=no &&
 make</userinput></screen>
 
-    <para>To test the results, issue: <command>make check</command>.</para>
+    <para>This package's testsuite is only intended to be used by the
+    maintainer to check the i18n files.</para>
 
     <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
 
@@ -99,8 +101,15 @@
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><parameter>--with-python=no</parameter>: This parameter disables the <application>Python</application> bindings from being built. Remove it if you have <application>PyGTK</application> installed and wish to enable them.</para>
+    <para><parameter>--with-gtk=3.0</parameter>: This parameter enables
+    <application>GTK+3</application> instead of <application>GTK+2</application>.</para>
 
+    <!-- python is not used with gtk+-3
+    <para><parameter>\-\-with-python=no</parameter>: This parameter disables the
+    <application>Python</application> bindings from being built. Remove it if you have
+    <application>PyGTK</application> installed and wish to enable them.</para>
+    -->
+
     <para><parameter>--with-sasl=no</parameter>: This parameter disables the use of <application>cyrus SASL</application> for authentication. Remove it if you have <application>Cyrus SASL</application> installed and wish to enable it for authentication.</para>
 
     <para><option>--enable-plugin</option>: This option enables the browser plugin.</para>
@@ -117,7 +126,7 @@
 
       <seglistitem>
         <seg>None</seg>
-        <seg>libgtk-vnc-1.0.{so,a} and gtkvnc.{so,a}</seg>
+        <seg>libgtk-vnc-1.0.{so,a}</seg>
         <seg>/usr/include/gtk-vnc-1.0</seg>
       </seglistitem>
     </segmentedlist>
@@ -138,6 +147,7 @@
         </listitem>
       </varlistentry>
 
+      <!-- not built if you use gtk+-3
       <varlistentry id="gtkvnc">
         <term><filename class='libraryfile'>gtkvnc.{so,a}</filename></term>
         <listitem>
@@ -146,7 +156,7 @@
             <primary sortas="c-gtkvnc">gtkvnc.{so,a}</primary>
           </indexterm>
         </listitem>
-      </varlistentry>
+      </varlistentry> -->
 
     </variablelist>
 




More information about the blfs-book mailing list