[blfs-book] r9290 - in trunk/BOOK: . introduction/welcome xsoft/office

andy at linuxfromscratch.org andy at linuxfromscratch.org
Mon Feb 6 14:07:03 PST 2012


Author: andy
Date: 2012-02-06 15:06:58 -0700 (Mon, 06 Feb 2012)
New Revision: 9290

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/xsoft/office/gimp.xml
Log:
gimp-2.6.12

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2012-02-06 17:45:21 UTC (rev 9289)
+++ trunk/BOOK/general.ent	2012-02-06 22:06:58 UTC (rev 9290)
@@ -811,7 +811,7 @@
 <!ENTITY AbiWord-version              "2.8.6">
 <!ENTITY gnumeric-version             "1.10.17">
 <!ENTITY gnucash-version              "2.2.4">
-<!ENTITY gimp-version                 "2.6.11">
+<!ENTITY gimp-version                 "2.6.12">
 <!ENTITY evolution-version            "2.30.2">
 <!ENTITY icedtea-web-version          "1.0.1">
 

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2012-02-06 17:45:21 UTC (rev 9289)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2012-02-06 22:06:58 UTC (rev 9290)
@@ -59,6 +59,9 @@
         <listitem>
           <para>[ken] - Add sound-theme-freedesktop-0.7 from Wayne.</para>
         </listitem>
+        <listitem>
+          <para>[abenton] - Gimp 2.6.12.</para>
+        </listitem>
       </itemizedlist>
     </listitem>
 

Modified: trunk/BOOK/xsoft/office/gimp.xml
===================================================================
--- trunk/BOOK/xsoft/office/gimp.xml	2012-02-06 17:45:21 UTC (rev 9289)
+++ trunk/BOOK/xsoft/office/gimp.xml	2012-02-06 22:06:58 UTC (rev 9290)
@@ -6,10 +6,10 @@
 
   <!ENTITY gimp-download-http "http://gd.tuwien.ac.at/graphics/gimp/gimp/v2.6/gimp-&gimp-version;.tar.bz2">
   <!ENTITY gimp-download-ftp  "ftp://ftp.gimp.org/pub/gimp/v2.6/gimp-&gimp-version;.tar.bz2">
-  <!ENTITY gimp-md5sum        "bb2939fe13e54fc7255cef5d097bb5dd">
+  <!ENTITY gimp-md5sum        "9f876ee63a0c4a4c83f50f32fb3bbe63">
   <!ENTITY gimp-size          "16 MB">
-  <!ENTITY gimp-buildsize     "349 MB to 530 MB (additional 78 MB to install help files)">
-  <!ENTITY gimp-time          "5.3 to 6.1 SBU (additional 0.8 SBU to run the test suite)">
+  <!ENTITY gimp-buildsize     "539 MB (additional 78 MB to install help files)">
+  <!ENTITY gimp-time          "5 SBU (additional 0.6 SBU to run the test suite)">
 
   <!ENTITY gimp-help-version  "2.6.0-html-en">
   <!ENTITY gimp-help-download "ftp://gimp.org/pub/gimp/help/gimp-help-&gimp-help-version;.tar.bz2">
@@ -17,7 +17,7 @@
   <!ENTITY gimp-help-size     "28 MB">
 ]>
 
-<sect1 id="gimp" xreflabel="GIMP-&gimp-version;">
+<sect1 id="gimp" xreflabel="Gimp-&gimp-version;">
   <?dbhtml filename="gimp.html" ?>
 
   <sect1info>
@@ -25,16 +25,16 @@
     <date>$Date$</date>
   </sect1info>
 
-  <title>GIMP-&gimp-version;</title>
+  <title>Gimp-&gimp-version;</title>
 
   <indexterm zone="gimp">
-    <primary sortas="a-GIMP">GIMP</primary>
+    <primary sortas="a-Gimp">Gimp</primary>
   </indexterm>
 
   <sect2 role="package">
-    <title>Introduction to GIMP</title>
+    <title>Introduction to The Gimp</title>
 
-    <para>The <application>GIMP</application> package contains
+    <para>The <application>Gimp</application> package contains
     the GNU Image Manipulation Program. This is useful for
     photo retouching, image composition and image authoring.</para>
 
@@ -63,19 +63,10 @@
     </itemizedlist>
 
     <bridgehead renderas="sect3">Additional Downloads</bridgehead>
-     <itemizedlist spacing="compact">
-      <title>Patches and Help System</title>
+    <itemizedlist spacing="compact">
       <listitem>
-         <para>Required patches: <ulink
-      url="&patch-root;/gimp-&gimp-version;-security_fix-1.patch"/>
-         and <ulink
-      url="&patch-root;/gimp-&gimp-version;-libpng_fix-1.patch"/>
-         </para>
-       </listitem>
-
-      <listitem>
-        <para>Optional help files: <ulink url="&gimp-help-download;"/> and/or
-        one or more of the other available languages - see <ulink
+        <para>Optional help files: <ulink url="&gimp-help-download;"/> or one
+        of the other available languages - see <ulink
         url="http://www.gimp.org/docs">gimp.org</ulink> for details.</para>
       </listitem>
       <listitem>
@@ -84,19 +75,21 @@
       <listitem>
         <para>Download size: &gimp-help-size;</para>
       </listitem>
-      </itemizedlist>
+    </itemizedlist>
 
-    <bridgehead renderas="sect3">GIMP Dependencies</bridgehead>
+    <bridgehead renderas="sect3">Gimp Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required"><xref linkend="fontconfig"/>,
     <xref linkend="gegl"/>,
     <xref linkend="intltool"/>,
-    <xref linkend="perl-xml-parser"/></para>
+    <xref linkend="gtk2"/></para>
 
     <bridgehead renderas="sect4">Recommended</bridgehead>
-    <para role="recommended"><xref linkend="libjpeg"/> and
-    <xref linkend="libtiff"/></para>
+    <para role="recommended"><xref linkend="libpng"/>,
+    <xref linkend="libjpeg"/>,
+    <xref linkend="libtiff"/> and
+    <xref linkend="pygtk"/> (including the gtk and pango modules).</para>
 
     <note>
       <para>If the recommended dependencies are not installed, the
@@ -115,43 +108,39 @@
     <xref linkend="lcms"/>,
     <xref linkend="libexif"/>,
     <xref linkend="librsvg"/>,
-    <xref linkend="libxml2"/>
-    <xref linkend="libxslt"/>,
     <ulink url="http://wvware.sourceforge.net/libwmf.html">libwmf</ulink>,
     <xref linkend="poppler"/>,
-    <xref linkend="pygtk"/> (including the gtk and pango modules),
     an <xref linkend="server-mail"/> (that provides a
     <command>sendmail</command> program),
-    <xref linkend="webkitgtk"/> (this must be compiled with <application>gtk+-2</application>),
-    <xref linkend="x-window-system"/>,
+    <xref linkend="webkitgtk"/> (this must be compiled with
+    <application>gtk+-2</application> backend, The
+    <application>Gimp</application> uses <application>Webkit</application> to
+    create it's help browser)
     and <xref linkend="gtk-doc"/></para>
 
     <para condition="html" role="usernotes">User Notes:
     <ulink url="&blfs-wiki;/gimp"/></para>
-
   </sect2>
 
   <sect2 role="installation">
-    <title>Installation of GIMP</title>
+    <title>Installation of The Gimp</title>
 
-    <para>Install <application>GIMP</application> by running
+    <para>Install The <application>Gimp</application> by running
     the following commands:</para>
 
-<screen><userinput>patch -Np1 -i ../gimp-&gimp-version;-security_fix-1.patch &&
-patch -Np1 -i ../gimp-&gimp-version;-libpng_fix-1.patch &&
-./configure --prefix=/usr \
-            --sysconfdir=/etc &&
+<screen><userinput>./configure --prefix=/usr --sysconfdir=/etc &&
 make</userinput></screen>
 
-    <para>To test the results, issue: <command>make -k check</command>.</para>
+    <para>To test the results, issue: <command>make check</command>.</para>
 
-    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+    <para>Now, as the <systemitem class="username">root</systemitem>
+    user:</para>
 
 <screen role="root"><userinput>make install</userinput></screen>
 
     <para>The <filename>gimp-help</filename> tarball contains preformatted HTML
     for use with external web browsers, the internal
-    <application>GIMP</application> help browser, and HTML renderers.</para>
+    <application>Gimp</application> help browser, and HTML renderers.</para>
 
     <para>If you downloaded the <filename>gimp-help</filename> tarball, unpack
     it and change into the root of the newly created source tree. Issue the
@@ -159,23 +148,18 @@
     user to install the help files:</para>
 
 <screen role="root"><userinput>make install</userinput></screen>
-
   </sect2>
 
-  <sect2 role="commands" id='gimp-cmd-explanations'>
+  <sect2 role="commands" id="gimp-cmd-explanations">
     <title>Command Explanations</title>
 
-    <!-- <para><parameter>-datadir=/usr/share</parameter>: This parameter is
-    required because there is a subtle bug in
-    <application>Autoconf-&lfs-autoconf-version;</application> which causes the
-    <command>configure</command> script to mishandle the
-    <envar>datarootdir</envar> variable. Fortunately, passing
-    <parameter>-datadir=</parameter> works around the problem.</para> -->
-
     <para><command>make -k check</command>: Although all the tests themselves
     are expected to pass, there is a bug in the i18n file validation which will
     fail with a warning message for the maintainer.</para>
 
+    <para><option>--without-libpng</option>: This option is necessary if
+    <application>libpng</application> is not installed.</para>
+
     <para><option>--without-libjpeg</option>: This option is necessary if
     <application>libjpeg</application> is not installed.</para>
 
@@ -183,16 +167,14 @@
     <application>libtiff</application> is not installed.</para>
 
     <para><option>--disable-python</option>: This option is necessary if
-    you installed <application>python</application> but have not installed
-    <application>pygtk</application>.</para>
+    you have not installed <application>pygtk</application>.</para>
 
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
     href="../../xincludes/gtk-doc-rebuild.xml"/>
-
   </sect2>
 
   <sect2 role="configuration">
-    <title>Configuring GIMP</title>
+    <title>Configuring The Gimp</title>
 
     <sect3 id="gimp-config">
       <title>Config Files</title>
@@ -207,16 +189,15 @@
       <indexterm zone="gimp gimp-config">
         <primary sortas="e-etc-gimp-2.0-star">/etc/gimp/2.0/*</primary>
       </indexterm>
-
     </sect3>
 
     <sect3>
       <title>Configuration Information</title>
 
-      <para><application>GIMP</application> executes a configuration wizard
+      <para>The <application>Gimp</application> executes a configuration wizard
       for each user upon their initial use of the program.</para>
 
-      <para><application>GIMP</application> executes the
+      <para>The <application>Gimp</application> executes the
       <command>firefox</command> web browser by default to view the help
       files.  If you do not have <application>firefox</application>, or
       prefer a different web browser, you can set a new system value in
@@ -226,9 +207,7 @@
       preferred web browser:</para>
 
 <screen role="root"><userinput>echo '(web-browser "<replaceable><browser></replaceable> %s")' >> /etc/gimp/2.0/gimprc</userinput></screen>
-
     </sect3>
-
   </sect2>
 
   <sect2 role="content">
@@ -243,9 +222,9 @@
         <seg>gimp, gimp-2.6, gimp-console, gimp-console-2.6,
         and gimptool-2.0</seg>
         <seg>libgimp-2.0.so, libgimpbase-2.0.so, libgimpcolor-2.0.so,
-        libgimpconfig-2.0.so, libgimpmath-2.0.so, libgimpmodule-2.0.so, libgimpthumb-2.0.so,
-        libgimpui-2.0.so, libgimpwidgets-2.0.so, and many other modules and
-        plugin libraries</seg>
+        libgimpconfig-2.0.so, libgimpmath-2.0.so, libgimpmodule-2.0.so,
+        libgimpthumb-2.0.so, libgimpui-2.0.so, libgimpwidgets-2.0.so, and many
+        other modules and plugin libraries</seg>
         <seg>/etc/gimp, /usr/include/gimp-2.0, /usr/lib/gimp,
         /usr/share/gimp and
         /usr/share/gtk-doc/html/libgimp{,base,color,config,math,module,thumb,widgets}</seg>
@@ -270,7 +249,7 @@
       <varlistentry id="gimp-2.6">
         <term><command>gimp-2.6</command></term>
         <listitem>
-          <para>is an image manipulation program. It works with a variety
+          <para>is the Gnu Image Manipulation Program. It works with a variety
           of image formats and provides a large selection of tools.</para>
           <indexterm zone="gimp gimp-2.6">
             <primary sortas="b-gimp-2.6">gimp-2.6</primary>
@@ -291,8 +270,8 @@
       <varlistentry id="gimp-console-2.6">
         <term><command>gimp-console-2.6</command></term>
         <listitem>
-          <para>is a console program that behaves as if
-          <application>GIMP</application> was called with the
+          <para>is a console program that behaves as if The
+          <application>Gimp</application> was called with the
           <option>--no-interface</option> command-line option.</para>
           <indexterm zone="gimp gimp-console-2.6">
             <primary sortas="b-gimp-console-2.6">gimp-console-2.6</primary>
@@ -306,8 +285,8 @@
           <para>is a tool that can build plug-ins or scripts and install them
           if they are distributed in one source file.
           <command>gimptool-2.0</command> can also be used by programs that
-          need to know what libraries and include-paths
-          <application>GIMP</application> was compiled with.</para>
+          need to know what libraries and include-paths The
+          <application>Gimp</application> was compiled with.</para>
           <indexterm zone="gimp gimptool-2.0">
             <primary sortas="b-gimptool-2.0">gimptool-2.0</primary>
           </indexterm>
@@ -315,9 +294,9 @@
       </varlistentry>
 
       <varlistentry id="libgimp-2.0">
-        <term><filename class='libraryfile'>libgimp-2.0.so</filename></term>
+        <term><filename class="libraryfile">libgimp-2.0.so</filename></term>
         <listitem>
-          <para> provides C bindings for <application>GIMP</application>'s
+          <para> provides C bindings for The <application>Gimp</application>'s
           Procedural Database (PDB) which offers an interface to core functions
           and to functionality provided by plug-ins.</para>
           <indexterm zone="gimp libgimp-2.0">
@@ -327,13 +306,13 @@
       </varlistentry>
 
       <varlistentry id="libgimpbase-2.0">
-        <term><filename class='libraryfile'>libgimpbase-2.0.so</filename></term>
+        <term><filename class="libraryfile">libgimpbase-2.0.so</filename></term>
         <listitem>
-          <para>provides the C functions for basic <application>GIMP</application>
-          functionality such as determining enumeration data types, gettext
-          translation, determining <application>GIMP</application>'s version
-          number and capabilities, handling data files and accessing the
-          environment.</para>
+          <para>provides the C functions for basic
+          <application>Gimp</application> functionality such as determining
+          enumeration data types, gettext translation, determining The
+          <application>Gimp</application>'s version number and capabilities,
+          handling data files and accessing the environment.</para>
           <indexterm zone="gimp libgimpbase-2.0">
             <primary sortas="c-libgimpbase-2.0">libgimpbase-2.0.so</primary>
           </indexterm>
@@ -341,11 +320,12 @@
       </varlistentry>
 
       <varlistentry id="libgimpcolor-2.0">
-        <term><filename class='libraryfile'>libgimpcolor-2.0.so</filename></term>
+        <term><filename
+        class="libraryfile">libgimpcolor-2.0.so</filename></term>
         <listitem>
           <para>provides the C functions relating to RGB, HSV and CMYK colors as
-          well as converting colors between different color models and performing
-          adaptive supersampling on an area.</para>
+          well as converting colors between different color models and
+          performing adaptive supersampling on an area.</para>
           <indexterm zone="gimp libgimpcolor-2.0">
             <primary sortas="c-libgimpcolor-2.0">libgimpcolor-2.0.so</primary>
           </indexterm>
@@ -353,7 +333,8 @@
       </varlistentry>
 
       <varlistentry id="libgimpconfig-2.0">
-        <term><filename class='libraryfile'>libgimpconfig-2.0.so</filename></term>
+        <term><filename
+        class="libraryfile">libgimpconfig-2.0.so</filename></term>
         <listitem>
           <para>contains C functions for reading and writing config information.
           </para>
@@ -364,7 +345,7 @@
       </varlistentry>
 
       <varlistentry id="libgimpmath-2.0">
-        <term><filename class='libraryfile'>libgimpmath-2.0.so</filename></term>
+        <term><filename class="libraryfile">libgimpmath-2.0.so</filename></term>
         <listitem>
           <para>contains C functions which provide mathematical definitions and
           macros, manipulate 3x3 transformation matrices, set up and manipulate
@@ -376,7 +357,8 @@
       </varlistentry>
 
       <varlistentry id="libgimpmodule-2.0">
-        <term><filename class='libraryfile'>libgimpmodule-2.0.so</filename></term>
+        <term><filename
+        class="libraryfile">libgimpmodule-2.0.so</filename></term>
         <listitem>
           <para>provides the C functions which implements module loading using
           GModule and keeps a list of GimpModule's found in a given
@@ -388,10 +370,11 @@
       </varlistentry>
 
       <varlistentry id="libgimpthumb-2.0">
-        <term><filename class='libraryfile'>libgimpthumb-2.0.so</filename></term>
+        <term><filename
+        class="libraryfile">libgimpthumb-2.0.so</filename></term>
         <listitem>
-          <para>provides the C functions for handling
-          <application>GIMP</application>'s thumbnail objects.</para>
+          <para>provides the C functions for handling The
+          <application>Gimp</application>'s thumbnail objects.</para>
           <indexterm zone="gimp libgimpthumb-2.0">
             <primary sortas="c-libgimpthumb-2.0">libgimpthumb-2.0.so</primary>
           </indexterm>
@@ -399,9 +382,9 @@
       </varlistentry>
 
       <varlistentry id="libgimpui-2.0">
-        <term><filename class='libraryfile'>libgimpui-2.0.so</filename></term>
+        <term><filename class="libraryfile">libgimpui-2.0.so</filename></term>
         <listitem>
-          <para>contains the <application>GIMP</application> common user
+          <para>contains The <application>Gimp</application>'s common user
           interface functions.</para>
           <indexterm zone="gimp libgimpui-2.0">
             <primary sortas="c-libgimpui-2.0">libgimpui-2.0.so</primary>
@@ -410,19 +393,18 @@
       </varlistentry>
 
       <varlistentry id="libgimpwidgets-2.0">
-        <term><filename class='libraryfile'>libgimpwidgets-2.0.so</filename></term>
+        <term><filename
+        class="libraryfile">libgimpwidgets-2.0.so</filename></term>
         <listitem>
-          <para>contains <application>GIMP</application>
-          and <application>GTK</application> widget creation and
+          <para>contains The <application>Gimp</application>
+          and <application>GTK</application>'s widget creation and
           manipulation functions.</para>
           <indexterm zone="gimp libgimpwidgets-2.0">
-            <primary sortas="c-libgimpwidgets-2.0">libgimpwidgets-2.0.so</primary>
+            <primary
+            sortas="c-libgimpwidgets-2.0">libgimpwidgets-2.0.so</primary>
           </indexterm>
         </listitem>
       </varlistentry>
-
     </variablelist>
-
   </sect2>
-
 </sect1>




More information about the blfs-book mailing list