[blfs-book] r9282 - in trunk/BOOK: . introduction/welcome multimedia/libdriv

ken at linuxfromscratch.org ken at linuxfromscratch.org
Sun Feb 5 15:32:06 PST 2012


Author: ken
Date: 2012-02-05 16:32:02 -0700 (Sun, 05 Feb 2012)
New Revision: 9282

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/multimedia/libdriv/opal.xml
Log:
Update to opal-3.10.2.

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2012-02-05 23:12:31 UTC (rev 9281)
+++ trunk/BOOK/general.ent	2012-02-05 23:32:02 UTC (rev 9282)
@@ -883,7 +883,7 @@
 <!ENTITY libmusicbrainz3-version      "3.0.3">
 <!ENTITY libmpeg2-version             "0.5.1">
 <!ENTITY libtheora-version            "1.1.1">
-<!ENTITY opal-version                 "3.6.8">
+<!ENTITY opal-version                 "3.10.2">
 <!ENTITY libvpx-version               "1.0.0">
 <!ENTITY libsndfile-version           "1.0.23">
 <!ENTITY pulseaudio-version           "0.9.23">

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2012-02-05 23:12:31 UTC (rev 9281)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2012-02-05 23:32:02 UTC (rev 9282)
@@ -49,7 +49,7 @@
         </listitem>
         <listitem>
           <para>[ken] - Merge gst-plugins-base-0.10.35, gst-plugins-good-0.10.30,
-          gst-plugins-ugly-0.10.18, and gstreamer-0.10.35 from Wayne.</para>
+          gst-plugins-ugly-0.10.18, gstreamer-0.10.35 and opal-3.10.2 from Wayne.</para>
         </listitem>
       </itemizedlist>
     </listitem>

Modified: trunk/BOOK/multimedia/libdriv/opal.xml
===================================================================
--- trunk/BOOK/multimedia/libdriv/opal.xml	2012-02-05 23:12:31 UTC (rev 9281)
+++ trunk/BOOK/multimedia/libdriv/opal.xml	2012-02-05 23:32:02 UTC (rev 9282)
@@ -4,12 +4,12 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY opal-download-http "&gnome-download-http;/opal/3.6/opal-&opal-version;.tar.bz2">
-  <!ENTITY opal-download-ftp  "&gnome-download-ftp;/opal/3.6/opal-&opal-version;.tar.bz2">
-  <!ENTITY opal-md5sum        "a5f4ddc12c5aa34dc9407fe1daaf0f45">
-  <!ENTITY opal-size          "6.5 MB">
-  <!ENTITY opal-buildsize     "166 MB">
-  <!ENTITY opal-time          "2.8 SBU">
+  <!ENTITY opal-download-http "&gnome-download-http;/opal/3.10/opal-&opal-version;.tar.xz">
+  <!ENTITY opal-download-ftp  "&gnome-download-ftp;/opal/3.10/opal-&opal-version;.tar.xz">
+  <!ENTITY opal-md5sum        "11263275c51e3ea77de202bf5ca87e0b">
+  <!ENTITY opal-size          "6.8 MB">
+  <!ENTITY opal-buildsize     "314 MB">
+  <!ENTITY opal-time          "2.7 SBU">
 ]>
 
 <sect1 id="opal" xreflabel="opal-&opal-version;">
@@ -33,7 +33,7 @@
     normalising the numerous telephony protocols into a single integrated call
     model.</para>
 
-    &lfs65_built;
+    &lfs70_built;
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
@@ -57,6 +57,14 @@
       </listitem>
     </itemizedlist>
 
+    <bridgehead renderas="sect3">Additional Downloads</bridgehead>
+    <itemizedlist spacing='compact'>
+      <listitem>
+        <para>Required Patch: <ulink
+        url="&patch-root;/opal-&opal-version;-ffmpeg-1.patch"/></para>
+      </listitem>
+    </itemizedlist>
+
     <bridgehead renderas="sect3">opal Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
@@ -80,7 +88,8 @@
     <para>Install <application>opal</application> by running the following
     commands:</para>
 
-<screen><userinput>./configure --prefix=/usr &&
+<screen><userinput>patch -Np1 -i ../opal-&opal-version;-ffmpeg-1.patch &&
+./configure --prefix=/usr &&
 make</userinput></screen>
 
     <para>This package does not come with a test suite.</para>
@@ -91,6 +100,14 @@
 
   </sect2>
 
+  <sect2 role="commands">
+    <title>Command Explanations</title>
+
+    <para><command>patch -Np1 -i ...</command>: The patch allows opal to build
+    with recent releases of <application>ffmpeg</application>.</para>
+
+  </sect2>
+
   <sect2 role="content">
     <title>Contents</title>
 




More information about the blfs-book mailing list