[blfs-book] r9274 - in trunk/BOOK: . introduction/welcome multimedia/libdriv

ken at linuxfromscratch.org ken at linuxfromscratch.org
Sun Feb 5 11:19:21 PST 2012


Author: ken
Date: 2012-02-05 12:19:10 -0700 (Sun, 05 Feb 2012)
New Revision: 9274

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/multimedia/libdriv/gst-plugins-good.xml
Log:
Update to gst-plugins-good-0.10.30.

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2012-02-05 18:52:45 UTC (rev 9273)
+++ trunk/BOOK/general.ent	2012-02-05 19:19:10 UTC (rev 9274)
@@ -872,7 +872,7 @@
 <!ENTITY libmikmod-version            "3.1.11">
 <!ENTITY gstreamer-version            "0.10.25">
 <!ENTITY gst-plugins-base-version     "0.10.35">
-<!ENTITY gst-plugins-good-version     "0.10.17">
+<!ENTITY gst-plugins-good-version     "0.10.30">
 <!ENTITY gst-plugins-bad-version      "0.10.21">
 <!ENTITY gst-plugins-ugly-version     "0.10.10">
 <!ENTITY gst-ffmpeg-version           "0.10.13">

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2012-02-05 18:52:45 UTC (rev 9273)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2012-02-05 19:19:10 UTC (rev 9274)
@@ -48,7 +48,7 @@
           <para>[ken] - Add gst-plugins-bad based on Wayne's work and updated to 0.10.21.</para>
         </listitem>
         <listitem>
-          <para>[ken] - Merge gst-plugins-base-0.10.35 from Wayne.</para>
+          <para>[ken] - Merge gst-plugins-base-0.10.35 and gst-plugins-good-0.10.30 from Wayne.</para>
         </listitem>
       </itemizedlist>
     </listitem>

Modified: trunk/BOOK/multimedia/libdriv/gst-plugins-good.xml
===================================================================
--- trunk/BOOK/multimedia/libdriv/gst-plugins-good.xml	2012-02-05 18:52:45 UTC (rev 9273)
+++ trunk/BOOK/multimedia/libdriv/gst-plugins-good.xml	2012-02-05 19:19:10 UTC (rev 9274)
@@ -4,12 +4,12 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gst-plugins-good-download-http "&gnome-download-http;/gst-plugins-good/0.10/gst-plugins-good-&gst-plugins-good-version;.tar.bz2">
-  <!ENTITY gst-plugins-good-download-ftp "&gnome-download-ftp;/gst-plugins-good/0.10/gst-plugins-good-&gst-plugins-good-version;.tar.bz2">
-  <!ENTITY gst-plugins-good-md5sum        "833546cd2b8bbf86b8ed083b00897918">
-  <!ENTITY gst-plugins-good-size          "2.5 MB">
-  <!ENTITY gst-plugins-good-buildsize     "82 MB">
-  <!ENTITY gst-plugins-good-time          "2.2 SBU">
+  <!ENTITY gst-plugins-good-download-http "&gnome-download-http;/gst-plugins-good/0.10/gst-plugins-good-&gst-plugins-good-version;.tar.xz">
+  <!ENTITY gst-plugins-good-download-ftp "&gnome-download-ftp;/gst-plugins-good/0.10/gst-plugins-good-&gst-plugins-good-version;.tar.xz">
+  <!ENTITY gst-plugins-good-md5sum        "bb9c03d950fe2f9d9392d1b47457440c">
+  <!ENTITY gst-plugins-good-size          "2.7 MB">
+  <!ENTITY gst-plugins-good-buildsize     "114 MB">
+  <!ENTITY gst-plugins-good-time          "1.2 SBU">
 ]>
 
 <sect1 id="gst-plugins-good"
@@ -35,12 +35,12 @@
     to have good quality code, correct functionality, and the preferred license
     (LGPL for the plug-in code, LGPL or LGPL-compatible for the supporting
     library). A wide range of video and audio decoders, encoders, and filters
-    are included. Also see the <xref linkend="gst-plugins-ugly"/>, <ulink
-    url="http://gstreamer.freedesktop.org/modules/gst-plugins-bad.html">
-    GStreamer Bad Plug-ins</ulink> and <ulink
-    url="http://gstreamer.freedesktop.org/modules/gst-ffmpeg.html">GStreamer
-    FFmpeg plug-in</ulink> packages.</para>
+    are included. Also see the <xref linkend="gst-plugins-ugly"/>, <xref
+    linkend="gst-plugins-bad"/>  and <xref linkend="gst-ffmpeg"/> packages.
+    </para>
 
+    &lfs70_built;
+
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
@@ -93,7 +93,7 @@
     <ulink url="http://www.icecast.org/">libshout</ulink>,
     <ulink url="http://freshmeat.net/projects/libv4l">libv4l</ulink>,
     <ulink url="http://www.oberhumer.com/opensource/lzo/">lzo</ulink>,
-    <ulink url="http://pulseaudio.org/">PulseAudio</ulink>,
+    <xref linkend="pulseaudio"/>,
     <xref linkend="speex"/>,
     <xref linkend="udev"/> (gudev),
     <ulink url="http://www.wavpack.com/">WavPack</ulink>,
@@ -127,7 +127,7 @@
     the following commands:</para>
 
 <screen><userinput>./configure --prefix=/usr \
-            --sysconfdir=&gnome-etc-dir; &&
+            --sysconfdir=/etc --with-gtk=3.0 &&
 make</userinput></screen>
 
     <para>To run the unit regression tests, issue: <command>make check</command>.
@@ -152,11 +152,11 @@
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><parameter>--sysconfdir=&gnome-etc-dir;</parameter>: This parameter
+    <para><parameter>--sysconfdir=$GNOME_SYSCONFDIR</parameter>: This parameter
     is used so that the <application>GConf</application> configuration files
     are installed in the system-wide GNOME <application>GConf</application>
     database located in
-    <filename class="directory">&gnome-etc-dir;/gconf</filename>
+    <filename class="directory">$GNOME_SYSCONFDIR/gconf</filename>
     instead of <filename class="directory">/usr/etc</filename>. You may omit
     this parameter if you don't have <application>GConf</application>
     installed.</para>




More information about the blfs-book mailing list