[blfs-book] r9011 - in trunk/BOOK: . introduction/welcome multimedia/videoutils

andy at linuxfromscratch.org andy at linuxfromscratch.org
Thu Nov 24 17:26:51 PST 2011


Author: andy
Date: 2011-11-24 18:26:46 -0700 (Thu, 24 Nov 2011)
New Revision: 9011

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/multimedia/videoutils/ffmpeg.xml
Log:
Updated ffmpeg to 0.8.6

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2011-11-24 22:03:27 UTC (rev 9010)
+++ trunk/BOOK/general.ent	2011-11-25 01:26:46 UTC (rev 9011)
@@ -863,7 +863,7 @@
 <!ENTITY amarok-version               "1.4.8">
 
 <!-- Chapter 40 -->
-<!ENTITY ffmpeg-version               "0.6.1">
+<!ENTITY ffmpeg-version               "0.8.6">
 <!ENTITY avifile-version              "0.7.45">
 <!ENTITY mplayer-version              "1.0rc1">
 <!ENTITY xine-ui-version              "0.99.5">

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2011-11-24 22:03:27 UTC (rev 9010)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2011-11-25 01:26:46 UTC (rev 9011)
@@ -42,6 +42,15 @@
 
 -->
     <listitem>
+      <para>November 25th, 2011</para>
+      <itemizedlist>
+        <listitem>
+          <para>[abenton] - Updated ffmpeg to 0.8.6.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
+    <listitem>
       <para>November 24th, 2011</para>
       <itemizedlist>
         <listitem>

Modified: trunk/BOOK/multimedia/videoutils/ffmpeg.xml
===================================================================
--- trunk/BOOK/multimedia/videoutils/ffmpeg.xml	2011-11-24 22:03:27 UTC (rev 9010)
+++ trunk/BOOK/multimedia/videoutils/ffmpeg.xml	2011-11-25 01:26:46 UTC (rev 9011)
@@ -6,10 +6,10 @@
 
   <!ENTITY ffmpeg-download-http "http://ffmpeg.org/releases/ffmpeg-&ffmpeg-version;.tar.bz2">
   <!ENTITY ffmpeg-download-ftp  " ">
-  <!ENTITY ffmpeg-md5sum        "4f5d732d25eedfb072251b5314ba2093">
-  <!ENTITY ffmpeg-size          "3.5 MB">
-  <!ENTITY ffmpeg-buildsize     "328 MB (built with recommended dependencies)">
-  <!ENTITY ffmpeg-time          "2.1 SBU">
+  <!ENTITY ffmpeg-md5sum        "b4ef1fa6506750569fdb64a0f0a646a8">
+  <!ENTITY ffmpeg-size          "4.3 MB">
+  <!ENTITY ffmpeg-buildsize     "178 MB (built with recommended dependency)">
+  <!ENTITY ffmpeg-time          "2.5 SBU">
 ]>
 
 <sect1 id="ffmpeg" xreflabel="FFmpeg-&ffmpeg-version;">
@@ -30,20 +30,21 @@
     <title>Introduction to FFmpeg</title>
 
     <para><application>FFmpeg</application> is a solution to record, convert and
-    stream audio and video. It is a very fast video and audio converter and it can
-    also acquire from a live audio/video source. Designed to be intuitive, the
-    command-line interface (<command>ffmpeg</command>) tries to figure out all the
-    parameters, when possible. <application>FFmpeg</application> can also convert
-    from any sample rate to any other, and resize video on the fly with a high
-    quality polyphase filter. <application>FFmpeg</application> can use a
-    video4linux compatible video source and any Open Sound System audio
+    stream audio and video. It is a very fast video and audio converter and it
+    can also acquire from a live audio/video source. Designed to be intuitive,
+    the command-line interface (<command>ffmpeg</command>) tries to figure out
+    all the parameters, when possible. <application>FFmpeg</application> can
+    also convert from any sample rate to any other, and resize video on the fly
+    with a high quality polyphase filter. <application>FFmpeg</application> can
+    use a video4linux compatible video source and any Open Sound System audio
     source.</para>
+
     <para>The developers of this package do not make releases very often, so you
-    may wish to use a snapshot instead of this release.  If you do that, you must
-    expect the acceptable <command>configure</command> switches, and the
+    may wish to use a snapshot instead of this release.  If you do that, you
+    must expect the acceptable <command>configure</command> switches, and the
     dependencies, to change.</para>
 
-    &lfs67_checked;
+    &lfs70_checked;
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
@@ -67,55 +68,39 @@
       </listitem>
     </itemizedlist>
 
-    <!-- <bridgehead renderas="sect3">Additional Downloads</bridgehead>
-    <itemizedlist spacing="compact">
-      <listitem>
-        <para>Required patch: <ulink
-        url="&patch-root;/ffmpeg-&ffmpeg-version;-gcc4-1.patch"/></para>
-      </listitem>
-      <listitem>
-        <para>Required patch: <ulink
-        url="&patch-root;/ffmpeg-&ffmpeg-version;-amr_fixes-1.patch"/></para>
-      </listitem>
-    </itemizedlist> -->
-
     <bridgehead renderas="sect3">FFmpeg Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Recommended</bridgehead>
     <para role="recommended">
-    <xref linkend="faad2"/>,
-    <xref linkend="lame"/>,
-    <xref linkend="libtheora"/>,
-    <xref linkend="libvorbis"/>,
-    <xref linkend="libvpx"/>,
-    <xref linkend="x-window-system"/>,
-    <ulink url="http://www.videolan.org/developers/x264.html">x264</ulink>
-    (tested with the 20100615-2245 snapshot : x264 needs 
-    <ulink url="http://www.tortall.net/projects/yasm/">yasm</ulink> unless you
-    configure it with <literal>--disable-asm</literal>),
-    <xref linkend="xvid"/></para>
+    <ulink url="http://www.tortall.net/projects/yasm/">yasm</ulink>.
+    </para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
-    <para role="optional">
-    <ulink url="http://www.penguin.cz/~utx/amr">AMR narrowband (floating point)</ulink>,
+    <para role="optional"><xref linkend="faad2"/>, <xref linkend="lame"/>,
+    <xref linkend="libtheora"/>, <xref linkend="libvorbis"/>,
+    <xref linkend="libvpx"/>, <xref linkend="x-window-system"/>,
+    <ulink url="http://www.videolan.org/developers/x264.html">x264</ulink>
+    (x264 needs <ulink url="http://www.tortall.net/projects/yasm/">yasm</ulink>
+    unless you configure it with <literal>--disable-asm</literal>),
+    <xref linkend="xvid"/>,
+    <ulink url="http://www.penguin.cz/~utx/amr">AMR narrowband
+    (floating point)</ulink>,
     <ulink url="http://www.penguin.cz/~utx/amr">AMR wideband</ulink>,
-    <xref linkend="faac"/>,
-    <xref linkend="freetype2"/>,
-    <ulink url="http://kbs.cs.tu-berlin.de/~jutta/gsm/">GSM</ulink>,
-    <xref linkend="imlib2"/>,
+    <xref linkend="faac"/>, <xref linkend="freetype2"/>,
+    <ulink url="http://libgsm.sourcearchive.com/">GSM</ulink>,
     <xref linkend="liba52"/>,
     <ulink url="http://sourceforge.net/projects/libdc1394">libdc1394</ulink>,
-    <ulink url="http://svn.mplayerhq.hu/nut/src/trunk/">libnut</ulink> (SVN checkout),
+    <ulink url="http://svn.mplayerhq.hu/nut/src/trunk/">libnut</ulink>
+    (SVN checkout),
     <ulink url="http://sourceforge.net/projects/librtmp">librtmp</ulink>,
     <ulink url="http://diracvideo.org/">libschroedinger</ulink>,
     <ulink url="http://medialibrary.sourceforge.net/">MediaLibrary</ulink>,
-    <ulink url="http://www.openjpeg.org">OpenJPEG</ulink>,
-    <xref linkend="sdl"/>,
-    <xref linkend="speex"/>,
-    <ulink url="http://www.tortall.net/projects/yasm/">yasm</ulink>, and
-    <xref linkend="tetex"/> or
+    <ulink url="http://www.openjpeg.org">OpenJPEG</ulink>
+    (<application>ffmpeg</application> includes code for it's own jpeg2000
+    encoder and decoder which is enabled by default), <xref linkend="speex"/>,
+    <!-- <xref linkend="tetex"/>, --> <xref linkend="sdl"/> and
     <ulink url="http://www.nongnu.org/texi2html">texi2html</ulink>
-   (to build HTML documentation)</para>
+    (to build HTML documentation).</para>
 
     <para condition="html" role="usernotes">User Notes:
     <ulink url="&blfs-wiki;/ffmpeg"/></para>
@@ -128,62 +113,32 @@
     <para>Install <application>FFmpeg</application> by running the following
     commands:</para>
 
-<screen><userinput>sed -i 's/-number//' Makefile &&
-./configure --prefix=/usr --enable-shared \
-            --enable-pthreads --enable-gpl \
-            --enable-swscale --enable-postproc \
-            --enable-libfaad --enable-libmp3lame \
-            --enable-libtheora --enable-libvorbis \
-            --enable-libvpx --enable-libx264 \
-            --enable-libxvid &&
+<screen><userinput>./configure --prefix=/usr --enable-shared --disable-static --enable-gpl &&
 make</userinput></screen>
 
-    <para>If you have <application>teTeX</application> or
-    <application>texi2html</application> installed, the HTML
-    documentation was built during the <command>make</command> process. If you
-    wish to create additional formats of the documentation, you must have
-    <application>teTeX</application> or <xref linkend="texlive"/> installed,
-    and issue the following commands:</para>
-
-<screen><userinput>cd doc &&
-for DOCNAME in faq ffmpeg-doc ffplay-doc ffprobe-doc ffserver-doc general libavfilter; do
-    texi2dvi -b -p $DOCNAME.texi
-    texi2dvi -b    $DOCNAME.texi
-    dvips -o $DOCNAME.ps $DOCNAME.dvi
-    if [ $DOCNAME = ffserver-doc ] || [ $DOCNAME = ffplay-doc ] || [ $DOCNAME = ffprobe-doc ]; then \
-        continue
-    fi
-    makeinfo --plaintext --force -o $DOCNAME.txt $DOCNAME.texi
-done &&
-cd .. &&
-unset DOCNAME</userinput></screen>
-
     <para>If you have <xref linkend="doxygen"/> installed and wish to create
     the API documentation (takes about 150 MB of space), issue
     <command>doxygen</command>.</para>
 
-    <para>If you wish to run the tests, issue: <command>make check</command> -
-    that will take about 0.9 SBU and use another 365 MB of space.</para>
+    <para>This package does not come with a working test suite.</para>
 
-    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+    <!-- make check is currently b0rken -->
 
+    <para>Now, as the <systemitem class="username">root</systemitem>
+    user:</para>
+
 <screen role="root"><userinput>make install &&
-install -v -m755 -d        /usr/share/doc/ffmpeg-&ffmpeg-version; &&
-install -v -m644 doc/*.txt /usr/share/doc/ffmpeg-&ffmpeg-version; &&
-texi2html --version >/dev/null 2>&1 || make install-man</userinput></screen>
+make install-man &&
+mkdir /usr/share/doc/ffmpeg-&ffmpeg-version; &&
+cp ../doc/*.txt /usr/share/doc/ffmpeg-&ffmpeg-version; &&
+texi2html --version &> /dev/null &&
+cp doc/*.html /usr/share/doc/ffmpeg-&ffmpeg-version;</userinput></screen>
 
-    <para>If you created additional formats of the documentation,
-    install it by issuing the following commands as the
+    <para>If you used <command>doxygen</command> to create the API
+    documentation, install it by issuing the following commands as the
     <systemitem class="username">root</systemitem> user:</para>
 
-<screen role="root"><userinput>install -v -m644 doc/*.{html,dvi,pdf,ps} \
-    /usr/share/doc/ffmpeg-&ffmpeg-version;</userinput></screen>
-
-    <para>If you created the API documentation, install it by issuing the
-    following commands as the
-    <systemitem class="username">root</systemitem> user:</para>
-
-<screen role="root"><userinput>install -v -m755 -d /usr/share/doc/ffmpeg-&ffmpeg-version;/api &&
+<screen role="root"><userinput>mkdir /usr/share/doc/ffmpeg-&ffmpeg-version;/api &&
 cp -v doxy/*        /usr/share/doc/ffmpeg-&ffmpeg-version;/api</userinput></screen>
 
   </sect2>
@@ -191,47 +146,34 @@
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><parameter>sed -i 's/-number//' Makefile</parameter>: Recent versions
-    of gnu <command>texi2html</command> error out because
-    <command>-number</command> is now ambiguous (for number-footnote or
-    number-sections).  Neither choice makes any difference to what is created
-    here, and the same is true with older versions of
-    <command>texi2html</command>, e.g. from application
-    <application>teTeX</application>.</para>
-
-    <para><parameter>--enable-shared</parameter>: This switch is needed to
+    <para><option>--enable-shared</option>: This switch is needed to
     build the shared libraries, otherwise only static libraries are built
     and installed.</para>
 
-    <para><parameter>--enable-pthreads</parameter>: This switch enables the
-    build to link against the Posix threads library.</para>
-
-    <para><parameter>--enable-gpl</parameter>: This switch enables the
-    use of GPL code and permits support for postprocessing, swscale, liba54,
-    xvid, x264, libfaad2 and x11grab to be selected.</para>
-
-    <para><parameter>--enable-swscale</parameter>: This switch causes libswscale
-    to be built.</para>
-
-    <para><parameter>--enable-postprocessing</parameter>: This switch causes
-    libpostproc to be built.</para>
-
-    <para><option>--enable-<replaceable><codec></replaceable></option>: Review
-    the available options and codecs using the
-    <command>./configure --help</command> command. You must explicitly enable
-    each optional codec. If you have not installed some of the recommended
-    dependencies, do not enable those you have omitted.</para>
-
-    <para><option>--disable-ffplay</option>: Only installs the server part.
-    Use this option if <application>X</application> is not installed.</para>
-
     <para><option>--disable-static</option>: This switch prevents the static
     libraries from being built.</para>
 
-    <para><command>if [ $DOCNAME = ffserver-doc ] ...</command> These three
-    .texi files are rejected by <command>makeinfo</command> because of syntax
-    errors.</para>
+    <para><option>--enable-gpl</option>: This switch enables the
+    use of GPL code and permits support for postprocessing, swscale and many
+    other features.</para>
 
+    <para><option>--enable-<replaceable><codec></replaceable></option>:
+    <application>ffmpeg</application> comes with code to compile decoders for
+    almost every codec you could think of. The only reason to enable a specific
+    codec (and make ffmpeg link to the prerequisite shared library installed on
+    your system) is to make ffmpeg compile an <emphasis>encoder</emphasis> for
+    that codec. Encoding video is a job for a specialist. If that is what you
+    want to do, study the output of <command>configure --help</command>.
+    Remember, the dependencies all install their own encoders that are often
+    better than <application>ffmpeg</application>'s.
+    <application>Ffmpeg</application> is an excellent collection of decoders.
+    If you just want to use ffmpeg to watch video or listen to music there is
+    no benefit from linking it to another library.</para>
+
+    <para><option>--disable-yasm</option>: use this option if you've not
+    installed yasm and you want what configure describes as "a crippled
+    build".</para>
+
   </sect2>
 
   <sect2 role="configuration">
@@ -252,8 +194,7 @@
       </indexterm>
 
       <para>You'll find a sample ffserver configuration file at
-      <ulink url="http://ffmpeg.sourceforge.net/sample.html"/> (also
-      <filename>doc/ffserver.conf</filename> in the source tree).</para>
+      <filename>doc/ffserver.conf</filename> in the source tree.</para>
 
     </sect3>
 
@@ -269,12 +210,12 @@
 
       <seglistitem>
         <seg>ffmpeg, ffplay, ffprobe, and ffserver</seg>
-        <seg>libavcodec.{so,a}, libavdevice.{so,a}, libavformat.{so,a},
-        libavutil.{so,a}, libpostproc.{so,a}, and libswscale.{so,a}</seg>
-        <seg>/usr/include/libavcodec, /usr/include/libavdevice,
-        /usr/include/libavformat, /usr/include/libavutil, /usr/include/postproc,
-        /usr/include/libswscale, /usr/share/ffmpeg, and
-        /usr/share/doc/ffmpeg-&ffmpeg-version;</seg>
+        <seg>libavcodec.so, libavdevice.so, libavfilter.so, libavformat.so,
+        libavutil.so, libpostproc.so, and libswscale.so</seg>
+        <seg>/usr/include/libavcodec, /usr/include/libavdevice, 
+        /usr/include/libavfilter, /usr/include/libavformat,
+        /usr/include/libavutil, /usr/include/postproc, /usr/include/libswscale,
+        /usr/share/ffmpeg, and /usr/share/doc/ffmpeg-&ffmpeg-version;</seg>
       </seglistitem>
     </segmentedlist>
 
@@ -317,45 +258,56 @@
       </varlistentry>
 
       <varlistentry id="libavcodec">
-        <term><filename class='libraryfile'>libavcodec.{so,a}</filename></term>
+        <term><filename class='libraryfile'>libavcodec.so</filename></term>
         <listitem>
           <para>is a library containing the <application>FFmpeg</application>
           codecs (both encoding and decoding).</para>
           <indexterm zone="ffmpeg libavcodec">
-            <primary sortas="c-libavcodec">libavcodec.{so,a}</primary>
+            <primary sortas="c-libavcodec">libavcodec.so</primary>
           </indexterm>
         </listitem>
       </varlistentry>
 
       <varlistentry id="libavdevice">
-        <term><filename class='libraryfile'>libavdevice.{so,a}</filename></term>
+        <term><filename class='libraryfile'>libavdevice.so</filename></term>
         <listitem>
           <para>is the <application>FFmpeg</application> device handling
           library.</para>
           <indexterm zone="ffmpeg libavdevice">
-            <primary sortas="c-libavdevice">libavdevice.{so,a}</primary>
+            <primary sortas="c-libavdevice">libavdevice.so</primary>
           </indexterm>
         </listitem>
       </varlistentry>
 
+      <varlistentry id="libavfilter">
+        <term><filename class='libraryfile'>libavfilter.so</filename></term>
+        <listitem>
+          <para>is a library of filters that can alter video or audio between
+          the decoder and the encoder (or output).</para>
+          <indexterm zone="ffmpeg libavfilter">
+            <primary sortas="c-libavfilter">libavfilter.so</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
       <varlistentry id="libavformat">
-        <term><filename class='libraryfile'>libavformat.{so,a}</filename></term>
+        <term><filename class='libraryfile'>libavformat.so</filename></term>
         <listitem>
           <para>is a library containing the file formats handling (mux and demux code
           for several formats) used by <command>ffplay</command> as well as
           allowing the generation of  audio or video streams.</para>
           <indexterm zone="ffmpeg libavformat">
-            <primary sortas="c-libavformat">libavformat.{so,a}</primary>
+            <primary sortas="c-libavformat">libavformat.so</primary>
           </indexterm>
         </listitem>
       </varlistentry>
 
       <varlistentry id="libavutil">
-        <term><filename class='libraryfile'>libavutil.{so,a}</filename></term>
+        <term><filename class='libraryfile'>libavutil.so</filename></term>
         <listitem>
           <para>is the <application>FFmpeg</application> utility library.</para>
           <indexterm zone="ffmpeg libavutil">
-            <primary sortas="c-libavutil">libavutil.{so,a}</primary>
+            <primary sortas="c-libavutil">libavutil.so</primary>
           </indexterm>
         </listitem>
       </varlistentry>
@@ -368,23 +320,23 @@
       the first hyphen, so that in longindex.html it looks just right (one library,
       two packages)  -->
       <varlistentry id="libpostproc-from-ffmpeg">
-        <term><filename class='libraryfile'>libpostproc.{so,a}</filename></term>
+        <term><filename class='libraryfile'>libpostproc.so</filename></term>
         <listitem>
           <para>is the <application>FFmpeg</application> post processing
           library.</para>
           <indexterm zone="ffmpeg libpostproc">
-            <primary sortas="c-libpostproc">libpostproc.{so,a}</primary>
+            <primary sortas="c-libpostproc">libpostproc.so</primary>
           </indexterm>
         </listitem>
       </varlistentry>
 
       <varlistentry id="libswscale">
-        <term><filename class='libraryfile'>libswscale.{so,a}</filename></term>
+        <term><filename class='libraryfile'>libswscale.so</filename></term>
         <listitem>
           <para>is the <application>FFmpeg</application> image rescaling
           library.</para>
           <indexterm zone="ffmpeg libswscale">
-            <primary sortas="c-libswscale">libswscale.{so,a}</primary>
+            <primary sortas="c-libswscale">libswscale.so</primary>
           </indexterm>
         </listitem>
       </varlistentry>




More information about the blfs-book mailing list