[BLFS Trac] #2596: New Package - CMake-2.8.3

BLFS Trac trac at linuxfromscratch.org
Wed Jan 12 15:06:09 PST 2011


#2596: New Package - CMake-2.8.3
--------------------------------------+-------------------------------------
 Reporter:  ken@…                     |       Owner:  blfs-book@…                   
     Type:  enhancement               |      Status:  new                           
 Priority:  normal                    |   Milestone:  future                        
Component:  BOOK                      |     Version:  SVN                           
 Severity:  normal                    |    Keywords:                                
--------------------------------------+-------------------------------------

Comment(by ken@…):

 Please don't hold your breathe waiting for a comment from me - I created
 this ticket in the expectation we would want to move to kde4, but since
 then I've given up on kde, and my current view is that if something
 requires cmake then I won't build it.  This has stopped me looking at
 current versions of one or two packages. To explain - most autotools
 packages have configure scripts that work in known ways.  Cmake is totally
 different, and appeared (when I last built it) to be both determined to do
 things differently, and determined to create static libraries.  For people
 who use windows, no doubt that it acceptable.  For people using libre
 software, it seems like a major step backwards.

-- 
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/2596#comment:8>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch



More information about the blfs-book mailing list