[BLFS Trac] #3159: cups libusb permissions

BLFS Trac trac at linuxfromscratch.org
Tue Sep 28 07:07:05 PDT 2010


#3159: cups libusb permissions
-------------------------------------+--------------------------------------
 Reporter:  dj@…                     |       Owner:  blfs-book@…                   
     Type:  task                     |      Status:  new                           
 Priority:  normal                   |   Milestone:  future                        
Component:  BOOK                     |     Version:  SVN                           
 Severity:  normal                   |    Keywords:                                
-------------------------------------+--------------------------------------

Comment(by ken@…):

 I saw the thread, but I wasn't in front of a suitable system to compare
 it.  Now that I am, I think something is missing.  In my case, I'm
 printing with cups, gutenprint, ghostscript to an epson 360 [usb] using a
 module for the usb lp printer.  This is on LFS-6.7.

 This printer has always loaded usb_storage, which is probably just a
 curiosity, but after printing I have
 {{{
 ken at ac30 ~ $lsmod
 Module                  Size  Used by
 usblp                  10412  0
 usb_storage            42679  0

 and sys.log shows the following (turned it on, printed, turned it off)
 Sep 28 14:49:08 ac30 kernel: usb 1-1: new high speed USB device using
 ehci_hcd and address 3
 Sep 28 14:49:08 ac30 kernel: scsi5 : usb-storage 1-1:1.0
 Sep 28 14:49:08 ac30 kernel: usblp0: USB Bidirectional printer dev 3 if 1
 alt 0 proto 2 vid 0x04B8 pid 0x082C
 Sep 28 14:49:09 ac30 kernel: scsi 5:0:0:0: Direct-Access     EPSON
 Stylus Storage   1.00 PQ: 0 ANSI: 2
 Sep 28 14:49:09 ac30 kernel: sd 5:0:0:0: Attached scsi generic sg2 type 0
 Sep 28 14:49:09 ac30 kernel: sd 5:0:0:0: [sdb] Attached SCSI removable
 disk
 Sep 28 14:50:19 ac30 kernel: usb 1-1: USB disconnect, address 3
 Sep 28 14:50:19 ac30 kernel: usblp0: removed
 }}}

 I have been vaguely aware of this since Greg KH first mentioned it on lkml
 in about April, and at that time I assumed it must be a cups-1.4 issue.
 But, as far as I can remember, I *haven't* had to change kernel config or
 udev rules,  I don't have libusb installed, but I *do* add a udev rule
 (24-usblp) to create /dev/usb/lp0, and  I add an lp user

 LFS _used_ to create that rule when we had our own voluminous rules, but
 it seems to have dropped out now we are following upstream in udev.
 Funnily enough, I had to add it to my scripts when I was building on CLFS,
 and I had assumed the test to see if it was needed would fail - that is,
 until I checked it today.
 .

-- 
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/3159#comment:1>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch



More information about the blfs-book mailing list