[BLFS Trac] #3169: Security Updates: firefox-3.6.11 (originally included thunderbird-3.0.9/3.1.5, seamonkey-2.0.9)

BLFS Trac trac at linuxfromscratch.org
Fri Oct 22 11:22:22 PDT 2010


#3169: Security Updates: firefox-3.6.11 (originally included
thunderbird-3.0.9/3.1.5, seamonkey-2.0.9)
--------------------+-------------------------------------------------------
 Reporter:  bambi   |       Owner:  ken@…                   
     Type:  task    |      Status:  assigned                
 Priority:  normal  |   Milestone:  future                  
Component:  BOOK    |     Version:  SVN                     
 Severity:  normal  |    Keywords:                          
--------------------+-------------------------------------------------------

Comment(by ken@…):

 Replying to [comment:3 dj@…]:
 > > that requires newer sqlite3
 >
 > or DB-5.1.19 with sqlite3 compatibility (hopefully).

  The test is

 {{{
 SQLITE_VERSION=3.7.1
 ...
 if $PKG_CONFIG --exists "sqlite3 >= $SQLITE_VERSION" ; then
             echo "$ac_t""yes" 1>&6
             succeeded=yes
 }}}
  I have no idea if db-5.1.19 will pass that, but if it does I'm (a)
 slightly worried that it pretends to be what it isn't, and (b) wondering
 what will happen the next time mozilla decides a newer version is needed.

 For now, I'll keep it as sqlite3.  When db-5.1.19 or later are in, whoever
 does that can review this if they wish.  At the moment I don't see any
 tickets for a newer db.

-- 
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/3169#comment:4>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch



More information about the blfs-book mailing list