[BLFS Trac] #3112: pan upgrade and modification

BLFS Trac trac at linuxfromscratch.org
Mon May 24 11:15:12 PDT 2010


#3112: pan upgrade and modification
--------------------+-------------------------------------------------------
 Reporter:  bambi   |       Owner:  blfs-book@…                   
     Type:  task    |      Status:  new                           
 Priority:  normal  |   Milestone:  future                        
Component:  BOOK    |     Version:  SVN                           
 Severity:  normal  |    Keywords:                                
--------------------+-------------------------------------------------------
 pan should be upgraded to version 0.133 because: "it contains an important
 security fix and build failures on modern compilers, as well as a handful
 of usability issues."

 However, unpatched pan-0.133 wont compile on BLFS. I made the attached
 patch from references within comments I got on MID:<4BDAB726.8080005 at herr-
 der-mails.de> on the blfs-dev list.

 This patch makes pan compile with the gmime and gcc versions installed in
 a blfs system.

 Pan Dependencies have changed to:
 Required: GTK+, PCRE, gmime

 Optional: gtkspell

 In particular, the GNET dependency is now gone.

-- 
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/3112>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch



More information about the blfs-book mailing list