r8351 - in trunk/BOOK: . introduction/welcome postlfs/security

randy at linuxfromscratch.org randy at linuxfromscratch.org
Tue Mar 23 19:13:28 PDT 2010


Author: randy
Date: 2010-03-23 20:13:27 -0600 (Tue, 23 Mar 2010)
New Revision: 8351

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/postlfs/security/heimdal.xml
Log:
Modified the Heimdal instructions to reflect that a newer version of E2fsprogs than is used in LFS-6.5 is required (replaces the text that used a patch to E2fsprogs that did the same thing)

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2010-03-23 17:49:13 UTC (rev 8350)
+++ trunk/BOOK/general.ent	2010-03-24 02:13:27 UTC (rev 8351)
@@ -3,18 +3,17 @@
 $Date$
 -->
 
-<!ENTITY day          "23">                   <!-- Always 2 digits -->
+<!ENTITY day          "24">                   <!-- Always 2 digits -->
 <!ENTITY month        "03">                   <!-- Always 2 digits -->
 <!ENTITY year         "2010">
 <!ENTITY copyrightdate "2001-&year;">
 <!ENTITY copyholder   "The BLFS Development Team">
 <!ENTITY version      "svn-&year;&month;&day;">
-<!ENTITY releasedate  "March &day;rd, &year;">
+<!ENTITY releasedate  "March &day;th, &year;">
 <!ENTITY pubdate      "&year;-&month;-&day;"> <!-- metadata req. by TLDP -->
 <!ENTITY blfs-version "svn">                  <!-- svn|[release #] -->
 <!ENTITY lfs-version  "6.5">          <!-- version|testing|unstable|development] -->
 <!ENTITY last-commit  "$Date$"> <!-- Automatic update -->
-
 <!ENTITY lfs-domainname       "linuxfromscratch.org">
 
 <!ENTITY maintainer-fullname  "Randy McMurchy">
@@ -31,6 +30,7 @@
 <!ENTITY errata               "http://www.&lfs-domainname;/blfs/errata/&blfs-version;/">
 <!-- <!ENTITY lfs-root             "http://www.&lfs-domainname;/lfs/view/&lfs-version;"> -->
 <!ENTITY lfs-root             "../../../../lfs/view/&lfs-version;">
+<!ENTITY lfs-dev              "../../../../lfs/view/development">
 <!ENTITY sourceforge-repo     "http://downloads.sourceforge.net">
 <!ENTITY gentoo-ftp-repo      "ftp://mirror.ovh.net/gentoo-distfiles/distfiles">
 <!ENTITY publisher            "Unknown">

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2010-03-23 17:49:13 UTC (rev 8350)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2010-03-24 02:13:27 UTC (rev 8351)
@@ -42,6 +42,18 @@
 -->
 
     <listitem>
+      <para>March 24th, 2010</para>
+      <itemizedlist>
+        <listitem>
+          <para>[randy] - Modified the Heimdal instructions to reflect that a
+          newer version of E2fsprogs than is used in LFS-6.5 is required
+          (replaces the text that used a patch to E2fsprogs that did the same
+          thing).</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
+    <listitem>
       <para>March 23rd, 2010</para>
       <itemizedlist>
         <listitem>

Modified: trunk/BOOK/postlfs/security/heimdal.xml
===================================================================
--- trunk/BOOK/postlfs/security/heimdal.xml	2010-03-23 17:49:13 UTC (rev 8350)
+++ trunk/BOOK/postlfs/security/heimdal.xml	2010-03-24 02:13:27 UTC (rev 8351)
@@ -30,31 +30,23 @@
     <title>Introduction to Heimdal</title>
 
     <warning>
-      <para>In its current condition, building <application>Heimdal</application>
-      will overwrite <filename class='libraryfile'>/usr/lib/libcom_err.so</filename>
-      and install an additional
-      <filename class='libraryfile'>libcom_err</filename> library in
+      <para>If you are using an LFS-&lfs-version; based system, building
+      <application>Heimdal</application> will overwrite <filename
+      class='libraryfile'>/usr/lib/libcom_err.so</filename> and install an
+      additional <filename class='libraryfile'>libcom_err</filename> library in
       <filename class='directory'>/usr/lib</filename>. This will directly
       conflict with the <filename class='libraryfile'>/lib/libcom_err</filename>
       library installed by the <application>E2fsprogs</application> package in LFS.
-      Both upstream maintainers are aware of the problem and both have taken action
-      to eliminate this condition. However, the combination that currently exists
-      will cause this problem.</para>
+      Both upstream maintainers have taken steps to eliminate this condition.
+      However, the combination that currently exists causes this problem.</para>
 
       <para>There is a fix for the problem, but it will require you to recompile
-      the LFS <application>E2fsprogs</application> package with a patch. The patch is
-      located at <ulink url="&patch-root;/e2fsprogs-1.41.8-heimdal_compat-1.patch"/>.
-      Download the patch, and while you are still in the
-      <filename class='directory'>e2fsprogs-&lfs-e2fsprogs-version;</filename>
-      source directory, install it using the command:</para>
-
-      <screen><userinput>patch -Np1 -i ../e2fsprogs-1.41.8-heimdal_compat-1.patch</userinput></screen>
-
-      <para>Then follow the existing instructions to build
-      <application>E2fsprogs</application> located at
-      <ulink url="&lfs-root;/chapter06/e2fsprogs.html"/>. After
-      recompiling <application>E2fsprogs</application>, you are now ready to
-      install <application>Heimdal</application>.</para>
+      the LFS-&lfs-version; <application>E2fsprogs</application> package to a
+      newer version than the &lfs-e2fsprogs-version; version used in that book.
+      Any version equal to or greater than the one used in the LFS-Development
+      book (&lfs-dev;) will do. After recompiling
+      <application>E2fsprogs</application>, you are now ready to install
+      <application>Heimdal</application>.</para>
     </warning>
 
     <para><application>Heimdal</application> is a free implementation




More information about the blfs-book mailing list