[BLFS Trac] #2849: libgsf-1.14.7 requires Python

BLFS Trac trac at linuxfromscratch.org
Fri Mar 12 13:26:20 PST 2010


#2849: libgsf-1.14.7 requires Python
---------------------+------------------------------------------------------
 Reporter:  caozhzh  |       Owner:  blfs-book@…                   
     Type:  task     |      Status:  new                           
 Priority:  high     |   Milestone:  6.5                           
Component:  BOOK     |     Version:  SVN                           
 Severity:  normal   |    Keywords:                                
---------------------+------------------------------------------------------

Comment(by bdubbs@…):

 The book already had PyGTK as an optional dependency, which requires
 python.  There is a section that builds Python Bindings.  I had python
 installed, and did not attempt to build libgsf without python.

 There is an option in configure

 --{with,without}-python   Build with the python support

 The default ./configure fails when the option --without-python is omitted.

 I suppose we should add python as an optional dependency and add -without-
 python to the configure line.

-- 
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/2849#comment:4>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch



More information about the blfs-book mailing list