r8295 - in trunk/BOOK: general/prog introduction/welcome

randy at linuxfromscratch.org randy at linuxfromscratch.org
Sat Mar 6 10:48:24 PST 2010


Author: randy
Date: 2010-03-06 11:48:24 -0700 (Sat, 06 Mar 2010)
New Revision: 8295

Modified:
   trunk/BOOK/general/prog/expect.xml
   trunk/BOOK/introduction/welcome/changelog.xml
Log:
Added a patch to the Expect instructions so that it is compatible with Tcl-8.5.6

Modified: trunk/BOOK/general/prog/expect.xml
===================================================================
--- trunk/BOOK/general/prog/expect.xml	2010-03-06 18:35:31 UTC (rev 8294)
+++ trunk/BOOK/general/prog/expect.xml	2010-03-06 18:48:24 UTC (rev 8295)
@@ -63,6 +63,10 @@
     <itemizedlist spacing="compact">
       <listitem>
         <para>Required Patch: <ulink
+        url="&patch-root;/expect-&expect-version;-tcl_&tcl-version;-1.patch"/></para>
+      </listitem>
+      <listitem>
+        <para>Required Patch: <ulink
         url="&patch-root;/expect-&expect-version;-spawn-2.patch"/></para>
       </listitem>
     </itemizedlist>
@@ -86,7 +90,8 @@
     <para>Install <application>Expect</application> by running the following
     commands:</para>
 
-<screen><userinput>patch -Np1 -i ../expect-&expect-version;-spawn-2.patch &&
+<screen><userinput>patch -Np1 -i ../expect-&expect-version;-tcl_&tcl-version;-1.patch &&
+patch -Np1 -i ../expect-&expect-version;-spawn-2.patch &&
 ./configure --prefix=/usr \
             --with-tcl=/usr/lib \
             --with-tclinclude=/usr/include \

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2010-03-06 18:35:31 UTC (rev 8294)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2010-03-06 18:48:24 UTC (rev 8295)
@@ -45,6 +45,10 @@
       <para>March 7th, 2010</para>
       <itemizedlist>
         <listitem>
+          <para>[randy] - Added a patch to the Expect instructions so that it
+          is compatible with Tcl-8.5.6.</para>
+        </listitem>
+        <listitem>
           <para>[randy] - Added a patch to the Python instructions so that it
           is compatible with Berkeley-DB-4.8.26.</para>
         </listitem>




More information about the blfs-book mailing list